]> git.pld-linux.org Git - packages/gtk-webkit3.git/blob - gtk-webkit3.spec
- revised deps
[packages/gtk-webkit3.git] / gtk-webkit3.spec
1 # TODO: 
2 # - optflags
3 # - review configure options
4 #
5 # Conditional build:
6 %bcond_without  introspection   # disable introspection
7 #
8 Summary:        Port of WebKit embeddable web component to GTK+
9 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
10 Name:           gtk-webkit3
11 Version:        1.3.13
12 Release:        0.1
13 License:        BSD-like
14 Group:          X11/Libraries
15 Source0:        http://webkitgtk.org/webkit-%{version}.tar.gz
16 # Source0-md5:  984adaafac545a89c24351fd4dbd743c
17 URL:            http://webkitgtk.org/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  bison
21 BuildRequires:  cairo-devel >= 1.6
22 BuildRequires:  enchant-devel >= 0.22
23 BuildRequires:  flex >= 2.5.33
24 BuildRequires:  fontconfig-devel >= 2.4.0
25 BuildRequires:  freetype-devel >= 1:2.1.8
26 BuildRequires:  geoclue-devel
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel >= 1:2.28.0
29 BuildRequires:  glibc-misc
30 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
31 BuildRequires:  gperf
32 BuildRequires:  gstreamer-devel >= 0.10
33 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.25
34 BuildRequires:  gtk+3-devel >= 3.0.0
35 BuildRequires:  gtk-doc >= 1.10
36 BuildRequires:  libicu-devel >= 4.2.1
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libsoup-devel >= 2.33.6
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool >= 2:1.5
42 BuildRequires:  libxml2-devel >= 1:2.6.30
43 BuildRequires:  libxslt-devel >= 1.1.7
44 BuildRequires:  pango-devel >= 1:1.12
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpmbuild(macros) >= 1.592
47 BuildRequires:  sqlite3-devel
48 BuildRequires:  xorg-lib-libXft-devel >= 2.0.0
49 BuildRequires:  xorg-lib-libXt-devel
50 Requires(post,postun):  glib2 >= 1:2.26.0
51 Requires:       cairo >= 1.6
52 Requires:       enchant >= 0.22
53 Requires:       gstreamer-plugins-base >= 0.10.25
54 Requires:       gtk+3 >= 3.0.0
55 Requires:       libsoup >= 2.33.6
56 Requires:       libxml2 >= 1:2.6.30
57 Requires:       libxslt >= 1.1.7
58 Requires:       pango >= 1:1.12
59 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 webkit is a port of the WebKit embeddable web component to GTK+.
64
65 %description -l pl.UTF-8
66 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
67
68 %package devel
69 Summary:        Development files for WebKit
70 Summary(pl.UTF-8):      Pliki programistyczne WebKit
71 Group:          X11/Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       glib2-devel >= 1:2.28.0
74 Requires:       gtk+3-devel >= 3.0.0
75 Requires:       libsoup-devel >= 2.33.6
76
77 %description devel
78 Development files for WebKit.
79
80 %description devel -l pl.UTF-8
81 Pliki programistyczne WebKit.
82
83 %prep
84 %setup -q -n webkit-%{version}
85
86 %build
87 %{__gtkdocize}
88 %{__libtoolize}
89 %{__aclocal} -I Source/autotools
90 %{__autoheader}
91 %{__automake}
92 %{__autoconf}
93 %configure \
94         --disable-silent-rules \
95         %{__enable_disable introspection} \
96         --with-gtk=3.0 \
97         --enable-3d-transforms \
98         --enable-dom-storage \
99         --enable-geolocation \
100         --enable-icon-database \
101         --enable-video \
102         --with-font-backend=freetype
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwebkitgtk-3.0.la
113
114 %find_lang webkit-3.0
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 /sbin/ldconfig
121 %glib_compile_schemas
122
123 %postun
124 /sbin/ldconfig
125 %glib_compile_schemas
126
127 %files -f webkit-3.0.lang
128 %defattr(644,root,root,755)
129 %doc ChangeLog
130 %attr(755,root,root) %{_bindir}/jsc-3
131 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-3.0.so.0
133 %if %{with introspection}
134 %{_libdir}/girepository-1.0/JSCore-3.0.typelib
135 %{_libdir}/girepository-1.0/WebKit-3.0.typelib
136 %endif
137 %dir %{_datadir}/webkit-3.0
138 %{_datadir}/webkit-3.0/resources
139 %dir %{_datadir}/webkitgtk-3.0
140 %{_datadir}/webkitgtk-3.0/images
141 %{_datadir}/webkitgtk-3.0/webinspector
142 %{_datadir}/glib-2.0/schemas/org.webkitgtk-3.0.gschema.xml
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so
147 %if %{with introspection}
148 %{_datadir}/gir-1.0/JSCore-3.0.gir
149 %{_datadir}/gir-1.0/WebKit-3.0.gir
150 %endif
151 %{_includedir}/webkit-3.0
152 %{_pkgconfigdir}/webkitgtk-3.0.pc
This page took 0.039584 seconds and 4 git commands to generate.