]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit3.spec
- BRs for .xz source
[packages/gtk-webkit4.git] / gtk-webkit3.spec
1 # TODO: review configure options:
2 # - accelerated-compositing, notifications, gamepad, dom-mutation-observers, input-color, media-source, media-stream, mhtml, web-audio, web-timing, touch-icon-loading, register-protocol-handler
3 # - directory-upload
4 # - webkit2
5 # - APIs: page-visibility-api, indexed-database, input-speech, image-resizer, quota, animation-api
6 # - HTML5: microdata, datagrid, data-transfer-items, video-track, file-system, style-scoped
7 #
8 # Conditional build:
9 %bcond_without  introspection   # disable introspection
10 #
11 Summary:        Port of WebKit embeddable web component to GTK+ 3
12 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
13 Name:           gtk-webkit3
14 Version:        1.8.2
15 Release:        1
16 License:        BSD-like
17 Group:          X11/Libraries
18 Source0:        http://webkitgtk.org/releases/webkit-%{version}.tar.xz
19 # Source0-md5:  f7bd0bd4f323039f15e19c82a9a8313c
20 Patch0:         %{name}-bison2.6.patch
21 URL:            http://webkitgtk.org/
22 BuildRequires:  OpenGL-GLU-devel
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake
25 BuildRequires:  bison >= 1.875
26 BuildRequires:  cairo-devel >= 1.10
27 BuildRequires:  enchant-devel >= 0.22
28 BuildRequires:  flex >= 2.5.33
29 BuildRequires:  fontconfig-devel >= 2.4.0
30 BuildRequires:  freetype-devel >= 1:2.1.8
31 BuildRequires:  geoclue-devel
32 BuildRequires:  gettext-devel
33 BuildRequires:  glib2-devel >= 1:2.32.0
34 BuildRequires:  glibc-misc
35 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
36 BuildRequires:  gperf
37 BuildRequires:  gstreamer-devel >= 0.10
38 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.30
39 BuildRequires:  gtk+3-devel >= 3.4.0
40 BuildRequires:  gtk-doc >= 1.10
41 BuildRequires:  libicu-devel >= 4.2.1
42 BuildRequires:  libjpeg-devel
43 BuildRequires:  libpng-devel
44 BuildRequires:  libsoup-devel >= 2.38.0
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool >= 2:1.5
47 BuildRequires:  libxml2-devel >= 1:2.6.30
48 BuildRequires:  libxslt-devel >= 1.1.7
49 BuildRequires:  pango-devel >= 1:1.21.0
50 BuildRequires:  pkgconfig
51 BuildRequires:  rpmbuild(macros) >= 1.592
52 BuildRequires:  sqlite3-devel >= 3.0
53 BuildRequires:  tar >= 1:1.22
54 BuildRequires:  xorg-lib-libXrender-devel
55 BuildRequires:  xorg-lib-libXt-devel
56 BuildRequires:  xz
57 BuildRequires:  zlib-devel
58 Requires:       cairo >= 1.10
59 Requires:       enchant >= 0.22
60 Requires:       glib2 >= 1:2.32.0
61 Requires:       gstreamer-plugins-base >= 0.10.30
62 Requires:       gtk+3 >= 3.4.0
63 Requires:       libsoup >= 2.38.0
64 Requires:       libxml2 >= 1:2.6.30
65 Requires:       libxslt >= 1.1.7
66 Requires:       pango >= 1:1.21.0
67 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 gtk-webkit3 is a port of the WebKit embeddable web component to GTK+ 3.
72
73 %description -l pl.UTF-8
74 gtk-webkit3 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
75
76 %package devel
77 Summary:        Development files for WebKit for GTK+ 3
78 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
79 Group:          X11/Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       glib2-devel >= 1:2.32.0
82 Requires:       gtk+3-devel >= 3.4.0
83 Requires:       libsoup-devel >= 2.38.0
84
85 %description devel
86 Development files for WebKit for GTK+ 3.
87
88 %description devel -l pl.UTF-8
89 Pliki programistyczne komponentu WebKit dla GTK+ 3.
90
91 %package apidocs
92 Summary:        WebKit API documentation
93 Summary(pl.UTF-8):      Dokumentacja API WebKita
94 Group:          Documentation
95 Requires:       gtk-doc-common
96
97 %description apidocs
98 WebKit API documentation.
99
100 %description apidocs -l pl.UTF-8
101 Dokumentacja API WebKita.
102
103 %prep
104 %setup -q -n webkit-%{version}
105 %patch0 -p2
106
107 %build
108 %{__gtkdocize}
109 %{__libtoolize}
110 %{__aclocal} -I Source/autotools
111 %{__autoheader}
112 %{__automake}
113 %{__autoconf}
114 %configure \
115         --disable-silent-rules \
116         %{__enable_disable introspection} \
117         --with-gtk=3.0 \
118         --enable-geolocation \
119         --enable-gtk-doc \
120         --with-html-dir=%{_gtkdocdir}
121
122 %{__make} -j1
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
131
132 %find_lang webkit-3.0
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files -f webkit-3.0.lang
141 %defattr(644,root,root,755)
142 %doc ChangeLog NEWS
143 %attr(755,root,root) %{_bindir}/jsc-3
144 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-3.0.so.0
146 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-3.0.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-3.0.so.0
148 %if %{with introspection}
149 %{_libdir}/girepository-1.0/JSCore-3.0.typelib
150 %{_libdir}/girepository-1.0/WebKit-3.0.typelib
151 %endif
152 %dir %{_datadir}/webkitgtk-3.0
153 %{_datadir}/webkitgtk-3.0/images
154 %{_datadir}/webkitgtk-3.0/resources
155 %{_datadir}/webkitgtk-3.0/webinspector
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so
160 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-3.0.so
161 %if %{with introspection}
162 %{_datadir}/gir-1.0/JSCore-3.0.gir
163 %{_datadir}/gir-1.0/WebKit-3.0.gir
164 %endif
165 %{_includedir}/webkitgtk-3.0
166 %{_pkgconfigdir}/webkitgtk-3.0.pc
167 %{_pkgconfigdir}/javascriptcoregtk-3.0.pc
168
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/webkitgtk
This page took 0.23574 seconds and 4 git commands to generate.