]> git.pld-linux.org Git - packages/gtatool.git/blob - gtatool.spec
- release 6 (by relup.sh)
[packages/gtatool.git] / gtatool.spec
1 # TODO: pmd (BR: proprietary libpmdaccess2)
2 # libequalizer (pkgconfig(Equalizer) >= 1.0.0) for multi-display OpenGL support
3 # libgls (pkgconfig(gls) >= 1.0.0) for stereoscopic-3D OpenGL support
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # do not build and package API docs
7 %bcond_without  qt              # Qt-based GUI
8 %bcond_without  muparser        # compute component module (based on MuParser)
9 %bcond_without  dcmtk           # DCMTK conv module
10 %bcond_without  ffmpeg          # FFmpeg conv module
11 %bcond_without  gdal            # GDAL conv module
12 %bcond_without  jpeg            # JPEG conv module (based on libjpeg)
13 %bcond_without  magick          # Magick conv module (based on ImageMagick's libMagick++)
14 %bcond_without  matio           # MAT conv module (MATLAB import/export, based on [lib]matio)
15 %bcond_without  netcdf          # NetCDF conv module
16 %bcond_without  netpbm          # NetPBM conv module
17 %bcond_without  openexr         # EXR conv module (based on OpenEXR)
18 %bcond_without  pcl             # PCD conv module (based on PCL's libpcl_io)
19 %bcond_without  pfs             # PFS conv module
20 %bcond_without  sndfile         # sndfile conv module
21 %bcond_without  teem            # teem (nrrd) conv module
22 #
23 Summary:        Tools to manipulate Generic Tagged Array (GTA) files
24 Summary(pl.UTF-8):      Narzędzia do obróbki plików GTA (ogólnych tablic etykietowanych)
25 Name:           gtatool
26 Version:        2.0.1
27 Release:        6
28 License:        GPL v3+
29 Group:          Applications/File
30 Source0:        http://download.savannah.gnu.org/releases/gta/%{name}-%{version}.tar.xz
31 # Source0-md5:  1133c5687bd14d321eefffab6b495d74
32 Patch0:         ffmpeg2.patch
33 Patch1:         %{name}-getopt.patch
34 Patch2:         %{name}-bashcomp.patch
35 Patch3:         pfstools2.patch
36 URL:            http://gta.nongnu.org/gtatool.html
37 %{?with_magick:BuildRequires:   ImageMagick-c++-devel}
38 %{?with_openexr:BuildRequires:  OpenEXR-devel}
39 %{?with_qt:BuildRequires:       OpenGL-devel}
40 %{?with_qt:BuildRequires:       QtGui-devel >= 4.8}
41 %{?with_qt:BuildRequires:       QtOpenGL-devel >= 4.8}
42 BuildRequires:  autoconf >= 2.65
43 BuildRequires:  automake >= 1:1.11.1
44 %{?with_dcmtk:BuildRequires:    dcmtk-devel}
45 %{?with_apidocs:BuildRequires:  doxygen}
46 # libavformat >= 52.110.0 libavdevice libswscale
47 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
48 %{?with_gdal:BuildRequires:     gdal-devel}
49 %{?with_qt:BuildRequires:       glew-devel >= 1.6.0}
50 BuildRequires:  libgta-devel >= 0.9.4
51 %{?with_jpeg:BuildRequires:     libjpeg-devel}
52 %{?with_sndfile:BuildRequires:  libsndfile-devel}
53 BuildRequires:  libstdc++-devel
54 BuildRequires:  libtool >= 2:2.2.6
55 %{?with_matio:BuildRequires:    matio-devel >= 1.5.0}
56 %{?with_muparser:BuildRequires: muparser-devel}
57 %{?with_netcdf:BuildRequires:   netcdf-devel}
58 %{?with_netpbm:BuildRequires:   netpbm-devel}
59 %{?with_pcl:BuildRequires:      pcl-devel >= 1.7}
60 %{?with_pfs:BuildRequires:      pfstools-devel >= 2.0}
61 BuildRequires:  pkgconfig
62 %{?with_qt:BuildRequires:       qt4-build >= 4.8}
63 BuildRequires:  rpmbuild(macros) >= 1.673
64 BuildRequires:  tar >= 1:1.22
65 %{?with_teem:BuildRequires:     teem-devel}
66 BuildRequires:  xz
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Gtatool manipulates Generic Tagged Array (GTA) files.
71
72 It provides a set of commands that manipulate GTAs on various levels,
73 and it can import from and export to many other file formats.
74
75 %description -l pl.UTF-8
76 gtatool pracuje na plikach GTA (Generic Tagged Array - ogólnych
77 tablicach etykietowanych).
78
79 Pakiet zawiera zestaw poleceń obrabiających GTA na różnych poziomach,
80 potrafiących importować i eksportować do wielu innych formatów plików.
81
82 %package component-compute
83 Summary:        gtatool module to compute array element components
84 Summary(pl.UTF-8):      Moduł gtatool do obliczania składowych elementów tablicy
85 Group:          Applications/File
86 Requires:       %{name} = %{version}-%{release}
87
88 %description component-compute
89 gtatool module to compute array element components.
90
91 %description component-compute -l pl.UTF-8
92 Moduł gtatool do obliczania składowych elementów tablicy.
93
94 %package conv-dcmtk
95 Summary:        gtatool module to convert from DICOM format
96 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatu DICOM
97 Group:          Applications/File
98 Requires:       %{name} = %{version}-%{release}
99
100 %description conv-dcmtk
101 gtatool module to convert from DICOM format.
102
103 %description conv-dcmtk -l pl.UTF-8
104 Moduł gtatool do konwersji z formatu DICOM.
105
106 %package conv-exr
107 Summary:        gtatool module to convert from/to EXR format
108 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu EXR
109 Group:          Applications/File
110 Requires:       %{name} = %{version}-%{release}
111
112 %description conv-exr
113 gtatool module to convert from/to EXR format.
114
115 %description conv-exr -l pl.UTF-8
116 Moduł gtatool do konwersji z/do formatu EXR.
117
118 %package conv-ffmpeg
119 Summary:        gtatool module to convert from FFmpeg formats
120 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatów FFmpeg
121 Group:          Applications/File
122 Requires:       %{name} = %{version}-%{release}
123
124 %description conv-ffmpeg
125 gtatool module to convert from FFmpeg formats.
126
127 %description conv-ffmpeg -l pl.UTF-8
128 Moduł gtatool do konwersji z formatów FFmpeg.
129
130 %package conv-gdal
131 Summary:        gtatool module to convert from/to GDAL supported formats
132 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL
133 Group:          Applications/File
134 Requires:       %{name} = %{version}-%{release}
135
136 %description conv-gdal
137 gtatool module to convert from/to GDAL supported formats.
138
139 %description conv-gdal -l pl.UTF-8
140 Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL.
141
142 %package conv-jpeg
143 Summary:        gtatool module to convert from/to JPEG formats
144 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu JPEG
145 Group:          Applications/File
146 Requires:       %{name} = %{version}-%{release}
147
148 %description conv-jpeg
149 gtatool module to convert from/to JPEG formats.
150
151 %description conv-jpeg -l pl.UTF-8
152 Moduł gtatool do konwersji z/do formatu JPEG.
153
154 %package conv-magick
155 Summary:        gtatool module to convert from/to ImageMagick supported formats
156 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez ImageMagick
157 Group:          Applications/File
158 Requires:       %{name} = %{version}-%{release}
159
160 %description conv-magick
161 gtatool module to convert from/to ImageMagick supported formats.
162
163 %description conv-magick -l pl.UTF-8
164 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
165 ImageMagick.
166
167 %package conv-mat
168 Summary:        gtatool module to convert from/to MAT format
169 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu MAT
170 Group:          Applications/File
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       matio >= 1.5.0
173
174 %description conv-mat
175 gtatool module to convert from/to MAT (Matlab) format.
176
177 %description conv-mat -l pl.UTF-8
178 Moduł gtatool do konwersji z/do formatu MAT (z programu Matlab).
179
180 %package conv-netcdf
181 Summary:        gtatool module to convert from/to NetCDF format
182 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu NetCDF
183 Group:          Applications/File
184 Requires:       %{name} = %{version}-%{release}
185
186 %description conv-netcdf
187 gtatool module to convert from/to NetCDF format.
188
189 %description conv-netcdf -l pl.UTF-8
190 Moduł gtatool do konwersji z/do formatu NetCDF.
191
192 %package conv-netpbm
193 Summary:        gtatool module to convert from/to NetPBM supported formats
194 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM
195 Group:          Applications/File
196 Requires:       %{name} = %{version}-%{release}
197
198 %description conv-netpbm
199 gtatool module to convert from/to NetPBM supported formats.
200
201 %description conv-netpbm -l pl.UTF-8
202 Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM.
203
204 %package conv-pcd
205 Summary:        gtatool module to convert from/to PCD format
206 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PCD
207 Group:          Applications/File
208 Requires:       %{name} = %{version}-%{release}
209
210 %description conv-pcd
211 gtatool module to convert from/to PCD format.
212
213 %description conv-pcd -l pl.UTF-8
214 Moduł gtatool do konwersji z/do formatu PCD.
215
216 %package conv-pfs
217 Summary:        gtatool module to convert from/to PFS format
218 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PFS
219 Group:          Applications/File
220 Requires:       %{name} = %{version}-%{release}
221
222 %description conv-pfs
223 gtatool module to convert from/to PFS format.
224
225 %description conv-pfs -l pl.UTF-8
226 Moduł gtatool do konwersji z/do formatu PFS.
227
228 %package conv-sndfile
229 Summary:        gtatool module to convert from/to libsndfile supported formats
230 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez libsndfile
231 Group:          Applications/File
232 Requires:       %{name} = %{version}-%{release}
233
234 %description conv-sndfile
235 gtatool module to convert from/to libsndfile supported formats.
236
237 %description conv-sndfile -l pl.UTF-8
238 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
239 libsndfile.
240
241 %package conv-teem
242 Summary:        gtatool module to convert from/to Teem (NRRD) format
243 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu Teem (NRRD)
244 Group:          Applications/File
245 Requires:       %{name} = %{version}-%{release}
246
247 %description conv-teem
248 gtatool module to convert from/to Teem (NRRD) format.
249
250 %description conv-teem -l pl.UTF-8
251 Moduł gtatool do konwersji z/do formatu Teem (NRRD).
252
253 %package gui
254 Summary:        Qt-based GUI module for gtatool
255 Summary(pl.UTF-8):      Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia gtatool
256 Group:          X11/Applications
257 Requires:       %{name} = %{version}-%{release}
258 Requires:       QtGui >= 4.8
259
260 %description gui
261 Qt-based GUI module for gtatool.
262
263 %description gui -l pl.UTF-8
264 Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia
265 gtatool.
266
267 %package -n bash-completion-gtatool
268 Summary:        Bash completion for gtatool command
269 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów programu gtatool
270 Group:          Applications/Shells
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       bash-completion >= 2
273 %if "%{_rpmversion}" >= "5"
274 BuildArch:      noarch
275 %endif
276
277 %description -n bash-completion-gtatool
278 Bash completion for gtatool command.
279
280 %description -n bash-completion-gtatool -l pl.UTF-8
281 Bashowe uzupełnianie parametrów programu gtatool.
282
283 %prep
284 %setup -q
285 %patch0 -p1
286 %patch1 -p1
287 %patch2 -p1
288 %patch3 -p1
289
290 %build
291 %{__libtoolize}
292 %{__aclocal} -I m4
293 %{__autoconf}
294 %{__autoheader}
295 %{__automake}
296 %configure \
297         BASHCOMPLETIONDIR=%{bash_compdir} \
298         --disable-silent-rules \
299         --with-bashcompletion \
300         %{!?with_dcmtk:--without-dcmtk} \
301         %{!?with_ffmpeg:--without-ffmpeg} \
302         %{!?with_gdal:--without-gdal} \
303         %{!?with_jpeg:--without-jpeg} \
304         %{?with_magick:--with-magick-flavor=ImageMagick} \
305         %{!?with_magick:--without-magick} \
306         %{!?with_matio:--without-matio} \
307         %{!?with_muparser:--without-muparser} \
308         %{!?with_netcdf:--without-netcdf} \
309         %{!?with_netpbm:--without-netpbm} \
310         %{!?with_openexr:--without-openexr} \
311         %{!?with_pcl:--without-pcd} \
312         %{!?with_pfs:--without-pfs} \
313         %{!?with_qt:--without-qt} \
314         %{!?with_sndfile:--without-sndfile} \
315         %{!?with_teem:--without-teem}
316 %{__make}
317
318 %install
319 rm -rf $RPM_BUILD_ROOT
320
321 %{__make} install \
322         DESTDIR=$RPM_BUILD_ROOT
323
324 %clean
325 rm -rf $RPM_BUILD_ROOT
326
327 %post   -p /sbin/postshell
328 -/usr/sbin/fix-info-dir -c %{_infodir}
329
330 %postun -p /sbin/postshell
331 -/usr/sbin/fix-info-dir -c %{_infodir}
332
333 %files
334 %defattr(644,root,root,755)
335 %doc AUTHORS ChangeLog NEWS README
336 %attr(755,root,root) %{_bindir}/gta
337 %dir %{_libdir}/gtatool
338 %attr(755,root,root) %{_libdir}/gtatool/conv-csv.so
339 %attr(755,root,root) %{_libdir}/gtatool/conv-datraw.so
340 %attr(755,root,root) %{_libdir}/gtatool/conv-ply.so
341 %attr(755,root,root) %{_libdir}/gtatool/conv-pvm.so
342 %attr(755,root,root) %{_libdir}/gtatool/conv-rat.so
343 %attr(755,root,root) %{_libdir}/gtatool/conv-raw.so
344 %{_mandir}/man1/gta.1*
345 %{_infodir}/gta.info*
346
347 %if %{with muparser}
348 %files component-compute
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_libdir}/gtatool/component-compute.so
351 %endif
352
353 %if %{with dcmtk}
354 %files conv-dcmtk
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_libdir}/gtatool/conv-dcmtk.so
357 %endif
358
359 %if %{with openexr}
360 %files conv-exr
361 %defattr(644,root,root,755)
362 %attr(755,root,root) %{_libdir}/gtatool/conv-exr.so
363 %endif
364
365 %if %{with ffmpeg}
366 %files conv-ffmpeg
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{_libdir}/gtatool/conv-ffmpeg.so
369 %endif
370
371 %if %{with gdal}
372 %files conv-gdal
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/gtatool/conv-gdal.so
375 %endif
376
377 %if %{with jpeg}
378 %files conv-jpeg
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_libdir}/gtatool/conv-jpeg.so
381 %endif
382
383 %if %{with magick}
384 %files conv-magick
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_libdir}/gtatool/conv-magick.so
387 %endif
388
389 %if %{with matio}
390 %files conv-mat
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_libdir}/gtatool/conv-mat.so
393 %endif
394
395 %if %{with netcdf}
396 %files conv-netcdf
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/gtatool/conv-netcdf.so
399 %endif
400
401 %if %{with netpbm}
402 %files conv-netpbm
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/gtatool/conv-netpbm.so
405 %endif
406
407 %if %{with pcl}
408 %files conv-pcd
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_libdir}/gtatool/conv-pcd.so
411 %endif
412
413 %if %{with pfs}
414 %files conv-pfs
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_libdir}/gtatool/conv-pfs.so
417 %endif
418
419 %if %{with sndfile}
420 %files conv-sndfile
421 %defattr(644,root,root,755)
422 %attr(755,root,root) %{_libdir}/gtatool/conv-sndfile.so
423 %endif
424
425 %if %{with teem}
426 %files conv-teem
427 %defattr(644,root,root,755)
428 %attr(755,root,root) %{_libdir}/gtatool/conv-teem.so
429 %endif
430
431 %if %{with qt}
432 %files gui
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_libdir}/gtatool/gui.so
435 %attr(755,root,root) %{_libdir}/gtatool/view.so
436 %{_desktopdir}/gta_gui.desktop
437 %{_iconsdir}/hicolor/*/apps/gta.png
438 %{_iconsdir}/hicolor/scalable/apps/gta.svg
439 %endif
440
441 %files -n bash-completion-gtatool
442 %defattr(644,root,root,755)
443 %{bash_compdir}/gta
This page took 0.093121 seconds and 3 git commands to generate.