]> git.pld-linux.org Git - packages/gtatool.git/blob - gtatool.spec
- rel 2; builds (with pcl with fixed pc files)
[packages/gtatool.git] / gtatool.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  qt              # Qt-based GUI
5 %bcond_without  muparser        # compute component module (based on MuParser)
6 %bcond_without  dcmtk           # DCMTK conv module
7 %bcond_without  ffmpeg          # FFmpeg conv module
8 %bcond_without  gdal            # GDAL conv module
9 %bcond_without  jpeg            # JPEG conv module (based on libjpeg)
10 %bcond_without  magick          # Magick conv module (based on ImageMagick's libMagick++)
11 %bcond_without  matio           # MAT conv module (MATLAB import/export, based on [lib]matio)
12 %bcond_without  netcdf          # NetCDF conv module
13 %bcond_without  netpbm          # NetPBM conv module
14 %bcond_without  openexr         # EXR conv module (based on OpenEXR)
15 %bcond_without  pcl             # PCD conv module (based on PCL's libpcl_io)
16 %bcond_without  pfs             # PFS conv module
17 %bcond_without  sndfile         # sndfile conv module
18 %bcond_without  teem            # teem (nrrd) conv module
19 #
20 Summary:        Tools to manipulate Generic Tagged Array (GTA) files
21 Summary(pl.UTF-8):      Narzędzia do obróbki plików GTA (ogólnych tablic etykietowanych)
22 Name:           gtatool
23 Version:        2.0.1
24 Release:        2
25 License:        GPL v3+
26 Group:          Applications/File
27 Source0:        http://download.savannah.gnu.org/releases/gta/%{name}-%{version}.tar.xz
28 # Source0-md5:  1133c5687bd14d321eefffab6b495d74
29 Patch0:         ffmpeg2.patch
30 Patch1:         %{name}-pcl.patch
31 Patch2:         %{name}-getopt.patch
32 URL:            http://gta.nongnu.org/gtatool.html
33 %{?with_magick:BuildRequires:   ImageMagick-c++-devel}
34 %{?with_openexr:BuildRequires:  OpenEXR-devel}
35 %{?with_qt:BuildRequires:       QtGui-devel >= 4.6}
36 BuildRequires:  autoconf >= 2.65
37 BuildRequires:  automake >= 1:1.11.1
38 %{?with_dcmtk:BuildRequires:    dcmtk-devel}
39 %{?with_apidocs:BuildRequires:  doxygen}
40 # libavformat >= 52.110.0 libavdevice libswscale
41 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
42 %{?with_gdal:BuildRequires:     gdal-devel}
43 BuildRequires:  libgta-devel >= 0.9.4
44 %{?with_jpeg:BuildRequires:     libjpeg-devel}
45 %{?with_sndfile:BuildRequires:  libsndfile-devel}
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool
48 %{?with_matio:BuildRequires:    matio-devel}
49 %{?with_muparser:BuildRequires: muparser-devel}
50 %{?with_netcdf:BuildRequires:   netcdf-devel}
51 %{?with_netpbm:BuildRequires:   netpbm-devel}
52 %{?with_pcl:BuildRequires:      pcl-devel >= 1.7}
53 %{?with_pfs:BuildRequires:      pfstools-devel}
54 BuildRequires:  pkgconfig
55 %{?with_qt:BuildRequires:       qt4-build >= 4.6}
56 BuildRequires:  tar >= 1:1.22
57 %{?with_teem:BuildRequires:     teem-devel}
58 BuildRequires:  xz
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 Gtatool manipulates Generic Tagged Array (GTA) files.
63
64 It provides a set of commands that manipulate GTAs on various levels,
65 and it can import from and export to many other file formats.
66
67 %description -l pl.UTF-8
68 gtatool pracuje na plikach GTA (Generic Tagged Array - ogólnych
69 tablicach etykietowanych).
70
71 Pakiet zawiera zestaw poleceń obrabiających GTA na różnych poziomach,
72 potrafiących importować i eksportować do wielu innych formatów plików.
73
74 %package component-compute
75 Summary:        gtatool module to compute array element components
76 Summary(pl.UTF-8):      Moduł gtatool do obliczania składowych elementów tablicy
77 Group:          Applications/File
78 Requires:       %{name} = %{version}-%{release}
79
80 %description component-compute
81 gtatool module to compute array element components.
82
83 %description component-compute -l pl.UTF-8
84 Moduł gtatool do obliczania składowych elementów tablicy.
85
86 %package conv-dcmtk
87 Summary:        gtatool module to convert from DICOM format
88 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatu DICOM
89 Group:          Applications/File
90 Requires:       %{name} = %{version}-%{release}
91
92 %description conv-dcmtk
93 gtatool module to convert from DICOM format.
94
95 %description conv-dcmtk -l pl.UTF-8
96 Moduł gtatool do konwersji z formatu DICOM.
97
98 %package conv-exr
99 Summary:        gtatool module to convert from/to EXR format
100 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu EXR
101 Group:          Applications/File
102 Requires:       %{name} = %{version}-%{release}
103
104 %description conv-exr
105 gtatool module to convert from/to EXR format.
106
107 %description conv-exr -l pl.UTF-8
108 Moduł gtatool do konwersji z/do formatu EXR.
109
110 %package conv-ffmpeg
111 Summary:        gtatool module to convert from FFmpeg formats
112 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatów FFmpeg
113 Group:          Applications/File
114 Requires:       %{name} = %{version}-%{release}
115
116 %description conv-ffmpeg
117 gtatool module to convert from FFmpeg formats.
118
119 %description conv-ffmpeg -l pl.UTF-8
120 Moduł gtatool do konwersji z formatów FFmpeg.
121
122 %package conv-gdal
123 Summary:        gtatool module to convert from/to GDAL supported formats
124 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL
125 Group:          Applications/File
126 Requires:       %{name} = %{version}-%{release}
127
128 %description conv-gdal
129 gtatool module to convert from/to GDAL supported formats.
130
131 %description conv-gdal -l pl.UTF-8
132 Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL.
133
134 %package conv-jpeg
135 Summary:        gtatool module to convert from/to JPEG formats
136 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu JPEG
137 Group:          Applications/File
138 Requires:       %{name} = %{version}-%{release}
139
140 %description conv-jpeg
141 gtatool module to convert from/to JPEG formats.
142
143 %description conv-jpeg -l pl.UTF-8
144 Moduł gtatool do konwersji z/do formatu JPEG.
145
146 %package conv-magick
147 Summary:        gtatool module to convert from/to ImageMagick supported formats
148 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez ImageMagick
149 Group:          Applications/File
150 Requires:       %{name} = %{version}-%{release}
151
152 %description conv-magick
153 gtatool module to convert from/to ImageMagick supported formats.
154
155 %description conv-magick -l pl.UTF-8
156 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
157 ImageMagick.
158
159 %package conv-mat
160 Summary:        gtatool module to convert from/to MAT format
161 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu MAT
162 Group:          Applications/File
163 Requires:       %{name} = %{version}-%{release}
164
165 %description conv-mat
166 gtatool module to convert from/to MAT (Matlab) format.
167
168 %description conv-mat -l pl.UTF-8
169 Moduł gtatool do konwersji z/do formatu MAT (z programu Matlab).
170
171 %package conv-netcdf
172 Summary:        gtatool module to convert from/to NetCDF format
173 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu NetCDF
174 Group:          Applications/File
175 Requires:       %{name} = %{version}-%{release}
176
177 %description conv-netcdf
178 gtatool module to convert from/to NetCDF format.
179
180 %description conv-netcdf -l pl.UTF-8
181 Moduł gtatool do konwersji z/do formatu NetCDF.
182
183 %package conv-netpbm
184 Summary:        gtatool module to convert from/to NetPBM supported formats
185 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM
186 Group:          Applications/File
187 Requires:       %{name} = %{version}-%{release}
188
189 %description conv-netpbm
190 gtatool module to convert from/to NetPBM supported formats.
191
192 %description conv-netpbm -l pl.UTF-8
193 Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM.
194
195 %package conv-pcd
196 Summary:        gtatool module to convert from/to PCD format
197 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PCD
198 Group:          Applications/File
199 Requires:       %{name} = %{version}-%{release}
200
201 %description conv-pcd
202 gtatool module to convert from/to PCD format.
203
204 %description conv-pcd -l pl.UTF-8
205 Moduł gtatool do konwersji z/do formatu PCD.
206
207 %package conv-pfs
208 Summary:        gtatool module to convert from/to PFS format
209 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PFS
210 Group:          Applications/File
211 Requires:       %{name} = %{version}-%{release}
212
213 %description conv-pfs
214 gtatool module to convert from/to PFS format.
215
216 %description conv-pfs -l pl.UTF-8
217 Moduł gtatool do konwersji z/do formatu PFS.
218
219 %package conv-sndfile
220 Summary:        gtatool module to convert from/to libsndfile supported formats
221 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez libsndfile
222 Group:          Applications/File
223 Requires:       %{name} = %{version}-%{release}
224
225 %description conv-sndfile
226 gtatool module to convert from/to libsndfile supported formats.
227
228 %description conv-sndfile -l pl.UTF-8
229 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
230 libsndfile.
231
232 %package conv-teem
233 Summary:        gtatool module to convert from/to Teem (NRRD) format
234 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu Teem (NRRD)
235 Group:          Applications/File
236 Requires:       %{name} = %{version}-%{release}
237
238 %description conv-teem
239 gtatool module to convert from/to Teem (NRRD) format.
240
241 %description conv-teem -l pl.UTF-8
242 Moduł gtatool do konwersji z/do formatu Teem (NRRD).
243
244 %package gui
245 Summary:        Qt-based GUI module for gtatool
246 Summary(pl.UTF-8):      Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia gtatool
247 Group:          X11/Applications
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       QtGui >= 4.6
250
251 %description gui
252 Qt-based GUI module for gtatool.
253
254 %description gui -l pl.UTF-8
255 Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia
256 gtatool.
257
258 %package -n bash-completion-gtatool
259 Summary:        Bash completion for gtatool command
260 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów programu gtatool
261 Group:          Applications/Shells
262 Requires:       %{name} = %{version}-%{release}
263 Requires:       bash-completion
264 %if "%{_rpmversion}" >= "5"
265 BuildArch:      noarch
266 %endif
267
268 %description -n bash-completion-gtatool
269 Bash completion for gtatool command.
270
271 %description -n bash-completion-gtatool -l pl.UTF-8
272 Bashowe uzupełnianie parametrów programu gtatool.
273
274 %prep
275 %setup -q
276 %patch0 -p1
277 #%patch1 -p1
278 %patch2 -p1
279
280 %build
281 %{__libtoolize}
282 %{__aclocal} -I m4
283 %{__autoconf}
284 %{__autoheader}
285 %{__automake}
286 %configure \
287         --disable-silent-rules \
288         %{!?with_dcmtk:--without-dcmtk} \
289         %{!?with_ffmpeg:--without-ffmpeg} \
290         %{!?with_gdal:--without-gdal} \
291         %{!?with_jpeg:--without-jpeg} \
292         %{?with_magick:--with-magick-flavor=ImageMagick} \
293         %{!?with_magick:--without-magick} \
294         %{!?with_matio:--without-matio} \
295         %{!?with_muparser:--without-muparser} \
296         %{!?with_netcdf:--without-netcdf} \
297         %{!?with_netpbm:--without-netpbm} \
298         %{!?with_openexr:--without-openexr} \
299         %{!?with_pcl:--without-pcd} \
300         %{!?with_pfs:--without-pfs} \
301         %{!?with_qt:--without-qt} \
302         %{!?with_sndfile:--without-sndfile} \
303         %{!?with_teem:--without-teem}
304 %{__make}
305
306 %install
307 rm -rf $RPM_BUILD_ROOT
308
309 %{__make} install \
310         DESTDIR=$RPM_BUILD_ROOT
311
312 %clean
313 rm -rf $RPM_BUILD_ROOT
314
315 %post   -p /sbin/postshell
316 -/usr/sbin/fix-info-dir -c %{_infodir}
317
318 %postun -p /sbin/postshell
319 -/usr/sbin/fix-info-dir -c %{_infodir}
320
321 %files
322 %defattr(644,root,root,755)
323 %doc AUTHORS ChangeLog NEWS README
324 %attr(755,root,root) %{_bindir}/gta
325 %dir %{_libdir}/gtatool
326 %attr(755,root,root) %{_libdir}/gtatool/conv-csv.so
327 %attr(755,root,root) %{_libdir}/gtatool/conv-datraw.so
328 %attr(755,root,root) %{_libdir}/gtatool/conv-ply.so
329 %attr(755,root,root) %{_libdir}/gtatool/conv-pvm.so
330 %attr(755,root,root) %{_libdir}/gtatool/conv-rat.so
331 %attr(755,root,root) %{_libdir}/gtatool/conv-raw.so
332 %{_mandir}/man1/gta.1*
333 %{_infodir}/gta.info*
334
335 %if %{with muparser}
336 %files component-compute
337 %defattr(644,root,root,755)
338 %attr(755,root,root) %{_libdir}/gtatool/component-compute.so
339 %endif
340
341 %if %{with dcmtk}
342 %files conv-dcmtk
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_libdir}/gtatool/conv-dcmtk.so
345 %endif
346
347 %if %{with openexr}
348 %files conv-exr
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_libdir}/gtatool/conv-exr.so
351 %endif
352
353 %if %{with ffmpeg}
354 %files conv-ffmpeg
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_libdir}/gtatool/conv-ffmpeg.so
357 %endif
358
359 %if %{with gdal}
360 %files conv-gdal
361 %defattr(644,root,root,755)
362 %attr(755,root,root) %{_libdir}/gtatool/conv-gdal.so
363 %endif
364
365 %if %{with jpeg}
366 %files conv-jpeg
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{_libdir}/gtatool/conv-jpeg.so
369 %endif
370
371 %if %{with magick}
372 %files conv-magick
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/gtatool/conv-magick.so
375 %endif
376
377 %if %{with matio}
378 %files conv-mat
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_libdir}/gtatool/conv-mat.so
381 %endif
382
383 %if %{with netcdf}
384 %files conv-netcdf
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_libdir}/gtatool/conv-netcdf.so
387 %endif
388
389 %if %{with netpbm}
390 %files conv-netpbm
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_libdir}/gtatool/conv-netpbm.so
393 %endif
394
395 %if %{with pcl}
396 %files conv-pcd
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/gtatool/conv-pcd.so
399 %endif
400
401 %if %{with pfs}
402 %files conv-pfs
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/gtatool/conv-pfs.so
405 %endif
406
407 %if %{with sndfile}
408 %files conv-sndfile
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_libdir}/gtatool/conv-sndfile.so
411 %endif
412
413 %if %{with teem}
414 %files conv-teem
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_libdir}/gtatool/conv-teem.so
417 %endif
418
419 %if %{with qt}
420 %files gui
421 %defattr(644,root,root,755)
422 %attr(755,root,root) %{_libdir}/gtatool/gui.so
423 %attr(755,root,root) %{_libdir}/gtatool/view.so
424 %{_desktopdir}/gta_gui.desktop
425 %{_iconsdir}/hicolor/*/apps/gta.png
426 %{_iconsdir}/hicolor/scalable/apps/gta.svg
427 %endif
428
429 %files -n bash-completion-gtatool
430 %defattr(644,root,root,755)
431 %{_datadir}/bash-completion/completions/gta
This page took 0.061311 seconds and 3 git commands to generate.