]> git.pld-linux.org Git - packages/gstreamermm.git/blob - gstreamermm.spec
- initial revision
[packages/gstreamermm.git] / gstreamermm.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        A C++ bindings for the GStreamer
6 Summary(pl.UTF-8):      Wiązania C++ dla GStreamer
7 Name:           gstreamermm
8 Version:        0.10.7.3
9 Release:        1
10 License:        LGPL
11 Group:          Applications
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gstreamermm/0.10/%{name}-%{version}.tar.bz2
13 # Source0-md5:  48df9161cec157cd74c2aac0d97d2c0f
14 Patch0:         %{name}-gcc45.patch
15 BuildRequires:  glibmm-devel >= 2.18.1
16 BuildRequires:  gtkmm-devel >= 2.12.0
17 BuildRequires:  libxml++-devel >= 2.14.0
18 BuildRequires:  pkgconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 gstreamermm provides C++ bindings for the GStreamer streaming
23 multimedia library. With gstreamermm it is possible to develop
24 applications that work with multimedia in C++.
25
26 %description -l pl.UTF-8
27 gstreamermm dostarcza wiązania C++ dla biblioteki strumieniowej
28 GStreamer. Za pomocą gstreamermm jest możliwe tworzenie aplikacji
29 multimedialnych w C++.
30
31 %package devel
32 Summary:        gstreamermm header files
33 Summary(pl.UTF-8):      Pliki nagłówkowe gstreamermm
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for gstreamermm library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki gstreamermm.
42
43 %package doc
44 Summary:        Reference documentation for gstreamermm
45 Summary(pl.UTF-8):      Szczegółowa dokumentacja gstreamermm
46 Group:          Documentation
47 Requires:       devhelp
48
49 %description doc
50 Reference documentation for gstreamermm.
51
52 %description doc -l pl.UTF-8
53 Szczegółowa dokumentacja gstreamermm.
54
55 %package static
56 Summary:        gstreamermm static libraries
57 Summary(pl.UTF-8):      Biblioteki statyczne gstreamermm
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 gstreamermm static libraries.
63
64 %description static -l pl.UTF-8
65 Biblioteki statyczne gstreamermm.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 %configure \
73         %{?with_static_libs:--enable-static}
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS ChangeLog NEWS README
91 %attr(755,root,root) %{_libdir}/libgstreamermm-0.10.so.*.*.*
92 %attr(755,root,root) %ghost %{_libdir}/libgstreamermm-0.10.so.2
93 %attr(755,root,root) %{_libdir}/libgstreamermm_get_plugin_defs-0.10.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libgstreamermm_get_plugin_defs-0.10.so.2
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libgstreamermm-0.10.so
99 %attr(755,root,root) %{_libdir}/libgstreamermm_get_plugin_defs-0.10.so
100 %{_libdir}/libgstreamermm-0.10.la
101 %{_libdir}/libgstreamermm_get_plugin_defs-0.10.la
102 %{_libdir}/gstreamermm-0.10
103 %{_includedir}/gstreamermm-0.10
104 %{_pkgconfigdir}/gstreamermm-0.10.pc
105
106 %files doc
107 %defattr(644,root,root,755)
108 %{_docdir}/gstreamermm-0.10
109 %{_datadir}/devhelp/books/gstreamermm-0.10
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libgstreamermm-0.10.a
115 %{_libdir}/libgstreamermm_get_plugin_defs-0.10.a
116 %endif
This page took 0.040596 seconds and 4 git commands to generate.