]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
- glsink will be distributed as a separate package
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # - new plugins:
3 #   - ivorbisdec (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
4 #   - theoraexpdec (BR: libtheora-exp, http://people.xiph.org/~tterribe/doc/libtheora-exp/)
5 # - system libmodplug?
6 #
7 # Conditional build:
8 %bcond_without  cdaudio         # don't build cdaudio plugin
9 %bcond_without  directfb        # don't build directfb videosink plugin
10 %bcond_without  dts             # don't build DTS plugin
11 %bcond_without  faad            # don't build faad plugin
12 %bcond_without  gsm             # don't build gsm plugin
13 %bcond_without  jack            # don't build JACK audio plugin
14 %bcond_without  ladspa          # don't build ladspa plugin
15 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
16 %bcond_without  mms             # don't build mms plugin
17 %bcond_without  musepack        # don't build musepack plugin
18 %bcond_without  neon            # don't build neonhttpsrc plugin
19 %bcond_without  sdl             # don't build sdl plugin
20 %bcond_with     soup            # libsoup 2.4 http source
21 %bcond_with     swfdec          # swfdec plugin
22 %bcond_without  spc             # don't build spc plugin
23 %bcond_without  wavpack         # don't build wavpack plugin
24 %bcond_without  xvid            # don't build XviD plugin
25 %bcond_with     amr             # build amrwb plugin
26 %bcond_with     divx4linux      # build divx4linux plugins
27 #
28 %define         gstname         gst-plugins-bad
29 %define         gst_major_ver   0.10
30 %define         gst_req_ver     0.10.14
31 #
32 Summary:        Bad GStreamer Streaming-media framework plugins
33 Summary(pl.UTF-8):      Złe wtyczki do środowiska obróbki strumieni GStreamer
34 Name:           gstreamer-plugins-bad
35 Version:        0.10.6
36 Release:        2
37 License:        LPL
38 Group:          Libraries
39 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
40 # Source0-md5:  fb47838aa0ccef52683cea5d89364053
41 Patch0:         %{name}-bashish.patch
42 Patch1:         %{name}-libdts.patch
43 Patch2:         %{name}-divx4linux.patch
44 Patch3:         %{name}-neon27.patch
45 Patch4:         %{name}-timidity.patch
46 Patch5:         %{name}-nas.patch
47 URL:            http://gstreamer.freedesktop.org/
48 BuildRequires:  autoconf >= 2.59-9
49 BuildRequires:  automake >= 1.6
50 BuildRequires:  glib2-devel >= 1:2.12.0
51 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
52 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
53 BuildRequires:  gtk-doc >= 1.6
54 BuildRequires:  liboil-devel >= 0.3.6
55 BuildRequires:  libtool >= 1.4
56 BuildRequires:  pkgconfig >= 1:0.9.0
57 BuildRequires:  python-PyXML
58 BuildRequires:  rpmbuild(macros) >= 1.98
59 ##
60 ## plugins
61 ##
62 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
63 BuildRequires:  OpenGL-devel
64 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
65 BuildRequires:  alsa-lib-devel >= 0.9.1
66 %{?with_amr:BuildRequires:      amrwb-devel}
67 BuildRequires:  bzip2-devel
68 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
69 BuildRequires:  faac-devel
70 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
71 BuildRequires:  gmyth-devel >= 0.7
72 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
73 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
74 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
75 %{?with_dts:BuildRequires:      libdts-devel}
76 %{?with_gsm:BuildRequires:      libgsm-devel}
77 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
78 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
79 BuildRequires:  libmusicbrainz-devel >= 2.1.0
80 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
81 %{?with_soup:BuildRequires:     libsoup-devel >= 2.3.0.1}
82 # for modplug and libSoundTouch
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libtimidity-devel
85 BuildRequires:  libx264-devel
86 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
87 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
88 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
89 BuildRequires:  libsndfile-devel
90 BuildRequires:  nas-devel
91 BuildRequires:  soundtouch-devel >= 1.3.1
92 %if %{with swfdec}
93 BuildRequires:  swfdec-devel < 0.4.0
94 BuildRequires:  swfdec-devel >= 0.3.6
95 %endif
96 BuildRequires:  wildmidi-devel
97 BuildRequires:  xorg-lib-libX11-devel
98 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
99 Requires:       gstreamer >= %{gst_req_ver}
100 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
101 Obsoletes:      gstreamer-quicktime
102 Obsoletes:      gstreamer-vcd
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
106
107 %description
108 GStreamer is a streaming-media framework, based on graphs of filters
109 which operate on media data. Applications using this library can do
110 anything from real-time sound processing to playing videos, and just
111 about anything else media-related. Its plugin-based architecture means
112 that new data types or processing capabilities can be added simply by
113 installing new plugins.
114
115 %description -l pl.UTF-8
116 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
117 grafie filtrów operujących na danych medialnych. Aplikacje używające
118 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
119 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
120 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
121 nowych typów danych lub możliwości obróbki.
122
123 %package devel
124 Summary:        Header files and API documentation for gstapp library
125 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API biblioteki gstapp
126 Group:          Development/Libraries
127 Requires:       %{name} = %{version}-%{release}
128
129 %description devel
130 Header files and API documentation for gstapp library.
131
132 %description devel -l pl.UTF-8
133 Pliki nagłówkowe i dokumentacja API biblioteki gstapp.
134
135 ## Plugins ##
136
137 %package -n gstreamer-aac
138 Summary:        GStreamer plugin for AAC audio encoding and decoding
139 Summary(pl.UTF-8):      Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
140 Group:          Libraries
141 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
142
143 %description -n gstreamer-aac
144 GStreamer plugin for AAC audio encoding and decoding.
145
146 %description -n gstreamer-aac -l pl.UTF-8
147 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
148
149 %package -n gstreamer-amrwb
150 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
151 Summary(pl.UTF-8):      Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie AMR-WB
152 Group:          Libraries
153 Requires:       gstreamer >= %{gst_req_ver}
154
155 %description -n gstreamer-amrwb
156 GStreamer plugin for AMR-WB audio encoding and decoding.
157
158 %description -n gstreamer-amrwb -l pl.UTF-8
159 Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie
160 AMR-WB.
161
162 %package -n gstreamer-audio-effects-bad
163 Summary:        Bad GStreamer audio effects plugins
164 Summary(pl.UTF-8):      Złe wtyczki efektów dźwiękowych do GStreamera
165 Group:          Libraries
166 Requires:       gstreamer >= %{gst_req_ver}
167 Obsoletes:      gstreamer-audio-effects
168
169 %description -n gstreamer-audio-effects-bad
170 Bad GStreamer audio effects plugins.
171
172 %description -n gstreamer-audio-effects-bad -l pl.UTF-8
173 Złe wtyczki efektów dźwiękowych do GStreamera.
174
175 %package -n gstreamer-audiosink-alsaspdif
176 Summary:        GStreamer ALSA plugin for S/PDIF output
177 Summary(pl.UTF-8):      Wtyczka ALSA GStreamera do wyjścia S/PDIF
178 Group:          Libraries
179 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
180 Provides:       gstreamer-audiosink = %{version}
181
182 %description -n gstreamer-audiosink-alsaspdif
183 GStreamer ALSA plugin for S/PDIF output.
184
185 %description -n gstreamer-audiosink-alsaspdif -l pl.UTF-8
186 Wtyczka ALSA GStreamera do wyjścia S/PDIF.
187
188 %package -n gstreamer-audiosink-nas
189 Summary:        GStreamer NAS audio output plugin
190 Summary(pl.UTF-8):      Wtyczka wyjścia dźwięku NAS dla GStreamera
191 Group:          Libraries
192 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
193 Provides:       gstreamer-audiosink = %{version}
194
195 %description -n gstreamer-audiosink-nas
196 GStreamer NAS audio output plugin.
197
198 %description -n gstreamer-audiosink-nas -l pl.UTF-8
199 Wtyczka wyjścia dźwięku NAS dla GStreamera.
200
201 %package -n gstreamer-cdaudio
202 Summary:        GStreamer plugin for CD audio input using libcdaudio
203 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdaudio
204 Group:          Libraries
205 Requires:       gstreamer >= %{gst_req_ver}
206
207 %description -n gstreamer-cdaudio
208 Plugin for playing audio tracks using libcdaudio under GStreamer.
209
210 %description -n gstreamer-cdaudio -l pl.UTF-8
211 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
212 libcdaudio.
213
214 %package -n gstreamer-divx
215 Summary:        GStreamer divx plugin
216 Summary(pl.UTF-8):      Wtyczka divx do GStreamera
217 Group:          Libraries
218 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
219
220 %description -n gstreamer-divx
221 GStreamer divx plugin.
222
223 %description -n gstreamer-divx -l pl.UTF-8
224 Wtyczka divx do GStreamera.
225
226 %package -n gstreamer-dts
227 Summary:        GStreamer DTS plugin
228 Summary(pl.UTF-8):      Wtyczka DTS do GStreamera
229 Group:          Libraries
230 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
231
232 %description -n gstreamer-dts
233 Plugin for DTS Coherent Acoustics support.
234
235 %description -n gstreamer-dts -l pl.UTF-8
236 Wtyczka do GStreamera obsługująca DTS Coherent Acoustics.
237
238 %package -n gstreamer-gsm
239 Summary:        GStreamer plugin for GSM lossy audio format
240 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca stratny format dźwięku GSM
241 Group:          Libraries
242 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
243
244 %description -n gstreamer-gsm
245 Output plugin for GStreamer to convert to GSM lossy audio format.
246
247 %description -n gstreamer-gsm -l pl.UTF-8
248 Wtyczka wyjścia dźwięku GSteamera konwertująca do stratnego formatu
249 GSM.
250
251 %package -n gstreamer-jack
252 Summary:        GStreamer plugin for the JACK Sound Server
253 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
254 Group:          Libraries
255 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
256 Provides:       gstreamer-audiosink = %{version}
257
258 %description -n gstreamer-jack
259 Plugin for the JACK professional sound server.
260
261 %description -n gstreamer-jack -l pl.UTF-8
262 Wtyczka dla profesjonalnego serwera dźwięku JACK.
263
264 %package -n gstreamer-ladspa
265 Summary:        GStreamer wrapper for LADSPA plugins
266 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
267 Group:          Libraries
268 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
269
270 %description -n gstreamer-ladspa
271 Plugin which wraps LADSPA plugins for use by GStreamer applications.
272
273 %description -n gstreamer-ladspa -l pl.UTF-8
274 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
275 GStreamera.
276
277 %package -n gstreamer-mjpegtools
278 Summary:        GStreamer mpeg2enc plugin
279 Summary(pl.UTF-8):      Wtyczka mpeg2enc do GStreamera
280 Group:          Libraries
281
282 %description -n gstreamer-mjpegtools
283 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
284
285 %description -n gstreamer-mjpegtools -l pl.UTF-8
286 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
287
288 %package -n gstreamer-mms
289 Summary:        GStreamer mms plugin
290 Summary(pl.UTF-8):      Wtyczka mms do GStreamera
291 Group:          Libraries
292 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
293
294 %description -n gstreamer-mms
295 GStreamer mms plugin.
296
297 %description -n gstreamer-mms -l pl.UTF-8
298 Wtyczka mms do GStreamera.
299
300 %package -n gstreamer-musepack
301 Summary:        GStreamer musepack plugin
302 Summary(pl.UTF-8):      Wtyczka musepack do GStreamera
303 Group:          Libraries
304 Requires:       gstreamer >= %{gst_req_ver}
305
306 %description -n gstreamer-musepack
307 GStreamer musepack plugin.
308
309 %description -n gstreamer-musepack -l pl.UTF-8
310 Wtyczka musepack do GStreamera.
311
312 %package -n gstreamer-mythtv
313 Summary:        GStreamer MythTV plugin
314 Summary(pl.UTF-8):      Wtyczka MythTV do GStreamera
315 Group:          Libraries
316 Requires:       gstreamer >= %{gst_req_ver}
317
318 %description -n gstreamer-mythtv
319 GStreamer MythTV plugin.
320
321 %description -n gstreamer-mythtv -l pl.UTF-8
322 Wtyczka MythTV do GStreamera.
323
324 %package -n gstreamer-musicbrainz
325 Summary:        GStreamer musicbrainz plugin
326 Summary(pl.UTF-8):      Wtyczka musicbrainz do GStreamera
327 Group:          Libraries
328 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
329
330 %description -n gstreamer-musicbrainz
331 GStreamer musicbrainz plugin - a TRM signature producer.
332
333 %description -n gstreamer-musicbrainz -l pl.UTF-8
334 Wtyczka musicbrainz do GStreamera, tworząca sygnatury TRM.
335
336 %package -n gstreamer-neon
337 Summary:        GStreamer neon HTTP source plugin
338 Summary(pl.UTF-8):      Wtyczka źródła HTTP neon do GStreamera
339 Group:          Libraries
340 Requires:       gstreamer >= %{gst_req_ver}
341
342 %description -n gstreamer-neon
343 GStreamer neon HTTP source plugin.
344
345 %description -n gstreamer-neon -l pl.UTF-8
346 Wtyczka źródła HTTP neon do GStreamera.
347
348 %package -n gstreamer-soundtouch
349 Summary:        GStreamer soundtouch plugin
350 Summary(pl.UTF-8):      Wtyczka soundtouch do GStreamera
351 Group:          Libraries
352 Requires:       gstreamer >= %{gst_req_ver}
353
354 %description -n gstreamer-soundtouch
355 GStreamer soundtouch source plugin - audio pitch controller.
356
357 %description -n gstreamer-soundtouch -l pl.UTF-8
358 Wtyczka soundtouch do GStreamera, sterująca wysokością dźwięku.
359
360 %package -n gstreamer-sndfile
361 Summary:        GStreamer sndfile plugin
362 Summary(pl.UTF-8):      Wtyczka sndfile do GStreamera
363 Group:          Libraries
364 Requires:       gstreamer >= %{gst_req_ver}
365
366 %description -n gstreamer-sndfile
367 GStreamer sndfile source plugin.
368
369 %description -n gstreamer-sndfile -l pl.UTF-8
370 Wtyczka sndfile do GStreamera.
371
372 %package -n gstreamer-spc
373 Summary:        GStreamer SPC plugin
374 Summary(pl.UTF-8):      Wtyczka SPC dla GStreamera
375 Group:          Libraries
376 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
377 Requires:       libopenspc >= 0.3.99
378
379 %description -n gstreamer-spc
380 GStreamer Plugin for playing SPC files using OpenSPC library.
381
382 %description -n gstreamer-spc -l pl.UTF-8
383 Wtyczka GStreamera odtwarzająca pliki SPC przy użyciu biblioteki
384 OpenSPC.
385
386 %package -n gstreamer-swfdec
387 Summary:        GStreamer Flash redering plugin
388 Summary(pl.UTF-8):      Wtyczka renderująca animacje flash dla GStreamera
389 Group:          Libraries
390 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
391 Requires:       swfdec >= 0.3.6
392
393 %description -n gstreamer-swfdec
394 Plugin for rendering Flash animations using swfdec library.
395
396 %description -n gstreamer-swfdec -l pl.UTF-8
397 Wtyczka renderująca animacje flash w oparciu o bibliotekę swfdec.
398
399 %package -n gstreamer-timidity
400 Summary:        timidity plugin for GStreamer
401 Summary(pl.UTF-8):      Wtyczka timidity do GStreamera
402 Group:          Libraries
403 Requires:       gstreamer >= %{gst_req_ver}
404
405 %description -n gstreamer-timidity
406 timidity plugin for GStreamer.
407
408 %description -n gstreamer-timidity -l pl.UTF-8
409 Wtyczka timidity do GStreamera.
410
411 %package -n gstreamer-videosink-sdl
412 Summary:        GStreamer plugin for outputing to SDL
413 Summary(pl.UTF-8):      Wtyczka wyjścia SDL do GStreamera
414 Group:          Libraries
415 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
416 Provides:       gstreamer-videosink = %{version}
417 Obsoletes:      gstreamer-SDL
418
419 %description -n gstreamer-videosink-sdl
420 Plugin for sending output to the Simple Direct Media architecture.
421 (http://www.libsdl.org/). Usefull for fullscreen playback.
422
423 %description -n gstreamer-videosink-sdl -l pl.UTF-8
424 Wtyczka przekazująca wyjście do architektury SDL. Użyteczna do
425 odtwarzania na pełnym ekranie.
426
427 %package -n gstreamer-videosink-directfb
428 Summary:        GStreamer DirectFB output plugin
429 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu DirectFB do GStreamera
430 Group:          Libraries
431 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
432 Provides:       gstreamer-videosink = %{version}
433
434 %description -n gstreamer-videosink-directfb
435 GStreamer DirectFB output plugin.
436
437 %description -n gstreamer-videosink-directfb -l pl.UTF-8
438 Wtyczka wyjścia obrazu DirectFB do GStreamera.
439
440 %package -n gstreamer-wildmidi
441 Summary:        wildmidi plugin for GStreamer
442 Summary(pl.UTF-8):      Wtyczka wildmidi do GStreamera
443 Group:          Libraries
444 Requires:       gstreamer >= %{gst_req_ver}
445
446 %description -n gstreamer-wildmidi
447 wildmidi plugin for GStreamer.
448
449 %description -n gstreamer-wildmidi -l pl.UTF-8
450 Wtyczka wildmidi do GStreamera.
451
452 %package -n gstreamer-xvid
453 Summary:        GStreamer xvid decoder plugin
454 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid
455 Group:          Libraries
456 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
457
458 %description -n gstreamer-xvid
459 GStreamer xvid decoder plugin.
460
461 %description -n gstreamer-xvid -l pl.UTF-8
462 Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid.
463
464 %package -n gstreamer-x264
465 Summary:        GStreamer x264 decoder plugin
466 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264
467 Group:          Libraries
468 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
469
470 %description -n gstreamer-x264
471 GStreamer x264 decoder plugin.
472
473 %description -n gstreamer-x264 -l pl.UTF-8
474 Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264.
475
476 %prep
477 %setup -q -n %{gstname}-%{version}
478 %patch0 -p1
479 %patch1 -p1
480 %patch2 -p1
481 %patch3 -p1
482 %patch4 -p1
483 %patch5 -p1
484
485 %build
486 %{__libtoolize}
487 %{__aclocal} -I m4 -I common/m4
488 %{__autoconf}
489 %{__autoheader}
490 %{__automake}
491 %configure \
492         %{!?with_amr:--disable-amrwb} \
493         %{!?with_cdaudio:--disable-cdaudio} \
494         %{!?with_divx4linux:--disable-divx} \
495         %{!?with_dts:--disable-dts} \
496         %{!?with_faad:--disable-faad} \
497         %{!?with_gsm:--disable-gsm} \
498         %{!?with_jack:--disable-jack} \
499         %{!?with_ladspa:--disable-ladspa} \
500         %{!?with_mms:--disable-libmms} \
501         %{!?with_mjpegtools:--disable-mpeg2enc} \
502         %{!?with_musepack:--disable-musepack} \
503         %{!?with_neon:--disable-neon} \
504         %{!?with_sdl:--disable-sdl} \
505         %{!?with_sdl:--disable-sdltest} \
506         %{!?with_spc:--disable-spc} \
507         %{!?with_soup:--disable-soup} \
508         %{!?with_swfdec:--disable-swfdec} \
509         %{!?with_xvid:--disable-xvid} \
510         --disable-dc1394 \
511         --disable-static \
512         --enable-gtk-doc \
513         --with-html-dir=%{_gtkdocdir}
514
515 %{__make}
516
517 %install
518 rm -rf $RPM_BUILD_ROOT
519
520 %{__make} install \
521         DESTDIR=$RPM_BUILD_ROOT
522
523 # We don't need plugins' *.la files
524 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
525
526 %find_lang %{gstname}-%{gst_major_ver}
527
528 %clean
529 rm -rf $RPM_BUILD_ROOT
530
531 %post   -p /sbin/ldconfig
532 %postun -p /sbin/ldconfig
533
534 %files -f %{gstname}-%{gst_major_ver}.lang
535 %defattr(644,root,root,755)
536 %doc AUTHORS ChangeLog NEWS README RELEASE
537 %attr(755,root,root) %{_libdir}/libgstapp-*.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libgstapp-*.so.0
539 # R: libgstapp-*
540 %attr(755,root,root) %{gstlibdir}/libgstapp.so
541 %attr(755,root,root) %{gstlibdir}/libgstbayer.so
542 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
543 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
544 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
545 # R: gst-plugins-bad locales
546 %attr(755,root,root) %{gstlibdir}/libgstdvb.so
547 %attr(755,root,root) %{gstlibdir}/libgstdvdspu.so
548 %attr(755,root,root) %{gstlibdir}/libgstfbdevsink.so
549 %attr(755,root,root) %{gstlibdir}/libgstfestival.so
550 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
551 %attr(755,root,root) %{gstlibdir}/libgstflvdemux.so
552 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
553 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
554 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
555 %attr(755,root,root) %{gstlibdir}/libgstmetadata.so
556 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
557 %attr(755,root,root) %{gstlibdir}/libgstmpeg4videoparse.so
558 %attr(755,root,root) %{gstlibdir}/libgstmpegtsparse.so
559 %attr(755,root,root) %{gstlibdir}/libgstmpegvideoparse.so
560 %attr(755,root,root) %{gstlibdir}/libgstmve.so
561 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
562 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
563 %attr(755,root,root) %{gstlibdir}/libgstrawparse.so
564 %ifarch %{ix86} %{x8664}
565 %attr(755,root,root) %{gstlibdir}/libgstreal.so
566 %endif
567 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
568 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
569 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
570 %attr(755,root,root) %{gstlibdir}/libgstsdpelem.so
571 %attr(755,root,root) %{gstlibdir}/libgstselector.so
572 %{?with_soup:%attr(755,root,root) %{gstlibdir}/libgstsouphttpsrc.so}
573 %attr(755,root,root) %{gstlibdir}/libgstspeexresample.so
574 %attr(755,root,root) %{gstlibdir}/libgststereo.so
575 %attr(755,root,root) %{gstlibdir}/libgsttta.so
576 %attr(755,root,root) %{gstlibdir}/libgstvcdsrc.so
577 %attr(755,root,root) %{gstlibdir}/libgstvideosignal.so
578 %attr(755,root,root) %{gstlibdir}/libgstvmnc.so
579 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
580 %{_gtkdocdir}/gst-plugins-bad-plugins-*
581
582 %files devel
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/libgstapp-*.so
585 %{_libdir}/libgstapp-*.la
586 %{_includedir}/gstreamer-*/gst/app
587
588 ##
589 ## Plugins
590 ##
591
592 %if %{with faad}
593 %files -n gstreamer-aac
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
596 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
597 %endif
598
599 %if %{with amr}
600 %files -n gstreamer-amrwb
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
603 %endif
604
605 %files -n gstreamer-audio-effects-bad
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
608
609 %files -n gstreamer-audiosink-alsaspdif
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
612
613 %files -n gstreamer-audiosink-nas
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{gstlibdir}/libgstnassink.so
616
617 %if %{with cdaudio}
618 %files -n gstreamer-cdaudio
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
621 %endif
622
623 %if %{with divx4linux}
624 %files -n gstreamer-divx
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
627 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
628 %endif
629
630 %if %{with dts}
631 %files -n gstreamer-dts
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
634 %endif
635
636 %if %{with gsm}
637 %files -n gstreamer-gsm
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
640 %endif
641
642 %if %{with jack}
643 %files -n gstreamer-jack
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{gstlibdir}/libgstjack.so
646 %endif
647
648 %if %{with ladspa}
649 %files -n gstreamer-ladspa
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
652 %endif
653
654 %if %{with mjpegtools}
655 %files -n gstreamer-mjpegtools
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
658 %endif
659
660 %if %{with mms}
661 %files -n gstreamer-mms
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{gstlibdir}/libgstmms.so
664 %endif
665
666 %if %{with musepack}
667 %files -n gstreamer-musepack
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
670 %endif
671
672 %files -n gstreamer-musicbrainz
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
675
676 %files -n gstreamer-mythtv
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{gstlibdir}/libgstmythtvsrc.so
679
680 %if %{with neon}
681 %files -n gstreamer-neon
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
684 %endif
685
686 %files -n gstreamer-soundtouch
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{gstlibdir}/libgstsoundtouch.so
689
690 %files -n gstreamer-sndfile
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{gstlibdir}/libgstsndfile.so
693
694 %if %{with spc}
695 %files -n gstreamer-spc
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{gstlibdir}/libgstspc.so
698 %endif
699
700 %if %{with swfdec}
701 %files -n gstreamer-swfdec
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
704 %endif
705
706 %files -n gstreamer-timidity
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{gstlibdir}/libgsttimidity.so
709
710 %files -n gstreamer-wildmidi
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{gstlibdir}/libgstwildmidi.so
713
714 %if %{with sdl}
715 %files -n gstreamer-videosink-sdl
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{gstlibdir}/libgstsdl.so
718 %endif
719
720 %if %{with directfb}
721 %files -n gstreamer-videosink-directfb
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
724 %endif
725
726 %if %{with xvid}
727 %files -n gstreamer-xvid
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
730 %endif
731
732 %files -n gstreamer-x264
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{gstlibdir}/libgstx264.so
This page took 0.096244 seconds and 4 git commands to generate.