]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
- rel 2
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # - new plugins:
3 #   - mplex (waiting for mjpegtools 1.9.0)
4 #   - ivorbisdec (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
5 #   - theoraexpdec (BR: libtheora-exp, http://people.xiph.org/~tterribe/doc/libtheora-exp/)
6 # - system libmodplug?
7 #
8 # Conditional build:
9 %bcond_without  cdaudio         # don't build cdaudio plugin
10 %bcond_without  dirac           # don't build Dirac plugin
11 %bcond_without  directfb        # don't build directfb videosink plugin
12 %bcond_without  dts             # don't build DTS plugin
13 %bcond_without  faad            # don't build faad plugin
14 %bcond_without  gsm             # don't build gsm plugin
15 %bcond_without  jack            # don't build JACK audio plugin
16 %bcond_without  ladspa          # don't build ladspa plugin
17 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
18 %bcond_without  mms             # don't build mms plugin
19 %bcond_without  musepack        # don't build musepack plugin
20 %bcond_without  neon            # don't build neonhttpsrc plugin
21 %bcond_without  ofa             # don't build OFA plugin
22 %bcond_without  sdl             # don't build sdl plugin
23 %bcond_with     swfdec          # swfdec plugin
24 %bcond_without  spc             # don't build spc plugin
25 %bcond_without  wavpack         # don't build wavpack plugin
26 %bcond_without  xvid            # don't build XviD plugin
27 %bcond_with     amr             # build amrwb plugin
28 %bcond_with     divx4linux      # build divx4linux plugins
29 #
30 %define         gstname         gst-plugins-bad
31 %define         gst_major_ver   0.10
32 %define         gst_req_ver     0.10.14
33 #
34 Summary:        Bad GStreamer Streaming-media framework plugins
35 Summary(pl.UTF-8):      Złe wtyczki do środowiska obróbki strumieni GStreamer
36 Name:           gstreamer-plugins-bad
37 Version:        0.10.7
38 Release:        2
39 License:        LPL
40 Group:          Libraries
41 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
42 # Source0-md5:  9a511c9e9a0510ca4e212ce1d67e2cba
43 Patch0:         %{name}-bashish.patch
44 Patch1:         %{name}-libdts.patch
45 Patch2:         %{name}-divx4linux.patch
46 Patch4:         %{name}-timidity.patch
47 Patch5:         %{name}-nas.patch
48 URL:            http://gstreamer.freedesktop.org/
49 BuildRequires:  autoconf >= 2.59-9
50 BuildRequires:  automake >= 1.6
51 BuildRequires:  glib2-devel >= 1:2.12.0
52 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
53 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
54 BuildRequires:  gtk-doc >= 1.6
55 BuildRequires:  liboil-devel >= 0.3.6
56 BuildRequires:  libtool >= 1.4
57 BuildRequires:  pkgconfig >= 1:0.9.0
58 BuildRequires:  python-PyXML
59 BuildRequires:  rpmbuild(macros) >= 1.98
60 ##
61 ## plugins
62 ##
63 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
64 BuildRequires:  OpenGL-devel
65 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
66 BuildRequires:  alsa-lib-devel >= 0.9.1
67 %{?with_amr:BuildRequires:      amrwb-devel}
68 BuildRequires:  bzip2-devel
69 %{?with_dirac:BuildRequires:    dirac-devel >= 0.9}
70 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
71 BuildRequires:  faac-devel
72 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
73 BuildRequires:  gmyth-devel >= 0.7
74 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
75 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
76 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
77 BuildRequires:  libdc1394-devel >= 2.0.0
78 %{?with_dts:BuildRequires:      libdts-devel}
79 %{?with_gsm:BuildRequires:      libgsm-devel}
80 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
81 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
82 BuildRequires:  libmusicbrainz-devel >= 2.1.0
83 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
84 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
85 # for modplug and libSoundTouch
86 BuildRequires:  libstdc++-devel
87 BuildRequires:  libtimidity-devel
88 BuildRequires:  libx264-devel
89 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
90 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
91 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
92 BuildRequires:  libsndfile-devel
93 BuildRequires:  nas-devel
94 BuildRequires:  soundtouch-devel >= 1.3.1
95 %if %{with swfdec}
96 BuildRequires:  swfdec-devel < 0.4.0
97 BuildRequires:  swfdec-devel >= 0.3.6
98 %endif
99 BuildRequires:  wildmidi-devel
100 BuildRequires:  xorg-lib-libX11-devel
101 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
102 Requires:       gstreamer >= %{gst_req_ver}
103 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
104 Obsoletes:      gstreamer-quicktime
105 Obsoletes:      gstreamer-vcd
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
109
110 %description
111 GStreamer is a streaming-media framework, based on graphs of filters
112 which operate on media data. Applications using this library can do
113 anything from real-time sound processing to playing videos, and just
114 about anything else media-related. Its plugin-based architecture means
115 that new data types or processing capabilities can be added simply by
116 installing new plugins.
117
118 %description -l pl.UTF-8
119 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
120 grafie filtrów operujących na danych medialnych. Aplikacje używające
121 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
122 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
123 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
124 nowych typów danych lub możliwości obróbki.
125
126 %package devel
127 Summary:        Header files and API documentation for gstapp library
128 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API biblioteki gstapp
129 Group:          Development/Libraries
130 Requires:       %{name} = %{version}-%{release}
131
132 %description devel
133 Header files and API documentation for gstapp library.
134
135 %description devel -l pl.UTF-8
136 Pliki nagłówkowe i dokumentacja API biblioteki gstapp.
137
138 ## Plugins ##
139
140 %package -n gstreamer-aac
141 Summary:        GStreamer plugin for AAC audio encoding and decoding
142 Summary(pl.UTF-8):      Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
143 Group:          Libraries
144 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
145
146 %description -n gstreamer-aac
147 GStreamer plugin for AAC audio encoding and decoding.
148
149 %description -n gstreamer-aac -l pl.UTF-8
150 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
151
152 %package -n gstreamer-amrwb
153 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
154 Summary(pl.UTF-8):      Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie AMR-WB
155 Group:          Libraries
156 Requires:       gstreamer >= %{gst_req_ver}
157
158 %description -n gstreamer-amrwb
159 GStreamer plugin for AMR-WB audio encoding and decoding.
160
161 %description -n gstreamer-amrwb -l pl.UTF-8
162 Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie
163 AMR-WB.
164
165 %package -n gstreamer-audio-effects-bad
166 Summary:        Bad GStreamer audio effects plugins
167 Summary(pl.UTF-8):      Złe wtyczki efektów dźwiękowych do GStreamera
168 Group:          Libraries
169 Requires:       gstreamer >= %{gst_req_ver}
170 Obsoletes:      gstreamer-audio-effects
171
172 %description -n gstreamer-audio-effects-bad
173 Bad GStreamer audio effects plugins.
174
175 %description -n gstreamer-audio-effects-bad -l pl.UTF-8
176 Złe wtyczki efektów dźwiękowych do GStreamera.
177
178 %package -n gstreamer-audiosink-alsaspdif
179 Summary:        GStreamer ALSA plugin for S/PDIF output
180 Summary(pl.UTF-8):      Wtyczka ALSA GStreamera do wyjścia S/PDIF
181 Group:          Libraries
182 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
183 Provides:       gstreamer-audiosink = %{version}
184
185 %description -n gstreamer-audiosink-alsaspdif
186 GStreamer ALSA plugin for S/PDIF output.
187
188 %description -n gstreamer-audiosink-alsaspdif -l pl.UTF-8
189 Wtyczka ALSA GStreamera do wyjścia S/PDIF.
190
191 %package -n gstreamer-audiosink-nas
192 Summary:        GStreamer NAS audio output plugin
193 Summary(pl.UTF-8):      Wtyczka wyjścia dźwięku NAS dla GStreamera
194 Group:          Libraries
195 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
196 Provides:       gstreamer-audiosink = %{version}
197 Obsoletes:      gstreamer-nas
198
199 %description -n gstreamer-audiosink-nas
200 GStreamer NAS audio output plugin.
201
202 %description -n gstreamer-audiosink-nas -l pl.UTF-8
203 Wtyczka wyjścia dźwięku NAS dla GStreamera.
204
205 %package -n gstreamer-cdaudio
206 Summary:        GStreamer plugin for CD audio input using libcdaudio
207 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdaudio
208 Group:          Libraries
209 Requires:       gstreamer >= %{gst_req_ver}
210
211 %description -n gstreamer-cdaudio
212 Plugin for playing audio tracks using libcdaudio under GStreamer.
213
214 %description -n gstreamer-cdaudio -l pl.UTF-8
215 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
216 libcdaudio.
217
218 %package -n gstreamer-dc1394
219 Summary:        GStreamer 1394 IIDC (Firewire digital cameras) video source plugin
220 Summary(pl.UTF-8):      Wtyczka źródła obrazu 1394 IIDC (z kamer cyfrowych Firewire) do GStreamera
221 Group:          Libraries
222 Requires:       gstreamer >= %{gst_req_ver}
223
224 %description -n gstreamer-dc1394
225 GStreamer 1394 IIDC (Firewire digital cameras) video source plugin.
226
227 %description -n gstreamer-dc1394 -l pl.UTF-8
228 Wtyczka źródła obrazu 1394 IIDC (z kamer cyfrowych Firewire) do GStreamera.
229
230 %package -n gstreamer-dirac
231 Summary:        GStreamer Dirac plugin
232 Summary(pl.UTF-8):      Wtyczka Dirac do GStreamera
233 Group:          Libraries
234 Requires:       gstreamer >= %{gst_req_ver}
235 Requires:       dirac >= 0.9
236
237 %description -n gstreamer-dirac
238 GStreamer Dirac video decoder/encoder plugin.
239
240 %description -n gstreamer-dirac -l pl.UTF-8
241 Wtyczka dekodująca i kodująca obraz Dirac do GStreamera.
242
243 %package -n gstreamer-divx
244 Summary:        GStreamer divx plugin
245 Summary(pl.UTF-8):      Wtyczka divx do GStreamera
246 Group:          Libraries
247 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
248
249 %description -n gstreamer-divx
250 GStreamer divx plugin.
251
252 %description -n gstreamer-divx -l pl.UTF-8
253 Wtyczka divx do GStreamera.
254
255 %package -n gstreamer-dts
256 Summary:        GStreamer DTS plugin
257 Summary(pl.UTF-8):      Wtyczka DTS do GStreamera
258 Group:          Libraries
259 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
260
261 %description -n gstreamer-dts
262 Plugin for DTS Coherent Acoustics support.
263
264 %description -n gstreamer-dts -l pl.UTF-8
265 Wtyczka do GStreamera obsługująca DTS Coherent Acoustics.
266
267 %package -n gstreamer-gsm
268 Summary:        GStreamer plugin for GSM lossy audio format
269 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca stratny format dźwięku GSM
270 Group:          Libraries
271 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
272
273 %description -n gstreamer-gsm
274 Output plugin for GStreamer to convert to GSM lossy audio format.
275
276 %description -n gstreamer-gsm -l pl.UTF-8
277 Wtyczka wyjścia dźwięku GSteamera konwertująca do stratnego formatu
278 GSM.
279
280 %package -n gstreamer-jack
281 Summary:        GStreamer plugin for the JACK Sound Server
282 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
283 Group:          Libraries
284 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
285 Provides:       gstreamer-audiosink = %{version}
286
287 %description -n gstreamer-jack
288 Plugin for the JACK professional sound server.
289
290 %description -n gstreamer-jack -l pl.UTF-8
291 Wtyczka dla profesjonalnego serwera dźwięku JACK.
292
293 %package -n gstreamer-ladspa
294 Summary:        GStreamer wrapper for LADSPA plugins
295 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
296 Group:          Libraries
297 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
298
299 %description -n gstreamer-ladspa
300 Plugin which wraps LADSPA plugins for use by GStreamer applications.
301
302 %description -n gstreamer-ladspa -l pl.UTF-8
303 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
304 GStreamera.
305
306 %package -n gstreamer-mjpegtools
307 Summary:        GStreamer mpeg2enc plugin
308 Summary(pl.UTF-8):      Wtyczka mpeg2enc do GStreamera
309 Group:          Libraries
310
311 %description -n gstreamer-mjpegtools
312 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
313
314 %description -n gstreamer-mjpegtools -l pl.UTF-8
315 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
316
317 %package -n gstreamer-mms
318 Summary:        GStreamer mms plugin
319 Summary(pl.UTF-8):      Wtyczka mms do GStreamera
320 Group:          Libraries
321 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
322
323 %description -n gstreamer-mms
324 GStreamer mms plugin.
325
326 %description -n gstreamer-mms -l pl.UTF-8
327 Wtyczka mms do GStreamera.
328
329 %package -n gstreamer-musepack
330 Summary:        GStreamer musepack plugin
331 Summary(pl.UTF-8):      Wtyczka musepack do GStreamera
332 Group:          Libraries
333 Requires:       gstreamer >= %{gst_req_ver}
334
335 %description -n gstreamer-musepack
336 GStreamer musepack plugin.
337
338 %description -n gstreamer-musepack -l pl.UTF-8
339 Wtyczka musepack do GStreamera.
340
341 %package -n gstreamer-mythtv
342 Summary:        GStreamer MythTV plugin
343 Summary(pl.UTF-8):      Wtyczka MythTV do GStreamera
344 Group:          Libraries
345 Requires:       gstreamer >= %{gst_req_ver}
346
347 %description -n gstreamer-mythtv
348 GStreamer MythTV plugin.
349
350 %description -n gstreamer-mythtv -l pl.UTF-8
351 Wtyczka MythTV do GStreamera.
352
353 %package -n gstreamer-musicbrainz
354 Summary:        GStreamer musicbrainz plugin
355 Summary(pl.UTF-8):      Wtyczka musicbrainz do GStreamera
356 Group:          Libraries
357 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
358
359 %description -n gstreamer-musicbrainz
360 GStreamer musicbrainz plugin - a TRM signature producer.
361
362 %description -n gstreamer-musicbrainz -l pl.UTF-8
363 Wtyczka musicbrainz do GStreamera, tworząca sygnatury TRM.
364
365 %package -n gstreamer-neon
366 Summary:        GStreamer neon HTTP source plugin
367 Summary(pl.UTF-8):      Wtyczka źródła HTTP neon do GStreamera
368 Group:          Libraries
369 Requires:       gstreamer >= %{gst_req_ver}
370
371 %description -n gstreamer-neon
372 GStreamer neon HTTP source plugin.
373
374 %description -n gstreamer-neon -l pl.UTF-8
375 Wtyczka źródła HTTP neon do GStreamera.
376
377 %package -n gstreamer-ofa
378 Summary:        GStreamer OFA fingerprint plugin
379 Summary(pl.UTF-8):      Wtyczka odcisków OFA do GStreamera
380 Group:          Libraries
381 Requires:       gstreamer >= %{gst_req_ver}
382 Requires:       libofa >= 0.9.3
383
384 %description -n gstreamer-ofa
385 GStreamer OFA plugin to calculate MusicIP fingerprints from audio
386 files.
387
388 %description -n gstreamer-ofa -l pl.UTF-8
389 Wtyczka OFA do GStreamera służąca do obliczania odcisków MusicIP
390 plików dźwiękowych.
391
392 %package -n gstreamer-oss4
393 Summary:        GStreamer OSS 4 audio sink, source and mixer plugin
394 Summary(pl.UTF-8):      Wtyczka wyjścia, wejścia i miksera dźwięku OSS 4 do GStreamera
395 Group:          Libraries
396 # for locales (when added to POTFILES)
397 #Requires:      %{name} = %{version}-%{release}
398 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
399 Provides:       gstreamer-audiosink = %{version}
400
401 %description -n gstreamer-oss4
402 GStreamer OSS (Open Sound System) 4 audio input/output/mixer plugin.
403
404 %description -n gstreamer-oss4 -l pl.UTF-8
405 Wtyczka wejścia/wyjścia/miksera dźwięku OSS (Open Sound System) 4 do
406 GStreamera.
407
408 %package -n gstreamer-soundtouch
409 Summary:        GStreamer soundtouch plugin
410 Summary(pl.UTF-8):      Wtyczka soundtouch do GStreamera
411 Group:          Libraries
412 Requires:       gstreamer >= %{gst_req_ver}
413
414 %description -n gstreamer-soundtouch
415 GStreamer soundtouch source plugin - audio pitch controller.
416
417 %description -n gstreamer-soundtouch -l pl.UTF-8
418 Wtyczka soundtouch do GStreamera, sterująca wysokością dźwięku.
419
420 %package -n gstreamer-sndfile
421 Summary:        GStreamer sndfile plugin
422 Summary(pl.UTF-8):      Wtyczka sndfile do GStreamera
423 Group:          Libraries
424 # for locales
425 Requires:       %{name} = %{version}-%{release}
426 Requires:       gstreamer >= %{gst_req_ver}
427
428 %description -n gstreamer-sndfile
429 GStreamer sndfile source plugin.
430
431 %description -n gstreamer-sndfile -l pl.UTF-8
432 Wtyczka sndfile do GStreamera.
433
434 %package -n gstreamer-spc
435 Summary:        GStreamer SPC plugin
436 Summary(pl.UTF-8):      Wtyczka SPC dla GStreamera
437 Group:          Libraries
438 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
439 Requires:       libopenspc >= 0.3.99
440
441 %description -n gstreamer-spc
442 GStreamer Plugin for playing SPC files using OpenSPC library.
443
444 %description -n gstreamer-spc -l pl.UTF-8
445 Wtyczka GStreamera odtwarzająca pliki SPC przy użyciu biblioteki
446 OpenSPC.
447
448 %package -n gstreamer-swfdec
449 Summary:        GStreamer Flash redering plugin
450 Summary(pl.UTF-8):      Wtyczka renderująca animacje flash dla GStreamera
451 Group:          Libraries
452 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
453 Requires:       swfdec >= 0.3.6
454
455 %description -n gstreamer-swfdec
456 Plugin for rendering Flash animations using swfdec library.
457
458 %description -n gstreamer-swfdec -l pl.UTF-8
459 Wtyczka renderująca animacje flash w oparciu o bibliotekę swfdec.
460
461 %package -n gstreamer-timidity
462 Summary:        timidity plugin for GStreamer
463 Summary(pl.UTF-8):      Wtyczka timidity do GStreamera
464 Group:          Libraries
465 Requires:       gstreamer >= %{gst_req_ver}
466
467 %description -n gstreamer-timidity
468 timidity plugin for GStreamer.
469
470 %description -n gstreamer-timidity -l pl.UTF-8
471 Wtyczka timidity do GStreamera.
472
473 %package -n gstreamer-videosink-sdl
474 Summary:        GStreamer plugin for outputing to SDL
475 Summary(pl.UTF-8):      Wtyczka wyjścia SDL do GStreamera
476 Group:          Libraries
477 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
478 Provides:       gstreamer-videosink = %{version}
479 Obsoletes:      gstreamer-SDL
480
481 %description -n gstreamer-videosink-sdl
482 Plugin for sending output to the Simple Direct Media architecture.
483 (http://www.libsdl.org/). Usefull for fullscreen playback.
484
485 %description -n gstreamer-videosink-sdl -l pl.UTF-8
486 Wtyczka przekazująca wyjście do architektury SDL. Użyteczna do
487 odtwarzania na pełnym ekranie.
488
489 %package -n gstreamer-videosink-directfb
490 Summary:        GStreamer DirectFB output plugin
491 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu DirectFB do GStreamera
492 Group:          Libraries
493 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
494 Provides:       gstreamer-videosink = %{version}
495
496 %description -n gstreamer-videosink-directfb
497 GStreamer DirectFB output plugin.
498
499 %description -n gstreamer-videosink-directfb -l pl.UTF-8
500 Wtyczka wyjścia obrazu DirectFB do GStreamera.
501
502 %package -n gstreamer-wildmidi
503 Summary:        wildmidi plugin for GStreamer
504 Summary(pl.UTF-8):      Wtyczka wildmidi do GStreamera
505 Group:          Libraries
506 Requires:       gstreamer >= %{gst_req_ver}
507
508 %description -n gstreamer-wildmidi
509 wildmidi plugin for GStreamer.
510
511 %description -n gstreamer-wildmidi -l pl.UTF-8
512 Wtyczka wildmidi do GStreamera.
513
514 %package -n gstreamer-xvid
515 Summary:        GStreamer xvid decoder plugin
516 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid
517 Group:          Libraries
518 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
519
520 %description -n gstreamer-xvid
521 GStreamer xvid decoder plugin.
522
523 %description -n gstreamer-xvid -l pl.UTF-8
524 Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid.
525
526 %package -n gstreamer-x264
527 Summary:        GStreamer x264 decoder plugin
528 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264
529 Group:          Libraries
530 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
531
532 %description -n gstreamer-x264
533 GStreamer x264 decoder plugin.
534
535 %description -n gstreamer-x264 -l pl.UTF-8
536 Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264.
537
538 %prep
539 %setup -q -n %{gstname}-%{version}
540 %patch0 -p1
541 %patch1 -p1
542 %patch2 -p1
543 %patch4 -p1
544 %patch5 -p1
545
546 %build
547 %{__libtoolize}
548 %{__aclocal} -I m4 -I common/m4
549 %{__autoconf}
550 %{__autoheader}
551 %{__automake}
552 %configure \
553         %{!?with_amr:--disable-amrwb} \
554         %{!?with_cdaudio:--disable-cdaudio} \
555         %{!?with_divx4linux:--disable-divx} \
556         %{!?with_dirac:--disable-dirac} \
557         %{!?with_dts:--disable-dts} \
558         %{!?with_faad:--disable-faad} \
559         %{!?with_gsm:--disable-gsm} \
560         %{!?with_jack:--disable-jack} \
561         %{!?with_ladspa:--disable-ladspa} \
562         %{!?with_mms:--disable-libmms} \
563         %{!?with_mjpegtools:--disable-mpeg2enc} \
564         %{!?with_musepack:--disable-musepack} \
565         %{!?with_neon:--disable-neon} \
566         %{!?with_ofa:--disable-ofa} \
567         %{!?with_sdl:--disable-sdl} \
568         %{!?with_sdl:--disable-sdltest} \
569         %{!?with_spc:--disable-spc} \
570         %{!?with_swfdec:--disable-swfdec} \
571         %{!?with_xvid:--disable-xvid} \
572         --disable-static \
573         --enable-gtk-doc \
574         --with-html-dir=%{_gtkdocdir}
575
576 %{__make}
577
578 %install
579 rm -rf $RPM_BUILD_ROOT
580
581 %{__make} install \
582         DESTDIR=$RPM_BUILD_ROOT
583
584 # We don't need plugins' *.la files
585 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
586
587 %find_lang %{gstname}-%{gst_major_ver}
588
589 %clean
590 rm -rf $RPM_BUILD_ROOT
591
592 %post   -p /sbin/ldconfig
593 %postun -p /sbin/ldconfig
594
595 %files -f %{gstname}-%{gst_major_ver}.lang
596 %defattr(644,root,root,755)
597 %doc AUTHORS ChangeLog NEWS README RELEASE
598 %attr(755,root,root) %{_libdir}/libgstapp-*.so.*.*.*
599 %attr(755,root,root) %ghost %{_libdir}/libgstapp-*.so.0
600 # R: libgstapp-*
601 %attr(755,root,root) %{gstlibdir}/libgstapp.so
602 %attr(755,root,root) %{gstlibdir}/libgstbayer.so
603 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
604 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
605 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
606 # R: gst-plugins-bad locales
607 %attr(755,root,root) %{gstlibdir}/libgstdvb.so
608 %attr(755,root,root) %{gstlibdir}/libgstdvdspu.so
609 %attr(755,root,root) %{gstlibdir}/libgstfbdevsink.so
610 %attr(755,root,root) %{gstlibdir}/libgstfestival.so
611 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
612 %attr(755,root,root) %{gstlibdir}/libgstflvdemux.so
613 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
614 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
615 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
616 %attr(755,root,root) %{gstlibdir}/libgstmetadata.so
617 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
618 %attr(755,root,root) %{gstlibdir}/libgstmpeg4videoparse.so
619 %attr(755,root,root) %{gstlibdir}/libgstmpegtsparse.so
620 %attr(755,root,root) %{gstlibdir}/libgstmpegvideoparse.so
621 %attr(755,root,root) %{gstlibdir}/libgstmve.so
622 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
623 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
624 %attr(755,root,root) %{gstlibdir}/libgstrawparse.so
625 %ifarch %{ix86} %{x8664}
626 %attr(755,root,root) %{gstlibdir}/libgstreal.so
627 %endif
628 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
629 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
630 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
631 %attr(755,root,root) %{gstlibdir}/libgstsdpelem.so
632 %attr(755,root,root) %{gstlibdir}/libgstselector.so
633 %attr(755,root,root) %{gstlibdir}/libgstspeexresample.so
634 %attr(755,root,root) %{gstlibdir}/libgststereo.so
635 %attr(755,root,root) %{gstlibdir}/libgstsubenc.so
636 %attr(755,root,root) %{gstlibdir}/libgsttta.so
637 %attr(755,root,root) %{gstlibdir}/libgstvcdsrc.so
638 %attr(755,root,root) %{gstlibdir}/libgstvideosignal.so
639 %attr(755,root,root) %{gstlibdir}/libgstvmnc.so
640 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
641 %{_gtkdocdir}/gst-plugins-bad-plugins-*
642
643 %files devel
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/libgstapp-*.so
646 %{_libdir}/libgstapp-*.la
647 %{_includedir}/gstreamer-*/gst/app
648
649 ##
650 ## Plugins
651 ##
652
653 %if %{with faad}
654 %files -n gstreamer-aac
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
657 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
658 %endif
659
660 %if %{with amr}
661 %files -n gstreamer-amrwb
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
664 %endif
665
666 %files -n gstreamer-audio-effects-bad
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
669
670 %files -n gstreamer-audiosink-alsaspdif
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
673
674 %files -n gstreamer-audiosink-nas
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{gstlibdir}/libgstnassink.so
677
678 %if %{with cdaudio}
679 %files -n gstreamer-cdaudio
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
682 %endif
683
684 %files -n gstreamer-dc1394
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{gstlibdir}/libgstdc1394.so
687
688 %if %{with dirac}
689 %files -n gstreamer-dirac
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{gstlibdir}/libgstdirac.so
692 %endif
693
694 %if %{with divx4linux}
695 %files -n gstreamer-divx
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
698 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
699 %endif
700
701 %if %{with dts}
702 %files -n gstreamer-dts
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
705 %endif
706
707 %if %{with gsm}
708 %files -n gstreamer-gsm
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
711 %endif
712
713 %if %{with jack}
714 %files -n gstreamer-jack
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{gstlibdir}/libgstjack.so
717 %endif
718
719 %if %{with ladspa}
720 %files -n gstreamer-ladspa
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
723 %endif
724
725 %if %{with mjpegtools}
726 %files -n gstreamer-mjpegtools
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
729 %endif
730
731 %if %{with mms}
732 %files -n gstreamer-mms
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{gstlibdir}/libgstmms.so
735 %endif
736
737 %if %{with musepack}
738 %files -n gstreamer-musepack
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
741 %endif
742
743 %files -n gstreamer-musicbrainz
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
746
747 %files -n gstreamer-mythtv
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{gstlibdir}/libgstmythtvsrc.so
750
751 %if %{with neon}
752 %files -n gstreamer-neon
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
755 %endif
756
757 %if %{with ofa}
758 %files -n gstreamer-ofa
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{gstlibdir}/libgstofa.so
761 %endif
762
763 %files -n gstreamer-oss4
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{gstlibdir}/libgstoss4audio.so
766
767 %files -n gstreamer-soundtouch
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{gstlibdir}/libgstsoundtouch.so
770
771 %files -n gstreamer-sndfile
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{gstlibdir}/libgstsndfile.so
774
775 %if %{with spc}
776 %files -n gstreamer-spc
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{gstlibdir}/libgstspc.so
779 %endif
780
781 %if %{with swfdec}
782 %files -n gstreamer-swfdec
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
785 %endif
786
787 %files -n gstreamer-timidity
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{gstlibdir}/libgsttimidity.so
790
791 %files -n gstreamer-wildmidi
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{gstlibdir}/libgstwildmidi.so
794
795 %if %{with sdl}
796 %files -n gstreamer-videosink-sdl
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{gstlibdir}/libgstsdl.so
799 %endif
800
801 %if %{with directfb}
802 %files -n gstreamer-videosink-directfb
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
805 %endif
806
807 %if %{with xvid}
808 %files -n gstreamer-xvid
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
811 %endif
812
813 %files -n gstreamer-x264
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{gstlibdir}/libgstx264.so
This page took 0.482943 seconds and 4 git commands to generate.