]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
- 0.10.6
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # - new plugins:
3 #   - ivorbisdec (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
4 #   - theoraexpdec (BR: libtheora-exp, http://people.xiph.org/~tterribe/doc/libtheora-exp/)
5 # - system libmodplug?
6 #
7 # Conditional build:
8 %bcond_without  cdaudio         # don't build cdaudio plugin
9 %bcond_without  directfb        # don't build directfb videosink plugin
10 %bcond_without  dts             # don't build DTS plugin
11 %bcond_without  faad            # don't build faad plugin
12 %bcond_without  gsm             # don't build gsm plugin
13 %bcond_without  jack            # don't build JACK audio plugin
14 %bcond_without  ladspa          # don't build ladspa plugin
15 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
16 %bcond_without  mms             # don't build mms plugin
17 %bcond_without  musepack        # don't build musepack plugin
18 %bcond_without  neon            # don't build neonhttpsrc plugin
19 %bcond_without  sdl             # don't build sdl plugin
20 %bcond_with     soup            # libsoup 2.4 http source
21 %bcond_with     swfdec          # swfdec plugin
22 %bcond_without  spc             # don't build spc plugin
23 %bcond_without  wavpack         # don't build wavpack plugin
24 %bcond_without  xvid            # don't build XviD plugin
25 %bcond_with     amr             # build amrwb plugin
26 %bcond_with     divx4linux      # build divx4linux plugins
27 #
28 %define         gstname         gst-plugins-bad
29 %define         gst_major_ver   0.10
30 %define         gst_req_ver     0.10.14
31 #
32 Summary:        Bad GStreamer Streaming-media framework plugins
33 Summary(pl.UTF-8):      Złe wtyczki do środowiska obróbki strumieni GStreamer
34 Name:           gstreamer-plugins-bad
35 Version:        0.10.6
36 Release:        1
37 License:        LPL
38 Group:          Libraries
39 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
40 # Source0-md5:  fb47838aa0ccef52683cea5d89364053
41 Patch0:         %{name}-bashish.patch
42 Patch1:         %{name}-libdts.patch
43 Patch2:         %{name}-divx4linux.patch
44 Patch3:         %{name}-neon27.patch
45 Patch4:         %{name}-timidity.patch
46 Patch5:         %{name}-nas.patch
47 URL:            http://gstreamer.freedesktop.org/
48 BuildRequires:  autoconf >= 2.59-9
49 BuildRequires:  automake >= 1.6
50 BuildRequires:  glib2-devel >= 1:2.12.0
51 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
52 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
53 BuildRequires:  gtk-doc >= 1.6
54 BuildRequires:  liboil-devel >= 0.3.6
55 BuildRequires:  libtool >= 1.4
56 BuildRequires:  pkgconfig >= 1:0.9.0
57 BuildRequires:  python-PyXML
58 BuildRequires:  rpmbuild(macros) >= 1.98
59 ##
60 ## plugins
61 ##
62 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
63 BuildRequires:  OpenGL-devel
64 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
65 BuildRequires:  alsa-lib-devel >= 0.9.1
66 %{?with_amr:BuildRequires:      amrwb-devel}
67 BuildRequires:  bzip2-devel
68 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
69 BuildRequires:  faac-devel
70 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
71 BuildRequires:  gmyth-devel >= 0.7
72 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
73 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
74 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
75 %{?with_dts:BuildRequires:      libdts-devel}
76 %{?with_gsm:BuildRequires:      libgsm-devel}
77 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
78 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
79 BuildRequires:  libmusicbrainz-devel >= 2.1.0
80 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
81 %{?with_soup:BuildRequires:     libsoup-devel >= 2.3.0.1}
82 # for modplug and libSoundTouch
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libtimidity-devel
85 BuildRequires:  libx264-devel
86 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
87 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
88 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
89 BuildRequires:  libsndfile-devel
90 BuildRequires:  nas-devel
91 BuildRequires:  soundtouch-devel >= 1.3.1
92 %if %{with swfdec}
93 BuildRequires:  swfdec-devel < 0.4.0
94 BuildRequires:  swfdec-devel >= 0.3.6
95 %endif
96 BuildRequires:  wildmidi-devel
97 BuildRequires:  xorg-lib-libX11-devel
98 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
99 Requires:       gstreamer >= %{gst_req_ver}
100 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
101 Obsoletes:      gstreamer-quicktime
102 Obsoletes:      gstreamer-vcd
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
106
107 %description
108 GStreamer is a streaming-media framework, based on graphs of filters
109 which operate on media data. Applications using this library can do
110 anything from real-time sound processing to playing videos, and just
111 about anything else media-related. Its plugin-based architecture means
112 that new data types or processing capabilities can be added simply by
113 installing new plugins.
114
115 %description -l pl.UTF-8
116 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
117 grafie filtrów operujących na danych medialnych. Aplikacje używające
118 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
119 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
120 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
121 nowych typów danych lub możliwości obróbki.
122
123 %package devel
124 Summary:        Header files and API documentation for gstapp library
125 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API biblioteki gstapp
126 Group:          Development/Libraries
127 Requires:       %{name} = %{version}-%{release}
128
129 %description devel
130 Header files and API documentation for gstapp library.
131
132 %description devel -l pl.UTF-8
133 Pliki nagłówkowe i dokumentacja API biblioteki gstapp.
134
135 ## Plugins ##
136
137 %package -n gstreamer-aac
138 Summary:        GStreamer plugin for AAC audio encoding and decoding
139 Summary(pl.UTF-8):      Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
140 Group:          Libraries
141 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
142
143 %description -n gstreamer-aac
144 GStreamer plugin for AAC audio encoding and decoding.
145
146 %description -n gstreamer-aac -l pl.UTF-8
147 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
148
149 %package -n gstreamer-amrwb
150 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
151 Summary(pl.UTF-8):      Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie AMR-WB
152 Group:          Libraries
153 Requires:       gstreamer >= %{gst_req_ver}
154
155 %description -n gstreamer-amrwb
156 GStreamer plugin for AMR-WB audio encoding and decoding.
157
158 %description -n gstreamer-amrwb -l pl.UTF-8
159 Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie
160 AMR-WB.
161
162 %package -n gstreamer-audio-effects-bad
163 Summary:        Bad GStreamer audio effects plugins
164 Summary(pl.UTF-8):      Złe wtyczki efektów dźwiękowych do GStreamera
165 Group:          Libraries
166 Requires:       gstreamer >= %{gst_req_ver}
167 Obsoletes:      gstreamer-audio-effects
168
169 %description -n gstreamer-audio-effects-bad
170 Bad GStreamer audio effects plugins.
171
172 %description -n gstreamer-audio-effects-bad -l pl.UTF-8
173 Złe wtyczki efektów dźwiękowych do GStreamera.
174
175 %package -n gstreamer-audiosink-alsaspdif
176 Summary:        GStreamer ALSA plugin for S/PDIF output
177 Summary(pl.UTF-8):      Wtyczka ALSA GStreamera do wyjścia S/PDIF
178 Group:          Libraries
179 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
180 Provides:       gstreamer-audiosink = %{version}
181
182 %description -n gstreamer-audiosink-alsaspdif
183 GStreamer ALSA plugin for S/PDIF output.
184
185 %description -n gstreamer-audiosink-alsaspdif -l pl.UTF-8
186 Wtyczka ALSA GStreamera do wyjścia S/PDIF.
187
188 %package -n gstreamer-audiosink-nas
189 Summary:        GStreamer NAS audio output plugin
190 Summary(pl.UTF-8):      Wtyczka wyjścia dźwięku NAS dla GStreamera
191 Group:          Libraries
192 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
193 Provides:       gstreamer-audiosink = %{version}
194
195 %description -n gstreamer-audiosink-nas
196 GStreamer NAS audio output plugin.
197
198 %description -n gstreamer-audiosink-nas -l pl.UTF-8
199 Wtyczka wyjścia dźwięku NAS dla GStreamera.
200
201 %package -n gstreamer-cdaudio
202 Summary:        GStreamer plugin for CD audio input using libcdaudio
203 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdaudio
204 Group:          Libraries
205 Requires:       gstreamer >= %{gst_req_ver}
206
207 %description -n gstreamer-cdaudio
208 Plugin for playing audio tracks using libcdaudio under GStreamer.
209
210 %description -n gstreamer-cdaudio -l pl.UTF-8
211 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
212 libcdaudio.
213
214 %package -n gstreamer-divx
215 Summary:        GStreamer divx plugin
216 Summary(pl.UTF-8):      Wtyczka divx do GStreamera
217 Group:          Libraries
218 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
219
220 %description -n gstreamer-divx
221 GStreamer divx plugin.
222
223 %description -n gstreamer-divx -l pl.UTF-8
224 Wtyczka divx do GStreamera.
225
226 %package -n gstreamer-dts
227 Summary:        GStreamer DTS plugin
228 Summary(pl.UTF-8):      Wtyczka DTS do GStreamera
229 Group:          Libraries
230 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
231
232 %description -n gstreamer-dts
233 Plugin for DTS Coherent Acoustics support.
234
235 %description -n gstreamer-dts -l pl.UTF-8
236 Wtyczka do GStreamera obsługująca DTS Coherent Acoustics.
237
238 %package -n gstreamer-gsm
239 Summary:        GStreamer plugin for GSM lossy audio format
240 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca stratny format dźwięku GSM
241 Group:          Libraries
242 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
243
244 %description -n gstreamer-gsm
245 Output plugin for GStreamer to convert to GSM lossy audio format.
246
247 %description -n gstreamer-gsm -l pl.UTF-8
248 Wtyczka wyjścia dźwięku GSteamera konwertująca do stratnego formatu
249 GSM.
250
251 %package -n gstreamer-imagesink-gl
252 Summary:        GStreamer plugin for outputing to OpenGL
253 Summary(pl.UTF-8):      Wtyczka wyjścia OpenGL do GStreamera
254 Group:          Libraries
255 Requires:       gstreamer >= %{gst_req_ver}
256 Provides:       gstreamer-imagesink = %{version}
257
258 %description -n gstreamer-imagesink-gl
259 GStreamer plugin for outputing to OpenGL.
260
261 %description -n gstreamer-imagesink-gl -l pl.UTF-8
262 Wtyczka wyjścia OpenGL do GStreamera.
263
264 %package -n gstreamer-jack
265 Summary:        GStreamer plugin for the JACK Sound Server
266 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
267 Group:          Libraries
268 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
269 Provides:       gstreamer-audiosink = %{version}
270
271 %description -n gstreamer-jack
272 Plugin for the JACK professional sound server.
273
274 %description -n gstreamer-jack -l pl.UTF-8
275 Wtyczka dla profesjonalnego serwera dźwięku JACK.
276
277 %package -n gstreamer-ladspa
278 Summary:        GStreamer wrapper for LADSPA plugins
279 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
280 Group:          Libraries
281 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
282
283 %description -n gstreamer-ladspa
284 Plugin which wraps LADSPA plugins for use by GStreamer applications.
285
286 %description -n gstreamer-ladspa -l pl.UTF-8
287 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
288 GStreamera.
289
290 %package -n gstreamer-mjpegtools
291 Summary:        GStreamer mpeg2enc plugin
292 Summary(pl.UTF-8):      Wtyczka mpeg2enc do GStreamera
293 Group:          Libraries
294
295 %description -n gstreamer-mjpegtools
296 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
297
298 %description -n gstreamer-mjpegtools -l pl.UTF-8
299 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
300
301 %package -n gstreamer-mms
302 Summary:        GStreamer mms plugin
303 Summary(pl.UTF-8):      Wtyczka mms do GStreamera
304 Group:          Libraries
305 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
306
307 %description -n gstreamer-mms
308 GStreamer mms plugin.
309
310 %description -n gstreamer-mms -l pl.UTF-8
311 Wtyczka mms do GStreamera.
312
313 %package -n gstreamer-musepack
314 Summary:        GStreamer musepack plugin
315 Summary(pl.UTF-8):      Wtyczka musepack do GStreamera
316 Group:          Libraries
317 Requires:       gstreamer >= %{gst_req_ver}
318
319 %description -n gstreamer-musepack
320 GStreamer musepack plugin.
321
322 %description -n gstreamer-musepack -l pl.UTF-8
323 Wtyczka musepack do GStreamera.
324
325 %package -n gstreamer-mythtv
326 Summary:        GStreamer MythTV plugin
327 Summary(pl.UTF-8):      Wtyczka MythTV do GStreamera
328 Group:          Libraries
329 Requires:       gstreamer >= %{gst_req_ver}
330
331 %description -n gstreamer-mythtv
332 GStreamer MythTV plugin.
333
334 %description -n gstreamer-mythtv -l pl.UTF-8
335 Wtyczka MythTV do GStreamera.
336
337 %package -n gstreamer-musicbrainz
338 Summary:        GStreamer musicbrainz plugin
339 Summary(pl.UTF-8):      Wtyczka musicbrainz do GStreamera
340 Group:          Libraries
341 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
342
343 %description -n gstreamer-musicbrainz
344 GStreamer musicbrainz plugin - a TRM signature producer.
345
346 %description -n gstreamer-musicbrainz -l pl.UTF-8
347 Wtyczka musicbrainz do GStreamera, tworząca sygnatury TRM.
348
349 %package -n gstreamer-neon
350 Summary:        GStreamer neon HTTP source plugin
351 Summary(pl.UTF-8):      Wtyczka źródła HTTP neon do GStreamera
352 Group:          Libraries
353 Requires:       gstreamer >= %{gst_req_ver}
354
355 %description -n gstreamer-neon
356 GStreamer neon HTTP source plugin.
357
358 %description -n gstreamer-neon -l pl.UTF-8
359 Wtyczka źródła HTTP neon do GStreamera.
360
361 %package -n gstreamer-soundtouch
362 Summary:        GStreamer soundtouch plugin
363 Summary(pl.UTF-8):      Wtyczka soundtouch do GStreamera
364 Group:          Libraries
365 Requires:       gstreamer >= %{gst_req_ver}
366
367 %description -n gstreamer-soundtouch
368 GStreamer soundtouch source plugin - audio pitch controller.
369
370 %description -n gstreamer-soundtouch -l pl.UTF-8
371 Wtyczka soundtouch do GStreamera, sterująca wysokością dźwięku.
372
373 %package -n gstreamer-sndfile
374 Summary:        GStreamer sndfile plugin
375 Summary(pl.UTF-8):      Wtyczka sndfile do GStreamera
376 Group:          Libraries
377 Requires:       gstreamer >= %{gst_req_ver}
378
379 %description -n gstreamer-sndfile
380 GStreamer sndfile source plugin.
381
382 %description -n gstreamer-sndfile -l pl.UTF-8
383 Wtyczka sndfile do GStreamera.
384
385 %package -n gstreamer-spc
386 Summary:        GStreamer SPC plugin
387 Summary(pl.UTF-8):      Wtyczka SPC dla GStreamera
388 Group:          Libraries
389 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
390 Requires:       libopenspc >= 0.3.99
391
392 %description -n gstreamer-spc
393 GStreamer Plugin for playing SPC files using OpenSPC library.
394
395 %description -n gstreamer-spc -l pl.UTF-8
396 Wtyczka GStreamera odtwarzająca pliki SPC przy użyciu biblioteki
397 OpenSPC.
398
399 %package -n gstreamer-swfdec
400 Summary:        GStreamer Flash redering plugin
401 Summary(pl.UTF-8):      Wtyczka renderująca animacje flash dla GStreamera
402 Group:          Libraries
403 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
404 Requires:       swfdec >= 0.3.6
405
406 %description -n gstreamer-swfdec
407 Plugin for rendering Flash animations using swfdec library.
408
409 %description -n gstreamer-swfdec -l pl.UTF-8
410 Wtyczka renderująca animacje flash w oparciu o bibliotekę swfdec.
411
412 %package -n gstreamer-timidity
413 Summary:        timidity plugin for GStreamer
414 Summary(pl.UTF-8):      Wtyczka timidity do GStreamera
415 Group:          Libraries
416 Requires:       gstreamer >= %{gst_req_ver}
417
418 %description -n gstreamer-timidity
419 timidity plugin for GStreamer.
420
421 %description -n gstreamer-timidity -l pl.UTF-8
422 Wtyczka timidity do GStreamera.
423
424 %package -n gstreamer-videosink-sdl
425 Summary:        GStreamer plugin for outputing to SDL
426 Summary(pl.UTF-8):      Wtyczka wyjścia SDL do GStreamera
427 Group:          Libraries
428 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
429 Provides:       gstreamer-videosink = %{version}
430 Obsoletes:      gstreamer-SDL
431
432 %description -n gstreamer-videosink-sdl
433 Plugin for sending output to the Simple Direct Media architecture.
434 (http://www.libsdl.org/). Usefull for fullscreen playback.
435
436 %description -n gstreamer-videosink-sdl -l pl.UTF-8
437 Wtyczka przekazująca wyjście do architektury SDL. Użyteczna do
438 odtwarzania na pełnym ekranie.
439
440 %package -n gstreamer-videosink-directfb
441 Summary:        GStreamer DirectFB output plugin
442 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu DirectFB do GStreamera
443 Group:          Libraries
444 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
445 Provides:       gstreamer-videosink = %{version}
446
447 %description -n gstreamer-videosink-directfb
448 GStreamer DirectFB output plugin.
449
450 %description -n gstreamer-videosink-directfb -l pl.UTF-8
451 Wtyczka wyjścia obrazu DirectFB do GStreamera.
452
453 %package -n gstreamer-wildmidi
454 Summary:        wildmidi plugin for GStreamer
455 Summary(pl.UTF-8):      Wtyczka wildmidi do GStreamera
456 Group:          Libraries
457 Requires:       gstreamer >= %{gst_req_ver}
458
459 %description -n gstreamer-wildmidi
460 wildmidi plugin for GStreamer.
461
462 %description -n gstreamer-wildmidi -l pl.UTF-8
463 Wtyczka wildmidi do GStreamera.
464
465 %package -n gstreamer-xvid
466 Summary:        GStreamer xvid decoder plugin
467 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid
468 Group:          Libraries
469 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
470
471 %description -n gstreamer-xvid
472 GStreamer xvid decoder plugin.
473
474 %description -n gstreamer-xvid -l pl.UTF-8
475 Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid.
476
477 %package -n gstreamer-x264
478 Summary:        GStreamer x264 decoder plugin
479 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264
480 Group:          Libraries
481 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
482
483 %description -n gstreamer-x264
484 GStreamer x264 decoder plugin.
485
486 %description -n gstreamer-x264 -l pl.UTF-8
487 Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264.
488
489 %prep
490 %setup -q -n %{gstname}-%{version}
491 %patch0 -p1
492 %patch1 -p1
493 %patch2 -p1
494 %patch3 -p1
495 %patch4 -p1
496 %patch5 -p1
497
498 %build
499 %{__libtoolize}
500 %{__aclocal} -I m4 -I common/m4
501 %{__autoconf}
502 %{__autoheader}
503 %{__automake}
504 %configure \
505         %{!?with_amr:--disable-amrwb} \
506         %{!?with_cdaudio:--disable-cdaudio} \
507         %{!?with_divx4linux:--disable-divx} \
508         %{!?with_dts:--disable-dts} \
509         %{!?with_faad:--disable-faad} \
510         %{!?with_gsm:--disable-gsm} \
511         %{!?with_jack:--disable-jack} \
512         %{!?with_ladspa:--disable-ladspa} \
513         %{!?with_mms:--disable-libmms} \
514         %{!?with_mjpegtools:--disable-mpeg2enc} \
515         %{!?with_musepack:--disable-musepack} \
516         %{!?with_neon:--disable-neon} \
517         %{!?with_sdl:--disable-sdl} \
518         %{!?with_sdl:--disable-sdltest} \
519         %{!?with_spc:--disable-spc} \
520         %{!?with_soup:--disable-soup} \
521         %{!?with_swfdec:--disable-swfdec} \
522         %{!?with_xvid:--disable-xvid} \
523         --disable-dc1394 \
524         --disable-static \
525         --enable-gtk-doc \
526         --with-html-dir=%{_gtkdocdir}
527
528 %{__make}
529
530 %install
531 rm -rf $RPM_BUILD_ROOT
532
533 %{__make} install \
534         DESTDIR=$RPM_BUILD_ROOT
535
536 # We don't need plugins' *.la files
537 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
538
539 %find_lang %{gstname}-%{gst_major_ver}
540
541 %clean
542 rm -rf $RPM_BUILD_ROOT
543
544 %post   -p /sbin/ldconfig
545 %postun -p /sbin/ldconfig
546
547 %files -f %{gstname}-%{gst_major_ver}.lang
548 %defattr(644,root,root,755)
549 %doc AUTHORS ChangeLog NEWS README RELEASE
550 %attr(755,root,root) %{_libdir}/libgstapp-*.so.*.*.*
551 %attr(755,root,root) %ghost %{_libdir}/libgstapp-*.so.0
552 # R: libgstapp-*
553 %attr(755,root,root) %{gstlibdir}/libgstapp.so
554 %attr(755,root,root) %{gstlibdir}/libgstbayer.so
555 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
556 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
557 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
558 # R: gst-plugins-bad locales
559 %attr(755,root,root) %{gstlibdir}/libgstdvb.so
560 %attr(755,root,root) %{gstlibdir}/libgstdvdspu.so
561 %attr(755,root,root) %{gstlibdir}/libgstfbdevsink.so
562 %attr(755,root,root) %{gstlibdir}/libgstfestival.so
563 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
564 %attr(755,root,root) %{gstlibdir}/libgstflvdemux.so
565 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
566 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
567 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
568 %attr(755,root,root) %{gstlibdir}/libgstmetadata.so
569 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
570 %attr(755,root,root) %{gstlibdir}/libgstmpeg4videoparse.so
571 %attr(755,root,root) %{gstlibdir}/libgstmpegtsparse.so
572 %attr(755,root,root) %{gstlibdir}/libgstmpegvideoparse.so
573 %attr(755,root,root) %{gstlibdir}/libgstmve.so
574 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
575 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
576 %attr(755,root,root) %{gstlibdir}/libgstrawparse.so
577 %ifarch %{ix86} %{x8664}
578 %attr(755,root,root) %{gstlibdir}/libgstreal.so
579 %endif
580 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
581 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
582 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
583 %attr(755,root,root) %{gstlibdir}/libgstsdpelem.so
584 %attr(755,root,root) %{gstlibdir}/libgstselector.so
585 %{?with_soup:%attr(755,root,root) %{gstlibdir}/libgstsouphttpsrc.so}
586 %attr(755,root,root) %{gstlibdir}/libgstspeexresample.so
587 %attr(755,root,root) %{gstlibdir}/libgststereo.so
588 %attr(755,root,root) %{gstlibdir}/libgsttta.so
589 %attr(755,root,root) %{gstlibdir}/libgstvcdsrc.so
590 %attr(755,root,root) %{gstlibdir}/libgstvideosignal.so
591 %attr(755,root,root) %{gstlibdir}/libgstvmnc.so
592 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
593 %{_gtkdocdir}/gst-plugins-bad-plugins-*
594
595 %files devel
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_libdir}/libgstapp-*.so
598 %{_libdir}/libgstapp-*.la
599 %{_includedir}/gstreamer-*/gst/app
600
601 ##
602 ## Plugins
603 ##
604
605 %if %{with faad}
606 %files -n gstreamer-aac
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
609 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
610 %endif
611
612 %if %{with amr}
613 %files -n gstreamer-amrwb
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
616 %endif
617
618 %files -n gstreamer-audio-effects-bad
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
621
622 %files -n gstreamer-audiosink-alsaspdif
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
625
626 %files -n gstreamer-audiosink-nas
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{gstlibdir}/libgstnassink.so
629
630 %if %{with cdaudio}
631 %files -n gstreamer-cdaudio
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
634 %endif
635
636 %if %{with divx4linux}
637 %files -n gstreamer-divx
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
640 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
641 %endif
642
643 %if %{with dts}
644 %files -n gstreamer-dts
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
647 %endif
648
649 %if %{with gsm}
650 %files -n gstreamer-gsm
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
653 %endif
654
655 %files -n gstreamer-imagesink-gl
656 %defattr(644,root,root,755)
657 #%attr(755,root,root) %{gstlibdir}/libgstglimagesink.so
658
659 %if %{with jack}
660 %files -n gstreamer-jack
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{gstlibdir}/libgstjack.so
663 %endif
664
665 %if %{with ladspa}
666 %files -n gstreamer-ladspa
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
669 %endif
670
671 %if %{with mjpegtools}
672 %files -n gstreamer-mjpegtools
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
675 %endif
676
677 %if %{with mms}
678 %files -n gstreamer-mms
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{gstlibdir}/libgstmms.so
681 %endif
682
683 %if %{with musepack}
684 %files -n gstreamer-musepack
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
687 %endif
688
689 %files -n gstreamer-musicbrainz
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
692
693 %files -n gstreamer-mythtv
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{gstlibdir}/libgstmythtvsrc.so
696
697 %if %{with neon}
698 %files -n gstreamer-neon
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
701 %endif
702
703 %files -n gstreamer-soundtouch
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{gstlibdir}/libgstsoundtouch.so
706
707 %files -n gstreamer-sndfile
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{gstlibdir}/libgstsndfile.so
710
711 %if %{with spc}
712 %files -n gstreamer-spc
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{gstlibdir}/libgstspc.so
715 %endif
716
717 %if %{with swfdec}
718 %files -n gstreamer-swfdec
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
721 %endif
722
723 %files -n gstreamer-timidity
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{gstlibdir}/libgsttimidity.so
726
727 %files -n gstreamer-wildmidi
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{gstlibdir}/libgstwildmidi.so
730
731 %if %{with sdl}
732 %files -n gstreamer-videosink-sdl
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{gstlibdir}/libgstsdl.so
735 %endif
736
737 %if %{with directfb}
738 %files -n gstreamer-videosink-directfb
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
741 %endif
742
743 %if %{with xvid}
744 %files -n gstreamer-xvid
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
747 %endif
748
749 %files -n gstreamer-x264
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{gstlibdir}/libgstx264.so
This page took 0.076042 seconds and 4 git commands to generate.