]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
- fixed copy-pastos in gstpb deps
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # new plugins:
3 # - ivorbis (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
4 # - theoradec (BR: libtheora-exp, http://people.xiph.org/~tterribe/doc/libtheora-exp/)
5 # - system libmodplug?
6 #
7 # Conditional build:
8 %bcond_without  cdaudio         # don't build cdaudio plugin
9 %bcond_without  directfb        # don't build directfb videosink plugin
10 %bcond_without  dts             # don't build DTS plugin
11 %bcond_without  faad            # don't build faad plugin
12 %bcond_without  gsm             # don't build gsm plugin
13 %bcond_without  jack            # don't build JACK audio plugin
14 %bcond_without  ladspa          # don't build ladspa plugin
15 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
16 %bcond_without  mms             # don't build mms plugin
17 %bcond_without  musepack        # don't build musepack plugin
18 %bcond_without  neon            # don't build neonhttpsrc plugin
19 %bcond_without  sdl             # don't build sdl plugin
20 %bcond_without  swfdec          # don't build swfdec plugin
21 %bcond_without  spc             # don't build spc plugin
22 %bcond_without  wavpack         # don't build wavpack plugin
23 %bcond_without  xvid            # don't build XviD plugin
24 %bcond_with     amr             # build amrwb plugin
25 %bcond_with     divx4linux      # build divx4linux plugins
26 #
27 %define         gstname         gst-plugins-bad
28 %define         gst_major_ver   0.10
29 %define         gst_req_ver     0.10.10.1
30 #
31 Summary:        Bad GStreamer Streaming-media framework plugins
32 Summary(pl):    Z³e wtyczki do ¶rodowiska obróbki strumieni GStreamer
33 Name:           gstreamer-plugins-bad
34 Version:        0.10.4
35 Release:        1
36 License:        LPL
37 Group:          Libraries
38 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
39 # Source0-md5:  2e57395cdf72733477fb328f1fa3f053
40 Patch0:         %{name}-bashish.patch
41 Patch1:         %{name}-libdts.patch
42 Patch2:         %{name}-divx4linux.patch
43 Patch3:         %{name}-soundtouch.patch
44 Patch4:         %{name}-amrwb.patch
45 Patch5:         %{name}-faad.patch
46 Patch6:         %{name}-link.patch
47 URL:            http://gstreamer.freedesktop.org/
48 BuildRequires:  autoconf >= 2.59-9
49 BuildRequires:  automake >= 1.6
50 BuildRequires:  glib2-devel >= 1:2.12.0
51 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
52 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
53 BuildRequires:  gtk-doc >= 1.6
54 BuildRequires:  liboil-devel >= 0.3.6
55 BuildRequires:  libtool >= 1.4
56 BuildRequires:  pkgconfig >= 1:0.9.0
57 BuildRequires:  rpmbuild(macros) >= 1.98
58 ##
59 ## plugins
60 ##
61 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
62 BuildRequires:  OpenGL-devel
63 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
64 BuildRequires:  alsa-lib-devel >= 0.9.1
65 %{?with_amr:BuildRequires:      amrwb-devel}
66 BuildRequires:  bzip2-devel
67 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
68 BuildRequires:  faac-devel
69 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
70 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
71 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
72 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
73 %{?with_dts:BuildRequires:      libdts-devel}
74 %{?with_gsm:BuildRequires:      libgsm-devel}
75 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
76 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
77 BuildRequires:  libmusicbrainz-devel >= 2.1.0
78 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
79 # for modplug and libSoundTouch
80 BuildRequires:  libstdc++-devel
81 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
82 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
83 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
84 BuildRequires:  soundtouch-devel >= 1.3.1
85 %{?with_swfdec:BuildRequires:   swfdec-devel >= 0.3.6}
86 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.40.0}
87 BuildRequires:  xorg-lib-libX11-devel
88 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
89 Requires:       gstreamer >= %{gst_req_ver}
90 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
91 Obsoletes:      gstreamer-quicktime
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
95
96 %description
97 GStreamer is a streaming-media framework, based on graphs of filters
98 which operate on media data. Applications using this library can do
99 anything from real-time sound processing to playing videos, and just
100 about anything else media-related. Its plugin-based architecture means
101 that new data types or processing capabilities can be added simply by
102 installing new plugins.
103
104 %description -l pl
105 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
106 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
107 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
108 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
109 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
110 nowych typów danych lub mo¿liwo¶ci obróbki.
111
112 ##
113 ## Plugins
114 ##
115
116 %package -n gstreamer-aac
117 Summary:        GStreamer plugin for AAC audio encoding and decoding
118 Summary(pl):    Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
119 Group:          Libraries
120 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
121
122 %description -n gstreamer-aac
123 GStreamer plugin for AAC audio encoding and decoding.
124
125 %description -n gstreamer-aac -l pl
126 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
127
128 %package -n gstreamer-amrwb
129 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
130 Summary(pl):    Wtyczka GStreamera do kodowania i dekodowania d¼wiêku w formacie AMR-WB
131 Group:          Libraries
132 Requires:       gstreamer >= %{gst_req_ver}
133
134 %description -n gstreamer-amrwb
135 GStreamer plugin for AMR-WB audio encoding and decoding.
136
137 %description -n gstreamer-amrwb -l pl
138 Wtyczka GStreamera do kodowania i dekodowania d¼wiêku w formacie
139 AMR-WB.
140
141 %package -n gstreamer-audio-effects-bad
142 Summary:        Bad GStreamer audio effects plugins
143 Summary(pl):    Z³e wtyczki efektów d¼wiêkowych do GStreamera
144 Group:          Libraries
145 Requires:       gstreamer >= %{gst_req_ver}
146 Obsoletes:      gstreamer-audio-effects
147
148 %description -n gstreamer-audio-effects-bad
149 Bad GStreamer audio effects plugins.
150
151 %description -n gstreamer-audio-effects-bad -l pl
152 Z³e wtyczki efektów d¼wiêkowych do GStreamera.
153
154 %package -n gstreamer-audiosink-alsaspdif
155 Summary:        GStreamer ALSA plugin for S/PDIF output
156 Summary(pl):    Wtyczka ALSA GStreamera do wyj¶cia S/PDIF
157 Group:          Libraries
158 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
159 Provides:       gstreamer-audiosink = %{version}
160
161 %description -n gstreamer-audiosink-alsaspdif
162 GStreamer ALSA plugin for S/PDIF output.
163
164 %description -n gstreamer-audiosink-alsaspdif -l pl
165 Wtyczka ALSA GStreamera do wyj¶cia S/PDIF.
166
167 %package -n gstreamer-cdaudio
168 Summary:        GStreamer plugin for CD audio input using libcdaudio
169 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca p³yty CD-Audio przy u¿yciu libcdaudio
170 Group:          Libraries
171 Requires:       gstreamer >= %{gst_req_ver}
172
173 %description -n gstreamer-cdaudio
174 Plugin for playing audio tracks using libcdaudio under GStreamer.
175
176 %description -n gstreamer-cdaudio -l pl
177 Wtyczka do odtwarzania ¶cie¿ek d¼wiêkowych pod GStreamerem za pomoc±
178 libcdaudio.
179
180 %package -n gstreamer-divx
181 Summary:        GStreamer divx plugin
182 Summary(pl):    Wtyczka divx do GStreamera
183 Group:          Libraries
184 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
185
186 %description -n gstreamer-divx
187 GStreamer divx plugin.
188
189 %description -n gstreamer-divx -l pl
190 Wtyczka divx do GStreamera.
191
192 %package -n gstreamer-dts
193 Summary:        GStreamer DTS plugin
194 Summary(pl):    Wtyczka DTS do GStreamera
195 Group:          Libraries
196 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
197
198 %description -n gstreamer-dts
199 Plugin for DTS Coherent Acoustics support.
200
201 %description -n gstreamer-dts -l pl
202 Wtyczka do GStreamera obs³uguj±ca DTS Coherent Acoustics.
203
204 %package -n gstreamer-gsm
205 Summary:        GStreamer plugin for GSM lossy audio format
206 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca stratny format d¼wiêku GSM
207 Group:          Libraries
208 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
209
210 %description -n gstreamer-gsm
211 Output plugin for GStreamer to convert to GSM lossy audio format.
212
213 %description -n gstreamer-gsm -l pl
214 Wtyczka wyj¶cia d¼wiêku GSteamera konwertuj±ca do stratnego formatu
215 GSM.
216
217 %package -n gstreamer-imagesink-gl
218 Summary:        GStreamer plugin for outputing to OpenGL
219 Summary(pl):    Wtyczka wyj¶cia OpenGL do GStreamera
220 Group:          Libraries
221 Requires:       gstreamer >= %{gst_req_ver}
222 Provides:       gstreamer-imagesink = %{version}
223
224 %description -n gstreamer-imagesink-gl
225 GStreamer plugin for outputing to OpenGL.
226
227 %description -n gstreamer-imagesink-gl -l pl
228 Wtyczka wyj¶cia OpenGL do GStreamera.
229
230 %package -n gstreamer-jack
231 Summary:        GStreamer plugin for the JACK Sound Server
232 Summary(pl):    Wtyczka serwera d¼wiêku JACK dla GStreamera
233 Group:          Libraries
234 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
235 Provides:       gstreamer-audiosink = %{version}
236
237 %description -n gstreamer-jack
238 Plugin for the JACK professional sound server.
239
240 %description -n gstreamer-jack -l pl
241 Wtyczka dla profesjonalnego serwera d¼wiêku JACK.
242
243 %package -n gstreamer-ladspa
244 Summary:        GStreamer wrapper for LADSPA plugins
245 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
246 Group:          Libraries
247 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
248
249 %description -n gstreamer-ladspa
250 Plugin which wraps LADSPA plugins for use by GStreamer applications.
251
252 %description -n gstreamer-ladspa -l pl
253 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
254 GStreamera.
255
256 %package -n gstreamer-mjpegtools
257 Summary:        GStreamer mpeg2enc plugin
258 Summary(pl):    Wtyczka mpeg2enc do GStreamera
259 Group:          Libraries
260 Requires(post,postun):  %{_bindir}/gst-register-0.8
261
262 %description -n gstreamer-mjpegtools
263 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
264
265 %description -n gstreamer-mjpegtools -l pl
266 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
267
268 %package -n gstreamer-mms
269 Summary:        GStreamer mms plugin
270 Summary(pl):    Wtyczka mms do GStreamera
271 Group:          Libraries
272 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
273
274 %description -n gstreamer-mms
275 GStreamer mms plugin.
276
277 %description -n gstreamer-mms -l pl
278 Wtyczka mms do GStreamera.
279
280 %package -n gstreamer-musepack
281 Summary:        GStreamer musepack plugin
282 Summary(pl):    Wtyczka musepack do GStreamera
283 Group:          Libraries
284 Requires:       gstreamer >= %{gst_req_ver}
285
286 %description -n gstreamer-musepack
287 GStreamer musepack plugin.
288
289 %description -n gstreamer-musepack -l pl
290 Wtyczka musepack do GStreamera.
291
292 %package -n gstreamer-musicbrainz
293 Summary:        GStreamer musicbrainz plugin
294 Summary(pl):    Wtyczka musicbrainz do GStreamera
295 Group:          Libraries
296 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
297
298 %description -n gstreamer-musicbrainz
299 GStreamer musicbrainz plugin - a TRM signature producer.
300
301 %description -n gstreamer-musicbrainz -l pl
302 Wtyczka musicbrainz do GStreamera, tworz±ca sygnatury TRM.
303
304 %package -n gstreamer-neon
305 Summary:        GStreamer neon HTTP source plugin
306 Summary(pl):    Wtyczka ¼ród³a HTTP neon do GStreamera
307 Group:          Libraries
308 Requires:       gstreamer >= %{gst_req_ver}
309
310 %description -n gstreamer-neon
311 GStreamer neon HTTP source plugin.
312
313 %description -n gstreamer-neon -l pl
314 Wtyczka ¼ród³a HTTP neon do GStreamera.
315
316 %package -n gstreamer-soundtouch
317 Summary:        GStreamer soundtouch plugin
318 Summary(pl):    Wtyczka soundtouch do GStreamera
319 Group:          Libraries
320 Requires:       gstreamer >= %{gst_req_ver}
321
322 %description -n gstreamer-soundtouch
323 GStreamer soundtouch source plugin - audio pitch controller.
324
325 %description -n gstreamer-soundtouch -l pl
326 Wtyczka soundtouch do GStreamera, steruj±ca wysoko¶ci± d¼wiêku.
327
328 %package -n gstreamer-spc
329 Summary:        GStreamer SPC plugin
330 Summary(pl):    Wtyczka SPC dla GStreamera
331 Group:          Libraries
332 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
333 Requires:       libopenspc >= 0.3.99
334
335 %description -n gstreamer-spc
336 GStreamer Plugin for playing SPC files using OpenSPC library.
337
338 %description -n gstreamer-spc -l pl
339 Wtyczka GStreamera odtwarzaj±ca pliki SPC przy u¿yciu biblioteki
340 OpenSPC.
341
342 %package -n gstreamer-swfdec
343 Summary:        GStreamer Flash redering plugin
344 Summary(pl):    Wtyczka renderuj±ca animacje flash dla GStreamera
345 Group:          Libraries
346 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
347 Requires:       swfdec >= 0.3.6
348
349 %description -n gstreamer-swfdec
350 Plugin for rendering Flash animations using swfdec library.
351
352 %description -n gstreamer-swfdec -l pl
353 Wtyczka renderuj±ca animacje flash w oparciu o bibliotekê swfdec.
354
355 %package -n gstreamer-videosink-sdl
356 Summary:        GStreamer plugin for outputing to SDL
357 Summary(pl):    Wtyczka wyj¶cia SDL do GStreamera
358 Group:          Libraries
359 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
360 Provides:       gstreamer-videosink = %{version}
361 Obsoletes:      gstreamer-SDL
362
363 %description -n gstreamer-videosink-sdl
364 Plugin for sending output to the Simple Direct Media architecture.
365 (http://www.libsdl.org/). Usefull for fullscreen playback.
366
367 %description -n gstreamer-videosink-sdl -l pl
368 Wtyczka przekazuj±ca wyj¶cie do architektury SDL. U¿yteczna do
369 odtwarzania na pe³nym ekranie.
370
371 %package -n gstreamer-videosink-directfb
372 Summary:        GStreamer DirectFB output plugin
373 Summary(pl):    Wtyczka wyj¶cia obrazu DirectFB do GStreamera
374 Group:          Libraries
375 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
376 Provides:       gstreamer-videosink = %{version}
377
378 %description -n gstreamer-videosink-directfb
379 GStreamer DirectFB output plugin.
380
381 %description -n gstreamer-videosink-directfb -l pl
382 Wtyczka wyj¶cia obrazu DirectFB do GStreamera.
383
384 %package -n gstreamer-wavpack
385 Summary:        GStreamer plugin for Wavpack lossless audio format
386 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku Wavpack
387 Group:          Libraries
388 Requires:       gstreamer >= %{gst_req_ver}
389
390 %description -n gstreamer-wavpack
391 Plugin for lossless Wavpack audio format.
392
393 %description -n gstreamer-wavpack -l pl
394 Wtyczka obs³uguj±ca bezstratny format d¼wiêku Wavpack.
395
396 %package -n gstreamer-xvid
397 Summary:        GStreamer xvid decoder plugin
398 Summary(pl):    Wtyczka do GStreamera dekoduj±ca przy u¿yciu biblioteki xvid
399 Group:          Libraries
400 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
401
402 %description -n gstreamer-xvid
403 GStreamer xvid decoder plugin.
404
405 %description -n gstreamer-xvid -l pl
406 Wtyczka do GStreamera dekoduj±ca przy u¿yciu biblioteki xvid.
407
408 %prep
409 %setup -q -n %{gstname}-%{version}
410 %patch0 -p1
411 %patch1 -p1
412 %patch2 -p1
413 %patch3 -p1
414 %patch4 -p1
415 %patch5 -p1
416 %patch6 -p1
417
418 %build
419 %{__libtoolize}
420 %{__aclocal} -I m4 -I common/m4
421 %{__autoconf}
422 %{__autoheader}
423 %{__automake}
424 %configure \
425         %{!?with_cdaudio:--disable-cdaudio} \
426         %{!?with_divx4linux:--disable-divx} \
427         %{!?with_dts:--disable-dts} \
428         %{!?with_faad:--disable-faad} \
429         %{!?with_gsm:--disable-gsm} \
430         %{!?with_jack:--disable-jack} \
431         %{!?with_ladspa:--disable-ladspa} \
432         %{!?with_mms:--disable-libmms} \
433         %{!?with_mjpegtools:--disable-mpeg2enc} \
434         %{!?with_musepack:--disable-musepack} \
435         %{!?with_neon:--disable-neon} \
436         %{!?with_sdl:--disable-sdl} \
437         %{!?with_sdl:--disable-sdltest} \
438         %{!?with_spc:--disable-spc} \
439         %{!?with_swfdec:--disable-swfdec} \
440         %{!?with_wavpack:--disable-wavpack} \
441         %{!?with_xvid:--disable-xvid} \
442         --disable-static \
443         --enable-gtk-doc \
444         --with-html-dir=%{_gtkdocdir}
445
446 %{__make}
447
448 %install
449 rm -rf $RPM_BUILD_ROOT
450
451 %{__make} install \
452         DESTDIR=$RPM_BUILD_ROOT
453
454 # We don't need plugins' *.la files
455 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
456
457 %find_lang %{gstname}-%{gst_major_ver}
458
459 %clean
460 rm -rf $RPM_BUILD_ROOT
461
462 %files -f %{gstname}-%{gst_major_ver}.lang
463 %defattr(644,root,root,755)
464 %doc AUTHORS ChangeLog NEWS README RELEASE
465 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
466 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
467 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
468 %attr(755,root,root) %{gstlibdir}/libgstdvbsrc.so
469 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
470 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
471 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
472 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
473 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
474 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
475 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
476 %attr(755,root,root) %{gstlibdir}/libgstqtdemux.so
477 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
478 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
479 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
480 %attr(755,root,root) %{gstlibdir}/libgsttta.so
481 %attr(755,root,root) %{gstlibdir}/libgstvideocrop.so
482 %attr(755,root,root) %{gstlibdir}/libgstvideoparse.so
483 %attr(755,root,root) %{gstlibdir}/libgstxingheader.so
484 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
485 %{_gtkdocdir}/gst-plugins-bad-plugins-*
486
487 ##
488 ## Plugins
489 ##
490
491 %if %{with faad}
492 %files -n gstreamer-aac
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
495 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
496 %endif
497
498 %if %{with amr}
499 %files -n gstreamer-amrwb
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
502 %endif
503
504 %files -n gstreamer-audio-effects-bad
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
507
508 %files -n gstreamer-audiosink-alsaspdif
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
511
512 %if %{with cdaudio}
513 %files -n gstreamer-cdaudio
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
516 %endif
517
518 %if %{with divx4linux}
519 %files -n gstreamer-divx
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
522 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
523 %endif
524
525 %if %{with dts}
526 %files -n gstreamer-dts
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
529 %endif
530
531 %if %{with gsm}
532 %files -n gstreamer-gsm
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
535 %endif
536
537 %files -n gstreamer-imagesink-gl
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{gstlibdir}/libgstglimagesink.so
540
541 %if %{with jack}
542 %files -n gstreamer-jack
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{gstlibdir}/libgstjack.so
545 %endif
546
547 %if %{with ladspa}
548 %files -n gstreamer-ladspa
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
551 %endif
552
553 %if %{with mjpegtools}
554 %files -n gstreamer-mjpegtools
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
557 %endif
558
559 %if %{with mms}
560 %files -n gstreamer-mms
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{gstlibdir}/libgstmms.so
563 %endif
564
565 %if %{with musepack}
566 %files -n gstreamer-musepack
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
569 %endif
570
571 %files -n gstreamer-musicbrainz
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
574
575 %if %{with neon}
576 %files -n gstreamer-neon
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
579 %endif
580
581 %files -n gstreamer-soundtouch
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{gstlibdir}/libgstpitch.so
584
585 %if %{with spc}
586 %files -n gstreamer-spc
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{gstlibdir}/libgstspc.so
589 %endif
590
591 %if %{with swfdec}
592 %files -n gstreamer-swfdec
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
595 %endif
596
597 %if %{with sdl}
598 %files -n gstreamer-videosink-sdl
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{gstlibdir}/libgstsdlvideosink.so
601 %endif
602
603 %if %{with directfb}
604 %files -n gstreamer-videosink-directfb
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
607 %endif
608
609 %if %{with wavpack}
610 %files -n gstreamer-wavpack
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
613 %endif
614
615 %if %{with xvid}
616 %files -n gstreamer-xvid
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
619 %endif
This page took 0.174333 seconds and 4 git commands to generate.