]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
- updated to 0.10.8
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # - new plugins:
3 #   - mplex (waiting for mjpegtools 1.9.0)
4 #   - ivorbisdec (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
5 #   - theoraexpdec (BR: libtheora-exp >= 1.0beta3, but currently disabled)
6 # - system libmodplug?
7 #
8 # Conditional build:
9 %bcond_without  cdaudio         # don't build cdaudio plugin
10 %bcond_without  dirac           # don't build Dirac plugin
11 %bcond_without  directfb        # don't build directfb videosink plugin
12 %bcond_without  dts             # don't build DTS plugin
13 %bcond_without  faad            # don't build faad plugin
14 %bcond_without  gsm             # don't build gsm plugin
15 %bcond_without  jack            # don't build JACK audio plugin
16 %bcond_without  ladspa          # don't build ladspa plugin
17 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
18 %bcond_without  mms             # don't build mms plugin
19 %bcond_without  musepack        # don't build musepack plugin
20 %bcond_without  neon            # don't build neonhttpsrc plugin
21 %bcond_without  ofa             # don't build OFA plugin
22 %bcond_without  sdl             # don't build sdl plugin
23 %bcond_with     swfdec          # swfdec plugin
24 %bcond_without  spc             # don't build spc plugin
25 %bcond_without  wavpack         # don't build wavpack plugin
26 %bcond_without  xvid            # don't build XviD plugin
27 %bcond_with     amr             # build amrwb plugin
28 %bcond_with     divx4linux      # build divx4linux plugins
29 #
30 %define         gstname         gst-plugins-bad
31 %define         gst_major_ver   0.10
32 %define         gst_req_ver     0.10.14
33 #
34 Summary:        Bad GStreamer Streaming-media framework plugins
35 Summary(pl.UTF-8):      Złe wtyczki do środowiska obróbki strumieni GStreamer
36 Name:           gstreamer-plugins-bad
37 Version:        0.10.8
38 Release:        1
39 License:        LGPL v2+
40 Group:          Libraries
41 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
42 # Source0-md5:  ddc8f92dab0081f131650ad6c95908b8
43 Patch0:         %{name}-bashish.patch
44 Patch1:         %{name}-libdts.patch
45 Patch2:         %{name}-divx4linux.patch
46 Patch4:         %{name}-timidity.patch
47 Patch5:         %{name}-nas.patch
48 URL:            http://gstreamer.freedesktop.org/
49 BuildRequires:  autoconf >= 2.59-9
50 BuildRequires:  automake >= 1.6
51 BuildRequires:  glib2-devel >= 1:2.12.0
52 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
53 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
54 BuildRequires:  gtk-doc >= 1.6
55 BuildRequires:  liboil-devel >= 0.3.6
56 BuildRequires:  libtool >= 1.4
57 BuildRequires:  pkgconfig >= 1:0.9.0
58 BuildRequires:  python-PyXML
59 BuildRequires:  rpmbuild(macros) >= 1.98
60 ##
61 ## plugins
62 ##
63 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
64 BuildRequires:  OpenGL-devel
65 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
66 BuildRequires:  alsa-lib-devel >= 0.9.1
67 %{?with_amr:BuildRequires:      amrwb-devel}
68 BuildRequires:  bzip2-devel
69 %{?with_dirac:BuildRequires:    dirac-devel >= 0.9}
70 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
71 BuildRequires:  faac-devel
72 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
73 BuildRequires:  gmyth-devel >= 0.7
74 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
75 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
76 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
77 BuildRequires:  libdc1394-devel >= 2.0.0
78 %{?with_dts:BuildRequires:      libdts-devel}
79 BuildRequires:  libdvdnav-devel >= 0.1.7
80 %{?with_gsm:BuildRequires:      libgsm-devel}
81 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
82 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
83 BuildRequires:  libmusicbrainz-devel >= 2.1.0
84 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
85 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
86 # for modplug and libSoundTouch
87 BuildRequires:  libstdc++-devel
88 BuildRequires:  libtimidity-devel
89 BuildRequires:  libx264-devel
90 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
91 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
92 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
93 BuildRequires:  libsndfile-devel
94 BuildRequires:  nas-devel
95 BuildRequires:  soundtouch-devel >= 1.3.1
96 %if %{with swfdec}
97 BuildRequires:  swfdec-devel < 0.4.0
98 BuildRequires:  swfdec-devel >= 0.3.6
99 %endif
100 BuildRequires:  wildmidi-devel
101 BuildRequires:  xorg-lib-libX11-devel
102 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
103 Requires:       gstreamer >= %{gst_req_ver}
104 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
105 Obsoletes:      gstreamer-quicktime
106 Obsoletes:      gstreamer-vcd
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
110
111 %description
112 GStreamer is a streaming-media framework, based on graphs of filters
113 which operate on media data. Applications using this library can do
114 anything from real-time sound processing to playing videos, and just
115 about anything else media-related. Its plugin-based architecture means
116 that new data types or processing capabilities can be added simply by
117 installing new plugins.
118
119 %description -l pl.UTF-8
120 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
121 grafie filtrów operujących na danych medialnych. Aplikacje używające
122 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
123 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
124 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
125 nowych typów danych lub możliwości obróbki.
126
127 %package devel
128 Summary:        Header files and API documentation for gstapp library
129 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API biblioteki gstapp
130 Group:          Development/Libraries
131 Requires:       %{name} = %{version}-%{release}
132
133 %description devel
134 Header files and API documentation for gstapp library.
135
136 %description devel -l pl.UTF-8
137 Pliki nagłówkowe i dokumentacja API biblioteki gstapp.
138
139 ## Plugins ##
140
141 %package -n gstreamer-aac
142 Summary:        GStreamer plugin for AAC audio encoding and decoding
143 Summary(pl.UTF-8):      Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
144 Group:          Libraries
145 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
146
147 %description -n gstreamer-aac
148 GStreamer plugin for AAC audio encoding and decoding.
149
150 %description -n gstreamer-aac -l pl.UTF-8
151 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
152
153 %package -n gstreamer-amrwb
154 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
155 Summary(pl.UTF-8):      Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie AMR-WB
156 Group:          Libraries
157 Requires:       gstreamer >= %{gst_req_ver}
158
159 %description -n gstreamer-amrwb
160 GStreamer plugin for AMR-WB audio encoding and decoding.
161
162 %description -n gstreamer-amrwb -l pl.UTF-8
163 Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie
164 AMR-WB.
165
166 %package -n gstreamer-audio-effects-bad
167 Summary:        Bad GStreamer audio effects plugins
168 Summary(pl.UTF-8):      Złe wtyczki efektów dźwiękowych do GStreamera
169 Group:          Libraries
170 Requires:       gstreamer >= %{gst_req_ver}
171 Obsoletes:      gstreamer-audio-effects
172
173 %description -n gstreamer-audio-effects-bad
174 Bad GStreamer audio effects plugins.
175
176 %description -n gstreamer-audio-effects-bad -l pl.UTF-8
177 Złe wtyczki efektów dźwiękowych do GStreamera.
178
179 %package -n gstreamer-audiosink-alsaspdif
180 Summary:        GStreamer ALSA plugin for S/PDIF output
181 Summary(pl.UTF-8):      Wtyczka ALSA GStreamera do wyjścia S/PDIF
182 Group:          Libraries
183 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
184 Provides:       gstreamer-audiosink = %{version}
185
186 %description -n gstreamer-audiosink-alsaspdif
187 GStreamer ALSA plugin for S/PDIF output.
188
189 %description -n gstreamer-audiosink-alsaspdif -l pl.UTF-8
190 Wtyczka ALSA GStreamera do wyjścia S/PDIF.
191
192 %package -n gstreamer-audiosink-nas
193 Summary:        GStreamer NAS audio output plugin
194 Summary(pl.UTF-8):      Wtyczka wyjścia dźwięku NAS dla GStreamera
195 Group:          Libraries
196 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
197 Provides:       gstreamer-audiosink = %{version}
198 Obsoletes:      gstreamer-nas
199
200 %description -n gstreamer-audiosink-nas
201 GStreamer NAS audio output plugin.
202
203 %description -n gstreamer-audiosink-nas -l pl.UTF-8
204 Wtyczka wyjścia dźwięku NAS dla GStreamera.
205
206 %package -n gstreamer-cdaudio
207 Summary:        GStreamer plugin for CD audio input using libcdaudio
208 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdaudio
209 Group:          Libraries
210 Requires:       gstreamer >= %{gst_req_ver}
211
212 %description -n gstreamer-cdaudio
213 Plugin for playing audio tracks using libcdaudio under GStreamer.
214
215 %description -n gstreamer-cdaudio -l pl.UTF-8
216 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
217 libcdaudio.
218
219 %package -n gstreamer-dc1394
220 Summary:        GStreamer 1394 IIDC (Firewire digital cameras) video source plugin
221 Summary(pl.UTF-8):      Wtyczka źródła obrazu 1394 IIDC (z kamer cyfrowych Firewire) do GStreamera
222 Group:          Libraries
223 Requires:       gstreamer >= %{gst_req_ver}
224
225 %description -n gstreamer-dc1394
226 GStreamer 1394 IIDC (Firewire digital cameras) video source plugin.
227
228 %description -n gstreamer-dc1394 -l pl.UTF-8
229 Wtyczka źródła obrazu 1394 IIDC (z kamer cyfrowych Firewire) do GStreamera.
230
231 %package -n gstreamer-dirac
232 Summary:        GStreamer Dirac plugin
233 Summary(pl.UTF-8):      Wtyczka Dirac do GStreamera
234 Group:          Libraries
235 Requires:       gstreamer >= %{gst_req_ver}
236 Requires:       dirac >= 0.9
237
238 %description -n gstreamer-dirac
239 GStreamer Dirac video decoder/encoder plugin.
240
241 %description -n gstreamer-dirac -l pl.UTF-8
242 Wtyczka dekodująca i kodująca obraz Dirac do GStreamera.
243
244 %package -n gstreamer-divx
245 Summary:        GStreamer divx plugin
246 Summary(pl.UTF-8):      Wtyczka divx do GStreamera
247 Group:          Libraries
248 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
249
250 %description -n gstreamer-divx
251 GStreamer divx plugin.
252
253 %description -n gstreamer-divx -l pl.UTF-8
254 Wtyczka divx do GStreamera.
255
256 %package -n gstreamer-dts
257 Summary:        GStreamer DTS plugin
258 Summary(pl.UTF-8):      Wtyczka DTS do GStreamera
259 Group:          Libraries
260 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
261
262 %description -n gstreamer-dts
263 Plugin for DTS Coherent Acoustics support.
264
265 %description -n gstreamer-dts -l pl.UTF-8
266 Wtyczka do GStreamera obsługująca DTS Coherent Acoustics.
267
268 %package -n gstreamer-gsm
269 Summary:        GStreamer plugin for GSM lossy audio format
270 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca stratny format dźwięku GSM
271 Group:          Libraries
272 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
273
274 %description -n gstreamer-gsm
275 Output plugin for GStreamer to convert to GSM lossy audio format.
276
277 %description -n gstreamer-gsm -l pl.UTF-8
278 Wtyczka wyjścia dźwięku GSteamera konwertująca do stratnego formatu
279 GSM.
280
281 %package -n gstreamer-jack
282 Summary:        GStreamer plugin for the JACK Sound Server
283 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
284 Group:          Libraries
285 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
286 Provides:       gstreamer-audiosink = %{version}
287
288 %description -n gstreamer-jack
289 Plugin for the JACK professional sound server.
290
291 %description -n gstreamer-jack -l pl.UTF-8
292 Wtyczka dla profesjonalnego serwera dźwięku JACK.
293
294 %package -n gstreamer-ladspa
295 Summary:        GStreamer wrapper for LADSPA plugins
296 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
297 Group:          Libraries
298 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
299
300 %description -n gstreamer-ladspa
301 Plugin which wraps LADSPA plugins for use by GStreamer applications.
302
303 %description -n gstreamer-ladspa -l pl.UTF-8
304 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
305 GStreamera.
306
307 %package -n gstreamer-mjpegtools
308 Summary:        GStreamer mpeg2enc plugin
309 Summary(pl.UTF-8):      Wtyczka mpeg2enc do GStreamera
310 Group:          Libraries
311
312 %description -n gstreamer-mjpegtools
313 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
314
315 %description -n gstreamer-mjpegtools -l pl.UTF-8
316 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
317
318 %package -n gstreamer-mms
319 Summary:        GStreamer mms plugin
320 Summary(pl.UTF-8):      Wtyczka mms do GStreamera
321 Group:          Libraries
322 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
323
324 %description -n gstreamer-mms
325 GStreamer mms plugin.
326
327 %description -n gstreamer-mms -l pl.UTF-8
328 Wtyczka mms do GStreamera.
329
330 %package -n gstreamer-musepack
331 Summary:        GStreamer musepack plugin
332 Summary(pl.UTF-8):      Wtyczka musepack do GStreamera
333 Group:          Libraries
334 Requires:       gstreamer >= %{gst_req_ver}
335
336 %description -n gstreamer-musepack
337 GStreamer musepack plugin.
338
339 %description -n gstreamer-musepack -l pl.UTF-8
340 Wtyczka musepack do GStreamera.
341
342 %package -n gstreamer-mythtv
343 Summary:        GStreamer MythTV plugin
344 Summary(pl.UTF-8):      Wtyczka MythTV do GStreamera
345 Group:          Libraries
346 Requires:       gstreamer >= %{gst_req_ver}
347
348 %description -n gstreamer-mythtv
349 GStreamer MythTV plugin.
350
351 %description -n gstreamer-mythtv -l pl.UTF-8
352 Wtyczka MythTV do GStreamera.
353
354 %package -n gstreamer-musicbrainz
355 Summary:        GStreamer musicbrainz plugin
356 Summary(pl.UTF-8):      Wtyczka musicbrainz do GStreamera
357 Group:          Libraries
358 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
359
360 %description -n gstreamer-musicbrainz
361 GStreamer musicbrainz plugin - a TRM signature producer.
362
363 %description -n gstreamer-musicbrainz -l pl.UTF-8
364 Wtyczka musicbrainz do GStreamera, tworząca sygnatury TRM.
365
366 %package -n gstreamer-neon
367 Summary:        GStreamer neon HTTP source plugin
368 Summary(pl.UTF-8):      Wtyczka źródła HTTP neon do GStreamera
369 Group:          Libraries
370 Requires:       gstreamer >= %{gst_req_ver}
371
372 %description -n gstreamer-neon
373 GStreamer neon HTTP source plugin.
374
375 %description -n gstreamer-neon -l pl.UTF-8
376 Wtyczka źródła HTTP neon do GStreamera.
377
378 %package -n gstreamer-ofa
379 Summary:        GStreamer OFA fingerprint plugin
380 Summary(pl.UTF-8):      Wtyczka odcisków OFA do GStreamera
381 Group:          Libraries
382 Requires:       gstreamer >= %{gst_req_ver}
383 Requires:       libofa >= 0.9.3
384
385 %description -n gstreamer-ofa
386 GStreamer OFA plugin to calculate MusicIP fingerprints from audio
387 files.
388
389 %description -n gstreamer-ofa -l pl.UTF-8
390 Wtyczka OFA do GStreamera służąca do obliczania odcisków MusicIP
391 plików dźwiękowych.
392
393 %package -n gstreamer-oss4
394 Summary:        GStreamer OSS 4 audio sink, source and mixer plugin
395 Summary(pl.UTF-8):      Wtyczka wyjścia, wejścia i miksera dźwięku OSS 4 do GStreamera
396 Group:          Libraries
397 # for locales (when added to POTFILES)
398 #Requires:      %{name} = %{version}-%{release}
399 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
400 Provides:       gstreamer-audiosink = %{version}
401
402 %description -n gstreamer-oss4
403 GStreamer OSS (Open Sound System) 4 audio input/output/mixer plugin.
404
405 %description -n gstreamer-oss4 -l pl.UTF-8
406 Wtyczka wejścia/wyjścia/miksera dźwięku OSS (Open Sound System) 4 do
407 GStreamera.
408
409 %package -n gstreamer-resindvd
410 Summary:        GStreamer Resin DVD playback plugin
411 Summary(pl.UTF-8):      Wtyczka odtwarzania Resin DVD do GStreamera
412 Group:          Libraries
413 Requires:       gstreamer >= %{gst_req_ver}
414
415 %description -n gstreamer-resindvd
416 GStreamer Resin DVD playback plugin.
417
418 %description -n gstreamer-resindvd -l pl.UTF-8
419 Wtyczka odtwarzania Resin DVD do GStreamera.
420
421 %package -n gstreamer-soundtouch
422 Summary:        GStreamer soundtouch plugin
423 Summary(pl.UTF-8):      Wtyczka soundtouch do GStreamera
424 Group:          Libraries
425 Requires:       gstreamer >= %{gst_req_ver}
426
427 %description -n gstreamer-soundtouch
428 GStreamer soundtouch source plugin - audio pitch controller.
429
430 %description -n gstreamer-soundtouch -l pl.UTF-8
431 Wtyczka soundtouch do GStreamera, sterująca wysokością dźwięku.
432
433 %package -n gstreamer-sndfile
434 Summary:        GStreamer sndfile plugin
435 Summary(pl.UTF-8):      Wtyczka sndfile do GStreamera
436 Group:          Libraries
437 # for locales
438 Requires:       %{name} = %{version}-%{release}
439 Requires:       gstreamer >= %{gst_req_ver}
440
441 %description -n gstreamer-sndfile
442 GStreamer sndfile source plugin.
443
444 %description -n gstreamer-sndfile -l pl.UTF-8
445 Wtyczka sndfile do GStreamera.
446
447 %package -n gstreamer-spc
448 Summary:        GStreamer SPC plugin
449 Summary(pl.UTF-8):      Wtyczka SPC dla GStreamera
450 Group:          Libraries
451 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
452 Requires:       libopenspc >= 0.3.99
453
454 %description -n gstreamer-spc
455 GStreamer Plugin for playing SPC files using OpenSPC library.
456
457 %description -n gstreamer-spc -l pl.UTF-8
458 Wtyczka GStreamera odtwarzająca pliki SPC przy użyciu biblioteki
459 OpenSPC.
460
461 %package -n gstreamer-swfdec
462 Summary:        GStreamer Flash redering plugin
463 Summary(pl.UTF-8):      Wtyczka renderująca animacje flash dla GStreamera
464 Group:          Libraries
465 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
466 Requires:       swfdec >= 0.3.6
467
468 %description -n gstreamer-swfdec
469 Plugin for rendering Flash animations using swfdec library.
470
471 %description -n gstreamer-swfdec -l pl.UTF-8
472 Wtyczka renderująca animacje flash w oparciu o bibliotekę swfdec.
473
474 %package -n gstreamer-timidity
475 Summary:        timidity plugin for GStreamer
476 Summary(pl.UTF-8):      Wtyczka timidity do GStreamera
477 Group:          Libraries
478 Requires:       gstreamer >= %{gst_req_ver}
479
480 %description -n gstreamer-timidity
481 timidity plugin for GStreamer.
482
483 %description -n gstreamer-timidity -l pl.UTF-8
484 Wtyczka timidity do GStreamera.
485
486 %package -n gstreamer-videosink-sdl
487 Summary:        GStreamer plugin for outputing to SDL
488 Summary(pl.UTF-8):      Wtyczka wyjścia SDL do GStreamera
489 Group:          Libraries
490 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
491 Provides:       gstreamer-videosink = %{version}
492 Obsoletes:      gstreamer-SDL
493
494 %description -n gstreamer-videosink-sdl
495 Plugin for sending output to the Simple Direct Media architecture.
496 (http://www.libsdl.org/). Usefull for fullscreen playback.
497
498 %description -n gstreamer-videosink-sdl -l pl.UTF-8
499 Wtyczka przekazująca wyjście do architektury SDL. Użyteczna do
500 odtwarzania na pełnym ekranie.
501
502 %package -n gstreamer-videosink-directfb
503 Summary:        GStreamer DirectFB output plugin
504 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu DirectFB do GStreamera
505 Group:          Libraries
506 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
507 Provides:       gstreamer-videosink = %{version}
508
509 %description -n gstreamer-videosink-directfb
510 GStreamer DirectFB output plugin.
511
512 %description -n gstreamer-videosink-directfb -l pl.UTF-8
513 Wtyczka wyjścia obrazu DirectFB do GStreamera.
514
515 %package -n gstreamer-wildmidi
516 Summary:        wildmidi plugin for GStreamer
517 Summary(pl.UTF-8):      Wtyczka wildmidi do GStreamera
518 Group:          Libraries
519 Requires:       gstreamer >= %{gst_req_ver}
520
521 %description -n gstreamer-wildmidi
522 wildmidi plugin for GStreamer.
523
524 %description -n gstreamer-wildmidi -l pl.UTF-8
525 Wtyczka wildmidi do GStreamera.
526
527 %package -n gstreamer-xvid
528 Summary:        GStreamer xvid decoder plugin
529 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid
530 Group:          Libraries
531 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
532
533 %description -n gstreamer-xvid
534 GStreamer xvid decoder plugin.
535
536 %description -n gstreamer-xvid -l pl.UTF-8
537 Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid.
538
539 %package -n gstreamer-x264
540 Summary:        GStreamer x264 decoder plugin
541 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264
542 Group:          Libraries
543 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
544
545 %description -n gstreamer-x264
546 GStreamer x264 decoder plugin.
547
548 %description -n gstreamer-x264 -l pl.UTF-8
549 Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264.
550
551 %prep
552 %setup -q -n %{gstname}-%{version}
553 %patch0 -p1
554 %patch1 -p1
555 %patch2 -p1
556 %patch4 -p1
557 %patch5 -p1
558
559 %build
560 %{__libtoolize}
561 %{__aclocal} -I m4 -I common/m4
562 %{__autoconf}
563 %{__autoheader}
564 %{__automake}
565 %configure \
566         %{!?with_amr:--disable-amrwb} \
567         %{!?with_cdaudio:--disable-cdaudio} \
568         %{!?with_divx4linux:--disable-divx} \
569         %{!?with_dirac:--disable-dirac} \
570         %{!?with_dts:--disable-dts} \
571         %{!?with_faad:--disable-faad} \
572         %{!?with_gsm:--disable-gsm} \
573         %{!?with_jack:--disable-jack} \
574         %{!?with_ladspa:--disable-ladspa} \
575         %{!?with_mms:--disable-libmms} \
576         %{!?with_mjpegtools:--disable-mpeg2enc} \
577         %{!?with_musepack:--disable-musepack} \
578         %{!?with_neon:--disable-neon} \
579         %{!?with_ofa:--disable-ofa} \
580         %{!?with_sdl:--disable-sdl} \
581         %{!?with_sdl:--disable-sdltest} \
582         %{!?with_spc:--disable-spc} \
583         %{!?with_swfdec:--disable-swfdec} \
584         %{!?with_xvid:--disable-xvid} \
585         --disable-static \
586         --enable-experimental \
587         --enable-gtk-doc \
588         --with-html-dir=%{_gtkdocdir}
589
590 %{__make}
591
592 %install
593 rm -rf $RPM_BUILD_ROOT
594
595 %{__make} install \
596         DESTDIR=$RPM_BUILD_ROOT
597
598 # We don't need plugins' *.la files
599 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
600
601 %find_lang %{gstname}-%{gst_major_ver}
602
603 %clean
604 rm -rf $RPM_BUILD_ROOT
605
606 %post   -p /sbin/ldconfig
607 %postun -p /sbin/ldconfig
608
609 %files -f %{gstname}-%{gst_major_ver}.lang
610 %defattr(644,root,root,755)
611 %doc AUTHORS ChangeLog NEWS README RELEASE
612 %attr(755,root,root) %{_libdir}/libgstapp-*.so.*.*.*
613 %attr(755,root,root) %ghost %{_libdir}/libgstapp-*.so.0
614 # R: libgstapp-*
615 %attr(755,root,root) %{gstlibdir}/libgstapp.so
616 %attr(755,root,root) %{gstlibdir}/libgstbayer.so
617 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
618 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
619 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
620 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace2.so
621 # R: gst-plugins-bad locales
622 %attr(755,root,root) %{gstlibdir}/libgstdvb.so
623 %attr(755,root,root) %{gstlibdir}/libgstdvdspu.so
624 %attr(755,root,root) %{gstlibdir}/libgstfbdevsink.so
625 %attr(755,root,root) %{gstlibdir}/libgstfestival.so
626 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
627 %attr(755,root,root) %{gstlibdir}/libgstflvdemux.so
628 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
629 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
630 %attr(755,root,root) %{gstlibdir}/libgstmetadata.so
631 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
632 %attr(755,root,root) %{gstlibdir}/libgstmpeg4videoparse.so
633 %attr(755,root,root) %{gstlibdir}/libgstmpegtsparse.so
634 %attr(755,root,root) %{gstlibdir}/libgstmpegvideoparse.so
635 %attr(755,root,root) %{gstlibdir}/libgstmve.so
636 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
637 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
638 %attr(755,root,root) %{gstlibdir}/libgstrawparse.so
639 %ifarch %{ix86} %{x8664}
640 %attr(755,root,root) %{gstlibdir}/libgstreal.so
641 %endif
642 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
643 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
644 %attr(755,root,root) %{gstlibdir}/libgstsdpelem.so
645 %attr(755,root,root) %{gstlibdir}/libgstselector.so
646 %attr(755,root,root) %{gstlibdir}/libgstspeexresample.so
647 %attr(755,root,root) %{gstlibdir}/libgststereo.so
648 %attr(755,root,root) %{gstlibdir}/libgstsubenc.so
649 %attr(755,root,root) %{gstlibdir}/libgsttta.so
650 %attr(755,root,root) %{gstlibdir}/libgstvcdsrc.so
651 %attr(755,root,root) %{gstlibdir}/libgstvideosignal.so
652 %attr(755,root,root) %{gstlibdir}/libgstvmnc.so
653 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
654 %{_gtkdocdir}/gst-plugins-bad-plugins-*
655
656 %files devel
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libgstapp-*.so
659 %{_libdir}/libgstapp-*.la
660 %{_includedir}/gstreamer-*/gst/app
661
662 ##
663 ## Plugins
664 ##
665
666 %if %{with faad}
667 %files -n gstreamer-aac
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
670 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
671 %endif
672
673 %if %{with amr}
674 %files -n gstreamer-amrwb
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
677 %endif
678
679 %files -n gstreamer-audio-effects-bad
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
682
683 %files -n gstreamer-audiosink-alsaspdif
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
686
687 %files -n gstreamer-audiosink-nas
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{gstlibdir}/libgstnassink.so
690
691 %if %{with cdaudio}
692 %files -n gstreamer-cdaudio
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
695 %endif
696
697 %files -n gstreamer-dc1394
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{gstlibdir}/libgstdc1394.so
700
701 %if %{with dirac}
702 %files -n gstreamer-dirac
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{gstlibdir}/libgstdirac.so
705 %endif
706
707 %if %{with divx4linux}
708 %files -n gstreamer-divx
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
711 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
712 %endif
713
714 %if %{with dts}
715 %files -n gstreamer-dts
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
718 %endif
719
720 %if %{with gsm}
721 %files -n gstreamer-gsm
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
724 %endif
725
726 %if %{with jack}
727 %files -n gstreamer-jack
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{gstlibdir}/libgstjack.so
730 %endif
731
732 %if %{with ladspa}
733 %files -n gstreamer-ladspa
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
736 %endif
737
738 %if %{with mjpegtools}
739 %files -n gstreamer-mjpegtools
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
742 %endif
743
744 %if %{with mms}
745 %files -n gstreamer-mms
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{gstlibdir}/libgstmms.so
748 %endif
749
750 %if %{with musepack}
751 %files -n gstreamer-musepack
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
754 %endif
755
756 %files -n gstreamer-musicbrainz
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
759
760 %files -n gstreamer-mythtv
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{gstlibdir}/libgstmythtvsrc.so
763
764 %if %{with neon}
765 %files -n gstreamer-neon
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
768 %endif
769
770 %if %{with ofa}
771 %files -n gstreamer-ofa
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{gstlibdir}/libgstofa.so
774 %endif
775
776 %files -n gstreamer-oss4
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{gstlibdir}/libgstoss4audio.so
779
780 %files -n gstreamer-resindvd
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{gstlibdir}/libresindvd.so
783
784 %files -n gstreamer-soundtouch
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{gstlibdir}/libgstsoundtouch.so
787
788 %files -n gstreamer-sndfile
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{gstlibdir}/libgstsndfile.so
791
792 %if %{with spc}
793 %files -n gstreamer-spc
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{gstlibdir}/libgstspc.so
796 %endif
797
798 %if %{with swfdec}
799 %files -n gstreamer-swfdec
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
802 %endif
803
804 %files -n gstreamer-timidity
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{gstlibdir}/libgsttimidity.so
807
808 %files -n gstreamer-wildmidi
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{gstlibdir}/libgstwildmidi.so
811
812 %if %{with sdl}
813 %files -n gstreamer-videosink-sdl
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{gstlibdir}/libgstsdl.so
816 %endif
817
818 %if %{with directfb}
819 %files -n gstreamer-videosink-directfb
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
822 %endif
823
824 %if %{with xvid}
825 %files -n gstreamer-xvid
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
828 %endif
829
830 %files -n gstreamer-x264
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{gstlibdir}/libgstx264.so
This page took 0.108538 seconds and 4 git commands to generate.