]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
cf001d5977eaea93a8140692923e5f57589a0c43
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # new plugins:
3 # - ivorbis (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
4 # - theoradec (BR: libtheora-exp, http://people.xiph.org/~tterribe/doc/libtheora-exp/)
5 # - system libmodplug?
6 #
7 # Conditional build:
8 %bcond_without  cdaudio         # don't build cdaudio plugin
9 %bcond_without  directfb        # don't build directfb videosink plugin
10 %bcond_without  dts             # don't build DTS plugin
11 %bcond_without  faad            # don't build faad plugin
12 %bcond_without  gsm             # don't build gsm plugin
13 %bcond_without  jack            # don't build JACK audio plugin
14 %bcond_without  ladspa          # don't build ladspa plugin
15 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
16 %bcond_without  mms             # don't build mms plugin
17 %bcond_without  musepack        # don't build musepack plugin
18 %bcond_without  neon            # don't build neonhttpsrc plugin
19 %bcond_without  sdl             # don't build sdl plugin
20 %bcond_without  swfdec          # don't build swfdec plugin
21 %bcond_without  spc             # don't build spc plugin
22 %bcond_without  wavpack         # don't build wavpack plugin
23 %bcond_without  xvid            # don't build XviD plugin
24 %bcond_with     amr             # build amrwb plugin
25 %bcond_with     divx4linux      # build divx4linux plugins
26 #
27 %define         gstname         gst-plugins-bad
28 %define         gst_major_ver   0.10
29 %define         gst_req_ver     0.10.10.1
30 #
31 Summary:        Bad GStreamer Streaming-media framework plugins
32 Summary(pl.UTF-8):      Złe wtyczki do środowiska obróbki strumieni GStreamer
33 Name:           gstreamer-plugins-bad
34 Version:        0.10.4
35 Release:        7
36 License:        LPL
37 Group:          Libraries
38 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
39 # Source0-md5:  2e57395cdf72733477fb328f1fa3f053
40 Patch0:         %{name}-bashish.patch
41 Patch1:         %{name}-libdts.patch
42 Patch2:         %{name}-divx4linux.patch
43 Patch3:         %{name}-soundtouch.patch
44 Patch4:         %{name}-amrwb.patch
45 Patch5:         %{name}-faad.patch
46 Patch6:         %{name}-link.patch
47 URL:            http://gstreamer.freedesktop.org/
48 BuildRequires:  autoconf >= 2.59-9
49 BuildRequires:  automake >= 1.6
50 BuildRequires:  glib2-devel >= 1:2.12.0
51 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
52 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
53 BuildRequires:  gtk-doc >= 1.6
54 BuildRequires:  liboil-devel >= 0.3.6
55 BuildRequires:  libtool >= 1.4
56 BuildRequires:  pkgconfig >= 1:0.9.0
57 BuildRequires:  python-PyXML
58 BuildRequires:  rpmbuild(macros) >= 1.98
59 ##
60 ## plugins
61 ##
62 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
63 BuildRequires:  OpenGL-devel
64 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
65 BuildRequires:  alsa-lib-devel >= 0.9.1
66 %{?with_amr:BuildRequires:      amrwb-devel}
67 BuildRequires:  bzip2-devel
68 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
69 BuildRequires:  faac-devel
70 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
71 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
72 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
73 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
74 %{?with_dts:BuildRequires:      libdts-devel}
75 %{?with_gsm:BuildRequires:      libgsm-devel}
76 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
77 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
78 BuildRequires:  libmusicbrainz-devel >= 2.1.0
79 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
80 # for modplug and libSoundTouch
81 BuildRequires:  libstdc++-devel
82 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
83 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
84 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
85 BuildRequires:  soundtouch-devel >= 1.3.1
86 %if %{with swfdec}
87 BuildRequires:  swfdec-devel < 0.4.0
88 BuildRequires:  swfdec-devel >= 0.3.6
89 %endif
90 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.40.0}
91 BuildRequires:  xorg-lib-libX11-devel
92 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
93 Requires:       gstreamer >= %{gst_req_ver}
94 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
95 Obsoletes:      gstreamer-quicktime
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
99
100 %description
101 GStreamer is a streaming-media framework, based on graphs of filters
102 which operate on media data. Applications using this library can do
103 anything from real-time sound processing to playing videos, and just
104 about anything else media-related. Its plugin-based architecture means
105 that new data types or processing capabilities can be added simply by
106 installing new plugins.
107
108 %description -l pl.UTF-8
109 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
110 grafie filtrów operujących na danych medialnych. Aplikacje używające
111 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
112 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
113 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
114 nowych typów danych lub możliwości obróbki.
115
116 ## ## Plugins ##
117
118 %package -n gstreamer-aac
119 Summary:        GStreamer plugin for AAC audio encoding and decoding
120 Summary(pl.UTF-8):      Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
121 Group:          Libraries
122 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
123
124 %description -n gstreamer-aac
125 GStreamer plugin for AAC audio encoding and decoding.
126
127 %description -n gstreamer-aac -l pl.UTF-8
128 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
129
130 %package -n gstreamer-amrwb
131 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
132 Summary(pl.UTF-8):      Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie AMR-WB
133 Group:          Libraries
134 Requires:       gstreamer >= %{gst_req_ver}
135
136 %description -n gstreamer-amrwb
137 GStreamer plugin for AMR-WB audio encoding and decoding.
138
139 %description -n gstreamer-amrwb -l pl.UTF-8
140 Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie
141 AMR-WB.
142
143 %package -n gstreamer-audio-effects-bad
144 Summary:        Bad GStreamer audio effects plugins
145 Summary(pl.UTF-8):      Złe wtyczki efektów dźwiękowych do GStreamera
146 Group:          Libraries
147 Requires:       gstreamer >= %{gst_req_ver}
148 Obsoletes:      gstreamer-audio-effects
149
150 %description -n gstreamer-audio-effects-bad
151 Bad GStreamer audio effects plugins.
152
153 %description -n gstreamer-audio-effects-bad -l pl.UTF-8
154 Złe wtyczki efektów dźwiękowych do GStreamera.
155
156 %package -n gstreamer-audiosink-alsaspdif
157 Summary:        GStreamer ALSA plugin for S/PDIF output
158 Summary(pl.UTF-8):      Wtyczka ALSA GStreamera do wyjścia S/PDIF
159 Group:          Libraries
160 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
161 Provides:       gstreamer-audiosink = %{version}
162
163 %description -n gstreamer-audiosink-alsaspdif
164 GStreamer ALSA plugin for S/PDIF output.
165
166 %description -n gstreamer-audiosink-alsaspdif -l pl.UTF-8
167 Wtyczka ALSA GStreamera do wyjścia S/PDIF.
168
169 %package -n gstreamer-cdaudio
170 Summary:        GStreamer plugin for CD audio input using libcdaudio
171 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdaudio
172 Group:          Libraries
173 Requires:       gstreamer >= %{gst_req_ver}
174
175 %description -n gstreamer-cdaudio
176 Plugin for playing audio tracks using libcdaudio under GStreamer.
177
178 %description -n gstreamer-cdaudio -l pl.UTF-8
179 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
180 libcdaudio.
181
182 %package -n gstreamer-divx
183 Summary:        GStreamer divx plugin
184 Summary(pl.UTF-8):      Wtyczka divx do GStreamera
185 Group:          Libraries
186 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
187
188 %description -n gstreamer-divx
189 GStreamer divx plugin.
190
191 %description -n gstreamer-divx -l pl.UTF-8
192 Wtyczka divx do GStreamera.
193
194 %package -n gstreamer-dts
195 Summary:        GStreamer DTS plugin
196 Summary(pl.UTF-8):      Wtyczka DTS do GStreamera
197 Group:          Libraries
198 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
199
200 %description -n gstreamer-dts
201 Plugin for DTS Coherent Acoustics support.
202
203 %description -n gstreamer-dts -l pl.UTF-8
204 Wtyczka do GStreamera obsługująca DTS Coherent Acoustics.
205
206 %package -n gstreamer-gsm
207 Summary:        GStreamer plugin for GSM lossy audio format
208 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca stratny format dźwięku GSM
209 Group:          Libraries
210 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
211
212 %description -n gstreamer-gsm
213 Output plugin for GStreamer to convert to GSM lossy audio format.
214
215 %description -n gstreamer-gsm -l pl.UTF-8
216 Wtyczka wyjścia dźwięku GSteamera konwertująca do stratnego formatu
217 GSM.
218
219 %package -n gstreamer-imagesink-gl
220 Summary:        GStreamer plugin for outputing to OpenGL
221 Summary(pl.UTF-8):      Wtyczka wyjścia OpenGL do GStreamera
222 Group:          Libraries
223 Requires:       gstreamer >= %{gst_req_ver}
224 Provides:       gstreamer-imagesink = %{version}
225
226 %description -n gstreamer-imagesink-gl
227 GStreamer plugin for outputing to OpenGL.
228
229 %description -n gstreamer-imagesink-gl -l pl.UTF-8
230 Wtyczka wyjścia OpenGL do GStreamera.
231
232 %package -n gstreamer-jack
233 Summary:        GStreamer plugin for the JACK Sound Server
234 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
235 Group:          Libraries
236 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
237 Provides:       gstreamer-audiosink = %{version}
238
239 %description -n gstreamer-jack
240 Plugin for the JACK professional sound server.
241
242 %description -n gstreamer-jack -l pl.UTF-8
243 Wtyczka dla profesjonalnego serwera dźwięku JACK.
244
245 %package -n gstreamer-ladspa
246 Summary:        GStreamer wrapper for LADSPA plugins
247 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
248 Group:          Libraries
249 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
250
251 %description -n gstreamer-ladspa
252 Plugin which wraps LADSPA plugins for use by GStreamer applications.
253
254 %description -n gstreamer-ladspa -l pl.UTF-8
255 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
256 GStreamera.
257
258 %package -n gstreamer-mjpegtools
259 Summary:        GStreamer mpeg2enc plugin
260 Summary(pl.UTF-8):      Wtyczka mpeg2enc do GStreamera
261 Group:          Libraries
262
263 %description -n gstreamer-mjpegtools
264 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
265
266 %description -n gstreamer-mjpegtools -l pl.UTF-8
267 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
268
269 %package -n gstreamer-mms
270 Summary:        GStreamer mms plugin
271 Summary(pl.UTF-8):      Wtyczka mms do GStreamera
272 Group:          Libraries
273 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
274
275 %description -n gstreamer-mms
276 GStreamer mms plugin.
277
278 %description -n gstreamer-mms -l pl.UTF-8
279 Wtyczka mms do GStreamera.
280
281 %package -n gstreamer-musepack
282 Summary:        GStreamer musepack plugin
283 Summary(pl.UTF-8):      Wtyczka musepack do GStreamera
284 Group:          Libraries
285 Requires:       gstreamer >= %{gst_req_ver}
286
287 %description -n gstreamer-musepack
288 GStreamer musepack plugin.
289
290 %description -n gstreamer-musepack -l pl.UTF-8
291 Wtyczka musepack do GStreamera.
292
293 %package -n gstreamer-musicbrainz
294 Summary:        GStreamer musicbrainz plugin
295 Summary(pl.UTF-8):      Wtyczka musicbrainz do GStreamera
296 Group:          Libraries
297 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
298
299 %description -n gstreamer-musicbrainz
300 GStreamer musicbrainz plugin - a TRM signature producer.
301
302 %description -n gstreamer-musicbrainz -l pl.UTF-8
303 Wtyczka musicbrainz do GStreamera, tworząca sygnatury TRM.
304
305 %package -n gstreamer-neon
306 Summary:        GStreamer neon HTTP source plugin
307 Summary(pl.UTF-8):      Wtyczka źródła HTTP neon do GStreamera
308 Group:          Libraries
309 Requires:       gstreamer >= %{gst_req_ver}
310
311 %description -n gstreamer-neon
312 GStreamer neon HTTP source plugin.
313
314 %description -n gstreamer-neon -l pl.UTF-8
315 Wtyczka źródła HTTP neon do GStreamera.
316
317 %package -n gstreamer-soundtouch
318 Summary:        GStreamer soundtouch plugin
319 Summary(pl.UTF-8):      Wtyczka soundtouch do GStreamera
320 Group:          Libraries
321 Requires:       gstreamer >= %{gst_req_ver}
322
323 %description -n gstreamer-soundtouch
324 GStreamer soundtouch source plugin - audio pitch controller.
325
326 %description -n gstreamer-soundtouch -l pl.UTF-8
327 Wtyczka soundtouch do GStreamera, sterująca wysokością dźwięku.
328
329 %package -n gstreamer-spc
330 Summary:        GStreamer SPC plugin
331 Summary(pl.UTF-8):      Wtyczka SPC dla GStreamera
332 Group:          Libraries
333 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
334 Requires:       libopenspc >= 0.3.99
335
336 %description -n gstreamer-spc
337 GStreamer Plugin for playing SPC files using OpenSPC library.
338
339 %description -n gstreamer-spc -l pl.UTF-8
340 Wtyczka GStreamera odtwarzająca pliki SPC przy użyciu biblioteki
341 OpenSPC.
342
343 %package -n gstreamer-swfdec
344 Summary:        GStreamer Flash redering plugin
345 Summary(pl.UTF-8):      Wtyczka renderująca animacje flash dla GStreamera
346 Group:          Libraries
347 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
348 Requires:       swfdec >= 0.3.6
349
350 %description -n gstreamer-swfdec
351 Plugin for rendering Flash animations using swfdec library.
352
353 %description -n gstreamer-swfdec -l pl.UTF-8
354 Wtyczka renderująca animacje flash w oparciu o bibliotekę swfdec.
355
356 %package -n gstreamer-videosink-sdl
357 Summary:        GStreamer plugin for outputing to SDL
358 Summary(pl.UTF-8):      Wtyczka wyjścia SDL do GStreamera
359 Group:          Libraries
360 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
361 Provides:       gstreamer-videosink = %{version}
362 Obsoletes:      gstreamer-SDL
363
364 %description -n gstreamer-videosink-sdl
365 Plugin for sending output to the Simple Direct Media architecture.
366 (http://www.libsdl.org/). Usefull for fullscreen playback.
367
368 %description -n gstreamer-videosink-sdl -l pl.UTF-8
369 Wtyczka przekazująca wyjście do architektury SDL. Użyteczna do
370 odtwarzania na pełnym ekranie.
371
372 %package -n gstreamer-videosink-directfb
373 Summary:        GStreamer DirectFB output plugin
374 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu DirectFB do GStreamera
375 Group:          Libraries
376 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
377 Provides:       gstreamer-videosink = %{version}
378
379 %description -n gstreamer-videosink-directfb
380 GStreamer DirectFB output plugin.
381
382 %description -n gstreamer-videosink-directfb -l pl.UTF-8
383 Wtyczka wyjścia obrazu DirectFB do GStreamera.
384
385 %package -n gstreamer-wavpack
386 Summary:        GStreamer plugin for Wavpack lossless audio format
387 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku Wavpack
388 Group:          Libraries
389 Requires:       gstreamer >= %{gst_req_ver}
390
391 %description -n gstreamer-wavpack
392 Plugin for lossless Wavpack audio format.
393
394 %description -n gstreamer-wavpack -l pl.UTF-8
395 Wtyczka obsługująca bezstratny format dźwięku Wavpack.
396
397 %package -n gstreamer-xvid
398 Summary:        GStreamer xvid decoder plugin
399 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid
400 Group:          Libraries
401 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
402
403 %description -n gstreamer-xvid
404 GStreamer xvid decoder plugin.
405
406 %description -n gstreamer-xvid -l pl.UTF-8
407 Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid.
408
409 %prep
410 %setup -q -n %{gstname}-%{version}
411 %patch0 -p1
412 %patch1 -p1
413 %patch2 -p1
414 %patch3 -p1
415 %patch4 -p1
416 %patch5 -p1
417 %patch6 -p1
418
419 %build
420 %{__libtoolize}
421 %{__aclocal} -I m4 -I common/m4
422 %{__autoconf}
423 %{__autoheader}
424 %{__automake}
425 %configure \
426         %{!?with_cdaudio:--disable-cdaudio} \
427         %{!?with_divx4linux:--disable-divx} \
428         %{!?with_dts:--disable-dts} \
429         %{!?with_faad:--disable-faad} \
430         %{!?with_gsm:--disable-gsm} \
431         %{!?with_jack:--disable-jack} \
432         %{!?with_ladspa:--disable-ladspa} \
433         %{!?with_mms:--disable-libmms} \
434         %{!?with_mjpegtools:--disable-mpeg2enc} \
435         %{!?with_musepack:--disable-musepack} \
436         %{!?with_neon:--disable-neon} \
437         %{!?with_sdl:--disable-sdl} \
438         %{!?with_sdl:--disable-sdltest} \
439         %{!?with_spc:--disable-spc} \
440         %{!?with_swfdec:--disable-swfdec} \
441         %{!?with_wavpack:--disable-wavpack} \
442         %{!?with_xvid:--disable-xvid} \
443         --disable-static \
444         --enable-gtk-doc \
445         --with-html-dir=%{_gtkdocdir}
446
447 %{__make}
448
449 %install
450 rm -rf $RPM_BUILD_ROOT
451
452 %{__make} install \
453         DESTDIR=$RPM_BUILD_ROOT
454
455 # We don't need plugins' *.la files
456 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
457
458 %find_lang %{gstname}-%{gst_major_ver}
459
460 %clean
461 rm -rf $RPM_BUILD_ROOT
462
463 %files -f %{gstname}-%{gst_major_ver}.lang
464 %defattr(644,root,root,755)
465 %doc AUTHORS ChangeLog NEWS README RELEASE
466 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
467 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
468 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
469 %attr(755,root,root) %{gstlibdir}/libgstdvbsrc.so
470 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
471 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
472 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
473 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
474 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
475 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
476 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
477 %attr(755,root,root) %{gstlibdir}/libgstqtdemux.so
478 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
479 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
480 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
481 %attr(755,root,root) %{gstlibdir}/libgsttta.so
482 %attr(755,root,root) %{gstlibdir}/libgstvideocrop.so
483 %attr(755,root,root) %{gstlibdir}/libgstvideoparse.so
484 %attr(755,root,root) %{gstlibdir}/libgstxingheader.so
485 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
486 %{_gtkdocdir}/gst-plugins-bad-plugins-*
487
488 ##
489 ## Plugins
490 ##
491
492 %if %{with faad}
493 %files -n gstreamer-aac
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
496 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
497 %endif
498
499 %if %{with amr}
500 %files -n gstreamer-amrwb
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
503 %endif
504
505 %files -n gstreamer-audio-effects-bad
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
508
509 %files -n gstreamer-audiosink-alsaspdif
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
512
513 %if %{with cdaudio}
514 %files -n gstreamer-cdaudio
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
517 %endif
518
519 %if %{with divx4linux}
520 %files -n gstreamer-divx
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
523 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
524 %endif
525
526 %if %{with dts}
527 %files -n gstreamer-dts
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
530 %endif
531
532 %if %{with gsm}
533 %files -n gstreamer-gsm
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
536 %endif
537
538 %files -n gstreamer-imagesink-gl
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{gstlibdir}/libgstglimagesink.so
541
542 %if %{with jack}
543 %files -n gstreamer-jack
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{gstlibdir}/libgstjack.so
546 %endif
547
548 %if %{with ladspa}
549 %files -n gstreamer-ladspa
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
552 %endif
553
554 %if %{with mjpegtools}
555 %files -n gstreamer-mjpegtools
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
558 %endif
559
560 %if %{with mms}
561 %files -n gstreamer-mms
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{gstlibdir}/libgstmms.so
564 %endif
565
566 %if %{with musepack}
567 %files -n gstreamer-musepack
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
570 %endif
571
572 %files -n gstreamer-musicbrainz
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
575
576 %if %{with neon}
577 %files -n gstreamer-neon
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
580 %endif
581
582 %files -n gstreamer-soundtouch
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{gstlibdir}/libgstpitch.so
585
586 %if %{with spc}
587 %files -n gstreamer-spc
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{gstlibdir}/libgstspc.so
590 %endif
591
592 %if %{with swfdec}
593 %files -n gstreamer-swfdec
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
596 %endif
597
598 %if %{with sdl}
599 %files -n gstreamer-videosink-sdl
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{gstlibdir}/libgstsdlvideosink.so
602 %endif
603
604 %if %{with directfb}
605 %files -n gstreamer-videosink-directfb
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
608 %endif
609
610 %if %{with wavpack}
611 %files -n gstreamer-wavpack
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
614 %endif
615
616 %if %{with xvid}
617 %files -n gstreamer-xvid
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
620 %endif
This page took 0.111038 seconds and 2 git commands to generate.