]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
- updated
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # new plugins:
3 # - ivorbis (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
4 # - theoradec (BR: libtheora-exp, http://people.xiph.org/~tterribe/doc/libtheora-exp/)
5 # - system libmodplug?
6 #
7 # Conditional build:
8 %bcond_without  cdaudio         # don't build cdaudio plugin
9 %bcond_without  directfb        # don't build directfb videosink plugin
10 %bcond_without  dts             # don't build DTS plugin
11 %bcond_without  faad            # don't build faad plugin
12 %bcond_without  gsm             # don't build gsm plugin
13 %bcond_without  jack            # don't build JACK audio plugin
14 %bcond_without  ladspa          # don't build ladspa plugin
15 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
16 %bcond_without  mms             # don't build mms plugin
17 %bcond_without  musepack        # don't build musepack plugin
18 %bcond_without  neon            # don't build neonhttpsrc plugin
19 %bcond_without  sdl             # don't build sdl plugin
20 %bcond_with     swfdec          # swfdec plugin
21 %bcond_without  spc             # don't build spc plugin
22 %bcond_without  wavpack         # don't build wavpack plugin
23 %bcond_without  xvid            # don't build XviD plugin
24 %bcond_with     amr             # build amrwb plugin
25 %bcond_with     divx4linux      # build divx4linux plugins
26 #
27 %define         gstname         gst-plugins-bad
28 %define         gst_major_ver   0.10
29 %define         gst_req_ver     0.10.10.1
30 #
31 Summary:        Bad GStreamer Streaming-media framework plugins
32 Summary(pl.UTF-8):      Złe wtyczki do środowiska obróbki strumieni GStreamer
33 Name:           gstreamer-plugins-bad
34 Version:        0.10.5
35 Release:        1
36 License:        LPL
37 Group:          Libraries
38 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
39 # Source0-md5:  395f3ed705928e77e5620cccf11a8cff
40 Patch0:         %{name}-bashish.patch
41 Patch1:         %{name}-libdts.patch
42 Patch2:         %{name}-divx4linux.patch
43 Patch3:         %{name}-soundtouch.patch
44 Patch4:         %{name}-link.patch
45 URL:            http://gstreamer.freedesktop.org/
46 BuildRequires:  autoconf >= 2.59-9
47 BuildRequires:  automake >= 1.6
48 BuildRequires:  glib2-devel >= 1:2.12.0
49 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
50 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
51 BuildRequires:  gtk-doc >= 1.6
52 BuildRequires:  liboil-devel >= 0.3.6
53 BuildRequires:  libtool >= 1.4
54 BuildRequires:  pkgconfig >= 1:0.9.0
55 BuildRequires:  python-PyXML
56 BuildRequires:  rpmbuild(macros) >= 1.98
57 ##
58 ## plugins
59 ##
60 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
61 BuildRequires:  OpenGL-devel
62 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
63 BuildRequires:  alsa-lib-devel >= 0.9.1
64 %{?with_amr:BuildRequires:      amrwb-devel}
65 BuildRequires:  bzip2-devel
66 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
67 BuildRequires:  faac-devel
68 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
69 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
70 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
71 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
72 %{?with_dts:BuildRequires:      libdts-devel}
73 %{?with_gsm:BuildRequires:      libgsm-devel}
74 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
75 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
76 BuildRequires:  libmusicbrainz-devel >= 2.1.0
77 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
78 # for modplug and libSoundTouch
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  libx264-devel
81 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
82 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
83 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
84 BuildRequires:  libsndfile-devel
85 BuildRequires:  soundtouch-devel >= 1.3.1
86 %if %{with swfdec}
87 BuildRequires:  swfdec-devel < 0.4.0
88 BuildRequires:  swfdec-devel >= 0.3.6
89 %endif
90 BuildRequires:  xorg-lib-libX11-devel
91 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
92 Requires:       gstreamer >= %{gst_req_ver}
93 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
94 Obsoletes:      gstreamer-quicktime
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
98
99 %description
100 GStreamer is a streaming-media framework, based on graphs of filters
101 which operate on media data. Applications using this library can do
102 anything from real-time sound processing to playing videos, and just
103 about anything else media-related. Its plugin-based architecture means
104 that new data types or processing capabilities can be added simply by
105 installing new plugins.
106
107 %description -l pl.UTF-8
108 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
109 grafie filtrów operujących na danych medialnych. Aplikacje używające
110 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
111 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
112 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
113 nowych typów danych lub możliwości obróbki.
114
115 %package devel
116 Summary:        Header files and develpment documentation for gstreamer plugins
117 Group:          Development/Libraries
118 Requires:       %{name} = %{epoch}:%{version}-%{release}
119
120 %description devel
121 Header files and develpment documentation for gstreamer plugins.
122
123
124 ## ## Plugins ##
125
126 %package -n gstreamer-aac
127 Summary:        GStreamer plugin for AAC audio encoding and decoding
128 Summary(pl.UTF-8):      Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
129 Group:          Libraries
130 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
131
132 %description -n gstreamer-aac
133 GStreamer plugin for AAC audio encoding and decoding.
134
135 %description -n gstreamer-aac -l pl.UTF-8
136 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
137
138 %package -n gstreamer-amrwb
139 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
140 Summary(pl.UTF-8):      Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie AMR-WB
141 Group:          Libraries
142 Requires:       gstreamer >= %{gst_req_ver}
143
144 %description -n gstreamer-amrwb
145 GStreamer plugin for AMR-WB audio encoding and decoding.
146
147 %description -n gstreamer-amrwb -l pl.UTF-8
148 Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie
149 AMR-WB.
150
151 %package -n gstreamer-audio-effects-bad
152 Summary:        Bad GStreamer audio effects plugins
153 Summary(pl.UTF-8):      Złe wtyczki efektów dźwiękowych do GStreamera
154 Group:          Libraries
155 Requires:       gstreamer >= %{gst_req_ver}
156 Obsoletes:      gstreamer-audio-effects
157
158 %description -n gstreamer-audio-effects-bad
159 Bad GStreamer audio effects plugins.
160
161 %description -n gstreamer-audio-effects-bad -l pl.UTF-8
162 Złe wtyczki efektów dźwiękowych do GStreamera.
163
164 %package -n gstreamer-audiosink-alsaspdif
165 Summary:        GStreamer ALSA plugin for S/PDIF output
166 Summary(pl.UTF-8):      Wtyczka ALSA GStreamera do wyjścia S/PDIF
167 Group:          Libraries
168 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
169 Provides:       gstreamer-audiosink = %{version}
170
171 %description -n gstreamer-audiosink-alsaspdif
172 GStreamer ALSA plugin for S/PDIF output.
173
174 %description -n gstreamer-audiosink-alsaspdif -l pl.UTF-8
175 Wtyczka ALSA GStreamera do wyjścia S/PDIF.
176
177 %package -n gstreamer-cdaudio
178 Summary:        GStreamer plugin for CD audio input using libcdaudio
179 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdaudio
180 Group:          Libraries
181 Requires:       gstreamer >= %{gst_req_ver}
182
183 %description -n gstreamer-cdaudio
184 Plugin for playing audio tracks using libcdaudio under GStreamer.
185
186 %description -n gstreamer-cdaudio -l pl.UTF-8
187 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
188 libcdaudio.
189
190 %package -n gstreamer-divx
191 Summary:        GStreamer divx plugin
192 Summary(pl.UTF-8):      Wtyczka divx do GStreamera
193 Group:          Libraries
194 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
195
196 %description -n gstreamer-divx
197 GStreamer divx plugin.
198
199 %description -n gstreamer-divx -l pl.UTF-8
200 Wtyczka divx do GStreamera.
201
202 %package -n gstreamer-dts
203 Summary:        GStreamer DTS plugin
204 Summary(pl.UTF-8):      Wtyczka DTS do GStreamera
205 Group:          Libraries
206 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
207
208 %description -n gstreamer-dts
209 Plugin for DTS Coherent Acoustics support.
210
211 %description -n gstreamer-dts -l pl.UTF-8
212 Wtyczka do GStreamera obsługująca DTS Coherent Acoustics.
213
214 %package -n gstreamer-gsm
215 Summary:        GStreamer plugin for GSM lossy audio format
216 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca stratny format dźwięku GSM
217 Group:          Libraries
218 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
219
220 %description -n gstreamer-gsm
221 Output plugin for GStreamer to convert to GSM lossy audio format.
222
223 %description -n gstreamer-gsm -l pl.UTF-8
224 Wtyczka wyjścia dźwięku GSteamera konwertująca do stratnego formatu
225 GSM.
226
227 %package -n gstreamer-imagesink-gl
228 Summary:        GStreamer plugin for outputing to OpenGL
229 Summary(pl.UTF-8):      Wtyczka wyjścia OpenGL do GStreamera
230 Group:          Libraries
231 Requires:       gstreamer >= %{gst_req_ver}
232 Provides:       gstreamer-imagesink = %{version}
233
234 %description -n gstreamer-imagesink-gl
235 GStreamer plugin for outputing to OpenGL.
236
237 %description -n gstreamer-imagesink-gl -l pl.UTF-8
238 Wtyczka wyjścia OpenGL do GStreamera.
239
240 %package -n gstreamer-jack
241 Summary:        GStreamer plugin for the JACK Sound Server
242 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
243 Group:          Libraries
244 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
245 Provides:       gstreamer-audiosink = %{version}
246
247 %description -n gstreamer-jack
248 Plugin for the JACK professional sound server.
249
250 %description -n gstreamer-jack -l pl.UTF-8
251 Wtyczka dla profesjonalnego serwera dźwięku JACK.
252
253 %package -n gstreamer-ladspa
254 Summary:        GStreamer wrapper for LADSPA plugins
255 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
256 Group:          Libraries
257 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
258
259 %description -n gstreamer-ladspa
260 Plugin which wraps LADSPA plugins for use by GStreamer applications.
261
262 %description -n gstreamer-ladspa -l pl.UTF-8
263 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
264 GStreamera.
265
266 %package -n gstreamer-mjpegtools
267 Summary:        GStreamer mpeg2enc plugin
268 Summary(pl.UTF-8):      Wtyczka mpeg2enc do GStreamera
269 Group:          Libraries
270
271 %description -n gstreamer-mjpegtools
272 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
273
274 %description -n gstreamer-mjpegtools -l pl.UTF-8
275 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
276
277 %package -n gstreamer-mms
278 Summary:        GStreamer mms plugin
279 Summary(pl.UTF-8):      Wtyczka mms do GStreamera
280 Group:          Libraries
281 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
282
283 %description -n gstreamer-mms
284 GStreamer mms plugin.
285
286 %description -n gstreamer-mms -l pl.UTF-8
287 Wtyczka mms do GStreamera.
288
289 %package -n gstreamer-musepack
290 Summary:        GStreamer musepack plugin
291 Summary(pl.UTF-8):      Wtyczka musepack do GStreamera
292 Group:          Libraries
293 Requires:       gstreamer >= %{gst_req_ver}
294
295 %description -n gstreamer-musepack
296 GStreamer musepack plugin.
297
298 %description -n gstreamer-musepack -l pl.UTF-8
299 Wtyczka musepack do GStreamera.
300
301 %package -n gstreamer-musicbrainz
302 Summary:        GStreamer musicbrainz plugin
303 Summary(pl.UTF-8):      Wtyczka musicbrainz do GStreamera
304 Group:          Libraries
305 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
306
307 %description -n gstreamer-musicbrainz
308 GStreamer musicbrainz plugin - a TRM signature producer.
309
310 %description -n gstreamer-musicbrainz -l pl.UTF-8
311 Wtyczka musicbrainz do GStreamera, tworząca sygnatury TRM.
312
313 %package -n gstreamer-neon
314 Summary:        GStreamer neon HTTP source plugin
315 Summary(pl.UTF-8):      Wtyczka źródła HTTP neon do GStreamera
316 Group:          Libraries
317 Requires:       gstreamer >= %{gst_req_ver}
318
319 %description -n gstreamer-neon
320 GStreamer neon HTTP source plugin.
321
322 %description -n gstreamer-neon -l pl.UTF-8
323 Wtyczka źródła HTTP neon do GStreamera.
324
325 %package -n gstreamer-soundtouch
326 Summary:        GStreamer soundtouch plugin
327 Summary(pl.UTF-8):      Wtyczka soundtouch do GStreamera
328 Group:          Libraries
329 Requires:       gstreamer >= %{gst_req_ver}
330
331 %description -n gstreamer-soundtouch
332 GStreamer soundtouch source plugin - audio pitch controller.
333
334 %description -n gstreamer-soundtouch -l pl.UTF-8
335 Wtyczka soundtouch do GStreamera, sterująca wysokością dźwięku.
336
337 %package -n gstreamer-sndfile
338 Summary:        GStreamer sndfile plugin
339 Summary(pl.UTF-8):      Wtyczka sndfile do GStreamera
340 Group:          Libraries
341 Requires:       gstreamer >= %{gst_req_ver}
342
343 %description -n gstreamer-sndfile
344 GStreamer sndfile source plugin.
345
346 %description -n gstreamer-sndfile -l pl.UTF-8
347 Wtyczka sndfile do GStreamera.
348
349 %package -n gstreamer-spc
350 Summary:        GStreamer SPC plugin
351 Summary(pl.UTF-8):      Wtyczka SPC dla GStreamera
352 Group:          Libraries
353 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
354 Requires:       libopenspc >= 0.3.99
355
356 %description -n gstreamer-spc
357 GStreamer Plugin for playing SPC files using OpenSPC library.
358
359 %description -n gstreamer-spc -l pl.UTF-8
360 Wtyczka GStreamera odtwarzająca pliki SPC przy użyciu biblioteki
361 OpenSPC.
362
363 %package -n gstreamer-swfdec
364 Summary:        GStreamer Flash redering plugin
365 Summary(pl.UTF-8):      Wtyczka renderująca animacje flash dla GStreamera
366 Group:          Libraries
367 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
368 Requires:       swfdec >= 0.3.6
369
370 %description -n gstreamer-swfdec
371 Plugin for rendering Flash animations using swfdec library.
372
373 %description -n gstreamer-swfdec -l pl.UTF-8
374 Wtyczka renderująca animacje flash w oparciu o bibliotekę swfdec.
375
376 %package -n gstreamer-videosink-sdl
377 Summary:        GStreamer plugin for outputing to SDL
378 Summary(pl.UTF-8):      Wtyczka wyjścia SDL do GStreamera
379 Group:          Libraries
380 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
381 Provides:       gstreamer-videosink = %{version}
382 Obsoletes:      gstreamer-SDL
383
384 %description -n gstreamer-videosink-sdl
385 Plugin for sending output to the Simple Direct Media architecture.
386 (http://www.libsdl.org/). Usefull for fullscreen playback.
387
388 %description -n gstreamer-videosink-sdl -l pl.UTF-8
389 Wtyczka przekazująca wyjście do architektury SDL. Użyteczna do
390 odtwarzania na pełnym ekranie.
391
392 %package -n gstreamer-videosink-directfb
393 Summary:        GStreamer DirectFB output plugin
394 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu DirectFB do GStreamera
395 Group:          Libraries
396 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
397 Provides:       gstreamer-videosink = %{version}
398
399 %description -n gstreamer-videosink-directfb
400 GStreamer DirectFB output plugin.
401
402 %description -n gstreamer-videosink-directfb -l pl.UTF-8
403 Wtyczka wyjścia obrazu DirectFB do GStreamera.
404
405 %package -n gstreamer-xvid
406 Summary:        GStreamer xvid decoder plugin
407 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid
408 Group:          Libraries
409 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
410
411 %description -n gstreamer-xvid
412 GStreamer xvid decoder plugin.
413
414 %description -n gstreamer-xvid -l pl.UTF-8
415 Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid.
416
417 %package -n gstreamer-x264
418 Summary:        GStreamer x264 decoder plugin
419 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264
420 Group:          Libraries
421 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
422
423 %description -n gstreamer-x264
424 GStreamer x264 decoder plugin.
425
426 %description -n gstreamer-x264 -l pl.UTF-8
427 Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264.
428
429 %prep
430 %setup -q -n %{gstname}-%{version}
431 %patch0 -p1
432 %patch1 -p1
433 %patch2 -p1
434 %patch3 -p1
435 %patch4 -p1
436
437 %build
438 %{__libtoolize}
439 %{__aclocal} -I m4 -I common/m4
440 %{__autoconf}
441 %{__autoheader}
442 %{__automake}
443 %configure \
444         %{!?with_cdaudio:--disable-cdaudio} \
445         %{!?with_divx4linux:--disable-divx} \
446         %{!?with_dts:--disable-dts} \
447         %{!?with_faad:--disable-faad} \
448         %{!?with_gsm:--disable-gsm} \
449         %{!?with_jack:--disable-jack} \
450         %{!?with_ladspa:--disable-ladspa} \
451         %{!?with_mms:--disable-libmms} \
452         %{!?with_mjpegtools:--disable-mpeg2enc} \
453         %{!?with_musepack:--disable-musepack} \
454         %{!?with_neon:--disable-neon} \
455         %{!?with_sdl:--disable-sdl} \
456         %{!?with_sdl:--disable-sdltest} \
457         %{!?with_spc:--disable-spc} \
458         %{!?with_swfdec:--disable-swfdec} \
459         %{!?with_xvid:--disable-xvid} \
460         --disable-static \
461         --enable-gtk-doc \
462         --with-html-dir=%{_gtkdocdir}
463
464 %{__make}
465
466 %install
467 rm -rf $RPM_BUILD_ROOT
468
469 %{__make} install \
470         DESTDIR=$RPM_BUILD_ROOT
471
472 # We don't need plugins' *.la files
473 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
474
475 %find_lang %{gstname}-%{gst_major_ver}
476
477 %clean
478 rm -rf $RPM_BUILD_ROOT
479
480 %post -p /sbin/ldconfig
481 %postun -p /sbin/ldconfig
482
483 %files -f %{gstname}-%{gst_major_ver}.lang
484 %defattr(644,root,root,755)
485 %doc AUTHORS ChangeLog NEWS README RELEASE
486 %attr(755,root,root) %{gstlibdir}/libgstapp.so
487 %attr(755,root,root) %{gstlibdir}/libgstbayer.so
488 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
489 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
490 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
491 %attr(755,root,root) %{gstlibdir}/libgstdvbsrc.so
492 %attr(755,root,root) %{gstlibdir}/libgstequalizer.so
493 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
494 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
495 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
496 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
497 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
498 %attr(755,root,root) %{gstlibdir}/libgstmpegvideoparse.so
499 %attr(755,root,root) %{gstlibdir}/libgstmve.so
500 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
501 %attr(755,root,root) %{gstlibdir}/libgstnassink.so
502 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
503 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
504 %attr(755,root,root) %{gstlibdir}/libgstreal.so
505 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
506 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
507 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
508 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
509 %attr(755,root,root) %{gstlibdir}/libgstswitch.so
510 %attr(755,root,root) %{gstlibdir}/libgsttta.so
511 %attr(755,root,root) %{gstlibdir}/libgstvideoparse.so
512 %attr(755,root,root) %{gstlibdir}/libgstvideosignal.so
513 %attr(755,root,root) %{gstlibdir}/libgstvmnc.so
514 %attr(755,root,root) %{gstlibdir}/libgstxingheader.so
515 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
516 %{_gtkdocdir}/gst-plugins-bad-plugins-*
517
518 %attr(755,root,root) %{_libdir}/libgstap*.so.*
519
520 %files devel
521 %defattr(644,root,root,755)
522 %{_includedir}/gstreamer-*/gst/app
523 %attr(755,root,root) %{_libdir}/libgstap*.so
524 %{_libdir}/libgstap*.la
525
526 ##
527 ## Plugins
528 ##
529
530 %if %{with faad}
531 %files -n gstreamer-aac
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
534 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
535 %endif
536
537 %if %{with amr}
538 %files -n gstreamer-amrwb
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
541 %endif
542
543 %files -n gstreamer-audio-effects-bad
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
546
547 %files -n gstreamer-audiosink-alsaspdif
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
550
551 %if %{with cdaudio}
552 %files -n gstreamer-cdaudio
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
555 %endif
556
557 %if %{with divx4linux}
558 %files -n gstreamer-divx
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
561 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
562 %endif
563
564 %if %{with dts}
565 %files -n gstreamer-dts
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
568 %endif
569
570 %if %{with gsm}
571 %files -n gstreamer-gsm
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
574 %endif
575
576 %files -n gstreamer-imagesink-gl
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{gstlibdir}/libgstglimagesink.so
579
580 %if %{with jack}
581 %files -n gstreamer-jack
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{gstlibdir}/libgstjack.so
584 %endif
585
586 %if %{with ladspa}
587 %files -n gstreamer-ladspa
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
590 %endif
591
592 %if %{with mjpegtools}
593 %files -n gstreamer-mjpegtools
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
596 %endif
597
598 %if %{with mms}
599 %files -n gstreamer-mms
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{gstlibdir}/libgstmms.so
602 %endif
603
604 %if %{with musepack}
605 %files -n gstreamer-musepack
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
608 %endif
609
610 %files -n gstreamer-musicbrainz
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
613
614 %if %{with neon}
615 %files -n gstreamer-neon
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
618 %endif
619
620 %files -n gstreamer-soundtouch
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{gstlibdir}/libgstpitch.so
623
624 %files -n gstreamer-sndfile
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{gstlibdir}/libgstsndfile.so
627
628 %if %{with spc}
629 %files -n gstreamer-spc
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{gstlibdir}/libgstspc.so
632 %endif
633
634 %if %{with swfdec}
635 %files -n gstreamer-swfdec
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
638 %endif
639
640 %if %{with sdl}
641 %files -n gstreamer-videosink-sdl
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{gstlibdir}/libgstsdl.so
644 %endif
645
646 %if %{with directfb}
647 %files -n gstreamer-videosink-directfb
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
650 %endif
651
652 %if %{with xvid}
653 %files -n gstreamer-xvid
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
656 %endif
657
658 %files -n gstreamer-x264
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{gstlibdir}/libgstx264.so
This page took 0.112658 seconds and 3 git commands to generate.