]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
b5ada61f3e44d142f9577ec0a160c57934abbcd3
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # - new plugins:
3 #   - ivorbisdec (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
4 #   - mythtvsrc (BR: gmyth-0.1 >= 0.1.0.3)
5 #   - theoraexpdec (BR: libtheora-exp, http://people.xiph.org/~tterribe/doc/libtheora-exp/)
6 #   - timidity (BR: libtimidity)
7 #   - wildmidi (BR: -lWildMidi)
8 # - system libmodplug?
9 #
10 # Conditional build:
11 %bcond_without  cdaudio         # don't build cdaudio plugin
12 %bcond_without  directfb        # don't build directfb videosink plugin
13 %bcond_without  dts             # don't build DTS plugin
14 %bcond_without  faad            # don't build faad plugin
15 %bcond_without  gsm             # don't build gsm plugin
16 %bcond_without  jack            # don't build JACK audio plugin
17 %bcond_without  ladspa          # don't build ladspa plugin
18 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
19 %bcond_without  mms             # don't build mms plugin
20 %bcond_without  musepack        # don't build musepack plugin
21 %bcond_without  neon            # don't build neonhttpsrc plugin
22 %bcond_without  sdl             # don't build sdl plugin
23 %bcond_with     swfdec          # swfdec plugin
24 %bcond_without  spc             # don't build spc plugin
25 %bcond_without  wavpack         # don't build wavpack plugin
26 %bcond_without  xvid            # don't build XviD plugin
27 %bcond_with     amr             # build amrwb plugin
28 %bcond_with     divx4linux      # build divx4linux plugins
29 #
30 %define         gstname         gst-plugins-bad
31 %define         gst_major_ver   0.10
32 %define         gst_req_ver     0.10.10.1
33 #
34 Summary:        Bad GStreamer Streaming-media framework plugins
35 Summary(pl.UTF-8):      Złe wtyczki do środowiska obróbki strumieni GStreamer
36 Name:           gstreamer-plugins-bad
37 Version:        0.10.5
38 Release:        2
39 License:        LPL
40 Group:          Libraries
41 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
42 # Source0-md5:  395f3ed705928e77e5620cccf11a8cff
43 Patch0:         %{name}-bashish.patch
44 Patch1:         %{name}-libdts.patch
45 Patch2:         %{name}-divx4linux.patch
46 Patch3:         %{name}-soundtouch.patch
47 Patch4:         %{name}-link.patch
48 Patch5:         %{name}-vcd.patch
49 URL:            http://gstreamer.freedesktop.org/
50 BuildRequires:  autoconf >= 2.59-9
51 BuildRequires:  automake >= 1.6
52 BuildRequires:  glib2-devel >= 1:2.12.0
53 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
54 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
55 BuildRequires:  gtk-doc >= 1.6
56 BuildRequires:  liboil-devel >= 0.3.6
57 BuildRequires:  libtool >= 1.4
58 BuildRequires:  pkgconfig >= 1:0.9.0
59 BuildRequires:  python-PyXML
60 BuildRequires:  rpmbuild(macros) >= 1.98
61 ##
62 ## plugins
63 ##
64 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
65 BuildRequires:  OpenGL-devel
66 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
67 BuildRequires:  alsa-lib-devel >= 0.9.1
68 %{?with_amr:BuildRequires:      amrwb-devel}
69 BuildRequires:  bzip2-devel
70 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
71 BuildRequires:  faac-devel
72 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
73 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
74 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
75 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
76 %{?with_dts:BuildRequires:      libdts-devel}
77 %{?with_gsm:BuildRequires:      libgsm-devel}
78 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
79 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
80 BuildRequires:  libmusicbrainz-devel >= 2.1.0
81 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
82 # for modplug and libSoundTouch
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libx264-devel
85 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
86 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
87 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
88 BuildRequires:  libsndfile-devel
89 BuildRequires:  soundtouch-devel >= 1.3.1
90 %if %{with swfdec}
91 BuildRequires:  swfdec-devel < 0.4.0
92 BuildRequires:  swfdec-devel >= 0.3.6
93 %endif
94 BuildRequires:  xorg-lib-libX11-devel
95 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
96 Requires:       gstreamer >= %{gst_req_ver}
97 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
98 Obsoletes:      gstreamer-quicktime
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
102
103 %description
104 GStreamer is a streaming-media framework, based on graphs of filters
105 which operate on media data. Applications using this library can do
106 anything from real-time sound processing to playing videos, and just
107 about anything else media-related. Its plugin-based architecture means
108 that new data types or processing capabilities can be added simply by
109 installing new plugins.
110
111 %description -l pl.UTF-8
112 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
113 grafie filtrów operujących na danych medialnych. Aplikacje używające
114 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
115 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
116 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
117 nowych typów danych lub możliwości obróbki.
118
119 %package devel
120 Summary:        Header files and API documentation for gstapp library
121 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API biblioteki gstapp
122 Group:          Development/Libraries
123 Requires:       %{name} = %{version}-%{release}
124
125 %description devel
126 Header files and API documentation for gstapp library.
127
128 %description devel -l pl.UTF-8
129 Pliki nagłówkowe i dokumentacja API biblioteki gstapp.
130
131 ## Plugins ##
132
133 %package -n gstreamer-aac
134 Summary:        GStreamer plugin for AAC audio encoding and decoding
135 Summary(pl.UTF-8):      Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
136 Group:          Libraries
137 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
138
139 %description -n gstreamer-aac
140 GStreamer plugin for AAC audio encoding and decoding.
141
142 %description -n gstreamer-aac -l pl.UTF-8
143 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
144
145 %package -n gstreamer-amrwb
146 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
147 Summary(pl.UTF-8):      Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie AMR-WB
148 Group:          Libraries
149 Requires:       gstreamer >= %{gst_req_ver}
150
151 %description -n gstreamer-amrwb
152 GStreamer plugin for AMR-WB audio encoding and decoding.
153
154 %description -n gstreamer-amrwb -l pl.UTF-8
155 Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie
156 AMR-WB.
157
158 %package -n gstreamer-audio-effects-bad
159 Summary:        Bad GStreamer audio effects plugins
160 Summary(pl.UTF-8):      Złe wtyczki efektów dźwiękowych do GStreamera
161 Group:          Libraries
162 Requires:       gstreamer >= %{gst_req_ver}
163 Obsoletes:      gstreamer-audio-effects
164
165 %description -n gstreamer-audio-effects-bad
166 Bad GStreamer audio effects plugins.
167
168 %description -n gstreamer-audio-effects-bad -l pl.UTF-8
169 Złe wtyczki efektów dźwiękowych do GStreamera.
170
171 %package -n gstreamer-audiosink-alsaspdif
172 Summary:        GStreamer ALSA plugin for S/PDIF output
173 Summary(pl.UTF-8):      Wtyczka ALSA GStreamera do wyjścia S/PDIF
174 Group:          Libraries
175 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
176 Provides:       gstreamer-audiosink = %{version}
177
178 %description -n gstreamer-audiosink-alsaspdif
179 GStreamer ALSA plugin for S/PDIF output.
180
181 %description -n gstreamer-audiosink-alsaspdif -l pl.UTF-8
182 Wtyczka ALSA GStreamera do wyjścia S/PDIF.
183
184 %package -n gstreamer-cdaudio
185 Summary:        GStreamer plugin for CD audio input using libcdaudio
186 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdaudio
187 Group:          Libraries
188 Requires:       gstreamer >= %{gst_req_ver}
189
190 %description -n gstreamer-cdaudio
191 Plugin for playing audio tracks using libcdaudio under GStreamer.
192
193 %description -n gstreamer-cdaudio -l pl.UTF-8
194 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
195 libcdaudio.
196
197 %package -n gstreamer-divx
198 Summary:        GStreamer divx plugin
199 Summary(pl.UTF-8):      Wtyczka divx do GStreamera
200 Group:          Libraries
201 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
202
203 %description -n gstreamer-divx
204 GStreamer divx plugin.
205
206 %description -n gstreamer-divx -l pl.UTF-8
207 Wtyczka divx do GStreamera.
208
209 %package -n gstreamer-dts
210 Summary:        GStreamer DTS plugin
211 Summary(pl.UTF-8):      Wtyczka DTS do GStreamera
212 Group:          Libraries
213 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
214
215 %description -n gstreamer-dts
216 Plugin for DTS Coherent Acoustics support.
217
218 %description -n gstreamer-dts -l pl.UTF-8
219 Wtyczka do GStreamera obsługująca DTS Coherent Acoustics.
220
221 %package -n gstreamer-gsm
222 Summary:        GStreamer plugin for GSM lossy audio format
223 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca stratny format dźwięku GSM
224 Group:          Libraries
225 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
226
227 %description -n gstreamer-gsm
228 Output plugin for GStreamer to convert to GSM lossy audio format.
229
230 %description -n gstreamer-gsm -l pl.UTF-8
231 Wtyczka wyjścia dźwięku GSteamera konwertująca do stratnego formatu
232 GSM.
233
234 %package -n gstreamer-imagesink-gl
235 Summary:        GStreamer plugin for outputing to OpenGL
236 Summary(pl.UTF-8):      Wtyczka wyjścia OpenGL do GStreamera
237 Group:          Libraries
238 Requires:       gstreamer >= %{gst_req_ver}
239 Provides:       gstreamer-imagesink = %{version}
240
241 %description -n gstreamer-imagesink-gl
242 GStreamer plugin for outputing to OpenGL.
243
244 %description -n gstreamer-imagesink-gl -l pl.UTF-8
245 Wtyczka wyjścia OpenGL do GStreamera.
246
247 %package -n gstreamer-jack
248 Summary:        GStreamer plugin for the JACK Sound Server
249 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
250 Group:          Libraries
251 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
252 Provides:       gstreamer-audiosink = %{version}
253
254 %description -n gstreamer-jack
255 Plugin for the JACK professional sound server.
256
257 %description -n gstreamer-jack -l pl.UTF-8
258 Wtyczka dla profesjonalnego serwera dźwięku JACK.
259
260 %package -n gstreamer-ladspa
261 Summary:        GStreamer wrapper for LADSPA plugins
262 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
263 Group:          Libraries
264 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
265
266 %description -n gstreamer-ladspa
267 Plugin which wraps LADSPA plugins for use by GStreamer applications.
268
269 %description -n gstreamer-ladspa -l pl.UTF-8
270 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
271 GStreamera.
272
273 %package -n gstreamer-mjpegtools
274 Summary:        GStreamer mpeg2enc plugin
275 Summary(pl.UTF-8):      Wtyczka mpeg2enc do GStreamera
276 Group:          Libraries
277
278 %description -n gstreamer-mjpegtools
279 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
280
281 %description -n gstreamer-mjpegtools -l pl.UTF-8
282 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
283
284 %package -n gstreamer-mms
285 Summary:        GStreamer mms plugin
286 Summary(pl.UTF-8):      Wtyczka mms do GStreamera
287 Group:          Libraries
288 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
289
290 %description -n gstreamer-mms
291 GStreamer mms plugin.
292
293 %description -n gstreamer-mms -l pl.UTF-8
294 Wtyczka mms do GStreamera.
295
296 %package -n gstreamer-musepack
297 Summary:        GStreamer musepack plugin
298 Summary(pl.UTF-8):      Wtyczka musepack do GStreamera
299 Group:          Libraries
300 Requires:       gstreamer >= %{gst_req_ver}
301
302 %description -n gstreamer-musepack
303 GStreamer musepack plugin.
304
305 %description -n gstreamer-musepack -l pl.UTF-8
306 Wtyczka musepack do GStreamera.
307
308 %package -n gstreamer-musicbrainz
309 Summary:        GStreamer musicbrainz plugin
310 Summary(pl.UTF-8):      Wtyczka musicbrainz do GStreamera
311 Group:          Libraries
312 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
313
314 %description -n gstreamer-musicbrainz
315 GStreamer musicbrainz plugin - a TRM signature producer.
316
317 %description -n gstreamer-musicbrainz -l pl.UTF-8
318 Wtyczka musicbrainz do GStreamera, tworząca sygnatury TRM.
319
320 %package -n gstreamer-neon
321 Summary:        GStreamer neon HTTP source plugin
322 Summary(pl.UTF-8):      Wtyczka źródła HTTP neon do GStreamera
323 Group:          Libraries
324 Requires:       gstreamer >= %{gst_req_ver}
325
326 %description -n gstreamer-neon
327 GStreamer neon HTTP source plugin.
328
329 %description -n gstreamer-neon -l pl.UTF-8
330 Wtyczka źródła HTTP neon do GStreamera.
331
332 %package -n gstreamer-soundtouch
333 Summary:        GStreamer soundtouch plugin
334 Summary(pl.UTF-8):      Wtyczka soundtouch do GStreamera
335 Group:          Libraries
336 Requires:       gstreamer >= %{gst_req_ver}
337
338 %description -n gstreamer-soundtouch
339 GStreamer soundtouch source plugin - audio pitch controller.
340
341 %description -n gstreamer-soundtouch -l pl.UTF-8
342 Wtyczka soundtouch do GStreamera, sterująca wysokością dźwięku.
343
344 %package -n gstreamer-sndfile
345 Summary:        GStreamer sndfile plugin
346 Summary(pl.UTF-8):      Wtyczka sndfile do GStreamera
347 Group:          Libraries
348 Requires:       gstreamer >= %{gst_req_ver}
349
350 %description -n gstreamer-sndfile
351 GStreamer sndfile source plugin.
352
353 %description -n gstreamer-sndfile -l pl.UTF-8
354 Wtyczka sndfile do GStreamera.
355
356 %package -n gstreamer-spc
357 Summary:        GStreamer SPC plugin
358 Summary(pl.UTF-8):      Wtyczka SPC dla GStreamera
359 Group:          Libraries
360 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
361 Requires:       libopenspc >= 0.3.99
362
363 %description -n gstreamer-spc
364 GStreamer Plugin for playing SPC files using OpenSPC library.
365
366 %description -n gstreamer-spc -l pl.UTF-8
367 Wtyczka GStreamera odtwarzająca pliki SPC przy użyciu biblioteki
368 OpenSPC.
369
370 %package -n gstreamer-swfdec
371 Summary:        GStreamer Flash redering plugin
372 Summary(pl.UTF-8):      Wtyczka renderująca animacje flash dla GStreamera
373 Group:          Libraries
374 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
375 Requires:       swfdec >= 0.3.6
376
377 %description -n gstreamer-swfdec
378 Plugin for rendering Flash animations using swfdec library.
379
380 %description -n gstreamer-swfdec -l pl.UTF-8
381 Wtyczka renderująca animacje flash w oparciu o bibliotekę swfdec.
382
383 %package -n gstreamer-videosink-sdl
384 Summary:        GStreamer plugin for outputing to SDL
385 Summary(pl.UTF-8):      Wtyczka wyjścia SDL do GStreamera
386 Group:          Libraries
387 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
388 Provides:       gstreamer-videosink = %{version}
389 Obsoletes:      gstreamer-SDL
390
391 %description -n gstreamer-videosink-sdl
392 Plugin for sending output to the Simple Direct Media architecture.
393 (http://www.libsdl.org/). Usefull for fullscreen playback.
394
395 %description -n gstreamer-videosink-sdl -l pl.UTF-8
396 Wtyczka przekazująca wyjście do architektury SDL. Użyteczna do
397 odtwarzania na pełnym ekranie.
398
399 %package -n gstreamer-videosink-directfb
400 Summary:        GStreamer DirectFB output plugin
401 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu DirectFB do GStreamera
402 Group:          Libraries
403 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
404 Provides:       gstreamer-videosink = %{version}
405
406 %description -n gstreamer-videosink-directfb
407 GStreamer DirectFB output plugin.
408
409 %description -n gstreamer-videosink-directfb -l pl.UTF-8
410 Wtyczka wyjścia obrazu DirectFB do GStreamera.
411
412 %package -n gstreamer-xvid
413 Summary:        GStreamer xvid decoder plugin
414 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid
415 Group:          Libraries
416 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
417
418 %description -n gstreamer-xvid
419 GStreamer xvid decoder plugin.
420
421 %description -n gstreamer-xvid -l pl.UTF-8
422 Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid.
423
424 %package -n gstreamer-x264
425 Summary:        GStreamer x264 decoder plugin
426 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264
427 Group:          Libraries
428 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
429
430 %description -n gstreamer-x264
431 GStreamer x264 decoder plugin.
432
433 %description -n gstreamer-x264 -l pl.UTF-8
434 Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264.
435
436 %prep
437 %setup -q -n %{gstname}-%{version}
438 %patch0 -p1
439 %patch1 -p1
440 %patch2 -p1
441 %patch3 -p1
442 %patch4 -p1
443 %patch5 -p1
444
445 %build
446 %{__libtoolize}
447 %{__aclocal} -I m4 -I common/m4
448 %{__autoconf}
449 %{__autoheader}
450 %{__automake}
451 %configure \
452         %{!?with_amr:--disable-amrwb} \
453         %{!?with_cdaudio:--disable-cdaudio} \
454         %{!?with_divx4linux:--disable-divx} \
455         %{!?with_dts:--disable-dts} \
456         %{!?with_faad:--disable-faad} \
457         %{!?with_gsm:--disable-gsm} \
458         %{!?with_jack:--disable-jack} \
459         %{!?with_ladspa:--disable-ladspa} \
460         %{!?with_mms:--disable-libmms} \
461         %{!?with_mjpegtools:--disable-mpeg2enc} \
462         %{!?with_musepack:--disable-musepack} \
463         %{!?with_neon:--disable-neon} \
464         %{!?with_sdl:--disable-sdl} \
465         %{!?with_sdl:--disable-sdltest} \
466         %{!?with_spc:--disable-spc} \
467         %{!?with_swfdec:--disable-swfdec} \
468         %{!?with_xvid:--disable-xvid} \
469         --disable-static \
470         --enable-gtk-doc \
471         --with-html-dir=%{_gtkdocdir}
472
473 %{__make}
474
475 %install
476 rm -rf $RPM_BUILD_ROOT
477
478 %{__make} install \
479         DESTDIR=$RPM_BUILD_ROOT
480
481 # We don't need plugins' *.la files
482 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
483
484 %find_lang %{gstname}-%{gst_major_ver}
485
486 %clean
487 rm -rf $RPM_BUILD_ROOT
488
489 %post -p /sbin/ldconfig
490 %postun -p /sbin/ldconfig
491
492 %files -f %{gstname}-%{gst_major_ver}.lang
493 %defattr(644,root,root,755)
494 %doc AUTHORS ChangeLog NEWS README RELEASE
495 %attr(755,root,root) %{_libdir}/libgstapp-*.so.*.*.*
496 # R: libgstapp-*
497 %attr(755,root,root) %{gstlibdir}/libgstapp.so
498 %attr(755,root,root) %{gstlibdir}/libgstbayer.so
499 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
500 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
501 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
502 # R: gst-plugins-bad locales
503 %attr(755,root,root) %{gstlibdir}/libgstdvbsrc.so
504 %attr(755,root,root) %{gstlibdir}/libgstequalizer.so
505 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
506 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
507 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
508 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
509 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
510 %attr(755,root,root) %{gstlibdir}/libgstmpegvideoparse.so
511 %attr(755,root,root) %{gstlibdir}/libgstmve.so
512 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
513 %attr(755,root,root) %{gstlibdir}/libgstnassink.so
514 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
515 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
516 %ifarch %{ix86} %{x8664}
517 %attr(755,root,root) %{gstlibdir}/libgstreal.so
518 %endif
519 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
520 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
521 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
522 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
523 %attr(755,root,root) %{gstlibdir}/libgstswitch.so
524 %attr(755,root,root) %{gstlibdir}/libgsttta.so
525 %attr(755,root,root) %{gstlibdir}/libgstvcdsrc.so
526 %attr(755,root,root) %{gstlibdir}/libgstvideoparse.so
527 %attr(755,root,root) %{gstlibdir}/libgstvideosignal.so
528 %attr(755,root,root) %{gstlibdir}/libgstvmnc.so
529 %attr(755,root,root) %{gstlibdir}/libgstxingheader.so
530 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
531 %{_gtkdocdir}/gst-plugins-bad-plugins-*
532
533 %files devel
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/libgstapp-*.so
536 %{_libdir}/libgstapp-*.la
537 %{_includedir}/gstreamer-*/gst/app
538
539 ##
540 ## Plugins
541 ##
542
543 %if %{with faad}
544 %files -n gstreamer-aac
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
547 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
548 %endif
549
550 %if %{with amr}
551 %files -n gstreamer-amrwb
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
554 %endif
555
556 %files -n gstreamer-audio-effects-bad
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
559
560 %files -n gstreamer-audiosink-alsaspdif
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
563
564 %if %{with cdaudio}
565 %files -n gstreamer-cdaudio
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
568 %endif
569
570 %if %{with divx4linux}
571 %files -n gstreamer-divx
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
574 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
575 %endif
576
577 %if %{with dts}
578 %files -n gstreamer-dts
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
581 %endif
582
583 %if %{with gsm}
584 %files -n gstreamer-gsm
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
587 %endif
588
589 %files -n gstreamer-imagesink-gl
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{gstlibdir}/libgstglimagesink.so
592
593 %if %{with jack}
594 %files -n gstreamer-jack
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{gstlibdir}/libgstjack.so
597 %endif
598
599 %if %{with ladspa}
600 %files -n gstreamer-ladspa
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
603 %endif
604
605 %if %{with mjpegtools}
606 %files -n gstreamer-mjpegtools
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
609 %endif
610
611 %if %{with mms}
612 %files -n gstreamer-mms
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{gstlibdir}/libgstmms.so
615 %endif
616
617 %if %{with musepack}
618 %files -n gstreamer-musepack
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
621 %endif
622
623 %files -n gstreamer-musicbrainz
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
626
627 %if %{with neon}
628 %files -n gstreamer-neon
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
631 %endif
632
633 %files -n gstreamer-soundtouch
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{gstlibdir}/libgstpitch.so
636
637 %files -n gstreamer-sndfile
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{gstlibdir}/libgstsndfile.so
640
641 %if %{with spc}
642 %files -n gstreamer-spc
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{gstlibdir}/libgstspc.so
645 %endif
646
647 %if %{with swfdec}
648 %files -n gstreamer-swfdec
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
651 %endif
652
653 %if %{with sdl}
654 %files -n gstreamer-videosink-sdl
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{gstlibdir}/libgstsdl.so
657 %endif
658
659 %if %{with directfb}
660 %files -n gstreamer-videosink-directfb
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
663 %endif
664
665 %if %{with xvid}
666 %files -n gstreamer-xvid
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
669 %endif
670
671 %files -n gstreamer-x264
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{gstlibdir}/libgstx264.so
This page took 0.073448 seconds and 3 git commands to generate.