]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
- rel 3; support xfs filesystems made with sparse inodes enabled (default for mkfs...
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664} x32
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} x32 ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664} x32
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} x32 ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 %define         rel     1
43 Summary:        GRand Unified Bootloader
44 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
45 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
46 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
47 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
48 Name:           grub2
49 Version:        2.02
50 Release:        3
51 License:        GPL v2
52 Group:          Base
53 Source0:        ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
54 # Source0-md5:  8a4a2a95aac551fb0fba860ceabfa1d3
55 Source1:        update-grub
56 Source2:        update-grub.8
57 Source3:        grub.sysconfig
58 Source4:        grub-custom.cfg
59 Patch1:         pld-sysconfdir.patch
60 Patch2:         grub-garbage.patch
61 Patch3:         grub-lvmdevice.patch
62 Patch4:         pld-mkconfigdir.patch
63 Patch5:         grub-mkconfig-diagnostics.patch
64 Patch6:         posix.patch
65 Patch7:         %{name}-fonts_path.patch
66 Patch8:         add-vlan-tag-support.patch
67 Patch9:         just-say-linux.patch
68 Patch10:        ignore-kernel-symlinks.patch
69 Patch11:        choose-preferred-initrd.patch
70 Patch12:        %{name}-cfg.patch
71 Patch13:        efi-net-fix.patch
72 Patch14:        blscfg.patch
73 # https://git.archlinux.org/svntogit/packages.git/plain/trunk/0002-intel-ucode.patch?h=packages/grub
74 Patch15:        intel-ucode.patch
75 Patch16:        xfs.patch
76 URL:            http://www.gnu.org/software/grub/
77 BuildRequires:  autoconf >= 2.53
78 BuildRequires:  automake >= 1:1.11.1-1
79 BuildRequires:  bison
80 BuildRequires:  device-mapper-devel
81 BuildRequires:  flex >= 2.5.35
82 BuildRequires:  fonts-TTF-DejaVu
83 BuildRequires:  freetype-devel >= 2
84 BuildRequires:  gawk
85 BuildRequires:  gcc >= 5:3.4
86 BuildRequires:  gettext-tools
87 BuildRequires:  glibc-localedb-all
88 BuildRequires:  glibc-static
89 BuildRequires:  help2man
90 BuildRequires:  libfuse-devel
91 BuildRequires:  libtool
92 BuildRequires:  ncurses-devel
93 BuildRequires:  python
94 BuildRequires:  python-modules
95 BuildRequires:  rpm >= 4.4.9-56
96 BuildRequires:  rpmbuild(macros) >= 1.213
97 BuildRequires:  sed >= 4.0
98 BuildRequires:  tar >= 1:1.22
99 BuildRequires:  texinfo
100 BuildRequires:  xz
101 BuildRequires:  xz-devel
102 %ifarch %{x8664}
103 BuildRequires:  /usr/lib/libc.so
104 %if "%{pld_release}" == "ac"
105 BuildRequires:  libgcc32
106 %else
107 BuildRequires:  gcc-multilib-32
108 %endif
109 %endif
110 Requires:       %{name}-platform = %{version}-%{release}
111 Requires:       pld-release
112 Requires:       which
113 %ifarch %{ix86} %{x8664}
114 Suggests:       %{name}-platform-pc
115 %endif
116 Suggests:       cdrkit-mkisofs
117 Suggests:       os-prober
118 Provides:       bootloader
119 Conflicts:      grub
120 ExclusiveArch:  %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define         _sbindir        /sbin
124 %define         _bindir         %{_sbindir}
125 %define         _libdir         /lib
126 %define         _datadir        %{_libdir}
127 %define         _libexecdir     %{_libdir}/grub
128 %define         _grubdir        /boot/grub
129 %define         _localedir      /usr/share/locale
130
131 # part of grub code is not relocable (these are not Linux libs)
132 # stack protector also breaks non-Linux binaries
133 # any kind of forced optimizations makes grub2 unreliable (random
134 # reboots and hangs on boot menu screen)
135 %define         filterout_c     -fPIC -O.
136 %undefine       _ssp_cflags
137 %undefine       _fortify_cflags
138
139 %description
140 GRUB is a GPLed bootloader intended to unify bootloading across x86
141 operating systems. In addition to loading the Linux and *BSD kernels,
142 it implements the Multiboot standard, which allows for flexible
143 loading of multiple boot images (needed for modular kernels such as
144 the GNU Hurd).
145
146 GRUB 2 is derived from PUPA which was a research project to
147 investigate the next generation of GRUB. GRUB 2 has been rewritten
148 from scratch to clean up everything for modularity and portability.
149
150 GRUB 2 targets at the following goals:
151 - Scripting support, such as conditionals, loops, variables and
152   functions.
153 - Graphical interface.
154 - Dynamic loading of modules in order to extend itself at the run time
155   rather than at the build time.
156 - Portability for various architectures.
157 - Internationalization. This includes support for non-ASCII character
158   code, message catalogs like gettext, fonts, graphics console, and so
159   on.
160 - Real memory management, to make GNU GRUB more extensible.
161 - Modular, hierarchical, object-oriented framework for file systems,
162   files, devices, drives, terminals, commands, partition tables and OS
163   loaders.
164 - Cross-platform installation which allows for installing GRUB from a
165   different architecture.
166 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
167 - Fix design mistakes in GRUB Legacy, which could not be solved for
168   backward-compatibility, such as the way of numbering partitions.
169
170 %description -l de.UTF-8
171 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
172 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
173 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
174
175 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
176 und wird unter der GPL vertrieben. Aufgrund seiner höheren
177 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
178 traditionellen Boot-Loader LILO.
179
180 %description -l hu.UTF-8
181 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
182 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
183 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
184 GNU Hurd).
185
186 GRUB2 céljai a következők:
187 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
188   függvények.
189 - grafikus felület
190 - modulok dinamikus betöltése futási időben
191 - hordozhatóság több architektúrára
192 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
193   mint gettext, betűtípusok, grafikus konzolon, és így tovább
194 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
195 - moduláris, hierarchikus, objektum-orientált keretrendszer
196   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
197   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
198
199 %description -l es.UTF-8
200 Éste es GRUB - Grand Unified Boot Loader - un administrador de
201 inicialización capaz de entrar en la mayoría de los sistemas
202 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
203 también en la mayoría de los sistemas operacionales comerciales para
204 PC.
205
206 El administrador GRUB puede ser una buena alternativa a LILO, para
207 usuarios conmás experiencia y que deseen obtener más recursos de su
208 cargador de inicialización (boot loader).
209
210 %description -l pl.UTF-8
211 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
212 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
213 Linuksa i *BSD: posiada również implementację standardu Multiboot,
214 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
215 (czego wymagają modułowe jądra, takie jak GNU Hurd).
216
217 %description -l pt_BR.UTF-8
218 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
219 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
220 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
221 operacionais comerciais para PC.
222
223 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
224 avançados e que querem mais recursos de seu boot loader.
225
226 %package -n bash-completion-%{name}
227 Summary:        bash-completion for GRUB
228 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
229 Group:          Applications/Shells
230 Requires:       bash-completion
231 %if "%{_rpmversion}" >= "5"
232 BuildArch:      noarch
233 %endif
234
235 %description -n bash-completion-%{name}
236 This package provides bash-completion for GRUB.
237
238 %description -n bash-completion-%{name} -l pl.UTF-8
239 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
240
241 %package platform-pc
242 Summary:        PC BIOS platform support for GRUB
243 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
244 Group:          Base
245 Provides:       %{name}-platform = %{version}-%{release}
246
247 %description platform-pc
248 PC BIOS platform support for GRUB.
249
250 %description platform-pc -l pl.UTF-8
251 Obsługa platformy PC BIOS dla GRUB-a.
252
253 %package platform-efi
254 Summary:        (U)EFI platform support for GRUB
255 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
256 Group:          Base
257 Suggests:       efibootmgr
258 Provides:       %{name}-platform = %{version}-%{release}
259
260 %description platform-efi
261 (U)EFI platform support for GRUB.
262
263 %description platform-efi -l pl.UTF-8
264 Obsługa platformy (U)EFI dla GRUB-a.
265
266 %package mkfont
267 Summary:        GRUB font files converter
268 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
269 Group:          Base
270
271 %description mkfont
272 Converts common font file formats into PF2.
273
274 %description mkfont -l pl.UTF-8
275 Program do konwersji popularnych formatów plików fontów do PF2.
276
277 %package theme-starfield
278 Summary:        starfield theme for GRUB
279 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
280 Group:          Base
281
282 %description theme-starfield
283 starfield theme for GRUB.
284
285 %description theme-starfield -l pl.UTF-8
286 Motyw starfield dla GRUB-a.
287
288 %prep
289 %setup -q -n grub-%{version}
290 %patch1 -p1
291 %patch2 -p1
292 %patch3 -p1
293 %patch4 -p1
294 %patch5 -p1
295 %patch6 -p1
296 %patch7 -p1
297 %patch8 -p1
298 %patch9 -p1
299 %patch10 -p1
300 %patch11 -p1
301 %patch12 -p0
302 %patch13 -p1
303 %patch14 -p1
304 %patch15 -p1
305 %patch16 -p1
306
307 # we don't have C.utf-8 and need an UTF-8 locale for build
308 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
309
310 %build
311 # if gold is used then grub doesn't even boot
312 # https://savannah.gnu.org/bugs/?34539
313 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
314 install -d our-ld
315 ln -f -s /usr/bin/ld.bfd our-ld/ld
316 export PATH=$(pwd)/our-ld:$PATH
317
318 ## not only the typicall autotools stuff
319 #./autogen.sh
320
321 #{__gettextize}
322 %{__aclocal} -I m4
323 %{__autoconf}
324 %{__autoheader}
325 %{__automake}
326
327 for platform in %{platforms} ; do
328         install -d build-${platform}
329         cd build-${platform}
330
331         if [ "$platform" != "efi" ] ; then
332                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
333         else
334                 platform_opts=""
335         fi
336
337         ln -f -s ../configure .
338         # mawk stalls at ./genmoddep.awk, so force gawk
339         AWK=gawk \
340         %configure \
341                 --with-platform=${platform} \
342                 --disable-werror \
343         %if %{with grubemu}
344                 --enable-grub-emu-usb \
345                 --enable-grub-emu-sdl \
346                 --enable-grub-emu-pci \
347         %endif
348                 $platform_opts \
349                 TARGET_LDFLAGS=-static
350
351         %{__make} -j1 -C po update-gmo
352         %{__make}
353         cd ..
354 done
355
356 %install
357 rm -rf $RPM_BUILD_ROOT
358
359 for platform in %{platforms} ; do
360         cd build-${platform}
361         %{__make} install \
362                 pkgdatadir=%{_libexecdir} \
363                 pkglibdir=%{_libexecdir} \
364                 DESTDIR=$RPM_BUILD_ROOT
365         cd ..
366 done
367
368 # not in Th (?)
369 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
370 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
371
372 %find_lang grub
373
374 # this must be after 'make install'
375 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
376
377 install -d $RPM_BUILD_ROOT%{_grubdir}
378 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
379
380 # grub.d/41_custom
381 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
382 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
383
384 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
385 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
386
387 install -d $RPM_BUILD_ROOT/etc/sysconfig
388 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
389
390 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
391 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
392
393 # platform specific, unnecessarily always installed
394 %ifnarch %{ix86} %{x8664} x32
395 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
396 %endif
397 %ifnarch sparc64
398 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
399 %endif
400
401 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
402 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
403 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
404
405 # needs to be exactly 1KiB
406 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
407 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
408
409 %clean
410 rm -rf $RPM_BUILD_ROOT
411
412 %post -p %{_sbindir}/postshell
413 -/usr/sbin/fix-info-dir -c %{_infodir}
414
415 %postun -p %{_sbindir}/postshell
416 -/usr/sbin/fix-info-dir -c %{_infodir}
417
418 %triggerpostun -- %{name} < 2.00-2
419 # Note this trigger on version upgrade needed only for upgrade from
420 # old grub2 packages which contained modules in /boot/grub
421 # or were built with optimizations enabled
422 # don't do anything on --downgrade
423 if [ $1 -le 1 ]; then
424         exit 0
425 fi
426 echo "Grub was upgraded, trying to setup it to boot sector"
427 /sbin/grub-install '(hd0)' || :
428
429 %triggerpostun -- %{name} < 1.99-7.3
430 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
431 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
432         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
433         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
434 fi
435
436 %files -f grub.lang
437 %defattr(644,root,root,755)
438 %doc AUTHORS ChangeLog NEWS README THANKS TODO
439 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
440 %attr(755,root,root) %{_sbindir}/grub-editenv
441 %attr(755,root,root) %{_sbindir}/grub-fstest
442 %attr(755,root,root) %{_sbindir}/grub-file
443 %attr(755,root,root) %{_sbindir}/grub-glue-efi
444 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
445 %attr(755,root,root) %{_sbindir}/grub-install
446 %attr(755,root,root) %{_sbindir}/grub-macbless
447 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
448 %attr(755,root,root) %{_sbindir}/grub-mkconfig
449 %attr(755,root,root) %{_sbindir}/grub-mklayout
450 %attr(755,root,root) %{_sbindir}/grub-mknetdir
451 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
452 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
453 %attr(755,root,root) %{_sbindir}/grub-mkrescue
454 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
455 %attr(755,root,root) %{_sbindir}/grub-mount
456 %attr(755,root,root) %{_sbindir}/grub-ofpathname
457 %attr(755,root,root) %{_sbindir}/grub-reboot
458 %attr(755,root,root) %{_sbindir}/grub-render-label
459 %attr(755,root,root) %{_sbindir}/grub-script-check
460 %attr(755,root,root) %{_sbindir}/grub-set-default
461 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
462 %attr(755,root,root) %{_sbindir}/update-grub
463 %ifarch %{ix86} %{x8664} x32
464 %attr(755,root,root) %{_sbindir}/grub-bios-setup
465 %{_mandir}/man8/grub-bios-setup.8*
466 %endif
467 %ifarch %{ix86} %{x8664} x32
468 %attr(755,root,root) %{_sbindir}/grub-mkimage
469 %{_mandir}/man1/grub-mkimage.1*
470 %else
471 %attr(755,root,root) %{_sbindir}/grub-probe
472 %{_mandir}/man8/grub-probe.8*
473 %endif
474 %ifarch sparc64
475 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
476 %{_mandir}/man8/grub-sparc64-setup.8*
477 %endif
478 %{_mandir}/man1/grub-editenv.1*
479 %{_mandir}/man1/grub-file.1*
480 %{_mandir}/man1/grub-fstest.1*
481 %{_mandir}/man1/grub-glue-efi.1*
482 %{_mandir}/man1/grub-kbdcomp.1*
483 %{_mandir}/man1/grub-menulst2cfg.1*
484 %{_mandir}/man1/grub-mklayout.1*
485 %{_mandir}/man1/grub-mknetdir.1*
486 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
487 %{_mandir}/man1/grub-mkrelpath.1*
488 %{_mandir}/man1/grub-mkrescue.1*
489 %{_mandir}/man1/grub-mkstandalone.1*
490 %{_mandir}/man1/grub-mount.1*
491 %{_mandir}/man1/grub-render-label.1*
492 %{_mandir}/man1/grub-script-check.1*
493 %{_mandir}/man1/grub-syslinux2cfg.1*
494 %{_mandir}/man8/grub-install.8*
495 %{_mandir}/man8/grub-macbless.8*
496 %{_mandir}/man8/grub-mkconfig.8*
497 %{_mandir}/man8/grub-ofpathname.8*
498 %{_mandir}/man8/grub-reboot.8*
499 %{_mandir}/man8/grub-set-default.8*
500 %{_mandir}/man8/update-grub.8*
501 %if %{with grubemu}
502 %attr(755,root,root) %{_sbindir}/grub-emu
503 %{_mandir}/man8/grub-emu.8*
504 %endif
505 %{_libexecdir}/grub-mkconfig_lib
506
507 %dir %{_grubdir}
508 %dir %{_libexecdir}
509 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
510
511 %dir %{_libexecdir}/locale
512 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
513 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
514
515 # generated by grub at runtime
516 %ghost %{_grubdir}/device.map
517 %ghost %{_grubdir}/core.img
518 %ghost %{_grubdir}/grubenv
519
520 %dir /lib/grub.d
521 %doc /lib/grub.d/README
522 %attr(755,root,root) /lib/grub.d/00_header
523 %attr(755,root,root) /lib/grub.d/10_linux
524 %attr(755,root,root) /lib/grub.d/20_linux_xen
525 %attr(755,root,root) /lib/grub.d/30_os-prober
526 %attr(755,root,root) /lib/grub.d/41_custom
527
528 # these are now installed only on matching hosts
529 #%attr(755,root,root) /lib/grub.d/10_hurd
530 #%attr(755,root,root) /lib/grub.d/10_illumos
531 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
532 #%attr(755,root,root) /lib/grub.d/10_netbsd
533 #%attr(755,root,root) /lib/grub.d/10_xnu
534
535 %ifarch %{ix86} %{x8664} x32
536 %attr(755,root,root) %{_sbindir}/grub-probe
537 %{_mandir}/man8/grub-probe.8*
538 %endif
539
540 %{_infodir}/grub*.info*
541
542 %dir %{_datadir}/grub/themes
543
544 %if %{with pc}
545 %files platform-pc
546 %defattr(644,root,root,755)
547 %dir %{_libexecdir}/*-pc
548 %{_libexecdir}/*-pc/modinfo.sh
549 %{_libexecdir}/*-pc/*.exec
550 %{_libexecdir}/*-pc/*.image
551 %{_libexecdir}/*-pc/*.lst
552 %{_libexecdir}/*-pc/*.mod
553 %{_libexecdir}/*-pc/*.module
554 %{_libexecdir}/*-pc/lzma_decompress.img
555 %{_libexecdir}/*-pc/config.h
556 %{_libexecdir}/*-pc/gdb_grub
557 %{_libexecdir}/*-pc/gmodule.pl
558 %if %{with efiemu}
559 %{_libexecdir}/*-pc/efiemu*.o
560 %endif
561 %{_libexecdir}/*-pc/kernel.img
562 %ifarch %{ix86} %{x8664} x32 sparc sparc64
563 %{_libexecdir}/*-pc/boot.img
564 %{_libexecdir}/*-pc/boot_hybrid.img
565 %{_libexecdir}/*-pc/cdboot.img
566 %{_libexecdir}/*-pc/diskboot.img
567 %{_libexecdir}/*-pc/lnxboot.img
568 %{_libexecdir}/*-pc/pxeboot.img
569 %endif
570 %endif
571
572 %if %{with efi}
573 %files platform-efi
574 %defattr(644,root,root,755)
575 %dir %{_libexecdir}/*-efi
576 %{_libexecdir}/*-efi/modinfo.sh
577 %{_libexecdir}/*-efi/*.exec
578 %{_libexecdir}/*-efi/*.lst
579 %{_libexecdir}/*-efi/*.mod
580 %{_libexecdir}/*-efi/*.module
581 %{_libexecdir}/*-efi/config.h
582 %{_libexecdir}/*-efi/gdb_grub
583 %{_libexecdir}/*-efi/gmodule.pl
584 %{_libexecdir}/*-efi/kernel.img
585 %endif
586
587 %files mkfont
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_sbindir}/grub-mkfont
590 %{_mandir}/man1/grub-mkfont.1*
591
592 %files theme-starfield
593 %defattr(644,root,root,755)
594 %{_datadir}/grub/themes/starfield
595
596 %files -n bash-completion-%{name}
597 %defattr(644,root,root,755)
598 /etc/bash_completion.d/grub
This page took 0.076686 seconds and 3 git commands to generate.