]> git.pld-linux.org Git - packages/grive2.git/blob - grive.spec
- rel 19 (rebuild with binutils 2.28)
[packages/grive2.git] / grive.spec
1 %define         commit          27817e835fe115ebbda5410ec904aa49a2ad01f1
2 # bash: %%(c=%{commit}; echo ${c:0:7})
3 %define         shortcommit     27817e8
4 %define         cdate           20130702
5 %define         rel             19
6 Summary:        An open source Linux client for Google Drive
7 Summary(pl.UTF-8):      Linuksowy, mające otwarte źródła klient Google Drive
8 Name:           grive
9 Version:        0.3.0
10 Release:        0.%{cdate}git%{shortcommit}.%{rel}
11 License:        GPL v2
12 Group:          Applications/Networking
13 Source0:        https://github.com/Grive/grive/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
14 # Source0-md5:  4f3c3411588f889801bd5b9297e6e2c9
15 # https://github.com/Grive/grive/issues/187
16 Patch0:         json-c.patch
17 Patch1:         %{name}-bgrive_cmake_fix.patch
18 Patch2:         build.patch
19 URL:            http://www.lbreda.com/grive/
20 BuildRequires:  QtCore-devel
21 BuildRequires:  binutils-devel
22 BuildRequires:  boost-devel
23 BuildRequires:  cmake
24 BuildRequires:  curl-devel
25 BuildRequires:  expat-devel
26 BuildRequires:  json-c-devel >= 0.11
27 BuildRequires:  libgcrypt-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  yajl-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The purpose of this project is to provide an independent
35 implementation of Google Drive client. It uses the Google Document
36 List API to talk to the servers in Google.
37
38 %description -l pl.UTF-8
39 Celem tego projektu jest zapewnienie niezależnej implementacji klienta
40 Google Drive. Do komunikacji z serwerami Google'a wykorzystuje API
41 Google Document List.
42
43 %package -n bgrive
44 Summary:        Qt frontend for Grive
45 Summary(pl.UTF-8):      Interfejs Qt do Grive
46 Group:          Applications/Networking
47 Requires:       %{name} = %{version}-%{release}
48
49 %description -n bgrive
50 GUI frontend for Grive.
51
52 %description -n bgrive -l pl.UTF-8
53 Graficzny interfejs użytkownika do Grive.
54
55 %prep
56 %setup -q -n %{name}-%{commit}
57 %patch0 -p1
58 %patch1 -p1
59 %patch2 -p1
60
61 %build
62 install -d build
63 cd build
64 %cmake ..
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %{__make} -C build install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README
78 %attr(755,root,root) %{_bindir}/%{name}
79 %{_mandir}/man1/%{name}.1*
80
81 %files -n bgrive
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/bgrive
This page took 0.044851 seconds and 3 git commands to generate.