]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
- more macros.
[packages/grep.git] / grep.spec
1 Summary:        GNU grep Utilities
2 Summary(fr):    Utilitaires grep de GNU
3 Summary(pl):    GNU grep 
4 Summary(tr):    Dosyalarda katar arama aracý
5 Name:           grep
6 Version:        2.3
7 Release:        4
8 Copyright:      GPL
9 Group:          Utilities/Text
10 Group(pl):      Narzêdzia/Tekst
11 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Source1:        grep.1.pl
13 Patch0:         grep-info.patch
14 Prereq:         /sbin/install-info
15 Buildroot:      /tmp/%{name}-%{version}-root
16
17 %description
18
19 This is the GNU implementation of the popular `grep' *nix utility. It
20 allows for the fast locating of strings in text files.
21
22 %description -l de
23 Dies ist die GNU-Implementierung des beliebten *nix-Dienstprogramms 'grep'.
24 Damit können schnell Zeichenketten in Textdateien finden.
25
26 %description -l fr
27 Ceci est l'implémentation par GNU du  populaire l'utilitaire grep su *nix.
28 Il permet de localiser rapidement des chaînes de caractéres dans les
29 fichiers.
30
31 %description -l pl 
32 GNU grep jest implementacj± popularnego programu unixowego `grep'. Grep jest
33 jednym z podstawowych narzêdzi, korzysta z niego prawie ka¿dy skrypt shella.
34
35 %description -l tr
36 Bu, bütün Unix'lerde bulunan ve yaygýn olarak kullanýlan grep aracýnýn GNU
37 sürümüdür. Metin dosyalarý içinde bulunan katarlarý aramada kullanýlýr.
38
39 %prep
40 %setup  -q
41 %patch0 -p1
42
43 %build
44 autoconf
45 gettextize --copy --force
46 %configure \
47         --prefix=%{_prefix} \
48         --exec-prefix=/
49 make
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_mandir}/pl/man1
54
55 make install \
56         bindir=$RPM_BUILD_ROOT/bin \
57         infodir=$RPM_BUILD_ROOT%{_infodir} \
58         mandir=$RPM_BUILD_ROOT%{_mandir}
59
60 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/grep.1
61
62 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
63 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
64
65 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/pl/man1/egrep.1
66 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/pl/man1/fgrep.1
67
68 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/{man1/*,pl/man1/*}} \
69         NEWS README ChangeLog TODO
70
71 %find_lang grep
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 /sbin/install-info %{_infodir}/grep.info.gz /etc/info-dir
78
79 %preun
80 if [ "$1" = "0" ]; then
81         /sbin/install-info --delete %{_infodir}/grep.info.gz /etc/info-dir
82 fi
83
84 %files -f grep.lang
85
86 %defattr(644,root,root,755)
87 %doc {NEWS,README,ChangeLog,TODO}.gz
88
89 %attr(755,root,root) /bin/*
90 %{_mandir}/man1/*
91 %lang(pl) %{_mandir}/pl/man1/*
92 %{_infodir}/*info*
93
94 %changelog
95 * Fri May 21 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
96   [2.3-4]
97 - added more macros.
98
99 * Wed Apr 28 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
100   [2.3-3]
101 - added el .mo file,
102 - added pl man page for grep,
103 - added info pages for grep.
104
105 * Tue Apr 27 1999 Piotr Czerwiñski <pius@pld.org.pl>
106   [2.2-6]
107 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
108 - gzipping documentation,
109 - removed man group from man pages,
110 - replacements in %files,
111 - minor changes,
112 - recompiled on rpm 3.
113
114 * Fri Dec 11 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
115   [2.2-4]
116 - added gzipping man pages,
117 - added using LDFLAGS="-s" to ./configure enviroment.
118
119 * Tue Oct 06 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
120   [2.2-3]
121 - added pl translation,
122 - minor modification of the spec file.
123 - build against GNU libc-2.1,
124 - start at invalid RH spec file.
This page took 0.061644 seconds and 4 git commands to generate.