]> git.pld-linux.org Git - packages/grass.git/blob - grass.spec
- updated todo
[packages/grass.git] / grass.spec
1
2 #
3 # todo:
4 # 1. Manuals conflicts with ImageMagick 
5 # file /usr/X11R6/man/man1/display.1.gz from install of grass-5.0.0pre3-1
6 #   conflicts with file from package ImageMagick-5.4.4-1
7 # file /usr/X11R6/man/man1/import.1.gz from install of grass-5.0.0pre3-1
8 #   conflicts with file from package ImageMagick-5.4.4-1
9 #
10 # 2. see %install section :-\
11 # 3. 755 for etc/bin/cmd/*
12 #
13
14 Summary:        The Geographic Resources Analysis Support System
15 Summary(pl):    System obs³uguj±cy analizê zasobów geograficznych
16 Name:           grass
17 Version:        5.0.0pre3
18 Release:        1
19 License:        GPL
20 Group:          X11/Applications
21 Source0:        http://grass.itc.it/grass5/source/%{name}%{version}.tar.gz
22 URL:            http://grass.itc.it/
23 BuildRequires:  blas-devel
24 #BuildRequires: gdal-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  fftw-devel
27 BuildRequires:  freetype-devel
28 BuildRequires:  gd-devel
29 BuildRequires:  gdbm-devel
30 BuildRequires:  lapack-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libtiff-devel
34 BuildRequires:  motif-devel
35 BuildRequires:  postgresql-backend-devel
36 BuildRequires:  postgresql-devel
37 BuildRequires:  tcl-devel
38 BuildRequires:  tk-devel
39 BuildRequires:  unixODBC-devel
40 BuildRequires:  zlib-devel
41 BuildRequires:  gcc-g77
42 BuildRequires:  flex
43 BuildRequires:  bison
44 BuildRequires:  ncurses-devel
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
48 %define         _prefix         /usr/X11R6
49 %define         _mandir         %{_prefix}/man
50 %define         _sysconfdir     /etc/X11
51
52 %description
53 GRASS (the Geographic Resources Analysis Support System) is a software
54 raster- and vector-based GIS (Geographic Information System), image
55 processing system, graphics production system, and spatial modeling
56 system. GRASS contains many modules for raster data manipulation,
57 vector data manipulation, rendering images on the monitor or paper,
58 multispectral image processing, point data management and general data
59 management. It also has tools for interfacing with digitizers,
60 scanners, and the RIM, Informix, Postgres, and Oracle databases.
61
62 %description -l pl
63 GRASS (System Wspierania Analiz Zasobów Geograficznych) jest rastrowym
64 oraz wektorowym systemem GIS (System Informacji Geograficznej),
65 obróbki obrazów, tworzenia grafiki oraz modelowania przestrzennego.
66 GRASS zawiera wiele modu³ów wspomagaj±cych manipulacjê danymi
67 rastrowymi i wektorowymi, renderowanie obrazów na monitorze lub
68 papierze, obróbkê multispektralnych obrazów, punktowe oraz ogólne
69 zarz±dzanie danymi. Zawiera równie¿ narzêdzia do wspó³pracy z
70 digitizerami, skanerami oraz bazami RIM, Informix, Postgres oraz
71 Oracle.
72
73 %package OpenGL
74 Summary:        NVIZ - a 3D-tool for GRASS
75 Summary(pl):    NVIZ - narzêdzie 3D dla GRASSa
76 Group:          X11/Applications
77 Requires:       %{name} = %{version}
78
79 %description OpenGL
80 Package contains nviz, which is a GRASS module-in-progress which
81 allows users to realistically render multiple surfaces in a 3D space,
82 optionally using thematic coloring, draping GRASS vector files over
83 the surfaces, and displaying GRASS site files either draped on the
84 surfaces or as 3D point locations.
85
86 %description OpenGL -l pl
87 Pakiet zawiera modu³ nviz, który rozszerza funkcjonalno¶æ systemu
88 GRASS o mo¿liwo¶æ realistycznego renderowania wielu powierzchni w
89 trójwymiarowej przestrzeni. Na renderowanych powierzchniach, które
90 mog± byæ tematycznie kolorowane, mo¿na zawieszaæ pliki wektorowe
91 GRASSa.
92
93 %package pg
94 Summary:        PostgreSQL database interface
95 Summary(pl):    Interfejs do bazy PostgreSQL
96 Group:          X11/Applications
97 Requires:       %{name} = %{version}
98
99 %description pg
100 PostgreSQL database interface for GRASS.
101
102 %dewscription pg -l pl
103 Interfejs do bazy PostgreSQL dla GRASSa.
104
105 %package odbc
106 Summary:        ODBC database interface
107 Summary(pl):    Interfejs ODBC dla GRASSa
108 Group:          X11/Applications
109 Requires:       %{name} = %{version}
110
111 %description odbc
112 ODBC database interface for GRASS.
113
114 %description odbc -l pl
115 Interfejs ODBC dla GRASSa.
116
117 %package devel
118 Summary:        Header files for GRASS
119 Summary(pl):    Pliki nag³ówkowe systemu GRASS
120 Group:          X11/Development/Libraries
121 Requires:       %{name} = %{version}
122
123 %description devel 
124 Header files for GRASS.
125
126 %description devel -l pl
127 Pliki nag³ówkowe systemu GRASS.
128
129 %package static
130 Summary:        GRASS static libraries
131 Summary(pl):    Biblioteki statyczne systemu GRASS
132 Group:          X11/Development/Libraries
133 Requires:       %{name} = %{version}
134
135 %description static 
136 GRASS static libraries.
137
138 %description static -l pl
139 Biblioteki statyczne systemu GRASS.
140
141 %prep
142 %setup -q -n %{name}%{version}
143
144 %build
145 if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
146         CPPFLAGS="`pkg-config libpng12 --cflags`"; export CPPFLAGS
147 fi
148 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"; export CFLAGS
149 %configure2_13 \
150         --with-lapack \
151         --with-motif \
152         --with-freetype \
153         --with-includes=%{_includedir} \
154         --with-libs=%{_libdir} \
155         --with-postgres-includes=/usr/include/postgresql/server \
156         --with-freetype-includes=/usr/include/freetype2
157 %{__make}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_includedir}/grass5,%{_libdir}/grass5}
163
164 cd dist.%{_host}
165
166 # bin: there are many binaries with the same content, i.e. d.*, i.* -
167 #      create symlinks instead of binaries?
168 # etc: it is a big mess; do not move the content of "etc" dir to /etc
169 # txt: move to %docdir?
170 # tcltkgrass: separate package?
171 # bwidget: move to devel or separate package?
172 # dev: move the content to /dev or leave it as below?
173 cp -a bin bwidget etc dev driver fonts scripts tcltkgrass txt $RPM_BUILD_ROOT%{_libdir}/grass5
174
175 install man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
176 install lib/* $RPM_BUILD_ROOT%{_libdir}
177 install include/* $RPM_BUILD_ROOT%{_includedir}/grass5
178
179 cd ..
180
181 gzip -9nf AUTHORS BUGS COPYING NEWS.html ONGOING TODO.txt documents/*.*
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %files
187 %defattr(644,root,root,755)
188 %doc *.gz */*.gz
189 %dir %{_libdir}/grass5
190 %dir %{_libdir}/grass5/bin
191 %attr(755,root,root) %{_libdir}/grass5/bin/*
192 %{_libdir}/grass5/bwidget
193 %{_libdir}/grass5/etc
194 %{_libdir}/grass5/dev
195 %{_libdir}/grass5/driver
196 %{_libdir}/grass5/fonts
197 %{_libdir}/grass5/scripts
198 %{_libdir}/grass5/tcltkgrass
199 %{_libdir}/grass5/txt
200 %{_mandir}/man1/*
201
202 %files devel
203 %defattr(644,root,root,755)
204 %{_includedir}/grass5
205
206 %files static
207 %defattr(644,root,root,755)
208 %{_libdir}/*.a
This page took 0.112342 seconds and 3 git commands to generate.