]> git.pld-linux.org Git - packages/graphviz.git/blob - graphviz.spec
- old one obsolete, new fixes for graphviz 2.8
[packages/graphviz.git] / graphviz.spec
1 #
2 # Conditional build:
3 %bcond_with     java    # build Java binding
4 #
5 Summary:        Graph Visualization Tools
6 Summary(pl):    Narzêdzie do wizualizacji w postaci grafów
7 Name:           graphviz
8 Version:        2.6
9 Release:        5
10 License:        CPL v1.0
11 Group:          X11/Applications/Graphics
12 Source0:        http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
13 # Source0-md5:  0d61fc4f8660be31503d4f9ab6f26bf0
14 Patch0:         %{name}-fontpath.patch
15 Patch1:         %{name}-php.patch
16 Patch2:         %{name}-gd.patch
17 Patch3:         %{name}-tk.patch
18 URL:            http://www.graphviz.org/
19 BuildRequires:  XFree86-devel
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  expat-devel
24 BuildRequires:  flex
25 BuildRequires:  freetype-devel >= 2.0.0
26 BuildRequires:  gawk
27 BuildRequires:  gd-devel >= 2.0.33-5
28 BuildRequires:  gettext-devel
29 %{?with_java:BuildRequires:     jdk}
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool
34 BuildRequires:  perl-devel
35 BuildRequires:  php-devel >= 3:5.0.0
36 BuildRequires:  php-program >= 3:5.0.0
37 BuildRequires:  pkgconfig
38 BuildRequires:  python-devel
39 BuildRequires:  rpmbuild(macros) >= 1.277
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  ruby-devel
42 BuildRequires:  tcl-devel >= 8.3.0
43 BuildRequires:  tk-devel >= 8.3.0
44 BuildRequires:  zlib-devel
45 Requires(post,postun):  /sbin/ldconfig
46 Requires:       gd >= 2.0.33-5
47 Requires:       ghostscript-fonts-std
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 A collection of tools and tcl packages for the manipulation and layout
52 of graphs (as in nodes and edges, not as in barcharts).
53
54 %description -l pl
55 Kolekcja narzêdzi oraz pakietów tcl s³u¿±cych do manipulacji i
56 rozmieszczania grafów.
57
58 %package devel
59 Summary:        Header files for graphviz libraries
60 Summary(pl):    Pliki nag³ówkowe do bibliotek graphviz
61 Group:          X11/Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       gd-devel >= 2.0.33-5
64 Requires:       libltdl-devel
65
66 %description devel
67 This package contains the header files for graphviz libraries.
68
69 %description devel -l pl
70 Ten pakiet zawiera pliki nag³ówkowe do bibliotek graphviz.
71
72 %package graphs
73 Summary:        Demo graphs for graphviz
74 Summary(pl):    Przyk³adowe grafy dla graphviza
75 Group:          X11/Applications/Graphics
76 Requires:       %{name} = %{version}-%{release}
77
78 %description graphs
79 This package provides some example graphs.
80
81 %description graphs -l pl
82 Ten pakiet zawiera trochê przyk³adowych grafów.
83
84 %package java
85 Summary:        Java binding for graphviz
86 Summary(pl):    Wi±zania Javy dla graphviza
87 Group:          Libraries
88 Requires:       %{name} = %{version}-%{release}
89
90 %description java
91 Java binding for graphviz.
92
93 %description java -l pl
94 Wi±zania Javy dla graphviza.
95
96 %package perl
97 Summary:        Perl binding for graphviz
98 Summary(pl):    Wi±zania Perla dla graphviza
99 Group:          Libraries
100 Requires:       %{name} = %{version}-%{release}
101
102 %description perl
103 Perl binding for graphviz.
104
105 %description perl -l pl
106 Wi±zania Perla dla graphviza.
107
108 %package php
109 Summary:        PHP binding for graphviz
110 Summary(pl):    Wi±zania PHP dla graphviza
111 Group:          Libraries
112 Requires:       %{name} = %{version}-%{release}
113 %{?requires_php_extension}
114
115 %description php
116 PHP binding for graphviz.
117
118 %description php -l pl
119 Wi±zania PHP dla graphviza.
120
121 %package python
122 Summary:        Python binding for graphviz
123 Summary(pl):    Wi±zania Pythona dla graphviza
124 Group:          Libraries
125 Requires:       %{name} = %{version}-%{release}
126
127 %description python
128 Python binding for graphviz.
129
130 %description python -l pl
131 Wi±zania Pythona dla graphviza.
132
133 %package ruby
134 Summary:        Ruby binding for graphviz
135 Summary(pl):    Wi±zania Ruby'ego dla graphviza
136 Group:          Libraries
137 Requires:       %{name} = %{version}-%{release}
138
139 %description ruby
140 Ruby binding for graphviz.
141
142 %description ruby -l pl
143 Wi±zania Ruby'ego dla graphviza.
144
145 %package tcl
146 Summary:        Tcl extension tools for graphviz
147 Summary(pl):    Rozszerzenia Tcl dla graphviza
148 Group:          X11/Applications/Graphics
149 Requires:       %{name} = %{version}-%{release}
150
151 %description tcl
152 This package contains the various Tcl packages (extensions) using
153 graphviz.
154
155 %description tcl -l pl
156 Ten pakiet zawiera ró¿ne pakiety (rozszerzenia) Tcl u¿ywaj±ce
157 graphviza.
158
159 %prep
160 %setup -q
161 %patch0 -p1
162 %patch1 -p1
163 %patch2 -p1
164 %patch3 -p1
165
166 %build
167 %{__libtoolize}
168 %{__aclocal}
169 %{__autoconf}
170 %{__autoheader}
171 %{__automake}
172 %configure \
173         --disable-static
174
175 %{__make}
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT
182
183 %if "%{_lib}" != "lib"
184 # tcl doesn't find pkgIndex.tcl outside /usr/lib...
185 install -d $RPM_BUILD_ROOT%{_prefix}/lib/graphviz
186 sed -e "s@\$dir @%{_libdir}/graphviz/@" $RPM_BUILD_ROOT%{_libdir}/graphviz/pkgIndex.tcl \
187 > $RPM_BUILD_ROOT%{_prefix}/lib/graphviz/pkgIndex.tcl
188 %endif
189
190 # replace dead (after compression) softlinks by groff redirections
191 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{circo,fdp,neato,twopi}.1
192 echo ".so dot.1" >$RPM_BUILD_ROOT%{_mandir}/man1/circo.1
193 echo ".so dot.1" >$RPM_BUILD_ROOT%{_mandir}/man1/fdp.1
194 echo ".so dot.1" >$RPM_BUILD_ROOT%{_mandir}/man1/neato.1
195 echo ".so dot.1" >$RPM_BUILD_ROOT%{_mandir}/man1/twopi.1
196
197 # created by %{_bindir}/dot -c
198 touch $RPM_BUILD_ROOT%{_libdir}/graphviz/config
199
200 rm -f $RPM_BUILD_ROOT%{_libdir}/graphviz/libgv_{java,perl,php,python,ruby,tcl}.la
201
202 %clean
203 rm -rf $RPM_BUILD_ROOT
204
205 %post
206 /sbin/ldconfig
207 umask 022
208 [ ! -x %{_bindir}/dot ] || %{_bindir}/dot -c > /dev/null 2>&1
209
210 %postun -p /sbin/ldconfig
211
212 %files
213 %defattr(644,root,root,755)
214 %doc AUTHORS COPYING ChangeLog NEWS doc/*.pdf
215 %attr(755,root,root) %{_bindir}/*
216 %dir %{_libdir}/graphviz
217 %{_libdir}/graphviz/config
218 # linkable libs
219 %attr(755,root,root) %{_libdir}/graphviz/libagraph.so.*
220 %attr(755,root,root) %{_libdir}/graphviz/libcdt.so.*
221 %attr(755,root,root) %{_libdir}/graphviz/libexpr.so.*
222 %attr(755,root,root) %{_libdir}/graphviz/libgraph.so.*
223 %attr(755,root,root) %{_libdir}/graphviz/libgvc.so.*
224 %attr(755,root,root) %{_libdir}/graphviz/libpack.so.*
225 %attr(755,root,root) %{_libdir}/graphviz/libpathplan.so.*
226 # plugins
227 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_dot_layout.so*
228 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_neato_layout.so*
229 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_usershape_gd.so*
230 # ??? (some *.so links are needed here for tcl, the rest "just in case")
231 %attr(755,root,root) %{_libdir}/graphviz/libgdtclft.so*
232 %attr(755,root,root) %{_libdir}/graphviz/libgvc_builtins.so*
233 %attr(755,root,root) %{_libdir}/graphviz/libtcldot.so*
234 %attr(755,root,root) %{_libdir}/graphviz/libtclplan.so*
235 %attr(755,root,root) %{_libdir}/graphviz/libtkspline.so*
236 # what about the rest of *.la?
237 %dir %{_datadir}/graphviz
238 %{_datadir}/graphviz/lefty
239 %{_mandir}/man1/*
240
241 %files devel
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_libdir}/graphviz/libagraph.so
244 %attr(755,root,root) %{_libdir}/graphviz/libcdt.so
245 %attr(755,root,root) %{_libdir}/graphviz/libexpr.so
246 %attr(755,root,root) %{_libdir}/graphviz/libgraph.so
247 %attr(755,root,root) %{_libdir}/graphviz/libgvc.so
248 %attr(755,root,root) %{_libdir}/graphviz/libpack.so
249 %attr(755,root,root) %{_libdir}/graphviz/libpathplan.so
250 %{_libdir}/graphviz/libagraph.la
251 %{_libdir}/graphviz/libcdt.la
252 %{_libdir}/graphviz/libexpr.la
253 %{_libdir}/graphviz/libgraph.la
254 %{_libdir}/graphviz/libgvc.la
255 %{_libdir}/graphviz/libpack.la
256 %{_libdir}/graphviz/libpathplan.la
257 %{_pkgconfigdir}/*.pc
258 %{_includedir}/graphviz
259 %{_mandir}/man3/*
260
261 %files graphs
262 %defattr(644,root,root,755)
263 %{_datadir}/graphviz/graphs
264
265 %if %{with java}
266 %files java
267 %defattr(644,root,root,755)
268 %attr(755,root,root) %{_libdir}/graphviz/libgv_java.so*
269 %endif
270
271 %files perl
272 %defattr(644,root,root,755)
273 %attr(755,root,root) %{_libdir}/graphviz/libgv_perl.so*
274
275 %files php
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{_libdir}/graphviz/libgv_php.so*
278
279 %files python
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_libdir}/graphviz/libgv_python.so*
282
283 %files ruby
284 %defattr(644,root,root,755)
285 %attr(755,root,root) %{_libdir}/graphviz/libgv_ruby.so*
286
287 %files tcl
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{_libdir}/graphviz/libgv_tcl.so*
290 %if "%{_lib}" != "lib"
291 %dir %{_prefix}/lib/graphviz
292 %endif
293 %{_prefix}/lib/graphviz/pkgIndex.tcl
294 %{_mandir}/mann/*
295 %dir %{_datadir}/graphviz/demo
296 %{_datadir}/graphviz/demo/pathplan_data
297 %{_datadir}/graphviz/demo/*.*
298 %attr(755,root,root) %{_datadir}/graphviz/demo/doted
299 %attr(755,root,root) %{_datadir}/graphviz/demo/entities
300 %attr(755,root,root) %{_datadir}/graphviz/demo/gcat
301 %attr(755,root,root) %{_datadir}/graphviz/demo/pathplan
302 %attr(755,root,root) %{_datadir}/graphviz/demo/spline
This page took 0.106868 seconds and 3 git commands to generate.