]> git.pld-linux.org Git - packages/graphviz.git/blob - graphviz.spec
- massive attack: adding Source-md5
[packages/graphviz.git] / graphviz.spec
1 #
2 # Conditional build:
3 # _with_dynagraph - with dynagraph program (they say it requires gcc 3.1;
4 #       it builds with 2.95.4, but doesn't seem to work - fstream problems)
5 #       -- doesn't build now anyway in 1.9 (missing file?)
6 # _without_system_gd - use included libgd instead of system-wide one
7 #                      (needed if your libgd doesn't support GIF format)
8 #
9 Summary:        Graph Visualization Tools
10 Summary(pl):    Narzêdzie do wizualizacji w postaci grafów
11 Name:           graphviz
12 Version:        1.9
13 Release:        1
14 License:        custom (AT&T)
15 Group:          X11/Applications/Graphics
16 Source0:        http://www.graphviz.org/pub/graphviz/%{name}-%{version}.tar.gz
17 # Source0-md5:  5f8d1e1f15594f4869fc9c68f32e7dbb
18 Patch0:         %{name}-lt14d.patch
19 Patch1:         %{name}-system-gd.patch
20 Patch2:         %{name}-fontpath.patch
21 URL:            http://www.graphviz.org/
22 BuildRequires:  XFree86-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  bison
26 BuildRequires:  flex
27 BuildRequires:  freetype-devel >= 2.0.0
28 BuildRequires:  gawk
29 %{!?_without_system_gd:BuildRequires:   gd-devel(gif) >= 2.0.9}
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool
34 BuildRequires:  tcl-devel >= 8.3.0
35 BuildRequires:  zlib-devel
36 %{!?_without_system_gd:Requires:        gd(gif) >= 2.0.9}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 A collection of tools and tcl packages for the manipulation and layout
41 of graphs (as in nodes and edges, not as in barcharts).
42
43 %description -l pl
44 Kolekcja narzêdzi oraz pakietów tcl s³u¿±cych do manipulacji i
45 rozmieszczania grafów.
46
47 %package graphs
48 Summary:        Demo graphs for graphviz
49 Summary(pl):    Przyk³adowe grafy dla graphviza
50 Group:          X11/Applications/Graphics
51 Requires:       %{name} = %{version}
52
53 %description graphs
54 This package provides some example graphs.
55
56 %description graphs -l pl
57 Ten pakiet zawiera trochê przyk³adowych grafów.
58
59 %package tcl
60 Summary:        Tcl extension tools for graphviz
61 Summary(pl):    Rozszerzenia Tcl dla graphviza
62 Group:          X11/Applications/Graphics
63 Requires:       %{name} = %{version}
64
65 %description tcl
66 This package contains the various tcl packages (extensions) using
67 graphviz.
68
69 %description tcl -l pl
70 Ten pakiet zawiera ró¿ne pakiety (rozszerzenia) tcl u¿ywaj±ce
71 graphviza.
72
73 %package devel
74 Summary:        Header files for graphviz libraries
75 Summary(pl):    Pliki nag³ówkowe do bibliotek graphviz
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{version}
78
79 %description devel
80 This package contains the header files for graphviz libraries.
81
82 %description devel -l pl
83 Ten pakiet zawiera pliki nag³ówkowe do bibliotek graphviz.
84
85 %prep
86 %setup -q
87 if grep -q '^VERSION=1\.\(4[de]\|5\)$' /usr/bin/libtool ; then
88 %patch0 -p1
89 fi
90 %{!?_without_system_gd:%patch1 -p1}
91 %patch2 -p1
92
93 %build
94 rm -f missing
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__automake}
99 %configure \
100         %{?_with_dynagraph:--with-dynagraph}
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 # tcl doesn't find pkgIndex.tcl outside /usr/lib...
111 install -d $RPM_BUILD_ROOT/usr/lib/graphviz
112 sed -e "s@\$dir @%{_libdir}/graphviz/@" $RPM_BUILD_ROOT%{_libdir}/graphviz/pkgIndex.tcl \
113         > $RPM_BUILD_ROOT/usr/lib/graphviz/pkgIndex.tcl
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS COPYING ChangeLog FAQ.txt NEWS doc/*.pdf
124 %attr(755,root,root) %{_bindir}/*
125 %dir %{_libdir}/graphviz
126 # *.so links are needed here for tcl
127 %attr(755,root,root) %{_libdir}/graphviz/lib*.so*
128 %dir %{_datadir}/graphviz
129 %{_datadir}/graphviz/lefty
130 %{_mandir}/man1/*
131
132 %files graphs
133 %defattr(644,root,root,755)
134 %{_datadir}/graphviz/graphs
135
136 %files tcl
137 %defattr(644,root,root,755)
138 %dir /usr/lib/graphviz
139 /usr/lib/graphviz/pkgIndex.tcl
140 %{_mandir}/mann/*
141 %dir %{_datadir}/graphviz/demo
142 %{_datadir}/graphviz/demo/pathplan_data
143 %{_datadir}/graphviz/demo/*.*
144 %attr(755,root,root) %{_datadir}/graphviz/demo/dge
145 %attr(755,root,root) %{_datadir}/graphviz/demo/doted
146 %attr(755,root,root) %{_datadir}/graphviz/demo/entities
147 %attr(755,root,root) %{_datadir}/graphviz/demo/gcat
148 %attr(755,root,root) %{_datadir}/graphviz/demo/ihi
149 %attr(755,root,root) %{_datadir}/graphviz/demo/pathplan
150 %attr(755,root,root) %{_datadir}/graphviz/demo/spline
151
152 %files devel
153 %defattr(644,root,root,755)
154 %{_libdir}/graphviz/lib*.la
155 %{_includedir}/graphviz
156 %{_mandir}/man3/*
This page took 0.05058 seconds and 3 git commands to generate.