]> git.pld-linux.org Git - packages/grace.git/blob - grace.spec
- added %description -l pl
[packages/grace.git] / grace.spec
1 Summary:        Numerical Data Processing and Visualization Tool (grace)
2 Name:           grace
3 Version:        5.1.0
4 Release:        1
5 License:        GPL
6 Group:          Applications/Math
7 Source0:        ftp://plasma-gate.weizmann.ac.il/pub/grace/src/%{name}-%{version}.tar.gz
8 Source1:        xmgrace
9 Source2:        fftw.tar.gz
10 Patch0:         %{name}.perl.patch
11 Icon:           %{name}.gif
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Grace is a Motif application for two-dimensional data visualization. Grace
16 can transform the data using free equations, FFT, cross- and
17 auto-correlation, differences, integrals, histograms, and much more. The
18 generated figures are of high quality. Grace is a very convenient tool for
19 data inspection, data transformation, and and for making figures for
20 publications.
21
22 %description -l pl
23 Grace jest Motiffow± aplikacj± s³u¿±c± do dwuwymiarowej wizualizacji danych.
24 Mo¿e przejszta³caæ dane za pomoc± wolnych równañ, FFT, autokorelacji,
25 ró¿niczek, ca³ek, histogramów itd. Powsta³e wykresy maj± wysok± jako¶æ.
26 Grace jest bardzo u¿ytecznym narzêdziem je¶li chodzi o monitorowanie i
27 transformacjê danych oraz tworzenie wykresów do publikacji.
28
29 %package dynamic
30 Group:          Applications/Math
31 Summary:        Numerical Data Processing and Visualization Tool (grace)
32 Provides:       %{name}
33 Conflicts:      %{name}-semistatic
34
35 %description dynamic
36 Grace is a Motif application for two-dimensional data visualization. Grace
37 can transform the data using free equations, FFT, cross- and
38 auto-correlation, differences, integrals, histograms, and much more. The
39 generated figures are of high quality. Grace is a very convenient tool for
40 data inspection, data transformation, and and for making figures for
41 publications.
42
43 %package semistatic
44 Group:          Applications/Math
45 Summary:        grace with statically linked Motif libraries
46 Provides:       %{name}
47 Conflicts:      %{name}-dynamic
48
49 %description semistatic
50 Grace is a Motif application for two-dimensional data visualization. Grace
51 can transform the data using free equations, FFT, cross- and
52 auto-correlation, differences, integrals, histograms, and much more. The
53 generated figures are of high quality. Grace is a very convenient tool for
54 data inspection, data transformation, and and for making figures for
55 publications.
56
57 In this package the Motif libraries are linked statically for users who have
58 no Motif runtime libraries.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 tar -xzf $RPM_SOURCE_DIR/fftw.tar.gz
64
65 %build
66 %configure
67
68 make
69
70 cd ..
71 rm -rf gd1.3 fftw-1.3
72 ./configure --prefix=/usr/X11R6 --enable-grace-home=/usr/X11R6/lib/X11/grace \
73         --enable-editres \
74         --enable-extra-incpath=$PKG_BUILD_DIR/include \
75         --enable-extra-ldpath=$PKG_BUILD_DIR/lib --enable-debug
76 make
77 cd src
78 rm xmgrace
79 `make -n xmgrace | grep '^gcc' | head -1 | \
80  sed -e 's/\([ \t]\|^\)-lnetcdf\b/\1-Wl,-Bstatic,-lnetcdf,-Bdynamic/g'`
81 mv xmgrace xmgrace.dynamic
82 `make -n xmgrace | grep '^gcc' | head -1 | \
83  sed -e 's/\([ \t]\|^\)-lXm\b/\1-Wl,-Bstatic,-lXm,-Bdynamic/g' \
84      -e 's/\([ \t]\|^\)-lXbae\b/\1-Wl,-Bstatic,-lXbae,-Bdynamic/g' \
85      -e 's/\([ \t]\|^\)-lnetcdf\b/\1-Wl,-Bstatic,-lnetcdf,-Bdynamic/g'`
86 cd ..
87
88 %install
89 if [ "x$RPM_BUILD_ROOT" != "x/" ]; then
90     rm -rf $RPM_BUILD_ROOT
91 fi
92 mkdir -p $RPM_BUILD_ROOT/usr/X11R6/bin
93 make PREFIX=$RPM_BUILD_ROOT/usr/X11R6 \
94      GRACE_HOME=$RPM_BUILD_ROOT/usr/X11R6/lib/X11/grace \
95      install
96 strip $RPM_BUILD_ROOT/usr/X11R6/lib/X11/grace/bin/xmgrace
97 mv $RPM_BUILD_ROOT/usr/X11R6/lib/X11/grace/bin/xmgrace \
98     $RPM_BUILD_ROOT/usr/X11R6/lib/X11/grace/bin/xmgrace.semistatic
99 strip $RPM_BUILD_ROOT/usr/X11R6/lib/X11/grace/bin/grconvert
100 install -s src/xmgrace.dynamic $RPM_BUILD_ROOT/usr/X11R6/lib/X11/grace/bin
101 rm -f $RPM_BUILD_ROOT/usr/X11R6/bin/xmgrace
102 rm -f $RPM_BUILD_ROOT/usr/X11R6/bin/gracebat
103 install -m755 $RPM_SOURCE_DIR/xmgrace $RPM_BUILD_ROOT/usr/X11R6/bin/xmgrace
104 ln -sf /usr/X11R6/bin/xmgrace $RPM_BUILD_ROOT/usr/X11R6/bin/gracebat
105 mkdir -p $RPM_BUILD_ROOT/usr/include
106 ln -sf /usr/X11R6/lib/X11/grace/include/grace_np.h \
107     $RPM_BUILD_ROOT/usr/include/grace_np.h
108 mkdir -p $RPM_BUILD_ROOT/usr/lib
109 ln -sf /usr/X11R6/lib/X11/grace/lib/libgrace_np.a \
110     $RPM_BUILD_ROOT/usr/lib/libgrace_np.a
111
112 cd $RPM_BUILD_ROOT
113 find ./usr/X11R6/lib/X11/grace -type d \
114         | sed 's,^\.,\%attr(-\,root\,root) \%dir ,' \
115         > $RPM_BUILD_DIR/file.list.%{name}
116 find . -type f \
117         | egrep -v 'xmgrace\.(dynamic|semistatic)' \
118         | sed 's,^\.,\%attr(-\,root\,root) ,' \
119         >> $RPM_BUILD_DIR/file.list.%{name}
120 find . -type l \
121         | sed 's,^\.,\%attr(-\,root\,root) ,' \
122         >> $RPM_BUILD_DIR/file.list.%{name}
123
124 %clean
125 if [ "x$RPM_BUILD_ROOT" != "x/" ]; then
126     rm -rf $RPM_BUILD_ROOT
127 fi
128 rm -f $RPM_BUILD_DIR/file.list.%{name}
129
130 %files dynamic -f ../file.list.%{name}
131 /usr/X11R6/lib/X11/grace/bin/xmgrace.dynamic
132
133 %files semistatic -f ../file.list.%{name}
134 /usr/X11R6/lib/X11/grace/bin/xmgrace.semistatic
This page took 0.083689 seconds and 4 git commands to generate.