]> git.pld-linux.org Git - packages/gpgme.git/blob - gpgme.spec
0e6fc28773c5ee42d745d5b382199d14007a1167
[packages/gpgme.git] / gpgme.spec
1 #
2 # Conditional build:
3 %bcond_with     gpgsm           # with gpgsm support
4 %bcond_without  pth             # without pth-based version of library
5 %bcond_without  static_libs     # Do not build static libraries
6 #
7 # TODO: separate pth version? disable by default (if !needed at all)?
8 Summary:        Library for accessing GnuPG
9 Summary(pl):    Biblioteka daj±ca dostêp do funkcji GnuPG
10 Name:           gpgme
11 Version:        0.4.7
12 Release:        2
13 License:        GPL v2+
14 Group:          Libraries
15 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gpgme/%{name}-%{version}.tar.gz
16 # Source0-md5:  c43a50de6b1220d5a1b59b0deb142e14
17 Patch0:         %{name}-info.patch
18 URL:            http://www.gnupg.org/gpgme.html
19 BuildRequires:  autoconf >= 2.57
20 BuildRequires:  automake >= 1.7.6
21 BuildRequires:  libgpg-error-devel >= 0.5
22 BuildRequires:  libtool
23 %{?with_pth:BuildRequires:      pth-devel >= 1.2.0}
24 BuildRequires:  texinfo
25 BuildConflicts: gnupg < 1.2.2
26 Requires:       gnupg >= 1.2.2
27 %{?with_gpgsm:Requires: gnupg >= 1.9.8}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 A library for accessing GnuPG.
32
33 %description -l pl
34 Biblioteka daj±ca dostêp do funkcji GnuPG.
35
36 %package devel
37 Summary:        Header files for GPGME library
38 Summary(pl):    Pliki nag³ówkowe biblioteki GPGME
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       libgpg-error-devel >= 0.5
42
43 %description devel
44 Header files for GPGME library, needed for compiling programs using
45 GPGME.
46
47 %description devel -l pl
48 Pliki nag³ówkowe biblioteki GPGME, potrzebne do kompilacji programów
49 u¿ywaj±cych GPGME.
50
51 %package static
52 Summary:        Static version of GPGME library
53 Summary(pl):    Statyczna wersja biblioteki GPGME
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static version of GPGME library.
59
60 %description static -l pl
61 Statyczna wersja biblioteki GPGME.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66
67 %build
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__automake}
72 %configure \
73         %{?with_static_libs:--enable-static} \
74         %{?with_gpgsm:--with-gpgsm=%{_bindir}/gpgsm} \
75         %{!?with_gpgsm:--without-gpgsm} \
76         %{!?with_pth:--without-pth}
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %post devel
93 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
94
95 %postun devel
96 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README ChangeLog THANKS TODO NEWS AUTHORS
101 %attr(755,root,root) %{_libdir}/lib*.so.*.*
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/gpgme-config
106 %attr(755,root,root) %{_libdir}/lib*.so
107 %{_libdir}/lib*.la
108 %{_includedir}/*
109 %{_aclocaldir}/*.m4
110 %{_infodir}/*.info*
111
112 %if %{with static_libs}
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/lib*.a
116 %endif
This page took 0.061448 seconds and 2 git commands to generate.