]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- BR: OpenGL-GLU-devel instead of OpenGL-devel
[packages/gpac.git] / gpac.spec
1 # TODO:
2 # - Platinum UPnP: http://www.plutinosoft.com/platinum
3 # - AVCap: http://libavcap.sourceforge.net/
4 # - OpenSVCDecoder: http://opensvcdecoder.sourceforge.net/
5 # - libfreenect: http://openkinect.org/wiki/Main_Page
6 #
7 # Conditional build:
8 %bcond_with     amr             # AMR-NB and AMR-WB (floating-point) support
9 %bcond_without  faad            # AAC decoding support
10 %bcond_without  ffmpeg          # ffmpeg support
11 %bcond_without  freetype        # freetype support
12 %bcond_without  jpeg            # JPEG support
13 %bcond_without  js              # JavaScript support
14 %bcond_without  mad             # MP3 support
15 %bcond_without  png             # PNG support
16 %bcond_without  xvid            # xvid support
17 %bcond_without  wx              # wxWidgets support
18 #
19 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
20 Summary(pl.UTF-8):      GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
21 Name:           gpac
22 Version:        0.5.0
23 Release:        2
24 License:        LGPL v2+
25 Group:          Applications/Multimedia
26 Source0:        http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
27 # Source0-md5:  19f7bb7c16913c22bdd453db1e653ca0
28 Patch0:         %{name}-install.patch
29 Patch1:         %{name}-xulrunner.patch
30 Patch2:         %{name}-amr.patch
31 Patch3:         %{name}-install-is-not-clean.patch
32 Patch4:         %{name}-flags.patch
33 Patch5:         %{name}-idl_uuid.patch
34 Patch6:         %{name}-js.patch
35 Patch7:         %{name}-apps.patch
36 Patch8:         %{name}-export.patch
37 URL:            http://gpac.sourceforge.net/
38 BuildRequires:  DirectFB-devel
39 BuildRequires:  OpenGL-GLU-devel
40 BuildRequires:  SDL-devel
41 BuildRequires:  a52dec-libs-devel
42 BuildRequires:  alsa-lib-devel >= 0.9
43 %{?with_amr:BuildRequires:      amrnb-devel}
44 %{?with_amr:BuildRequires:      amrwb-devel}
45 %{?with_faad:BuildRequires:     faad2-devel}
46 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.6}
47 %{?with_freetype:BuildRequires: freetype-devel}
48 %{?with_wx:BuildRequires:       gtk+2-devel >= 2:2.20.1}
49 BuildRequires:  jack-audio-connection-kit-devel
50 %{?with_js:BuildRequires:       js-devel < 2:1.8.5}
51 %{?with_jpeg:BuildRequires:     libjpeg-devel}
52 %{?with_mad:BuildRequires:      libmad-devel}
53 BuildRequires:  libogg-devel
54 %{?with_png:BuildRequires:      libpng-devel}
55 BuildRequires:  libtheora-devel
56 BuildRequires:  libvorbis-devel
57 BuildRequires:  libxml2-devel
58 BuildRequires:  openjpeg-devel
59 BuildRequires:  openssl-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  pulseaudio-devel
62 BuildRequires:  rpmbuild(macros) >= 1.357
63 BuildRequires:  sed >= 4.0
64 BuildRequires:  unzip
65 %{?with_wx:BuildRequires:       wxGTK2-unicode-devel >= 2.6.0}
66 BuildRequires:  xmlrpc-c-server-devel
67 BuildRequires:  xorg-lib-libXext-devel
68 BuildRequires:  xorg-lib-libXv-devel
69 BuildRequires:  xulrunner-devel >= 2:9.0.0
70 %{?with_xvid:BuildRequires:     xvid-devel}
71 BuildRequires:  zlib-devel
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
76 14496-1) developed from scratch in ANSI C.
77
78 The main development goal is to provide a clean (a.k.a. readable by as
79 many people as possible), small and flexible alternative to the MPEG-4
80 Systems reference software (known as IM1 and distributed in ISO/IEC
81 14496-5). The MPEG-4 Reference software is indeed a very large piece
82 of software, designed to verify the standard rather than provide a
83 small, production-stable software. GPAC is written in ANSI C for
84 portability reasons (embedded platforms and DSPs) with a simple goal:
85 keep the memory footprint as low as possible. The project will at term
86 provide player(s), systems encoders and publishing tools for content
87 distribution.
88
89 %description -l pl.UTF-8
90 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
91 stworzona od zera w ANSI C.
92
93 Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
94 dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
95 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
96 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
97 jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
98 standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
99 jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
100 DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
101 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
102 do publikacji w celu dystrybucji materiałów.
103
104 %package devel
105 Summary:        Header files for GPAC library
106 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GPAC
107 Group:          Development/Libraries
108 Requires:       %{name} = %{version}-%{release}
109
110 %description devel
111 Header files for GPAC library.
112
113 %description devel -l pl.UTF-8
114 Pliki nagłówkowe biblioteki GPAC.
115
116 %package static
117 Summary:        Static GPAC library
118 Summary(pl.UTF-8):      Statyczna biblioteka GPAC
119 Group:          Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121
122 %description static
123 Static GPAC library.
124
125 %description static -l pl.UTF-8
126 Statyczna biblioteka GPAC.
127
128 %package gui
129 Summary:        wxWidgets-based GUI for GPAC
130 Summary(pl.UTF-8):      Oparty na wxWidgets graficzny interfejs do GPAC
131 Group:          X11/Applications/Multimedia
132 Requires:       %{name} = %{version}-%{release}
133
134 %description gui
135 Osmo4 - wxWidgets-based GUI for GPAC.
136
137 %description gui -l pl.UTF-8
138 Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
139
140 %package -n browser-plugin-%{name}
141 Summary:        GPAC browser plugin
142 Summary(pl.UTF-8):      Wtyczka GPAC do przegląderek WWW
143 Group:          X11/Libraries
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       browser-plugins >= 2.0
146 Requires:       browser-plugins(%{_target_base_arch})
147
148 %description -n browser-plugin-%{name}
149 GPAC plugin for Netscape-compatible WWW browsers.
150
151 %description -n browser-plugin-%{name} -l pl.UTF-8
152 Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
153
154 %prep
155 %setup -q -n %{name}
156 %patch0 -p1
157 %patch1 -p1
158 %patch2 -p1
159 %patch3 -p1
160 %patch4 -p1
161 %patch5 -p1
162 %patch6 -p1
163 %patch7 -p1
164 %patch8 -p1
165
166 sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
167 chmod a+x configure
168
169 %build
170 # not autoconf configure
171 ./configure \
172         --prefix=%{_prefix} \
173         --libdir=%{_lib} \
174         --mandir=%{_mandir} \
175         --X11-path=/usr \
176         --cc="%{__cc}" \
177         --cpp="%{__cxx}" \
178         --disable-opt \
179         %{!?with_wx:--disable-wx} \
180         %{?with_amr:--enable-amr} \
181         --enable-joystick \
182         --enable-pic \
183         --extra-cflags="%{rpmcflags}" \
184         --extra-ldflags="%{rpmldflags}" \
185         --mozdir=%{_browserpluginsdir} \
186         %{!?with_faad:--use-faad=no} \
187         %{!?with_ffmpeg:--use-ffmpeg=no} \
188         %{!?with_freetype:--use-ft=no} \
189         %{!?with_jpeg:--use-jpeg=no} \
190         %{!?with_js:--use-js=no} \
191         %{!?with_mad:--use-mad=no} \
192         %{!?with_png:--use-png=no} \
193         %{!?with_xvid:--use-xvid=no} \
194         --xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"
195
196 %{__make} -j1
197
198 %install
199 rm -rf $RPM_BUILD_ROOT
200 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
201
202 %{__make} install install-lib \
203         DESTDIR=$RPM_BUILD_ROOT
204
205 %{__make} -C applications install \
206         DESTDIR=$RPM_BUILD_ROOT \
207         MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
208
209 %clean
210 rm -rf $RPM_BUILD_ROOT
211
212 %post   -p /sbin/ldconfig
213 %postun -p /sbin/ldconfig
214
215 %post -n browser-plugin-%{name}
216 %update_browser_plugins
217
218 %postun -n browser-plugin-%{name}
219 if [ "$1" = 0 ]; then
220         %update_browser_plugins
221 fi
222
223 %files
224 %defattr(644,root,root,755)
225 %doc AUTHORS BUGS Changelog README TODO
226 %attr(755,root,root) %{_bindir}/MP4Box
227 %attr(755,root,root) %{_bindir}/MP4Client
228 %attr(755,root,root) %{_libdir}/libgpac.so.*.*.*
229 %attr(755,root,root) %ghost %{_libdir}/libgpac.so.2
230 %dir %{_libdir}/gpac
231 %attr(755,root,root) %{_libdir}/gpac/gm_*.so
232 %{_datadir}/gpac
233 %{_mandir}/man1/gpac.1*
234 %{_mandir}/man1/mp4box.1*
235 %{_mandir}/man1/mp4client.1*
236
237 %files devel
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_libdir}/libgpac.so
240 %{_includedir}/gpac
241 %{_pkgconfigdir}/gpac.pc
242
243 %files static
244 %defattr(644,root,root,755)
245 %{_libdir}/libgpac_static.a
246
247 %if %{with wx}
248 %files gui
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_bindir}/Osmo4
251 %endif
252
253 %files -n browser-plugin-%{name}
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
256 %{_browserpluginsdir}/nposmozilla.xpt
This page took 0.060217 seconds and 4 git commands to generate.