]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
a906aeed557f22f261ee2feed08f818e28161683
[packages/gpac.git] / gpac.spec
1 #
2 # TODO: soname for libm4systems(?)
3 #
4 # Conditional build:
5 %bcond_with     amr
6 %bcond_without  faad
7 %bcond_without  ffmpeg
8 %bcond_without  freetype
9 %bcond_without  jpeg
10 %bcond_without  js
11 %bcond_without  mad
12 %bcond_without  png
13 %bcond_without  xvid
14 %bcond_with     wx
15 #
16 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
17 Summary(pl):    GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
18 Name:           gpac
19 Version:        0.2.4
20 Release:        2
21 License:        GPL
22 Group:          Applications
23 Source0:        http://dl.sourceforge.net/gpac/%{name}-%{version}.tar.gz
24 # Source0-md5:  cbbea28e99c23d1839d38c54c2cc090a
25 Source1:        http://www.3gpp.org/ftp/Specs/archive/26_series/26.073/26073-530.zip
26 # Source1-md5:  705f6993fbf890e92eb7a331e7c716d1
27 Patch0:         %{name}-install.patch
28 Patch1:         %{name}-wxWidgets.patch
29 URL:            http://gpac.sourceforge.net/
30 BuildRequires:  SDL-devel
31 %{?with_wx:BuildRequires:       wxGTK2-devel >= 2.5.4}
32 %{?with_faad:BuildRequires:     faad2-devel}
33 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
34 %{?with_freetype:BuildRequires: freetype-devel}
35 %{?with_js:BuildRequires:       js-devel}
36 %{?with_jpeg:BuildRequires:     libjpeg-devel}
37 %{?with_mad:BuildRequires:      libmad-devel}
38 %{?with_png:BuildRequires:      libpng-devel}
39 BuildRequires:  libxml2-devel
40 %{?with_xvid:BuildRequires:     xvid-devel}
41 Requires:       SDL
42 %{?with_faad:Requires:  faad2}
43 %{?with_ffmpeg:Requires:        ffmpeg}
44 %{?with_freetype:Requires:      freetype}
45 %{?with_js:Requires:    js}
46 %{?with_jpeg:Requires:  libjpeg}
47 %{?with_png:Requires:   libpng}
48 %{?with_mad:Requires:   libmad}
49 %{?with_xvid:Requires:  xvid}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _noautoreq   libm4systems.so
53
54 %description
55 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
56 14496-1) developed from scratch in ANSI C.
57
58 The main development goal is to provide a clean (a.k.a. readable by as
59 many people as possible), small and flexible alternative to the MPEG-4
60 Systems reference software (known as IM1 and distributed in ISO/IEC
61 14496-5). The MPEG-4 Reference software is indeed a very large piece
62 of software, designed to verify the standard rather than provide a
63 small, production-stable software. GPAC is written in ANSI C for
64 portability reasons (embedded platforms and DSPs) with a simple goal:
65 keep the memory footprint as low as possible. The project will at term
66 provide player(s), systems encoders and publishing tools for content
67 distribution.
68
69 %description -l pl
70 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
71 stworzona od zera w ANSI C.
72
73 G³ównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
74 dla jak najwiêkszej liczby ludzi), ma³ej i elastycznej alternatywy dla
75 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
76 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
77 jest bardzo du¿± porcj± kodu, zaprojektowan± raczej do zweryfikowania
78 standardu ni¿ dostarczenia ma³ej, stabilnej wersji produkcyjnej. GPAC
79 jest pisany w ANSI C ze wzglêdu na przeno¶no¶æ (platformy wbudowane i
80 DSP) z prostym celem: wymagaæ tak ma³o pamiêci, jak to tylko mo¿liwe.
81 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzêdzia
82 do publikacji w celu dystrybucji materia³ów.
83
84 %prep
85 %setup -q -n gpac
86 %patch0 -p1 
87 %{?with_wx:%patch1 -p1}
88 %if %{with amr}
89 mkdir -p Plugins/amr_dec/AMR_NB
90 cd Plugins/amr_dec/AMR_NB
91 # XXX: (conditional?) SourceN?
92 unzip -j %{_sourcedir}/26073-530.zip
93 unzip -j 26073-530_ANSI_C_source_code.zip
94 %endif
95 chmod a+x configure
96
97 %build
98 %configure \
99         --enable-oss-audio \
100         %{?with_amr: --enable-amr-nb} \
101         %{!?with_faad: --disable-faad} \
102         %{!?with_ffmpeg: --disable-ffmpeg} \
103         %{!?with_freetype: --disable-ft} \
104         %{!?with_jpeg: --disable-jpeg} \
105         %{!?with_js: --disable-js} \
106         %{!?with_mad: --disable-mad} \
107         %{!?with_png: --disable-png} \
108         --extra-cflags="-fPIC" \
109         --extra-ldflags="-fPIC" \
110         %{!?with_xvid: --disable-xvid}
111
112 %{__make} \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         bindir=$RPM_BUILD_ROOT%{_bindir} \
120         libdir=$RPM_BUILD_ROOT%{_libdir} \
121         mandir=$RPM_BUILD_ROOT%{_mandir} \
122         plugdir=$RPM_BUILD_ROOT%{_libdir}/gpac \
123         real_plugdir=%{_libdir}/gpac \
124         prefix=$RPM_BUILD_ROOT/usr
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS BUGS Changelog README TODO
135 %attr(755,root,root) %{_bindir}/*
136 %attr(755,root,root) %{_libdir}/lib*.so
137 %dir %{_libdir}/gpac
138 %attr(755,root,root) %{_libdir}/gpac/*.so
139 %{_mandir}/man1/*
This page took 0.391 seconds and 2 git commands to generate.