]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- wxWidgets rebuild
[packages/gpac.git] / gpac.spec
1 # TODO:
2 # - Platinum UPnP: http://www.plutinosoft.com/platinum
3 # - AVCap: http://libavcap.sourceforge.net/
4 # - OpenSVCDecoder: http://opensvcdecoder.sourceforge.net/
5 # - libfreenect: http://openkinect.org/wiki/Main_Page
6 #
7 # Conditional build:
8 %bcond_with     amr             # AMR-NB and AMR-WB (floating-point) support
9 %bcond_without  directfb        # DirectFB support
10 %bcond_without  faad            # AAC decoding support
11 %bcond_without  ffmpeg          # ffmpeg support
12 %bcond_without  freetype        # freetype support
13 %bcond_without  jpeg            # JPEG support
14 %bcond_with     js              # JavaScript support
15 %bcond_without  mad             # MP3 support
16 %bcond_without  png             # PNG support
17 %bcond_without  xvid            # xvid support
18 %bcond_without  wx              # wxWidgets support
19 #
20 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
21 Summary(pl.UTF-8):      GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
22 Name:           gpac
23 Version:        0.5.0
24 Release:        11
25 License:        LGPL v2+
26 Group:          Applications/Multimedia
27 Source0:        http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
28 # Source0-md5:  19f7bb7c16913c22bdd453db1e653ca0
29 Patch0:         %{name}-install.patch
30 Patch1:         %{name}-xulrunner.patch
31 Patch2:         %{name}-amr.patch
32 Patch3:         %{name}-install-is-not-clean.patch
33 Patch4:         %{name}-flags.patch
34 Patch5:         %{name}-idl_uuid.patch
35 Patch6:         %{name}-js.patch
36 Patch7:         %{name}-apps.patch
37 Patch8:         %{name}-export.patch
38 Patch9:         %{name}-ffmpeg2.patch
39 URL:            http://gpac.sourceforge.net/
40 %{?with_directfb:BuildRequires: DirectFB-devel}
41 BuildRequires:  OpenGL-GLU-devel
42 BuildRequires:  SDL-devel
43 BuildRequires:  a52dec-libs-devel
44 BuildRequires:  alsa-lib-devel >= 0.9
45 %{?with_amr:BuildRequires:      amrnb-devel}
46 %{?with_amr:BuildRequires:      amrwb-devel}
47 %{?with_faad:BuildRequires:     faad2-devel}
48 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.6}
49 %{?with_freetype:BuildRequires: freetype-devel}
50 %{?with_wx:BuildRequires:       gtk+2-devel >= 2:2.20.1}
51 BuildRequires:  jack-audio-connection-kit-devel
52 %{?with_js:BuildRequires:       js-devel < 2:1.8.5}
53 %{?with_jpeg:BuildRequires:     libjpeg-devel}
54 %{?with_mad:BuildRequires:      libmad-devel}
55 BuildRequires:  libogg-devel
56 %{?with_png:BuildRequires:      libpng-devel}
57 BuildRequires:  libtheora-devel
58 BuildRequires:  libvorbis-devel
59 BuildRequires:  libxml2-devel
60 BuildRequires:  openjpeg-devel
61 BuildRequires:  openssl-devel
62 BuildRequires:  pkgconfig
63 BuildRequires:  pulseaudio-devel
64 BuildRequires:  rpmbuild(macros) >= 1.357
65 BuildRequires:  sed >= 4.0
66 BuildRequires:  unzip
67 %{?with_wx:BuildRequires:       wxGTK2-unicode-devel >= 2.6.0}
68 BuildRequires:  xmlrpc-c-server-devel
69 BuildRequires:  xorg-lib-libXext-devel
70 BuildRequires:  xorg-lib-libXv-devel
71 BuildRequires:  xulrunner-devel >= 2:9.0.0
72 %{?with_xvid:BuildRequires:     xvid-devel}
73 BuildRequires:  zlib-devel
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
78 14496-1) developed from scratch in ANSI C.
79
80 The main development goal is to provide a clean (a.k.a. readable by as
81 many people as possible), small and flexible alternative to the MPEG-4
82 Systems reference software (known as IM1 and distributed in ISO/IEC
83 14496-5). The MPEG-4 Reference software is indeed a very large piece
84 of software, designed to verify the standard rather than provide a
85 small, production-stable software. GPAC is written in ANSI C for
86 portability reasons (embedded platforms and DSPs) with a simple goal:
87 keep the memory footprint as low as possible. The project will at term
88 provide player(s), systems encoders and publishing tools for content
89 distribution.
90
91 %description -l pl.UTF-8
92 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
93 stworzona od zera w ANSI C.
94
95 Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
96 dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
97 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
98 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
99 jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
100 standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
101 jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
102 DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
103 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
104 do publikacji w celu dystrybucji materiałów.
105
106 %package devel
107 Summary:        Header files for GPAC library
108 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GPAC
109 Group:          Development/Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description devel
113 Header files for GPAC library.
114
115 %description devel -l pl.UTF-8
116 Pliki nagłówkowe biblioteki GPAC.
117
118 %package static
119 Summary:        Static GPAC library
120 Summary(pl.UTF-8):      Statyczna biblioteka GPAC
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description static
125 Static GPAC library.
126
127 %description static -l pl.UTF-8
128 Statyczna biblioteka GPAC.
129
130 %package gui
131 Summary:        wxWidgets-based GUI for GPAC
132 Summary(pl.UTF-8):      Oparty na wxWidgets graficzny interfejs do GPAC
133 Group:          X11/Applications/Multimedia
134 Requires:       %{name} = %{version}-%{release}
135
136 %description gui
137 Osmo4 - wxWidgets-based GUI for GPAC.
138
139 %description gui -l pl.UTF-8
140 Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
141
142 %package -n browser-plugin-%{name}
143 Summary:        GPAC browser plugin
144 Summary(pl.UTF-8):      Wtyczka GPAC do przegląderek WWW
145 Group:          X11/Libraries
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       browser-plugins >= 2.0
148 Requires:       browser-plugins(%{_target_base_arch})
149
150 %description -n browser-plugin-%{name}
151 GPAC plugin for Netscape-compatible WWW browsers.
152
153 %description -n browser-plugin-%{name} -l pl.UTF-8
154 Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
155
156 %prep
157 %setup -q -n %{name}
158 %patch0 -p1
159 %patch1 -p1
160 %patch2 -p1
161 %patch3 -p1
162 %patch4 -p1
163 %patch5 -p1
164 %patch6 -p1
165 %patch7 -p1
166 %patch8 -p1
167 %patch9 -p0
168
169 sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
170 chmod a+x configure
171
172 %build
173 # not autoconf configure
174 ./configure \
175         --prefix=%{_prefix} \
176         --libdir=%{_lib} \
177         --mandir=%{_mandir} \
178         --X11-path=/usr \
179         --cc="%{__cc}" \
180         --cpp="%{__cxx}" \
181         --disable-opt \
182         %{!?with_wx:--disable-wx} \
183         %{?with_amr:--enable-amr} \
184         --enable-joystick \
185         --enable-pic \
186         --extra-cflags="%{rpmcflags}" \
187         --extra-ldflags="%{rpmldflags}" \
188         --mozdir=%{_browserpluginsdir} \
189         %{!?with_faad:--use-faad=no} \
190         %{!?with_ffmpeg:--use-ffmpeg=no} \
191         %{!?with_freetype:--use-ft=no} \
192         %{!?with_jpeg:--use-jpeg=no} \
193         %{!?with_js:--use-js=no} \
194         %{!?with_mad:--use-mad=no} \
195         %{!?with_png:--use-png=no} \
196         %{!?with_xvid:--use-xvid=no} \
197         --xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"
198
199 %{!?with_directfb: sed -i 's/CONFIG_DIRECTFB.*/CONFIG_DIRECTFB=no/' config.mak}
200
201 %{__make} -j1
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
206
207 %{__make} -j1 install install-lib \
208         DESTDIR=$RPM_BUILD_ROOT
209
210 %{__make} -j1 -C applications install \
211         DESTDIR=$RPM_BUILD_ROOT \
212         MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %post   -p /sbin/ldconfig
218 %postun -p /sbin/ldconfig
219
220 %post -n browser-plugin-%{name}
221 %update_browser_plugins
222
223 %postun -n browser-plugin-%{name}
224 if [ "$1" = 0 ]; then
225         %update_browser_plugins
226 fi
227
228 %files
229 %defattr(644,root,root,755)
230 %doc AUTHORS BUGS Changelog README TODO
231 %attr(755,root,root) %{_bindir}/MP4Box
232 %attr(755,root,root) %{_bindir}/MP4Client
233 %attr(755,root,root) %{_libdir}/libgpac.so.*.*.*
234 %attr(755,root,root) %ghost %{_libdir}/libgpac.so.2
235 %dir %{_libdir}/gpac
236 %attr(755,root,root) %{_libdir}/gpac/gm_*.so
237 %{_datadir}/gpac
238 %{_mandir}/man1/gpac.1*
239 %{_mandir}/man1/mp4box.1*
240 %{_mandir}/man1/mp4client.1*
241
242 %files devel
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_libdir}/libgpac.so
245 %{_includedir}/gpac
246 %{_pkgconfigdir}/gpac.pc
247
248 %files static
249 %defattr(644,root,root,755)
250 %{_libdir}/libgpac_static.a
251
252 %if %{with wx}
253 %files gui
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_bindir}/Osmo4
256 %endif
257
258 %files -n browser-plugin-%{name}
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
261 %{_browserpluginsdir}/nposmozilla.xpt
This page took 0.06914 seconds and 3 git commands to generate.