]> git.pld-linux.org Git - packages/golang.git/blob - golang.spec
drop testdata
[packages/golang.git] / golang.spec
1 # NOTE: build needs >128 processes limit
2 # TODO
3 # - allow disabling tests (currently bcond exists just for showing which are test deps)
4 # - add verbose build output (currently dummy bcond)
5 # - setup GOMAXPROCS=2 from _smp_mflags
6 # - fix CC containing spaces (ccache)
7 # - check if hg use at build time can be dropped
8 # - build all target archs, subpackage them: http://golang.org/doc/install/source#environment
9 #   or choose only useful crosscompilers?
10 # - subpackage -src files?
11
12 # Conditional build:
13 %bcond_without  verbose         # verbose build (V=1)
14 %bcond_without  tests           # build without tests [nop actually]
15 %bcond_without  shared          # Build golang shared objects for stdlib
16 %bcond_without  ext_linker      # Build golang using external/internal (close to cgo disabled) linking
17 %bcond_without  cgo             # cgo (importing C libraries) support
18 %bcond_with     bootstrap       # bootstrap build
19
20 %ifnarch %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64le
21 %undefine       with_shared
22 %undefine       with_ext_linker
23 %undefine       with_cgo
24 %endif
25
26 Summary:        Go compiler and tools
27 Summary(pl.UTF-8):      Kompilator języka Go i narzędzia
28 Name:           golang
29 Version:        1.14.9
30 Release:        1
31 # source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
32 License:        BSD and Public Domain
33 Group:          Development/Languages
34 # Source0Download: https://golang.org/dl/
35 Source0:        https://storage.googleapis.com/golang/go%{version}.src.tar.gz
36 # Source0-md5:  6f6dd1377421d27ca4bb607283b31738
37 Patch0:         ca-certs.patch
38 Patch1:         0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
39 URL:            https://golang.org/
40 BuildRequires:  bash
41 BuildRequires:  rpm-pythonprov
42 # The compiler is written in Go. Needs go(1.4+) compiler for build.
43 %if %{with bootstrap}
44 BuildRequires:  gcc-go >= 6:5
45 %else
46 BuildRequires:  golang >= 1.4
47 %endif
48 %if %{with tests}
49 BuildRequires:  glibc-static
50 BuildRequires:  hostname
51 BuildRequires:  pcre-devel
52 BuildRequires:  tzdata
53 %endif
54 Requires:       ca-certificates
55 Conflicts:      gcc-go
56 ExclusiveArch:  %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         no_install_post_strip   1
60 %define         no_install_post_chrpath 1
61 %define         _enable_debug_packages  0
62 %define         _noautoreqfiles         %{_libdir}/%{name}/src
63
64 %define goroot %{_libdir}/%{name}
65
66 %ifarch %{ix86}
67 %define GOARCH 386
68 %endif
69 %ifarch %{x8664}
70 %define GOARCH amd64
71 %endif
72 %ifarch %{arm}
73 %define GOARCH arm
74 %endif
75 %ifarch aarch64
76 %define GOARCH arm64
77 %endif
78 %ifarch mips64
79 %define GOARCH mips64x
80 %endif
81 %ifarch ppc64 ppc64le s390x
82 %define GOARCH %{_arch}
83 %endif
84
85 %description
86 Go is an open source programming environment that makes it easy to
87 build simple, reliable, and efficient software.
88
89 %description -l pl.UTF-8
90 Go to mające otwarte źródła środowisko do programowania, pozwalające
91 na łatwe tworzenie prostych, pewnych i wydajnych programów.
92
93 %package shared
94 Summary:        Golang shared object libraries
95 Summary(pl.UTF-8):      Biblioteki obiektów współdzielonych dla języka Go
96 Group:          Libraries
97 Requires:       %{name} = %{version}-%{release}
98
99 %description shared
100 Golang shared object libraries.
101
102 %description shared -l pl.UTF-8
103 Biblioteki obiektów współdzielonych dla języka Go.
104
105 %package doc
106 Summary:        Documentation for Go language
107 Summary(fr.UTF-8):      Documentation pour Go
108 Summary(it.UTF-8):      Documentazione di Go
109 Summary(pl.UTF-8):      Dokumentacja do języka Go
110 Group:          Documentation
111 %if "%{_rpmversion}" >= "5"
112 BuildArch:      noarch
113 %endif
114
115 %description doc
116 Documentation for Go language.
117
118 %description doc -l fr.UTF-8
119 Documentation pour Go.
120
121 %description doc -l it.UTF-8
122 Documentazione di Go.
123
124 %description doc -l pl.UTF-8
125 Dokumentacja do języka Go.
126
127 %prep
128 %setup -qc
129 %{__mv} go/* .
130 %patch0 -p1
131 %patch1 -p1
132
133 # clean patch backups
134 find . -name '*.orig' | xargs -r %{__rm}
135
136 cat > env.sh <<'EOF'
137 # bootstrap compiler GOROOT
138 %if %{with bootstrap}
139 export GOROOT_BOOTSTRAP=%{_prefix}
140 %else
141 export GOROOT_BOOTSTRAP=%{goroot}
142 %endif
143 export GOROOT_FINAL=%{goroot}
144
145 export GOHOSTOS=linux
146 export GOHOSTARCH=%{GOARCH}
147
148 export GOOS=linux
149 export GOARCH=%{GOARCH}
150 %if %{without external_linker}
151 export GO_LDFLAGS="-linkmode internal"
152 %endif
153 %if %{with cgo}
154 export CGO_ENABLED=1
155 %else
156 export CGO_ENABLED=0
157 %endif
158
159 # use our gcc options for this build, but store gcc as default for compiler
160 export CFLAGS="%{rpmcflags}"
161 export LDFLAGS="%{rpmldflags}"
162
163 CC="%{__cc}"
164 export CC="${CC#ccache }"
165 export CC_FOR_TARGET="$CC"
166 EOF
167
168 %if 0
169 # optflags for go tools build
170 nflags="\"$(echo '%{rpmcflags}' | sed -e 's/^[  ]*//;s/[        ]*$//;s/[       ]\+/ /g' -e 's/ /\",\"/g')\""
171 %{__sed} -i -e "s/\"-O2\"/$nflags/" src/cmd/dist/build.c
172 # NOTE: optflags used in gcc calls from go compiler are in src/cmd/go/build.go
173 %endif
174
175 %build
176 . ./env.sh
177 cd src
178 ./make.bash --no-clean
179 cd ..
180
181 # build shared std lib
182 %if %{with shared}
183 GOROOT=$(pwd) PATH=$(pwd)/bin:$PATH go install -buildmode=shared std
184 %endif
185
186 %install
187 rm -rf $RPM_BUILD_ROOT
188 GOROOT=$RPM_BUILD_ROOT%{goroot}
189
190 install -d $GOROOT/{misc,lib,src}
191 install -d $RPM_BUILD_ROOT%{_bindir}
192
193 cp -a pkg lib bin src VERSION $GOROOT
194 cp -a misc/cgo $GOROOT/misc
195
196 # kill Win32 and Plan9 scripts
197 find $GOROOT -name '*.bat' -o -name '*.rc' | xargs %{__rm}
198
199 # https://github.com/golang/go/issues/4749
200 find $GOROOT/src | xargs touch -r $GOROOT/VERSION
201 # and level out all the built archives
202 touch $GOROOT/pkg
203 find $GOROOT/pkg | xargs touch -r $GOROOT/pkg
204
205 ln -sf %{_libdir}/%{name}/bin/go $RPM_BUILD_ROOT%{_bindir}/go
206 ln -sf %{_libdir}/%{name}/bin/gofmt $RPM_BUILD_ROOT%{_bindir}/gofmt
207 ln -sf %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/cgo $RPM_BUILD_ROOT%{_bindir}/cgo
208
209 # FIXME: do we need whole sources, including build scripts?
210 # for now, remove only non-Linux stuff
211 %{__rm} \
212         $RPM_BUILD_ROOT%{_libdir}/%{name}/src/syscall/{mksyscall,mksysctl_openbsd,mksysnum_{darwin,dragonfly,freebsd,netbsd,openbsd}}.pl
213 # ...and tests
214 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/src/internal/trace \
215            $RPM_BUILD_ROOT%{_libdir}/%{name}/misc/cgo/{errors,fortran,test*}
216 find $RPM_BUILD_ROOT%{_libdir}/%{name} -name testdata -prune | xargs %{__rm} -r
217
218 # unenvize remaining scripts
219 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' $RPM_BUILD_ROOT%{_libdir}/%{name}/src/*.bash
220 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' $RPM_BUILD_ROOT%{_libdir}/%{name}/src/syscall/*.sh
221 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' $RPM_BUILD_ROOT%{_libdir}/%{name}/src/cmd/vendor/golang.org/x/sys/unix/*.sh
222 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' $RPM_BUILD_ROOT%{_libdir}/%{name}/src/cmd/go/*.sh
223 %{__sed} -i -e '1s,/usr/bin/env perl,/usr/bin/perl,' $RPM_BUILD_ROOT%{_libdir}/%{name}/src/syscall/*.pl
224
225 %clean
226 rm -rf $RPM_BUILD_ROOT
227
228 %files
229 %defattr(644,root,root,755)
230 %doc AUTHORS CONTRIBUTORS LICENSE
231 %attr(755,root,root) %{_bindir}/cgo
232 %attr(755,root,root) %{_bindir}/go
233 %attr(755,root,root) %{_bindir}/gofmt
234 %dir %{_libdir}/%{name}
235 %{_libdir}/%{name}/VERSION
236 %dir %{_libdir}/%{name}/bin
237 %attr(755,root,root) %{_libdir}/%{name}/bin/go
238 %attr(755,root,root) %{_libdir}/%{name}/bin/gofmt
239
240 %{_libdir}/%{name}/lib
241 %{_libdir}/%{name}/misc
242 %{_libdir}/%{name}/src
243 %dir %{_libdir}/%{name}/pkg
244 %{_libdir}/%{name}/pkg/linux_%{GOARCH}
245 %{_libdir}/%{name}/pkg/obj
246 %dir %{_libdir}/%{name}/pkg/tool
247 %dir %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}
248 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/addr2line
249 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/api
250 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/asm
251 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/buildid
252 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/cgo
253 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/compile
254 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/cover
255 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/dist
256 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/doc
257 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/fix
258 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/link
259 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/nm
260 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/objdump
261 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/pack
262 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/pprof
263 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/test2json
264 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/trace
265 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/vet
266
267 %{_libdir}/%{name}/pkg/include
268
269 %if %{with shared}
270 %files shared
271 %defattr(644,root,root,755)
272 %{_libdir}/%{name}/pkg/linux_%{GOARCH}_dynlink
273 %endif
274
275 %files doc
276 %defattr(644,root,root,755)
277 %doc doc/*
This page took 0.089743 seconds and 4 git commands to generate.