]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
cbe8243ede6bc6876cc1bef70b43cb10d73489a7
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
4 %bcond_without  openssl         # libgnutls-openssl compatibility library
5 %bcond_without  tpm             # TPM support in gnutls
6 %bcond_without  static_libs     # static libraries
7 %bcond_without  doc             # do not generate documentation
8 %bcond_without  guile           # Guile binding
9 #
10 Summary:        The GNU Transport Layer Security Library
11 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
12 Name:           gnutls
13 Version:        3.6.8
14 Release:        1
15 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
16 Group:          Libraries
17 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.6/%{name}-%{version}.tar.xz
18 # Source0-md5:  9dcf0aa45d1a42e1b3ca5d39ec7c61a8
19 Patch0:         %{name}-info.patch
20 Patch1:         %{name}-link.patch
21 Patch2:         %{name}-pl.po-update.patch
22 URL:            http://www.gnutls.org/
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  autogen >= 5.16
25 BuildRequires:  autogen-devel >= 5.16
26 BuildRequires:  automake >= 1:1.12.2
27 BuildRequires:  gcc >= 5:3.2
28 BuildRequires:  gettext-tools >= 0.19
29 BuildRequires:  gmp-devel
30 %{?with_doc:BuildRequires:      gtk-doc >= 1.14}
31 %{?with_guile:BuildRequires:    guile-devel >= 5:2.2.0}
32 BuildRequires:  libidn2-devel
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtasn1-devel >= 4.11
35 BuildRequires:  libunistring-devel
36 BuildRequires:  libtool >= 2:2
37 BuildRequires:  nettle-devel >= 3.3
38 # miniopencdk is included in sources and currently maintained
39 # as part of gnutls, not external package
40 #BuildRequires: opencdk-devel >= 0.6.6
41 BuildRequires:  p11-kit-devel >= 0.23.1
42 BuildRequires:  pkgconfig
43 BuildRequires:  readline-devel
44 BuildRequires:  rpmbuild(macros) >= 1.383
45 BuildRequires:  sed >= 4.0
46 BuildRequires:  tar >= 1:1.22
47 %{?with_doc:BuildRequires:      texinfo >= 4.8}
48 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
49 %{?with_dane:BuildRequires:     unbound-devel}
50 BuildRequires:  xz
51 BuildRequires:  zlib-devel
52 Requires:       %{name}-libs = %{version}-%{release}
53 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         _noautostrip    .*\.go
57
58 %description
59 GnuTLS is a project that aims to develop a library which provides a
60 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
61 the gnuTLS library implements the proposed standards by the IETF's TLS
62 working group.
63
64 %description -l pl.UTF-8
65 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
66 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
67 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
68 grupę roboczą IETF TLS.
69
70 %package libs
71 Summary:        GnuTLS shared libraries
72 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
73 Group:          Libraries
74 Requires:       libtasn1 >= 4.11
75 Requires:       nettle >= 3.3
76 #Requires:      opencdk >= 0.6.6
77 Requires:       p11-kit >= 0.23.1
78 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
79 Conflicts:      gnutls < 3.2.0
80
81 %description libs
82 GnuTLS shared libraries.
83
84 %description libs -l pl.UTF-8
85 Biblioteki współdzielone GnuTLS.
86
87 %package devel
88 Summary:        Header files etc to develop gnutls applications
89 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
90 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
91 Group:          Development/Libraries
92 Requires:       %{name}-libs = %{version}-%{release}
93 Requires:       libidn2-devel
94 Requires:       libtasn1-devel >= 4.11
95 Requires:       libunistring-devel
96 Requires:       nettle-devel >= 3.3
97 #Requires:      opencdk-devel >= 0.6.6
98 Requires:       p11-kit-devel >= 0.23.1
99 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
100 Requires:       zlib-devel
101
102 %description devel
103 Header files etc to develop gnutls applications.
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe i inne do gnutls.
107
108 %package static
109 Summary:        Static gnutls library
110 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
111 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114
115 %description static
116 Static gnutls library.
117
118 %description static -l pl.UTF-8
119 Biblioteka statyczna gnutls.
120
121 %package c++
122 Summary:        libgnutlsxx - C++ interface to gnutls library
123 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
124 License:        LGPL v2.1+
125 Group:          Libraries
126 Requires:       %{name}-libs = %{version}-%{release}
127
128 %description c++
129 libgnutlsxx - C++ interface to gnutls library.
130
131 %description c++ -l pl.UTF-8
132 libgnutlsxx - interfejs C++ do biblioteki gnutls.
133
134 %package c++-devel
135 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
136 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
137 License:        LGPL v2.1+
138 Group:          Development/Libraries
139 Requires:       %{name}-c++ = %{version}-%{release}
140 Requires:       %{name}-devel = %{version}-%{release}
141 Requires:       libstdc++-devel
142
143 %description c++-devel
144 Header files for libgnutlsxx, a C++ interface to gnutls library.
145
146 %description c++-devel -l pl.UTF-8
147 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
148
149 %package c++-static
150 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
151 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
152 License:        LGPL v2.1+
153 Group:          Development/Libraries
154 Requires:       %{name}-c++-devel = %{version}-%{release}
155
156 %description c++-static
157 Static version of libgnutlsxx, a C++ interface to gnutls library.
158
159 %description c++-static -l pl.UTF-8
160 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
161
162 %package dane
163 Summary:        DANE security library
164 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
165 Group:          Libraries
166 Requires:       %{name}-libs = %{version}-%{release}
167
168 %description dane
169 DANE security library.
170
171 %description dane -l pl.UTF-8
172 Biblioteka bezpieczeństwa DANE.
173
174 %package dane-devel
175 Summary:        Header file for DANE security library
176 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
177 Group:          Development/Libraries
178 Requires:       %{name}-dane = %{version}-%{release}
179 Requires:       %{name}-devel = %{version}-%{release}
180 Requires:       unbound-devel
181
182 %description dane-devel
183 Header file for DANE security library.
184
185 %description dane-devel -l pl.UTF-8
186 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
187
188 %package dane-static
189 Summary:        Static DANE security library
190 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
191 Group:          Development/Libraries
192 Requires:       %{name}-dane-devel = %{version}-%{release}
193
194 %description dane-static
195 Static DANE security library.
196
197 %description dane-static -l pl.UTF-8
198 Statyczna biblioteka bezpieczeństwa DANE.
199
200 %package openssl
201 Summary:        OpenSSL compatibility library for GnuTLS
202 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
203 Group:          Libraries
204 Requires:       %{name}-libs = %{version}-%{release}
205
206 %description openssl
207 OpenSSL compatibility library for GnuTLS.
208
209 %description openssl -l pl.UTF-8
210 Biblioteka zgodności z OpenSSL dla GnuTLS.
211
212 %package openssl-devel
213 Summary:        Header file for gnutls-openssl library
214 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
215 Group:          Development/Libraries
216 Requires:       %{name}-devel = %{version}-%{release}
217 Requires:       %{name}-openssl = %{version}-%{release}
218
219 %description openssl-devel
220 Header file for gnutls-openssl library.
221
222 %description openssl-devel -l pl.UTF-8
223 Plik nagłówkowy biblioteki gnutls-openssl.
224
225 %package openssl-static
226 Summary:        Static gnutls-openssl library
227 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
228 Group:          Development/Libraries
229 Requires:       %{name}-openssl-devel = %{version}-%{release}
230
231 %description openssl-static
232 Static gnutls-openssl library.
233
234 %description openssl-static -l pl.UTF-8
235 Statyczna biblioteka gnutls-openssl.
236
237 %package -n guile-gnutls
238 Summary:        Guile bindings for GnuTLS
239 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
240 License:        LGPL v2.1+
241 Group:          Development/Languages
242 Requires:       %{name}-libs = %{version}-%{release}
243 Requires:       guile >= 5:2.2.0
244
245 %description -n guile-gnutls
246 Guile bindings for GnuTLS.
247
248 %description -n guile-gnutls -l pl.UTF-8
249 Wiązania Guile do GnuTLS.
250
251 %prep
252 %setup -q
253 %patch0 -p1
254 %patch1 -p1
255 %patch2 -p1
256
257 %{__rm} po/stamp-po
258
259 %build
260 %{__libtoolize}
261 %{__aclocal} -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4
262 %{__autoconf}
263 %{__autoheader}
264 %{__automake}
265 %configure \
266         %{!?with_doc:--disable-doc} \
267         %{!?with_guile:--disable-guile} \
268         %{?with_openssl:--enable-openssl-compatibility} \
269         --disable-silent-rules \
270         %{?with_static_libs:--enable-static} \
271         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
272         %{!?with_tpm:--without-tpm} \
273         --with-trousers-lib=%{_libdir}/libtspi.so.1
274
275 # docs build is broken with -jN
276 %{__make} -j1
277
278 %install
279 rm -rf $RPM_BUILD_ROOT
280
281 %{__make} install \
282         DESTDIR=$RPM_BUILD_ROOT
283
284 # although libgnutls.la is obsoleted by pkg-config, there is
285 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
286
287 %if %{with guile}
288 # guile module - dynamic only
289 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.*/extensions/guile-gnutls-*.la
290 %if %{with static_libs}
291 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.*/extensions/guile-gnutls-*.a
292 %endif
293 %endif
294
295 # images for (not installed) htmlized infos - already packaged with infos
296 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnutls/*.png
297
298 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
299
300 %find_lang %{name}
301
302 %clean
303 rm -rf $RPM_BUILD_ROOT
304
305 %post
306 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
307
308 %postun
309 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
310
311 %post   libs -p /sbin/ldconfig
312 %postun libs -p /sbin/ldconfig
313
314 %post   c++ -p /sbin/ldconfig
315 %postun c++ -p /sbin/ldconfig
316
317 %post   dane -p /sbin/ldconfig
318 %postun dane -p /sbin/ldconfig
319
320 %post   openssl -p /sbin/ldconfig
321 %postun openssl -p /sbin/ldconfig
322
323 %post   -n guile-gnutls -p /sbin/ldconfig
324 %postun -n guile-gnutls -p /sbin/ldconfig
325
326 %files -f %{name}.lang
327 %defattr(644,root,root,755)
328 %doc AUTHORS ChangeLog NEWS README.md THANKS
329 %attr(755,root,root) %{_bindir}/certtool
330 %attr(755,root,root) %{_bindir}/gnutls-*
331 %attr(755,root,root) %{_bindir}/ocsptool
332 %attr(755,root,root) %{_bindir}/p11tool
333 %attr(755,root,root) %{_bindir}/psktool
334 %attr(755,root,root) %{_bindir}/srptool
335 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
336 %if %{with doc}
337 %{_mandir}/man1/certtool.1*
338 %{_mandir}/man1/gnutls-*.1*
339 %{_mandir}/man1/ocsptool.1*
340 %{_mandir}/man1/p11tool.1*
341 %{_mandir}/man1/psktool.1*
342 %{_mandir}/man1/srptool.1*
343 %{_mandir}/man1/tpmtool.1*
344 %{_infodir}/gnutls.info*
345 %{_infodir}/gnutls-*.png
346 %{_infodir}/pkcs11-vision.png
347 %endif
348
349 %files libs
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
352 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.30
353
354 %files devel
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_libdir}/libgnutls.so
357 %{_libdir}/libgnutls.la
358 %{_includedir}/gnutls
359 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
360 %exclude %{_includedir}/gnutls/gnutlsxx.h
361 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
362 %{_pkgconfigdir}/gnutls.pc
363 %{?with_doc:%{_mandir}/man3/gnutls_*.3*}
364
365 %if %{with static_libs}
366 %files static
367 %defattr(644,root,root,755)
368 %{_libdir}/libgnutls.a
369 %endif
370
371 %files c++
372 %defattr(644,root,root,755)
373 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
374 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
375
376 %files c++-devel
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
379 %{_libdir}/libgnutlsxx.la
380 %{_includedir}/gnutls/gnutlsxx.h
381
382 %if %{with static_libs}
383 %files c++-static
384 %defattr(644,root,root,755)
385 %{_libdir}/libgnutlsxx.a
386 %endif
387
388 %if %{with dane}
389 %files dane
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_bindir}/danetool
392 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
393 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
394 %{?with_doc:%{_mandir}/man1/danetool.1*}
395
396 %files dane-devel
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
399 %{_libdir}/libgnutls-dane.la
400 %{_includedir}/gnutls/dane.h
401 %{_pkgconfigdir}/gnutls-dane.pc
402 %{_mandir}/man3/dane_*.3*
403
404 %if %{with static_libs}
405 %files dane-static
406 %defattr(644,root,root,755)
407 %{_libdir}/libgnutls-dane.a
408 %endif
409 %endif
410
411 %if %{with openssl}
412 %files openssl
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
415 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
416
417 %files openssl-devel
418 %defattr(644,root,root,755)
419 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
420 %{_libdir}/libgnutls-openssl.la
421 %{_includedir}/gnutls/openssl.h
422
423 %files openssl-static
424 %defattr(644,root,root,755)
425 %{_libdir}/libgnutls-openssl.a
426 %endif
427
428 %if %{with guile}
429 %files -n guile-gnutls
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_libdir}/guile/2.*/extensions/guile-gnutls-v-2.so*
432 %{_libdir}/guile/2.*/site-ccache/gnutls.go
433 %{_libdir}/guile/2.*/site-ccache/gnutls
434 %{_datadir}/guile/site/2.*/gnutls.scm
435 %{_datadir}/guile/site/2.*/gnutls
436 %{_infodir}/gnutls-guile.info*
437 %endif
This page took 0.0847 seconds and 3 git commands to generate.