]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- 0.13.1
[packages/gnustep-gui.git] / gnustep-gui.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # GSCUPS bundle
4 %bcond_without  portaudio       # gsnd tool
5 #
6 Summary:        GNUstep GUI library package
7 Summary(pl.UTF-8):      Biblioteka GNUstep GUI
8 Name:           gnustep-gui
9 %define ver     0.13
10 Version:        %{ver}.1
11 Release:        1
12 License:        LGPL/GPL
13 Group:          Libraries
14 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
15 # Source0-md5:  efbc128440514a4aa5ca290a669b9cb7
16 Patch0:         %{name}-themes.patch
17 Patch1:         %{name}-nocompressdocs.patch
18 Patch2:         %{name}-segv.patch
19 Patch3:         %{name}-doc.patch
20 URL:            http://www.gnustep.org/
21 BuildRequires:  aspell-devel
22 BuildRequires:  audiofile-devel
23 %{?with_cups:BuildRequires:     cups-devel}
24 BuildRequires:  gcc-objc
25 BuildRequires:  giflib-devel
26 BuildRequires:  gnustep-base-devel >= 1.13.0
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libtiff-devel
30 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
31 BuildRequires:  zlib-devel
32 Requires:       gnustep-base >= 1.13.0
33 Conflicts:      gnustep-core
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 It is a library of graphical user interface classes written completely
38 in the Objective-C language; the classes are based upon the OpenStep
39 specification as release by NeXT Software, Inc. The library does not
40 completely conform to the specification and has been enhanced in a
41 number of ways to take advantage of the GNU system. These classes
42 include graphical objects such as buttons, text fields, popup lists,
43 browser lists, and windows; there are also many associated classes for
44 handling events, colors, fonts, pasteboards and images.
45
46 %description -l pl.UTF-8
47 To jest biblioteka klas graficznego interfejsu użytkownika napisana w
48 Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
49 NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
50 została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
51 zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
52 rozwijane, listy przewijane i okienka; jest także wiele klas do
53 obsługi zdarzeń, kolorów, fontów i obrazków.
54
55 %package devel
56 Summary:        GNUstep GUI headers and libs
57 Summary(pl.UTF-8):      Pliki nagłówkowe GNUstep GUI
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       audiofile-devel
61 Requires:       gnustep-base-devel >= 1.13.0
62 Requires:       libjpeg-devel
63 Requires:       libtiff-devel
64 Conflicts:      gnustep-core
65
66 %description devel
67 Header files required to build applications against the GNUstep GUI
68 library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
72 biblioteki GNUstep GUI.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79 %patch3 -p1
80
81 %build
82 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
83 export GNUSTEP_FLATTENED=yes
84 # disable gsnd - not ready for current portaudio
85 %configure \
86         %{!?with_cups:--disable-cups} \
87         %{!?with_portaudio:--disable-gsnd}
88
89 # with __make -jN we can got non-deterministic errors
90 %{__make} -j1 \
91         messages=yes
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
96 export GNUSTEP_FLATTENED=yes
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %{__make} install -C Documentation \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
105         -type f -name .cvsignore | xargs rm -f
106
107 # not (yet?) supported by rpm-compress-doc
108 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
109         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc ChangeLog
120 %docdir %{_datadir}/GNUstep/Documentation
121 %dir %{_datadir}/GNUstep/Documentation/Developer
122 %dir %{_datadir}/GNUstep/Documentation/Developer/Gui
123 %{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
124 %{_datadir}/GNUstep/Documentation/User
125
126 %{_mandir}/man1/*
127
128 %attr(755,root,root) %{_bindir}/*
129 %attr(755,root,root) %{_libdir}/libgnustep-gui.so.*
130
131 %dir %{_libdir}/GNUstep/Bundles
132 %dir %{_libdir}/GNUstep/Bundles/GSPrinting
133 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
134 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
135 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
136 %if %{with cups}
137 # R: cups-lib - separate?
138 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
139 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
140 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
141 %endif
142
143 %dir %{_libdir}/GNUstep/Bundles/TextConverters
144 %dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
145 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
146 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
147 %dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
148 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
149 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
150
151 %dir %{_libdir}/GNUstep/ColorPickers
152 %dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
153 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
154 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
155 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
156 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
157 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
158 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
159 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
160 %lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
161 %lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
162 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
163 %dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
164 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
165 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
166
167 %{_libdir}/GNUstep/Images
168 %{_libdir}/GNUstep/KeyBindings
169
170 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui
171 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
172 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
173 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
174 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
175 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
176 %lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
177 %lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
178 %lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
179 %lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
180
181 %dir %{_libdir}/GNUstep/PostScript
182 %{_libdir}/GNUstep/PostScript/GSProlog.ps
183 %dir %{_libdir}/GNUstep/PostScript/PPD
184 %{_libdir}/GNUstep/PostScript/PPD/English.lproj
185 %dir %{_libdir}/GNUstep/Services
186 %dir %{_libdir}/GNUstep/Services/GSspell.service
187 %{_libdir}/GNUstep/Services/GSspell.service/Resources
188 %attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
189
190 %files devel
191 %defattr(644,root,root,755)
192 %docdir %{_datadir}/GNUstep/Documentation
193 %{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
194 %{_datadir}/GNUstep/Documentation/Developer/Gui/General
195 %{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
196 %{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
197 %{_infodir}/*.info*
198
199 %{_includedir}/AppKit
200 %{_includedir}/Cocoa
201 %{_includedir}/GNUstepGUI
202 %{_includedir}/gnustep/gui
203
204 %attr(755,root,root) %{_libdir}/libgnustep-gui.so
205 %{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.082552 seconds and 3 git commands to generate.