]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- updated to 0.10.0 (note: new soname)
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.10.0
5 Release:        1
6 License:        LGPL/GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
9 # Source0-md5:  1f35061e045fe7915bfa80ff037dee3a
10 Patch0:         %{name}-themes.patch
11 Patch1:         %{name}-nocompressdocs.patch
12 Patch2:         %{name}-segv.patch
13 Patch3:         %{name}-doc.patch
14 URL:            http://www.gnustep.org/
15 BuildRequires:  aspell-devel
16 BuildRequires:  audiofile-devel
17 BuildRequires:  gcc-objc
18 BuildRequires:  gnustep-base-devel >= 1.11.0
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  zlib-devel
22 Requires:       gnustep-base >= 1.11.0
23 Conflicts:      gnustep-core
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _prefix         /usr/%{_lib}/GNUstep
27
28 %define         libcombo        gnu-gnu-gnu
29 %define         gsos            linux-gnu
30 %ifarch %{ix86}
31 %define         gscpu           ix86
32 %else
33 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
34 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
35 %endif
36
37 %description
38 It is a library of graphical user interface classes written completely
39 in the Objective-C language; the classes are based upon the OpenStep
40 specification as release by NeXT Software, Inc. The library does not
41 completely conform to the specification and has been enhanced in a
42 number of ways to take advantage of the GNU system. These classes
43 include graphical objects such as buttons, text fields, popup lists,
44 browser lists, and windows; there are also many associated classes for
45 handling events, colors, fonts, pasteboards and images.
46
47 %description -l pl
48 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
49 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
50 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
51 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
52 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
53 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
54 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
55
56 %package devel
57 Summary:        GNUstep GUI headers and libs
58 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       audiofile-devel
62 Requires:       gnustep-base-devel >= 1.11.0
63 Requires:       libjpeg-devel
64 Requires:       libtiff-devel
65 Conflicts:      gnustep-core
66
67 %description devel
68 Header files required to build applications against the GNUstep GUI
69 library.
70
71 %description devel -l pl
72 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
73 biblioteki GNUstep GUI.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80 %patch3 -p1
81
82 %build
83 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
84 # disable gsnd - not ready for current portaudio
85 %configure \
86         --disable-gsnd
87
88 %{__make} \
89         messages=yes
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
94
95 %{__make} install \
96         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
97         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
98 %{__make} install -C Documentation \
99         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
100         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
101
102 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
103         -type f -name .cvsignore | xargs rm -f
104 # not (yet?) supported by rpm-compress-doc
105 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
106         -type f -a ! -name '*.html' | xargs gzip -9nf
107
108 mv $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation/info/manual.info.gz $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation/info/gnustep-gui.info.gz
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc ChangeLog
119
120 %docdir %{_prefix}/System/Library/Documentation
121 %dir %{_prefix}/System/Library/Documentation/Developer/Gui
122 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
123 %{_prefix}/System/Library/Documentation/User/Gui
124 %{_prefix}/System/Library/Documentation/man/man1/*
125
126 %dir %{_prefix}/System/Library/Bundles/TextConverters
127 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
128 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
129 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
130 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
131 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
132 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
133
134 %dir %{_prefix}/System/Library/Bundles/GSPrinting
135 %dir %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle
136 %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/Resources
137 %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/%{gscpu}
138
139 %dir %{_prefix}/System/Library/ColorPickers
140 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
141 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
142 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
143 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
144 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
145 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
146 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
147 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
148 %dir %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle
149 %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/Resources
150 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/%{gscpu}
151 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
152 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
153 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
154
155 %{_prefix}/System/Library/Images/*
156 %{_prefix}/System/Library/KeyBindings/*.dict
157
158 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
159 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/*.plist
160 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
161 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
162
163 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
164
165 %dir %{_prefix}/System/Library/PostScript
166 %{_prefix}/System/Library/PostScript/GSProlog.ps
167 %dir %{_prefix}/System/Library/PostScript/PPD
168 %{_prefix}/System/Library/PostScript/PPD/English.lproj
169 %dir %{_prefix}/System/Library/Services/GSspell.service
170 %{_prefix}/System/Library/Services/GSspell.service/Resources
171 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
172
173 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
174
175 %files devel
176 %defattr(644,root,root,755)
177 %docdir %{_prefix}/System/Library/Documentation
178 %{_prefix}/System/Library/Documentation/Developer/Gui/Additions
179 %{_prefix}/System/Library/Documentation/Developer/Gui/General
180 %{_prefix}/System/Library/Documentation/Developer/Gui/ProgrammingManual
181 %{_prefix}/System/Library/Documentation/Developer/Gui/Reference
182 %{_prefix}/System/Library/Documentation/info/gnustep-gui.info*
183
184 %{_prefix}/System/Library/Headers/%{libcombo}/AppKit
185 %{_prefix}/System/Library/Headers/%{libcombo}/GNUstepGUI
186 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/gui
187
188 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
189 %{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.066711 seconds and 3 git commands to generate.