]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- updated to 0.11.0, use flattened directory structure
[packages/gnustep-gui.git] / gnustep-gui.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # GSCUPS bundle
4 %bcond_without  portaudio       # gsnd tool
5 #
6 Summary:        GNUstep GUI library package
7 Summary(pl):    Biblioteka GNUstep GUI
8 Name:           gnustep-gui
9 Version:        0.11.0
10 Release:        1
11 License:        LGPL/GPL
12 Group:          Libraries
13 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
14 # Source0-md5:  7821a516ce5f683885116d78ac09b79e
15 Patch0:         %{name}-themes.patch
16 Patch1:         %{name}-nocompressdocs.patch
17 Patch2:         %{name}-segv.patch
18 Patch3:         %{name}-doc.patch
19 URL:            http://www.gnustep.org/
20 BuildRequires:  aspell-devel
21 BuildRequires:  audiofile-devel
22 %{?with_cups:BuildRequires:     cups-devel}
23 BuildRequires:  gcc-objc
24 BuildRequires:  giflib-devel
25 BuildRequires:  gnustep-base-devel >= 1.13.0
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtiff-devel
29 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
30 BuildRequires:  zlib-devel
31 Requires:       gnustep-base >= 1.13.0
32 Conflicts:      gnustep-core
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _prefix         /usr/%{_lib}/GNUstep
36
37 %description
38 It is a library of graphical user interface classes written completely
39 in the Objective-C language; the classes are based upon the OpenStep
40 specification as release by NeXT Software, Inc. The library does not
41 completely conform to the specification and has been enhanced in a
42 number of ways to take advantage of the GNU system. These classes
43 include graphical objects such as buttons, text fields, popup lists,
44 browser lists, and windows; there are also many associated classes for
45 handling events, colors, fonts, pasteboards and images.
46
47 %description -l pl
48 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
49 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
50 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
51 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
52 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
53 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
54 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
55
56 %package devel
57 Summary:        GNUstep GUI headers and libs
58 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       audiofile-devel
62 Requires:       gnustep-base-devel >= 1.13.0
63 Requires:       libjpeg-devel
64 Requires:       libtiff-devel
65 Conflicts:      gnustep-core
66
67 %description devel
68 Header files required to build applications against the GNUstep GUI
69 library.
70
71 %description devel -l pl
72 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
73 biblioteki GNUstep GUI.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80 %patch3 -p1
81
82 %build
83 export GNUSTEP_MAKEFILES=%{_prefix}/System/Library/Makefiles
84 export GNUSTEP_FLATTENED=yes
85 # disable gsnd - not ready for current portaudio
86 %configure \
87         %{!?with_cups:--disable-cups} \
88         %{!?with_portaudio:--disable-gsnd}
89
90 %{__make} \
91         messages=yes
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 export GNUSTEP_MAKEFILES=%{_prefix}/System/Library/Makefiles
96 export GNUSTEP_FLATTENED=yes
97
98 %{__make} install \
99         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
100         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
101 %{__make} install -C Documentation \
102         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
103         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
104
105 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
106         -type f -name .cvsignore | xargs rm -f
107 # not (yet?) supported by rpm-compress-doc
108 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
109         -type f -a ! -name '*.html' | xargs gzip -9nf
110
111 mv $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation/info/manual.info.gz $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation/info/gnustep-gui.info.gz
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc ChangeLog
122
123 %docdir %{_prefix}/System/Library/Documentation
124 %dir %{_prefix}/System/Library/Documentation/Developer/Gui
125 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
126 %{_prefix}/System/Library/Documentation/User/Gui
127 %{_prefix}/System/Library/Documentation/man/man1/*
128
129 %dir %{_prefix}/System/Library/Bundles/GSPrinting
130 %if %{with cups}
131 # R: cups-lib - separate?
132 %dir %{_prefix}/System/Library/Bundles/GSPrinting/GSCUPS.bundle
133 %{_prefix}/System/Library/Bundles/GSPrinting/GSCUPS.bundle/Resources
134 %{_prefix}/System/Library/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
135 %endif
136 %dir %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle
137 %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/Resources
138 %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/GSLPR
139
140 %dir %{_prefix}/System/Library/Bundles/TextConverters
141 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
142 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
143 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
144 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
145 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
146 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/libgmodel
147
148 %dir %{_prefix}/System/Library/ColorPickers
149 %dir %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle
150 %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/Resources
151 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/NamedPicker
152 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
153 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
154 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
155 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
156 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
157 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
158 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
159 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/StandardPicker
160 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
161 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
162 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/WheelPicker
163
164 %{_prefix}/System/Library/Images/*
165 %{_prefix}/System/Library/KeyBindings/*.dict
166
167 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
168 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/*.plist
169 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
170 %lang(eo) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Esperanto.lproj
171 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/German.lproj
172 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
173 %lang(jbo) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Lojban.lproj
174
175 %attr(755,root,root) %{_prefix}/System/Library/Libraries/libgnustep-gui.so.*
176
177 %dir %{_prefix}/System/Library/PostScript
178 %{_prefix}/System/Library/PostScript/GSProlog.ps
179 %dir %{_prefix}/System/Library/PostScript/PPD
180 %{_prefix}/System/Library/PostScript/PPD/English.lproj
181 %dir %{_prefix}/System/Library/Services/GSspell.service
182 %{_prefix}/System/Library/Services/GSspell.service/Resources
183 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/GSspell
184
185 %attr(755,root,root) %{_prefix}/System/Tools/*
186
187 %files devel
188 %defattr(644,root,root,755)
189 %docdir %{_prefix}/System/Library/Documentation
190 %{_prefix}/System/Library/Documentation/Developer/Gui/Additions
191 %{_prefix}/System/Library/Documentation/Developer/Gui/General
192 %{_prefix}/System/Library/Documentation/Developer/Gui/ProgrammingManual
193 %{_prefix}/System/Library/Documentation/Developer/Gui/Reference
194 %{_prefix}/System/Library/Documentation/info/gnustep-gui.info*
195
196 %{_prefix}/System/Library/Headers/AppKit
197 %{_prefix}/System/Library/Headers/Cocoa
198 %{_prefix}/System/Library/Headers/GNUstepGUI
199 %{_prefix}/System/Library/Headers/gnustep/gui
200
201 %attr(755,root,root) %{_prefix}/System/Library/Libraries/libgnustep-gui.so
202 %{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.047963 seconds and 3 git commands to generate.