]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- updated to 0.23.1
[packages/gnustep-gui.git] / gnustep-gui.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # GSCUPS bundle
4 %bcond_without  magick          # ImageMagick support
5 %bcond_without  portaudio       # gsnd tool
6 #
7 Summary:        GNUstep GUI library package
8 Summary(pl.UTF-8):      Biblioteka GNUstep GUI
9 Name:           gnustep-gui
10 %define ver     0.23
11 Version:        %{ver}.1
12 Release:        1
13 License:        LGPL v2+ (library), GPL v3+ (applications)
14 Group:          Libraries
15 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
16 # Source0-md5:  1771bdb42f27ee946b17bf60fef5eb2e
17 Patch0:         %{name}-nocompressdocs.patch
18 Patch1:         %{name}-doc.patch
19 URL:            http://www.gnustep.org/
20 %{?with_magick:BuildRequires:   ImageMagick-devel}
21 BuildRequires:  aspell-devel
22 BuildRequires:  audiofile-devel
23 %{?with_cups:BuildRequires:     cups-devel}
24 BuildRequires:  flite-devel
25 BuildRequires:  gcc-objc
26 BuildRequires:  giflib-devel
27 BuildRequires:  gnustep-base-devel >= 1.13.0
28 BuildRequires:  gnustep-make-devel
29 BuildRequires:  libao-devel
30 BuildRequires:  libicu-devel >= 4.0
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libsndfile-devel
34 BuildRequires:  libtiff-devel
35 BuildRequires:  pkgconfig
36 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
37 BuildRequires:  zlib-devel
38 Requires:       gnustep-base >= 1.13.0
39 Conflicts:      gnustep-core
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 It is a library of graphical user interface classes written completely
44 in the Objective-C language; the classes are based upon the OpenStep
45 specification as release by NeXT Software, Inc. The library does not
46 completely conform to the specification and has been enhanced in a
47 number of ways to take advantage of the GNU system. These classes
48 include graphical objects such as buttons, text fields, popup lists,
49 browser lists, and windows; there are also many associated classes for
50 handling events, colors, fonts, pasteboards and images.
51
52 %description -l pl.UTF-8
53 To jest biblioteka klas graficznego interfejsu użytkownika napisana w
54 Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
55 NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
56 została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
57 zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
58 rozwijane, listy przewijane i okienka; jest także wiele klas do
59 obsługi zdarzeń, kolorów, fontów i obrazków.
60
61 %package devel
62 Summary:        GNUstep GUI headers and libs
63 Summary(pl.UTF-8):      Pliki nagłówkowe GNUstep GUI
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       audiofile-devel
67 Requires:       gnustep-base-devel >= 1.13.0
68 Requires:       libjpeg-devel
69 Requires:       libtiff-devel
70 Conflicts:      gnustep-core
71
72 %description devel
73 Header files required to build applications against the GNUstep GUI
74 library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
78 biblioteki GNUstep GUI.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84
85 %build
86 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
87 export GNUSTEP_FLATTENED=yes
88 # disable gsnd - not ready for current portaudio
89 %configure \
90         %{!?with_cups:--disable-cups} \
91         %{!?with_portaudio:--disable-gsnd} \
92         %{?with_magick:--enable-imagemagick} \
93         --enable-libgif \
94         --disable-ungif
95
96 # with __make -jN we can got non-deterministic errors
97 %{__make} -j1 \
98         messages=yes
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
103 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
104 export GNUSTEP_FLATTENED=yes
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{__make} install -C Documentation \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
113         -type f -name .cvsignore | xargs rm -f
114
115 # not (yet?) supported by rpm-compress-doc
116 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
117         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc ChangeLog
128 %docdir %{_datadir}/GNUstep/Documentation
129 %dir %{_datadir}/GNUstep/Documentation/Developer
130 %dir %{_datadir}/GNUstep/Documentation/Developer/Gui
131 %{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
132 %{_datadir}/GNUstep/Documentation/User
133
134 %{_mandir}/man1/gclose.1*
135 %{_mandir}/man1/gcloseall.1*
136 %{_mandir}/man1/gopen.1*
137 %{_mandir}/man1/make_services.1*
138 %{_mandir}/man1/set_show_service.1*
139
140 %attr(755,root,root) %{_bindir}/GSSpeechServer
141 %attr(755,root,root) %{_bindir}/gclose
142 %attr(755,root,root) %{_bindir}/gcloseall
143 %attr(755,root,root) %{_bindir}/gopen
144 %attr(755,root,root) %{_bindir}/make_services
145 %attr(755,root,root) %{_bindir}/say
146 %attr(755,root,root) %{_bindir}/set_show_service
147 %attr(755,root,root) %{_libdir}/libgnustep-gui.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libgnustep-gui.so.%{ver}
149
150 %dir %{_libdir}/GNUstep/Applications
151 %dir %{_libdir}/GNUstep/Applications/GSSpeechServer.app
152 %attr(755,root,root) %{_libdir}/GNUstep/Applications/GSSpeechServer.app/GSSpeechServer
153 %{_libdir}/GNUstep/Applications/GSSpeechServer.app/Resources
154 %{_libdir}/GNUstep/Applications/GSSpeechServer.app/stamp.make
155
156 %dir %{_libdir}/GNUstep/Bundles
157
158 %dir %{_libdir}/GNUstep/Bundles/AudioOutput.nssound
159 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/AudioOutput
160 %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/Resources
161 %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/stamp.make
162
163 %dir %{_libdir}/GNUstep/Bundles/GSPrinting
164 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
165 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
166 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
167 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/stamp.make
168 %if %{with cups}
169 # R: cups-lib - separate?
170 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
171 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
172 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
173 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/stamp.make
174 %endif
175
176 %dir %{_libdir}/GNUstep/Bundles/Sndfile.nssound
177 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Sndfile
178 %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Resources
179 %{_libdir}/GNUstep/Bundles/Sndfile.nssound/stamp.make
180
181 %dir %{_libdir}/GNUstep/Bundles/TextConverters
182 %dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
183 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
184 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
185 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/stamp.make
186
187 %dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
188 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
189 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
190 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/stamp.make
191
192 %dir %{_libdir}/GNUstep/ColorPickers
193
194 %dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
195 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
196 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
197 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/stamp.make
198
199 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
200 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
201 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
202 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
203 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
204 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
205 %lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
206 %lang(es) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Spanish.lproj
207 %lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
208 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/stamp.make
209
210 %dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
211 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
212 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
213 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/stamp.make
214
215 %{_libdir}/GNUstep/Images
216 %{_libdir}/GNUstep/KeyBindings
217
218 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui
219 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
220 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
221 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
222 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
223 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
224 %lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
225 %lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/French.lproj
226 %lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
227 %lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
228 %lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
229 %lang(es) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Spanish.lproj
230
231 %dir %{_libdir}/GNUstep/PostScript
232 %{_libdir}/GNUstep/PostScript/GSProlog.ps
233 %dir %{_libdir}/GNUstep/PostScript/PPD
234 %{_libdir}/GNUstep/PostScript/PPD/English.lproj
235
236 %dir %{_libdir}/GNUstep/Services
237
238 %dir %{_libdir}/GNUstep/Services/GSspell.service
239 %attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
240 %{_libdir}/GNUstep/Services/GSspell.service/Resources
241
242 %{_libdir}/GNUstep/Sounds
243
244 %files devel
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/libgnustep-gui.so
247 %{_includedir}/AppKit
248 %{_includedir}/Cocoa
249 %{_includedir}/GNUstepGUI
250 %{_includedir}/gnustep/gui
251
252 %docdir %{_datadir}/GNUstep/Documentation
253 %{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
254 %{_datadir}/GNUstep/Documentation/Developer/Gui/General
255 %{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
256 %{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
257 %{_infodir}/AppKit.info*
258
259 %{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.076696 seconds and 3 git commands to generate.