]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- updated to 0.9.5
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.9.5
5 Release:        1
6 License:        LGPL/GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
9 # Source0-md5:  59c151b1edc2e8e9c1e5aff70569783e
10 Patch0:         %{name}-themes.patch
11 Patch1:         %{name}-nocompressdocs.patch
12 Patch2:         %{name}-segv.patch
13 Patch3:         %{name}-doc.patch
14 URL:            http://www.gnustep.org/
15 BuildRequires:  aspell-devel
16 BuildRequires:  audiofile-devel
17 BuildRequires:  gcc-objc
18 BuildRequires:  gnustep-base-devel >= 1.10.0
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  zlib-devel
22 Requires:       gnustep-base >= 1.10.0
23 Conflicts:      gnustep-core
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _prefix         /usr/%{_lib}/GNUstep
27
28 %define         libcombo        gnu-gnu-gnu
29 %define         gsos            linux-gnu
30 %ifarch %{ix86}
31 %define         gscpu           ix86
32 %else
33 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
34 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
35 %endif
36
37 %description
38 It is a library of graphical user interface classes written completely
39 in the Objective-C language; the classes are based upon the OpenStep
40 specification as release by NeXT Software, Inc. The library does not
41 completely conform to the specification and has been enhanced in a
42 number of ways to take advantage of the GNU system. These classes
43 include graphical objects such as buttons, text fields, popup lists,
44 browser lists, and windows; there are also many associated classes for
45 handling events, colors, fonts, pasteboards and images.
46
47 %description -l pl
48 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
49 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
50 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
51 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
52 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
53 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
54 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
55
56 %package devel
57 Summary:        GNUstep GUI headers and libs
58 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       audiofile-devel
62 Requires:       gnustep-base-devel >= 1.9.0
63 Requires:       libjpeg-devel
64 Requires:       libtiff-devel
65 Conflicts:      gnustep-core
66
67 %description devel
68 Header files required to build applications against the GNUstep GUI
69 library.
70
71 %description devel -l pl
72 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
73 biblioteki GNUstep GUI.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80 %patch3 -p1
81
82 %build
83 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
84 %configure
85
86 %{__make} \
87         messages=yes
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
92
93 %{__make} install \
94         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
95         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
96 %{__make} install -C Documentation \
97         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
98         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
99
100 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
101         -type f -name .cvsignore | xargs rm -f
102 # not (yet?) supported by rpm-compress-doc
103 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
104         -type f -a ! -name '*.html' | xargs gzip -9nf
105
106 mv $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation/info/manual.info.gz $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation/info/gnustep-gui.info.gz
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc ChangeLog
117
118 %docdir %{_prefix}/System/Library/Documentation
119 %dir %{_prefix}/System/Library/Documentation/Developer/Gui
120 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
121 %{_prefix}/System/Library/Documentation/User/Gui
122 %{_prefix}/System/Library/Documentation/man/man1/*
123
124 %dir %{_prefix}/System/Library/Bundles/TextConverters
125 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
126 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
127 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
128 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
129 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
130 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
131
132 %dir %{_prefix}/System/Library/Bundles/GSPrinting
133 %dir %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle
134 %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/Resources
135 %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/%{gscpu}
136
137 %dir %{_prefix}/System/Library/ColorPickers
138 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
139 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
140 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
141 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
142 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
143 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
144 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
145 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
146 %dir %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle
147 %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/Resources
148 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/%{gscpu}
149 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
150 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
151 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
152
153 %{_prefix}/System/Library/Images/*
154 %{_prefix}/System/Library/KeyBindings/*.dict
155
156 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
157 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/*.plist
158 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
159 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
160
161 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
162
163 %dir %{_prefix}/System/Library/PostScript
164 %{_prefix}/System/Library/PostScript/GSProlog.ps
165 %dir %{_prefix}/System/Library/PostScript/PPD
166 %{_prefix}/System/Library/PostScript/PPD/English.lproj
167 %dir %{_prefix}/System/Library/Services/GSspell.service
168 %{_prefix}/System/Library/Services/GSspell.service/Resources
169 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
170
171 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %docdir %{_prefix}/System/Library/Documentation
176 %{_prefix}/System/Library/Documentation/Developer/Gui/Additions
177 %{_prefix}/System/Library/Documentation/Developer/Gui/General
178 %{_prefix}/System/Library/Documentation/Developer/Gui/ProgrammingManual
179 %{_prefix}/System/Library/Documentation/Developer/Gui/Reference
180 %{_prefix}/System/Library/Documentation/info/gnustep-gui.info*
181
182 %{_prefix}/System/Library/Headers/%{libcombo}/AppKit
183 %{_prefix}/System/Library/Headers/%{libcombo}/GNUstepGUI
184 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/gui
185
186 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
187 %{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.132298 seconds and 3 git commands to generate.