]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- release 3
[packages/gnustep-gui.git] / gnustep-gui.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # GSCUPS bundle
4 %bcond_without  portaudio       # gsnd tool
5 #
6 Summary:        GNUstep GUI library package
7 Summary(pl.UTF-8):      Biblioteka GNUstep GUI
8 Name:           gnustep-gui
9 %define ver     0.16
10 Version:        %{ver}.0
11 Release:        3
12 License:        LGPL/GPL
13 Group:          Libraries
14 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
15 # Source0-md5:  464b80094e438fe0cc8e6ae691b3384c
16 Patch0:         %{name}-themes.patch
17 Patch1:         %{name}-nocompressdocs.patch
18 Patch2:         %{name}-segv.patch
19 Patch3:         %{name}-doc.patch
20 URL:            http://www.gnustep.org/
21 BuildRequires:  aspell-devel
22 BuildRequires:  audiofile-devel
23 %{?with_cups:BuildRequires:     cups-devel}
24 BuildRequires:  gcc-objc
25 BuildRequires:  giflib-devel
26 BuildRequires:  gnustep-base-devel >= 1.13.0
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libtiff-devel
30 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
31 BuildRequires:  zlib-devel
32 Requires:       gnustep-base >= 1.13.0
33 Conflicts:      gnustep-core
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 It is a library of graphical user interface classes written completely
38 in the Objective-C language; the classes are based upon the OpenStep
39 specification as release by NeXT Software, Inc. The library does not
40 completely conform to the specification and has been enhanced in a
41 number of ways to take advantage of the GNU system. These classes
42 include graphical objects such as buttons, text fields, popup lists,
43 browser lists, and windows; there are also many associated classes for
44 handling events, colors, fonts, pasteboards and images.
45
46 %description -l pl.UTF-8
47 To jest biblioteka klas graficznego interfejsu użytkownika napisana w
48 Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
49 NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
50 została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
51 zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
52 rozwijane, listy przewijane i okienka; jest także wiele klas do
53 obsługi zdarzeń, kolorów, fontów i obrazków.
54
55 %package devel
56 Summary:        GNUstep GUI headers and libs
57 Summary(pl.UTF-8):      Pliki nagłówkowe GNUstep GUI
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       audiofile-devel
61 Requires:       gnustep-base-devel >= 1.13.0
62 Requires:       libjpeg-devel
63 Requires:       libtiff-devel
64 Conflicts:      gnustep-core
65
66 %description devel
67 Header files required to build applications against the GNUstep GUI
68 library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
72 biblioteki GNUstep GUI.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79 %patch3 -p1
80
81 %build
82 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
83 export GNUSTEP_FLATTENED=yes
84 # disable gsnd - not ready for current portaudio
85 %configure \
86         %{!?with_cups:--disable-cups} \
87         %{!?with_portaudio:--disable-gsnd}
88
89 # with __make -jN we can got non-deterministic errors
90 %{__make} -j1 \
91         messages=yes
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
96 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
97 export GNUSTEP_FLATTENED=yes
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %{__make} install -C Documentation \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
106         -type f -name .cvsignore | xargs rm -f
107
108 # not (yet?) supported by rpm-compress-doc
109 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
110         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc ChangeLog
121 %docdir %{_datadir}/GNUstep/Documentation
122 %dir %{_datadir}/GNUstep/Documentation/Developer
123 %dir %{_datadir}/GNUstep/Documentation/Developer/Gui
124 %{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
125 %{_datadir}/GNUstep/Documentation/User
126
127 %{_mandir}/man1/*
128
129 %attr(755,root,root) %{_bindir}/*
130 %attr(755,root,root) %{_libdir}/libgnustep-gui.so.*
131
132 %dir %{_libdir}/GNUstep/Bundles
133 %dir %{_libdir}/GNUstep/Bundles/GSPrinting
134 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
135 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
136 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
137 %if %{with cups}
138 # R: cups-lib - separate?
139 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
140 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
141 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
142 %endif
143
144 %dir %{_libdir}/GNUstep/Bundles/TextConverters
145 %dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
146 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
147 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
148 %dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
149 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
150 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
151
152 %dir %{_libdir}/GNUstep/ColorPickers
153 %dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
154 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
155 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
156 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
157 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
158 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
159 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
160 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
161 %lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
162 %lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
163 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
164 %dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
165 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
166 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
167
168 %{_libdir}/GNUstep/Images
169 %{_libdir}/GNUstep/KeyBindings
170
171 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui
172 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
173 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
174 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
175 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
176 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
177 %lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
178 %lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
179 %lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
180 %lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
181
182 %dir %{_libdir}/GNUstep/PostScript
183 %{_libdir}/GNUstep/PostScript/GSProlog.ps
184 %dir %{_libdir}/GNUstep/PostScript/PPD
185 %{_libdir}/GNUstep/PostScript/PPD/English.lproj
186 %dir %{_libdir}/GNUstep/Services
187 %dir %{_libdir}/GNUstep/Services/GSspell.service
188 %{_libdir}/GNUstep/Services/GSspell.service/Resources
189 %attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
190
191 %files devel
192 %defattr(644,root,root,755)
193 %docdir %{_datadir}/GNUstep/Documentation
194 %{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
195 %{_datadir}/GNUstep/Documentation/Developer/Gui/General
196 %{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
197 %{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
198 %{_infodir}/*.info*
199
200 %{_includedir}/AppKit
201 %{_includedir}/Cocoa
202 %{_includedir}/GNUstepGUI
203 %{_includedir}/gnustep/gui
204
205 %attr(755,root,root) %{_libdir}/libgnustep-gui.so
206 %{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.085982 seconds and 3 git commands to generate.