]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
- updated to 1.9.21 (gcc 4 is assumed now)
[packages/gnupg2.git] / gnupg2.spec
1 #
2 # Conditional build:
3 %bcond_without  pth     # without pth-based based version of gnupg
4 #
5 Summary:        GNU Privacy Guard - tool for secure communication and data storage - development version
6 Summary(pl):    GnuPG - narzêdzie do bezpiecznej komunikacji i bezpiecznego przechowywania danych - wersja rozwojowa
7 Name:           gnupg2
8 Version:        1.9.21
9 Release:        1
10 License:        GPL
11 Group:          Applications/File
12 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.bz2
13 # Source0-md5:  94f4e2ded63820efa6903543c2e06017
14 Source1:        gnupg-agent.sh
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-pth.patch
17 URL:            http://www.gnupg.org/
18 BuildRequires:  automake
19 BuildRequires:  bzip2-devel
20 # -Wno-pointer-sign in g10/Makefile.am
21 BuildRequires:  gcc >= 5:4.0
22 BuildRequires:  gettext-devel >= 0.14.1
23 BuildRequires:  libassuan-devel >= 1:0.6.10
24 BuildRequires:  libgcrypt-devel >= 1.1.94
25 BuildRequires:  libgpg-error-devel >= 1.0
26 BuildRequires:  libksba-devel >= 0.9.13
27 BuildRequires:  libusb-devel
28 BuildRequires:  pcsc-lite-devel
29 %{?with_pth:BuildRequires:      pth-devel >= 2.0.0}
30 BuildRequires:  rpmbuild(macros) >= 1.177
31 BuildRequires:  texinfo
32 BuildRequires:  zlib-devel
33 Requires:       gnupg2-common = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _libexecdir     %{_libdir}/gnupg2
37
38 %description
39 GnuPG is GNU's tool for secure communication and data storage. It can
40 be used to encrypt data and to create digital signatures. It includes
41 an advanced key management facility and is compliant with the proposed
42 OpenPGP Internet standard as described in RFC2440.
43
44 This is development version. Don't use it with production keys.
45
46 %description -l pl
47 GnuPG (GNU Privacy Guard) jest narzêdziem do bezpiecznej komunikacji i
48 bezpiecznego przechowywania danych. Mo¿e byæ u¿ywany do szyfrowania
49 oraz podpisywania danych. Umo¿liwia zaawansowane zarz±dzanie kluczami
50 i spe³nia normy zdefiniowane w standardzie OpenPGP, który jest opisany
51 w RFC2440.
52
53 Wersja rozwojowa. Nie do u¿ytku z kluczami produkcyjnymi.
54
55 %package common
56 Summary:        GnuPG - common files
57 Summary(pl):    GnuPG - pliki wspólne
58 Group:          Applications/File
59 Requires:       libgpg-error >= 1.0
60 Conflicts:      gnupg-agent < 1.9.14-2
61
62 %description common
63 Common files used by tools from GnuPG project.
64
65 %description common -l pl
66 Pliki wspólne u¿ywane przez ró¿ne narzêdzia z projektu GnuPG.
67
68 %package -n gnupg-agent
69 Summary:        GnuPG extension - agent
70 Summary(pl):    Rozszerzenie GnuPG - agent
71 Group:          Applications/File
72 Requires:       gnupg2-common = %{version}-%{release}
73 Requires:       pinentry
74 Obsoletes:      newpg
75
76 %description -n gnupg-agent
77 GnuPG extension - agent.
78
79 %description -n gnupg-agent -l pl
80 Rozszerzenie GnuPG - agent.
81
82 %package -n gnupg-agent-profile_d
83 Summary:        gnupg-agent start script for text mode
84 Summary(pl):    Skrypt startowy gnupg-agenta dla trybu tekstowego
85 Group:          Applications/File
86 Requires:       gnupg-agent = %{version}-%{release}
87
88 %description -n gnupg-agent-profile_d
89 gnupg-agent start script for text mode.
90
91 %description -n gnupg-agent-profile_d -l pl
92 Skrypt startowy gnupg-agenta dla trybu tekstowego.
93
94 %package -n gnupg-agent-xinitrc
95 Summary:        gnupg-agent start script for X-Window mode
96 Summary(pl):    Skrypt startowy gnupg-agenta dla trybu X-Window
97 Group:          Applications/File
98 Requires:       gnupg-agent = %{version}-%{release}
99 Requires:       xinitrc
100
101 %description -n gnupg-agent-xinitrc
102 gnupg-agent start script for X-Window mode.
103
104 %description -n gnupg-agent-xinitrc -l pl
105 Skrypt startowy gnupg-agenta dla trybu X-Window.
106
107 %package -n gnupg-smime
108 Summary:        GnuPG extension - S/MIME support
109 Summary(pl):    Rozszerzenie GnuPG - obs³uga S/MIME
110 Group:          Applications/File
111 Requires:       gnupg2-common = %{version}-%{release}
112 Conflicts:      gnupg-agent < 1.9.14-2
113
114 %description -n gnupg-smime
115 GnuPG extension - S/MIME support.
116
117 %description -n gnupg-smime -l pl
118 Rozszerzenie GnuPG - obs³uga S/MIME.
119
120 %prep
121 %setup -q -n gnupg-%{version}
122 %patch0 -p1
123 %patch1 -p1
124
125 %build
126 cp -f /usr/share/automake/config.* scripts
127 %configure \
128         --with-capabilities \
129         %{!?with_pth:--disable-threads} \
130         --enable-gpg \
131 %ifarch sparc sparc64
132         --disable-m-guard \
133 %else
134         --enable-m-guard \
135 %endif
136         --without-included-gettext \
137         --disable-m-debug \
138         --with-mailprog=/usr/lib/sendmail
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT \
147         pkglibdir=%{_libexecdir}
148
149 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/gnupg-agent.sh
150 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gnupg-agent.sh
151
152 mv ChangeLog main-ChangeLog || :
153 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
154
155 %find_lang gnupg2
156 rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post
162 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
163
164 %postun
165 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
166
167 %triggerpostun -n gnupg-agent -- gnupg-agent < 1.9.16-2
168 %banner gnupg-agent-1.9.16-2 << EOF
169 Scripts for starting gnupg-agent have been moved to separate
170 subpackages: gnupg-agent-profile_d and gnupg-agent-xinitrc.
171 EOF
172
173 %files
174 %defattr(644,root,root,755)
175 %doc g10-ChangeLog g10/options.skel
176 %attr(755,root,root) %{_bindir}/gpg2
177 %attr(755,root,root) %{_bindir}/gpgv2
178
179 %files common -f gnupg2.lang
180 %defattr(644,root,root,755)
181 %doc AUTHORS main-ChangeLog NEWS README THANKS TODO
182 %doc intl-ChangeLog jnlib-ChangeLog m4-ChangeLog po-ChangeLog scripts-ChangeLog common-ChangeLog kbx-ChangeLog tools-ChangeLog doc-ChangeLog
183 %attr(755,root,root) %{_bindir}/gpg-connect-agent
184 %attr(755,root,root) %{_bindir}/gpgconf
185 %attr(755,root,root) %{_bindir}/gpgkey2ssh
186 %attr(755,root,root) %{_bindir}/gpgparsemail
187 %attr(755,root,root) %{_bindir}/watchgnupg
188 %attr(755,root,root) %{_sbindir}/addgnupghome
189 %attr(755,root,root) %{_bindir}/kbxutil
190 %{_datadir}/gnupg
191 %{_infodir}/*info*
192
193 %files -n gnupg-smime
194 %defattr(644,root,root,755)
195 %doc sm-ChangeLog
196 %attr(755,root,root) %{_bindir}/gpgsm
197 %attr(755,root,root) %{_bindir}/gpgsm-gencert.sh
198
199 %files -n gnupg-agent
200 %defattr(644,root,root,755)
201 %doc agent-ChangeLog scd-ChangeLog
202 %attr(755,root,root) %{_bindir}/gpg-agent
203 %attr(755,root,root) %{_bindir}/scdaemon
204 %dir %{_libexecdir}
205 %attr(755,root,root) %{_libexecdir}/gpg-protect-tool
206 %attr(755,root,root) %{_libexecdir}/gpg-preset-passphrase
207 %attr(755,root,root) %{_libexecdir}/pcsc-wrapper
208
209 %files -n gnupg-agent-profile_d
210 %defattr(644,root,root,755)
211 %attr(755,root,root) /etc/profile.d/gnupg-agent.sh
212
213 %files -n gnupg-agent-xinitrc
214 %defattr(644,root,root,755)
215 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/gnupg-agent.sh
This page took 0.088543 seconds and 4 git commands to generate.