]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
provide 'gnupg' when built with default_gpg
[packages/gnupg2.git] / gnupg2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # testsuite on build
4 %bcond_without  dirmngr         # dirmngr packages build
5 %bcond_with     default_gpg     # install as gpg/gpgv instead of gpg2/gpgv2
6 %bcond_with     gnutls          # GnuTLS instead of NTBTLS
7 %bcond_with     selinux         # "SELinux hacks"
8 #
9 Summary:        GNU Privacy Guard - tool for secure communication and data storage - enhanced version
10 Summary(pl.UTF-8):      GnuPG - narzędzie do bezpiecznej komunikacji i bezpiecznego przechowywania danych - wersja rozszerzona
11 Name:           gnupg2
12 # 2.1.x is development version unfortunately (see gpg2 --version)
13 Version:        2.2.5
14 Release:        0.1
15 License:        GPL v3+
16 Group:          Applications/File
17 Source0:        ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-%{version}.tar.bz2
18 # Source0-md5:  567cd2d41fa632903066fde73d2005cb
19 Source1:        gnupg-agent.sh
20 Patch0:         %{name}-info.patch
21 Patch1:         %{name}-pth.patch
22 Patch2:         %{name}-disable_tests.patch
23 Patch3:         %{name}-pl.po-update.patch
24 Patch4:         %{name}-am.patch
25 URL:            http://www.gnupg.org/
26 BuildRequires:  autoconf >= 2.61
27 BuildRequires:  automake >= 1:1.14
28 BuildRequires:  bzip2-devel
29 BuildRequires:  curl-devel >= 7.10
30 BuildRequires:  gettext-tools >= 0.17
31 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.0}
32 BuildRequires:  libassuan-devel >= 1:2.5.0
33 BuildRequires:  libgcrypt-devel >= 1.7.0
34 BuildRequires:  libgpg-error-devel >= 1.24
35 BuildRequires:  libksba-devel >= 1.3.4
36 BuildRequires:  libusb-devel >= 1.0
37 BuildRequires:  npth-devel >= 1.2
38 %{!?with_gnutls:BuildRequires:  ntbtls-devel >= 0.1.0}
39 %{?with_dirmngr:BuildRequires:  openldap-devel >= 2.4.6}
40 BuildRequires:  pkgconfig
41 BuildRequires:  readline-devel
42 BuildRequires:  rpmbuild(macros) >= 1.177
43 BuildRequires:  texinfo
44 BuildRequires:  zlib-devel
45 Requires:       gnupg2-common = %{version}-%{release}
46 Requires:       sqlite3 >= 3.7
47 %if %{with default_gpg}
48 Obsoletes:      gnupg < 2
49 Provides:       gnupg = %{version}-%{release}
50 %endif
51 Suggests:       gnupg-agent
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         pkglibexecdir   %{_libexecdir}/gnupg2
55
56 %description
57 GnuPG is GNU's tool for secure communication and data storage. It can
58 be used to encrypt data and to create digital signatures. It includes
59 an advanced key management facility and is compliant with the proposed
60 OpenPGP Internet standard as described in RFC2440.
61
62 This is enhanced version.
63
64 %description -l pl.UTF-8
65 GnuPG (GNU Privacy Guard) jest narzędziem do bezpiecznej komunikacji i
66 bezpiecznego przechowywania danych. Może być używany do szyfrowania
67 oraz podpisywania danych. Umożliwia zaawansowane zarządzanie kluczami
68 i spełnia normy zdefiniowane w standardzie OpenPGP, który jest opisany
69 w RFC2440.
70
71 To jest wersja rozszerzona.
72
73 %package common
74 Summary:        GnuPG - common files
75 Summary(pl.UTF-8):      GnuPG - pliki wspólne
76 Group:          Applications/File
77 Requires:       libassuan >= 1:2.5.0
78 Requires:       libgcrypt >= 1.7.0
79 Requires:       libgpg-error >= 1.24
80 Requires:       libksba >= 1.3.4
81 Requires:       npth >= 1.2
82 Obsoletes:      gnupg2-plugin-keys_curl
83 Obsoletes:      gnupg2-plugin-keys_finger
84 Obsoletes:      gnupg2-plugin-keys_hkp
85 Obsoletes:      gnupg2-plugin-keys_kdns
86 Obsoletes:      gnupg2-plugin-keys_ldap
87 Conflicts:      gnupg < 1.4.18-2
88 Conflicts:      gnupg-agent < 1.9.14-2
89
90 %description common
91 Common files used by tools from GnuPG project.
92
93 %description common -l pl.UTF-8
94 Pliki wspólne używane przez różne narzędzia z projektu GnuPG.
95
96 %package plugin-keys_curl
97 Summary:        GnuPG 2 plugin for allow talk to a HTTP/FTP keyserver
98 Summary(pl.UTF-8):      Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy HTTP/FTP
99 Group:          Applications/File
100 Requires:       %{name}-common = %{version}-%{release}
101 Requires:       curl-libs >= 7.10
102
103 %description plugin-keys_curl
104 GnuPG 2 plugin for allow talk to a HTTP(S)/FTP(S) keyserver.
105
106 %description plugin-keys_curl -l pl.UTF-8
107 Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy
108 HTTP(S)/FTP(S).
109
110 %package plugin-keys_finger
111 Summary:        GnuPG 2 plugin for allow talk to a FINGER keyserver
112 Summary(pl.UTF-8):      Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy FINGER
113 Group:          Applications/File
114 Requires:       %{name}-common = %{version}-%{release}
115
116 %description plugin-keys_finger
117 GnuPG 2 plugin for allow talk to a FINGER keyserver.
118
119 %description plugin-keys_finger -l pl.UTF-8
120 Wtyczka 2 GnuPG pozwalająca komunikować się z serwerem kluczy FINGER.
121
122 %package plugin-keys_hkp
123 Summary:        GnuPG 2 plugin for allow talk to a HKP keyserver
124 Summary(pl.UTF-8):      Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy HKP
125 Group:          Applications/File
126 Requires:       %{name}-common = %{version}-%{release}
127
128 %description plugin-keys_hkp
129 GnuPG 2 plugin for allow talk to a HKP keyserver.
130
131 %description plugin-keys_hkp -l pl.UTF-8
132 Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy HKP.
133
134 %package plugin-keys_kdns
135 Summary:        GnuPG 2 plugin for allow talk to a KDNS keyserver
136 Summary(pl.UTF-8):      Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy KDNS
137 Group:          Applications/File
138 Requires:       %{name}-common = %{version}-%{release}
139
140 %description plugin-keys_kdns
141 GnuPG 2 plugin for allow talk to a KDNS keyserver.
142
143 %description plugin-keys_kdns -l pl.UTF-8
144 Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy KDNS.
145
146 %package plugin-keys_ldap
147 Summary:        GnuPG 2 plugin for allow talk to a LDAP keyserver
148 Summary(pl.UTF-8):      Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy LDAP
149 Group:          Applications/File
150 Requires:       %{name}-common = %{version}-%{release}
151
152 %description plugin-keys_ldap
153 GnuPG 2 plugin for allow talk to a LDAP keyserver.
154
155 %description plugin-keys_ldap -l pl.UTF-8
156 Wtyczka GnuPG 2 pozwalająca komunikować się z serwerem kluczy LDAP.
157
158 %package -n gnupg-agent
159 Summary:        GnuPG extension - agent
160 Summary(pl.UTF-8):      Rozszerzenie GnuPG - agent
161 Group:          Applications/File
162 Requires:       %{name}-common = %{version}-%{release}
163 Requires:       pinentry >= 0.7.5-2
164 Obsoletes:      newpg
165
166 %description -n gnupg-agent
167 GnuPG extension - agent.
168
169 %description -n gnupg-agent -l pl.UTF-8
170 Rozszerzenie GnuPG - agent.
171
172 %package -n gnupg-agent-profile_d
173 Summary:        gnupg-agent start script for text mode
174 Summary(pl.UTF-8):      Skrypt startowy gnupg-agenta dla trybu tekstowego
175 Group:          Applications/File
176 Requires:       gnupg-agent = %{version}-%{release}
177
178 %description -n gnupg-agent-profile_d
179 gnupg-agent start script for text mode.
180
181 %description -n gnupg-agent-profile_d -l pl.UTF-8
182 Skrypt startowy gnupg-agenta dla trybu tekstowego.
183
184 %package -n gnupg-agent-xinitrc
185 Summary:        gnupg-agent start script for X-Window mode
186 Summary(pl.UTF-8):      Skrypt startowy gnupg-agenta dla trybu X-Window
187 Group:          Applications/File
188 Requires:       gnupg-agent = %{version}-%{release}
189 Requires:       xinitrc
190
191 %description -n gnupg-agent-xinitrc
192 gnupg-agent start script for X-Window mode.
193
194 %description -n gnupg-agent-xinitrc -l pl.UTF-8
195 Skrypt startowy gnupg-agenta dla trybu X-Window.
196
197 %package -n gnupg-smime
198 Summary:        GnuPG extension - S/MIME support
199 Summary(pl.UTF-8):      Rozszerzenie GnuPG - obsługa S/MIME
200 Group:          Applications/File
201 Requires:       %{name}-common = %{version}-%{release}
202 Conflicts:      gnupg-agent < 1.9.14-2
203
204 %description -n gnupg-smime
205 GnuPG extension - S/MIME support.
206
207 %description -n gnupg-smime -l pl.UTF-8
208 Rozszerzenie GnuPG - obsługa S/MIME.
209
210 %package -n dirmngr
211 Summary:        X509/LDAP certificate and revocation list client
212 Summary(pl.UTF-8):      Klient certyfikatów i list anulujących X509/LDAP
213 Group:          Applications
214 Requires:       %{name}-common = %{version}-%{release}
215
216 %description -n dirmngr
217 DirMngr is a client for managing and downloading certificate
218 revocation lists (CRLs) for X509 certificates and for downloading the
219 certificates themselves. DirMngr is usually invoked by gpgsm and in
220 general not used directly.
221
222 %description -n dirmngr -l pl.UTF-8
223 DirMngr to klient do zarządzania i pobierania list anulujących
224 certyfikaty (CRLs - certificate revocation lists) dla certyfikatów
225 X509 oraz do pobierania samych certyfikatów. DirMngr jest zwykle
226 wywoływany przez gpgsm i nie używany bezpośrednio.
227
228 %prep
229 %setup -q -n gnupg-%{version}
230 %patch0 -p1
231 %patch1 -p1
232 %{!?with_tests:%patch2 -p1}
233 %patch3 -p1
234 %patch4 -p1
235
236 %{__rm} po/stamp-po
237
238 %build
239 %{__gettextize}
240 %{__aclocal} -I m4 -I gl/m4
241 %{__autoconf}
242 %{__autoheader}
243 %{__automake}
244 %configure \
245         --libexecdir=%{pkglibexecdir} \
246         %{!?with_dirmngr:--disable-dirmngr} \
247         --enable-g13 \
248         %{!?with_default_gpg:--enable-gpg-is-gpg2} \
249         %{?with_gnutls:--disable-ntbtls} \
250         %{?with_selinux:--enable-selinux-support} \
251         --enable-symcryptrun \
252         --enable-wks-tools \
253         --with-capabilities \
254         --with-pinentry-pgm=%{_bindir}/pinentry \
255         --with-mailprog=/usr/lib/sendmail
256
257 %{__make}
258
259 %install
260 rm -rf $RPM_BUILD_ROOT
261
262 %{__make} install \
263         DESTDIR=$RPM_BUILD_ROOT \
264         pkglibdir=%{_libexecdir}
265
266 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/gnupg-agent.sh
267 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gnupg-agent.sh
268
269 %if %{without dirmngr}
270 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{man1/dirmngr-client.1,man8/dirmngr.8}
271 %endif
272
273 %{__rm} -f $RPM_BUILD_ROOT%{_datadir}/info/dir
274
275 # files useful for users packaged as %doc
276 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gnupg
277
278 %find_lang gnupg2
279 rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
280
281 %clean
282 rm -rf $RPM_BUILD_ROOT
283
284 %post   -p /sbin/postshell
285 -/usr/sbin/fix-info-dir -c %{_infodir}
286
287 %postun -p /sbin/postshell
288 -/usr/sbin/fix-info-dir -c %{_infodir}
289
290 %triggerpostun -n gnupg-agent -- gnupg-agent < 1.9.16-2
291 %banner gnupg-agent-1.9.16-2 << EOF
292 Scripts for starting gnupg-agent have been moved to separate
293 subpackages: gnupg-agent-profile_d and gnupg-agent-xinitrc.
294 EOF
295
296 %files
297 %defattr(644,root,root,755)
298 %if %{with default_gpg}
299 %attr(755,root,root) %{_bindir}/gpg
300 %attr(755,root,root) %{_bindir}/gpgv
301 %{_mandir}/man1/gpg.1*
302 %{_mandir}/man1/gpgv.1*
303 %else
304 %attr(755,root,root) %{_bindir}/gpg2
305 %attr(755,root,root) %{_bindir}/gpgv2
306 %{_mandir}/man1/gpg2.1*
307 %{_mandir}/man1/gpgv2.1*
308 %endif
309
310 %files common -f gnupg2.lang
311 %defattr(644,root,root,755)
312 %doc AUTHORS ChangeLog ChangeLog-2011 NEWS README THANKS TODO
313 %attr(755,root,root) %{_bindir}/gpg-connect-agent
314 %attr(755,root,root) %{_bindir}/gpgconf
315 %attr(755,root,root) %{_bindir}/gpgkey2ssh
316 %attr(755,root,root) %{_bindir}/gpgparsemail
317 %attr(755,root,root) %{_bindir}/kbxutil
318 %attr(755,root,root) %{_bindir}/watchgnupg
319 %attr(755,root,root) %{_sbindir}/addgnupghome
320 %attr(755,root,root) %{_sbindir}/applygnupgdefaults
321 %attr(755,root,root) %{_sbindir}/g13-syshelp
322 %dir %{pkglibexecdir}
323
324 %{_datadir}/gnupg
325 %{_mandir}/man1/gpg-connect-agent.1*
326 %{_mandir}/man1/gpgconf.1*
327 %{_mandir}/man1/gpgparsemail.1*
328 %{_mandir}/man1/gpgtar.1*
329 %{_mandir}/man1/watchgnupg.1*
330 %{_mandir}/man8/addgnupghome.8*
331 %{_mandir}/man8/applygnupgdefaults.8*
332 %{_infodir}/gnupg.info*
333
334 %files plugin-keys_curl
335 %defattr(644,root,root,755)
336 %attr(755,root,root) %{_libexecdir}/gpg2keys_curl
337
338 %files plugin-keys_finger
339 %defattr(644,root,root,755)
340 %attr(755,root,root) %{_libexecdir}/gpg2keys_finger
341
342 %files plugin-keys_hkp
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_libexecdir}/gpg2keys_hkp
345
346 %files plugin-keys_kdns
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libexecdir}/gpg2keys_kdns
349
350 %files plugin-keys_ldap
351 %defattr(644,root,root,755)
352 %attr(755,root,root) %{_libexecdir}/gpg2keys_ldap
353
354 %files -n gnupg-smime
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_bindir}/gpgsm
357 %attr(755,root,root) %{_bindir}/gpgsm-gencert.sh
358 %{_mandir}/man1/gpgsm.1*
359 %{_mandir}/man1/gpgsm-gencert.sh.1*
360
361 %files -n gnupg-agent
362 %defattr(644,root,root,755)
363 %attr(755,root,root) %{_bindir}/gpg-agent
364 %attr(755,root,root) %{_bindir}/gpg-wks-server
365 %attr(755,root,root) %{_bindir}/symcryptrun
366 %attr(755,root,root) %{pkglibexecdir}/gpg-check-pattern
367 %attr(755,root,root) %{pkglibexecdir}/gpg-protect-tool
368 %attr(755,root,root) %{pkglibexecdir}/gpg-preset-passphrase
369 %attr(755,root,root) %{pkglibexecdir}/gpg-wks-client
370 %attr(755,root,root) %{pkglibexecdir}/scdaemon
371 %{_mandir}/man1/gpg-agent.1*
372 %{_mandir}/man1/gpg-preset-passphrase.1*
373 %{_mandir}/man1/gpg-wks-client.1*
374 %{_mandir}/man1/gpg-wks-server.1*
375 %{_mandir}/man1/scdaemon.1*
376 %{_mandir}/man1/symcryptrun.1*
377
378 %files -n gnupg-agent-profile_d
379 %defattr(644,root,root,755)
380 %attr(755,root,root) /etc/profile.d/gnupg-agent.sh
381
382 %files -n gnupg-agent-xinitrc
383 %defattr(644,root,root,755)
384 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/gnupg-agent.sh
385
386 %if %{with dirmngr}
387 %files -n dirmngr
388 %defattr(644,root,root,755)
389 %attr(755,root,root) %{_bindir}/dirmngr
390 %attr(755,root,root) %{_bindir}/dirmngr-client
391 %attr(755,root,root) %{pkglibexecdir}/dirmngr_ldap
392 %{_mandir}/man1/dirmngr-client.1*
393 %{_mandir}/man8/dirmngr.8*
394 %endif
This page took 0.073878 seconds and 4 git commands to generate.