]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
- BR(pth) fixed.
[packages/gnupg2.git] / gnupg2.spec
1 #
2 # Conditional build:
3 %bcond_without  xinitrc # don't use xinitrc's directory
4 %bcond_without  pth     # without pth-based based version of gnupg
5 #
6 Summary:        GNU Privacy Guard - tool for secure communication and data storage - development version
7 Summary(pl):    GnuPG - narzêdzie do bezpiecznej komunikacji i bezpiecznego przechowywania danych - wersja rozwojowa
8 Name:           gnupg2
9 Version:        1.9.15
10 Release:        1
11 License:        GPL
12 Group:          Applications/File
13 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.gz
14 # Source0-md5:  c1955d88280ff6e847f82f37b9a9a008
15 Source1:        gnupg-agent.sh
16 Patch0:         %{name}-info.patch
17 Icon:           gnupg.gif
18 URL:            http://www.gnupg.org/
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel >= 0.12.1
21 BuildRequires:  libassuan-devel >= 1:0.6.9
22 BuildRequires:  libgcrypt-devel >= 1.1.94
23 BuildRequires:  libgpg-error-devel >= 0.6
24 BuildRequires:  libksba-devel >= 0.9.7
25 BuildRequires:  pcsc-lite-devel
26 BuildRequires:  opensc-devel >= 0.8.0
27 %{?with_pth:BuildRequires:      pth-devel >= 2.0.0}
28 BuildRequires:  texinfo
29 BuildRequires:  zlib-devel
30 Requires:       gnupg2-common = %{version}-%{release}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _libexecdir     %{_libdir}/gnupg2
34
35 %description
36 GnuPG is GNU's tool for secure communication and data storage. It can
37 be used to encrypt data and to create digital signatures. It includes
38 an advanced key management facility and is compliant with the proposed
39 OpenPGP Internet standard as described in RFC2440.
40
41 This is development version. Don't use it with production keys.
42
43 %description -l pl
44 GnuPG (GNU Privacy Guard) jest narzêdziem do bezpiecznej komunikacji i
45 bezpiecznego przechowywania danych. Mo¿e byæ u¿ywany do szyfrowania
46 oraz podpisywania danych. Umo¿liwia zaawansowane zarz±dzanie kluczami
47 i spe³nia normy zdefiniowane w standardzie OpenPGP, który jest opisany
48 w RFC2440.
49
50 Wersja rozwojowa. Nie do u¿ytku z kluczami produkcyjnymi.
51
52 %package common
53 Summary:        GnuPG - common files
54 Summary(pl):    GnuPG - pliki wspólne 
55 Group:          Applications/File
56 Conflicts:      gnupg-agent < 1.9.14-2
57
58 %description common
59 Common files used by tools from GnuPG project.
60
61 %description common -l pl
62 Pliki wspólne u¿ywane przez ró¿ne narzêdzia z projektu GnuPG.
63
64 %package -n gnupg-agent
65 Summary:        GnuPG extension - agent
66 Summary(pl):    Rozszerzenie GnuPG - agent
67 Group:          Applications/File
68 Requires:       gnupg2-common = %{version}-%{release}
69 Requires:       pinentry
70 %{?with_xinitrc:Requires: xinitrc}
71 Obsoletes:      newpg
72
73 %description -n gnupg-agent
74 GnuPG extension - agent.
75
76 %description -n gnupg-agent -l pl
77 Rozszerzenie GnuPG - agent.
78
79 %package -n gnupg-smime
80 Summary:        GnuPG extension - S/MIME support
81 Summary(pl):    Rozszerzenie GnuPG - obs³uga S/MIME
82 Group:          Applications/File
83 Requires:       gnupg2-common = %{version}-%{release}
84 Conflicts:      gnupg-agent < 1.9.14-2
85
86 %description -n gnupg-smime
87 GnuPG extension - S/MIME support.
88
89 %description -n gnupg-smime -l pl
90 Rozszerzenie GnuPG - obs³uga S/MIME.
91
92 %prep
93 %setup -q -n gnupg-%{version}
94 %patch0 -p1
95
96 %build
97 cp -f /usr/share/automake/config.* scripts
98 %configure \
99         --with-capabilities \
100         %{!?with_pth:--disable-threads} \
101 %ifarch sparc sparc64
102         --disable-m-guard \
103 %else
104         --enable-m-guard \
105 %endif
106         --without-included-gettext \
107         --disable-m-debug \
108         --with-mailprog=/usr/lib/sendmail
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT/etc/profile.d
115 %{?with_xinitrc:install -d $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT \
119         pkglibdir=%{_libexecdir}
120
121 install %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/gnupg-agent.sh
122 %{?with_xinitrc:ln -sf /etc/profile.d/gnupg-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gnupg-agent.sh}
123
124 mv ChangeLog main-ChangeLog || :
125 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
126
127 %find_lang gnupg2
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
134
135 %postun
136 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
137
138 %files 
139 %defattr(644,root,root,755)
140 %doc g10-ChangeLog g10/options.skel
141 %attr(755,root,root) %{_bindir}/gpg2
142 %attr(755,root,root) %{_bindir}/gpgv2
143
144 %files common -f gnupg2.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS main-ChangeLog NEWS README THANKS TODO 
147 %doc intl-ChangeLog jnlib-ChangeLog m4-ChangeLog po-ChangeLog scripts-ChangeLog common-ChangeLog kbx-ChangeLog tools-ChangeLog doc-ChangeLog
148 %attr(755,root,root) %{_bindir}/gpgconf
149 %attr(755,root,root) %{_bindir}/watchgnupg
150 %attr(755,root,root) %{_sbindir}/addgnupghome
151 %attr(755,root,root) %{_bindir}/kbxutil
152 %{_datadir}/gnupg
153 %{_infodir}/*info*
154
155 %files -n gnupg-smime
156 %defattr(644,root,root,755)
157 %doc sm-ChangeLog
158 %attr(755,root,root) %{_bindir}/gpgsm
159 %attr(755,root,root) %{_bindir}/gpgsm-gencert.sh
160
161 %files -n gnupg-agent
162 %defattr(644,root,root,755)
163 %doc agent-ChangeLog scd-ChangeLog
164 %attr(755,root,root) %{_bindir}/gpg-agent
165 %attr(755,root,root) %{_bindir}/sc-copykeys
166 %attr(755,root,root) %{_bindir}/scdaemon
167 %attr(755,root,root) %{_libexecdir}/gpg-protect-tool
168 %attr(755,root,root) %{_libexecdir}/gpg-preset-passphrase
169 %attr(755,root,root) %{_libexecdir}/pcsc-wrapper
170 %attr(755,root,root) /etc/profile.d/gnupg-agent.sh
171 %{?with_xinitrc:%attr(755,root,root) /etc/X11/xinit/xinitrc.d/gnupg-agent.sh}
This page took 0.09411 seconds and 4 git commands to generate.