]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
- kill Icon: field (support for these is obsolete says jbj)
[packages/gnupg2.git] / gnupg2.spec
1 #
2 # Conditional build:
3 %bcond_without  pth     # without pth-based based version of gnupg
4 #
5 Summary:        GNU Privacy Guard - tool for secure communication and data storage - development version
6 Summary(pl):    GnuPG - narzêdzie do bezpiecznej komunikacji i bezpiecznego przechowywania danych - wersja rozwojowa
7 Name:           gnupg2
8 Version:        1.9.20
9 Release:        1
10 License:        GPL
11 Group:          Applications/File
12 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.bz2
13 # Source0-md5:  93899203fc0530f03e146d49b65c1e28
14 Source1:        gnupg-agent.sh
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-pth.patch
17 URL:            http://www.gnupg.org/
18 BuildRequires:  automake
19 BuildRequires:  gettext-devel >= 0.14.1
20 BuildRequires:  libassuan-devel >= 1:0.6.10
21 BuildRequires:  libgcrypt-devel >= 1.1.94
22 BuildRequires:  libgpg-error-devel >= 1.0
23 BuildRequires:  libksba-devel >= 0.9.13
24 BuildRequires:  libusb-devel
25 BuildRequires:  pcsc-lite-devel
26 %{?with_pth:BuildRequires:      pth-devel >= 2.0.0}
27 BuildRequires:  rpmbuild(macros) >= 1.177
28 BuildRequires:  texinfo
29 BuildRequires:  zlib-devel
30 Requires:       gnupg2-common = %{version}-%{release}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _libexecdir     %{_libdir}/gnupg2
34
35 %description
36 GnuPG is GNU's tool for secure communication and data storage. It can
37 be used to encrypt data and to create digital signatures. It includes
38 an advanced key management facility and is compliant with the proposed
39 OpenPGP Internet standard as described in RFC2440.
40
41 This is development version. Don't use it with production keys.
42
43 %description -l pl
44 GnuPG (GNU Privacy Guard) jest narzêdziem do bezpiecznej komunikacji i
45 bezpiecznego przechowywania danych. Mo¿e byæ u¿ywany do szyfrowania
46 oraz podpisywania danych. Umo¿liwia zaawansowane zarz±dzanie kluczami
47 i spe³nia normy zdefiniowane w standardzie OpenPGP, który jest opisany
48 w RFC2440.
49
50 Wersja rozwojowa. Nie do u¿ytku z kluczami produkcyjnymi.
51
52 %package common
53 Summary:        GnuPG - common files
54 Summary(pl):    GnuPG - pliki wspólne 
55 Group:          Applications/File
56 Requires:       libgpg-error >= 1.0
57 Conflicts:      gnupg-agent < 1.9.14-2
58
59 %description common
60 Common files used by tools from GnuPG project.
61
62 %description common -l pl
63 Pliki wspólne u¿ywane przez ró¿ne narzêdzia z projektu GnuPG.
64
65 %package -n gnupg-agent
66 Summary:        GnuPG extension - agent
67 Summary(pl):    Rozszerzenie GnuPG - agent
68 Group:          Applications/File
69 Requires:       gnupg2-common = %{version}-%{release}
70 Requires:       pinentry
71 Obsoletes:      newpg
72
73 %description -n gnupg-agent
74 GnuPG extension - agent.
75
76 %description -n gnupg-agent -l pl
77 Rozszerzenie GnuPG - agent.
78
79 %package -n gnupg-agent-profile_d
80 Summary:        gnupg-agent start script for text mode
81 Summary(pl):    Skrypt startowy gnupg-agenta dla trybu tekstowego
82 Group:          Applications/File
83 Requires:       gnupg-agent = %{version}-%{release}
84
85 %description -n gnupg-agent-profile_d
86 gnupg-agent start script for text mode.
87
88 %description -n gnupg-agent-profile_d -l pl
89 Skrypt startowy gnupg-agenta dla trybu tekstowego.
90
91 %package -n gnupg-agent-xinitrc
92 Summary:        gnupg-agent start script for X-Window mode
93 Summary(pl):    Skrypt startowy gnupg-agenta dla trybu X-Window
94 Group:          Applications/File
95 Requires:       gnupg-agent = %{version}-%{release}
96 Requires:       xinitrc
97
98 %description -n gnupg-agent-xinitrc
99 gnupg-agent start script for X-Window mode.
100
101 %description -n gnupg-agent-xinitrc -l pl
102 Skrypt startowy gnupg-agenta dla trybu X-Window.
103
104 %package -n gnupg-smime
105 Summary:        GnuPG extension - S/MIME support
106 Summary(pl):    Rozszerzenie GnuPG - obs³uga S/MIME
107 Group:          Applications/File
108 Requires:       gnupg2-common = %{version}-%{release}
109 Conflicts:      gnupg-agent < 1.9.14-2
110
111 %description -n gnupg-smime
112 GnuPG extension - S/MIME support.
113
114 %description -n gnupg-smime -l pl
115 Rozszerzenie GnuPG - obs³uga S/MIME.
116
117 %prep
118 %setup -q -n gnupg-%{version}
119 %patch0 -p1
120 %patch1 -p1
121
122 %build
123 cp -f /usr/share/automake/config.* scripts
124 %configure \
125         --with-capabilities \
126         %{!?with_pth:--disable-threads} \
127         --enable-gpg \
128 %ifarch sparc sparc64
129         --disable-m-guard \
130 %else
131         --enable-m-guard \
132 %endif
133         --without-included-gettext \
134         --disable-m-debug \
135         --with-mailprog=/usr/lib/sendmail
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         pkglibdir=%{_libexecdir}
145
146 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/gnupg-agent.sh
147 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gnupg-agent.sh
148
149 mv ChangeLog main-ChangeLog || :
150 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
151
152 %find_lang gnupg2
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
159
160 %postun
161 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
162
163 %triggerpostun -n gnupg-agent -- gnupg-agent < 1.9.16-2
164 %banner gnupg-agent-1.9.16-2 << EOF
165 Scripts for starting gnupg-agent have been moved to separate
166 subpackages: gnupg-agent-profile_d and gnupg-agent-xinitrc.
167 EOF 
168
169 %files 
170 %defattr(644,root,root,755)
171 %doc g10-ChangeLog g10/options.skel
172 %attr(755,root,root) %{_bindir}/gpg2
173 %attr(755,root,root) %{_bindir}/gpgv2
174
175 %files common -f gnupg2.lang
176 %defattr(644,root,root,755)
177 %doc AUTHORS main-ChangeLog NEWS README THANKS TODO 
178 %doc intl-ChangeLog jnlib-ChangeLog m4-ChangeLog po-ChangeLog scripts-ChangeLog common-ChangeLog kbx-ChangeLog tools-ChangeLog doc-ChangeLog
179 %attr(755,root,root) %{_bindir}/gpg-connect-agent
180 %attr(755,root,root) %{_bindir}/gpgconf
181 %attr(755,root,root) %{_bindir}/gpgkey2ssh
182 %attr(755,root,root) %{_bindir}/gpgparsemail
183 %attr(755,root,root) %{_bindir}/watchgnupg
184 %attr(755,root,root) %{_sbindir}/addgnupghome
185 %attr(755,root,root) %{_bindir}/kbxutil
186 %{_datadir}/gnupg
187 %{_infodir}/*info*
188
189 %files -n gnupg-smime
190 %defattr(644,root,root,755)
191 %doc sm-ChangeLog
192 %attr(755,root,root) %{_bindir}/gpgsm
193 %attr(755,root,root) %{_bindir}/gpgsm-gencert.sh
194
195 %files -n gnupg-agent
196 %defattr(644,root,root,755)
197 %doc agent-ChangeLog scd-ChangeLog
198 %attr(755,root,root) %{_bindir}/gpg-agent
199 %attr(755,root,root) %{_bindir}/scdaemon
200 %attr(755,root,root) %{_libexecdir}/gpg-protect-tool
201 %attr(755,root,root) %{_libexecdir}/gpg-preset-passphrase
202 %attr(755,root,root) %{_libexecdir}/pcsc-wrapper
203
204 %files -n gnupg-agent-profile_d
205 %defattr(644,root,root,755)
206 %attr(755,root,root) /etc/profile.d/gnupg-agent.sh
207
208 %files -n gnupg-agent-xinitrc
209 %defattr(644,root,root,755)
210 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/gnupg-agent.sh
This page took 0.06509 seconds and 3 git commands to generate.