]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
95e3368ea454128aac717b814dee187611b34523
[packages/gnupg2.git] / gnupg2.spec
1 #
2 # Conditional build:
3 %bcond_without  xinitrc # don't use xinitrc's directory
4 %bcond_without  pth     # without pth-based based version of gnupg
5 #
6 Summary:        GNU Privacy Guard - tool for secure communication and data storage - development version
7 Summary(pl):    GnuPG - narzêdzie do bezpiecznej komunikacji i bezpiecznego przechowywania danych - wersja rozwojowa
8 Name:           gnupg2
9 Version:        1.9.16
10 Release:        1
11 License:        GPL
12 Group:          Applications/File
13 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.bz2
14 # Source0-md5:  1282755dce9cf4a84e904ca0191017a3
15 Source1:        gnupg-agent.sh
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-pth.patch
18 Icon:           gnupg.gif
19 URL:            http://www.gnupg.org/
20 BuildRequires:  automake
21 BuildRequires:  gettext-devel >= 0.12.1
22 BuildRequires:  libassuan-devel >= 1:0.6.9
23 BuildRequires:  libgcrypt-devel >= 1.1.94
24 BuildRequires:  libgpg-error-devel >= 1.0
25 BuildRequires:  libksba-devel >= 0.9.11
26 BuildRequires:  pcsc-lite-devel
27 BuildRequires:  opensc-devel >= 0.8.0
28 %{?with_pth:BuildRequires:      pth-devel >= 2.0.0}
29 BuildRequires:  texinfo
30 BuildRequires:  zlib-devel
31 Requires:       gnupg2-common = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _libexecdir     %{_libdir}/gnupg2
35
36 %description
37 GnuPG is GNU's tool for secure communication and data storage. It can
38 be used to encrypt data and to create digital signatures. It includes
39 an advanced key management facility and is compliant with the proposed
40 OpenPGP Internet standard as described in RFC2440.
41
42 This is development version. Don't use it with production keys.
43
44 %description -l pl
45 GnuPG (GNU Privacy Guard) jest narzêdziem do bezpiecznej komunikacji i
46 bezpiecznego przechowywania danych. Mo¿e byæ u¿ywany do szyfrowania
47 oraz podpisywania danych. Umo¿liwia zaawansowane zarz±dzanie kluczami
48 i spe³nia normy zdefiniowane w standardzie OpenPGP, który jest opisany
49 w RFC2440.
50
51 Wersja rozwojowa. Nie do u¿ytku z kluczami produkcyjnymi.
52
53 %package common
54 Summary:        GnuPG - common files
55 Summary(pl):    GnuPG - pliki wspólne 
56 Group:          Applications/File
57 Requires:       libgpg-error >= 1.0
58 Conflicts:      gnupg-agent < 1.9.14-2
59
60 %description common
61 Common files used by tools from GnuPG project.
62
63 %description common -l pl
64 Pliki wspólne u¿ywane przez ró¿ne narzêdzia z projektu GnuPG.
65
66 %package -n gnupg-agent
67 Summary:        GnuPG extension - agent
68 Summary(pl):    Rozszerzenie GnuPG - agent
69 Group:          Applications/File
70 Requires:       gnupg2-common = %{version}-%{release}
71 Requires:       pinentry
72 %{?with_xinitrc:Requires: xinitrc}
73 Obsoletes:      newpg
74
75 %description -n gnupg-agent
76 GnuPG extension - agent.
77
78 %description -n gnupg-agent -l pl
79 Rozszerzenie GnuPG - agent.
80
81 %package -n gnupg-smime
82 Summary:        GnuPG extension - S/MIME support
83 Summary(pl):    Rozszerzenie GnuPG - obs³uga S/MIME
84 Group:          Applications/File
85 Requires:       gnupg2-common = %{version}-%{release}
86 Conflicts:      gnupg-agent < 1.9.14-2
87
88 %description -n gnupg-smime
89 GnuPG extension - S/MIME support.
90
91 %description -n gnupg-smime -l pl
92 Rozszerzenie GnuPG - obs³uga S/MIME.
93
94 %prep
95 %setup -q -n gnupg-%{version}
96 %patch0 -p1
97 %patch1 -p1
98
99 %build
100 cp -f /usr/share/automake/config.* scripts
101 %configure \
102         --with-capabilities \
103         %{!?with_pth:--disable-threads} \
104         --enable-gpg \
105 %ifarch sparc sparc64
106         --disable-m-guard \
107 %else
108         --enable-m-guard \
109 %endif
110         --without-included-gettext \
111         --disable-m-debug \
112         --with-mailprog=/usr/lib/sendmail
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT/etc/profile.d
119 %{?with_xinitrc:install -d $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         pkglibdir=%{_libexecdir}
124
125 install %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/gnupg-agent.sh
126 %{?with_xinitrc:ln -sf /etc/profile.d/gnupg-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gnupg-agent.sh}
127
128 mv ChangeLog main-ChangeLog || :
129 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
130
131 %find_lang gnupg2
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
138
139 %postun
140 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
141
142 %files 
143 %defattr(644,root,root,755)
144 %doc g10-ChangeLog g10/options.skel
145 %attr(755,root,root) %{_bindir}/gpg2
146 %attr(755,root,root) %{_bindir}/gpgv2
147
148 %files common -f gnupg2.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS main-ChangeLog NEWS README THANKS TODO 
151 %doc intl-ChangeLog jnlib-ChangeLog m4-ChangeLog po-ChangeLog scripts-ChangeLog common-ChangeLog kbx-ChangeLog tools-ChangeLog doc-ChangeLog
152 %attr(755,root,root) %{_bindir}/gpg-connect-agent
153 %attr(755,root,root) %{_bindir}/gpgconf
154 %attr(755,root,root) %{_bindir}/watchgnupg
155 %attr(755,root,root) %{_sbindir}/addgnupghome
156 %attr(755,root,root) %{_bindir}/kbxutil
157 %{_datadir}/gnupg
158 %{_infodir}/*info*
159
160 %files -n gnupg-smime
161 %defattr(644,root,root,755)
162 %doc sm-ChangeLog
163 %attr(755,root,root) %{_bindir}/gpgsm
164 %attr(755,root,root) %{_bindir}/gpgsm-gencert.sh
165
166 %files -n gnupg-agent
167 %defattr(644,root,root,755)
168 %doc agent-ChangeLog scd-ChangeLog
169 %attr(755,root,root) %{_bindir}/gpg-agent
170 %attr(755,root,root) %{_bindir}/sc-copykeys
171 %attr(755,root,root) %{_bindir}/scdaemon
172 %attr(755,root,root) %{_libexecdir}/gpg-protect-tool
173 %attr(755,root,root) %{_libexecdir}/gpg-preset-passphrase
174 %attr(755,root,root) %{_libexecdir}/pcsc-wrapper
175 %attr(755,root,root) /etc/profile.d/gnupg-agent.sh
176 %{?with_xinitrc:%attr(755,root,root) /etc/X11/xinit/xinitrc.d/gnupg-agent.sh}
This page took 0.046453 seconds and 3 git commands to generate.