]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
6aeae71b1e1d933a63aa0f0b284329d054ee9f62
[packages/gnupg2.git] / gnupg2.spec
1 #
2 # Conditional build:
3 %bcond_without  xinitrc # don't use xinitrc's directory
4 %bcond_without  pth     # without pth-based based version of gnupg
5 #
6 Summary:        GNU Privacy Guard - tool for secure communication and data storage - development version
7 Summary(pl):    GnuPG - narzêdzie do bezpiecznej komunikacji i bezpiecznego przechowywania danych - wersja rozwojowa
8 Name:           gnupg2
9 Version:        1.9.15
10 Release:        1
11 License:        GPL
12 Group:          Applications/File
13 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.gz
14 # Source0-md5:  c1955d88280ff6e847f82f37b9a9a008
15 Source1:        gnupg-agent.sh
16 Patch0:         %{name}-info.patch
17 Icon:           gnupg.gif
18 URL:            http://www.gnupg.org/
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel >= 0.12.1
21 BuildRequires:  libassuan-devel >= 1:0.6.9
22 BuildRequires:  libgcrypt-devel >= 1.1.94
23 BuildRequires:  libgpg-error-devel >= 0.6
24 BuildRequires:  libksba-devel >= 0.9.7
25 BuildRequires:  pcsc-lite-devel
26 BuildRequires:  opensc-devel >= 0.8.0
27 %{?with_pth:BuildRequires:      pth-devel >= 2.0.0}
28 BuildRequires:  texinfo
29 BuildRequires:  zlib-devel
30 Requires:       gnupg2-common = %{version}-%{release}
31 Provides:       gnupg = %{version}-%{release}
32 Obsoletes:      gnupg
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _libexecdir     %{_libdir}/gnupg2
36
37 %description
38 GnuPG is GNU's tool for secure communication and data storage. It can
39 be used to encrypt data and to create digital signatures. It includes
40 an advanced key management facility and is compliant with the proposed
41 OpenPGP Internet standard as described in RFC2440.
42
43 This is development version. Don't use it with production keys.
44
45 %description -l pl
46 GnuPG (GNU Privacy Guard) jest narzêdziem do bezpiecznej komunikacji i
47 bezpiecznego przechowywania danych. Mo¿e byæ u¿ywany do szyfrowania
48 oraz podpisywania danych. Umo¿liwia zaawansowane zarz±dzanie kluczami
49 i spe³nia normy zdefiniowane w standardzie OpenPGP, który jest opisany
50 w RFC2440.
51
52 Wersja rozwojowa. Nie do u¿ytku z kluczami produkcyjnymi.
53
54 %package common
55 Summary:        GnuPG - common files
56 Summary(pl):    GnuPG - pliki wspólne 
57 Group:          Applications/File
58 Conflicts:      gnupg-agent < 1.9.14-2
59
60 %description common
61 Common files used by tools from GnuPG project.
62
63 %description common -l pl
64 Pliki wspólne u¿ywane przez ró¿ne narzêdzia z projektu GnuPG.
65
66 %package -n gnupg-agent
67 Summary:        GnuPG extension - agent
68 Summary(pl):    Rozszerzenie GnuPG - agent
69 Group:          Applications/File
70 Requires:       gnupg2-common = %{version}-%{release}
71 Requires:       pinentry
72 %{?with_xinitrc:Requires: xinitrc}
73 Obsoletes:      newpg
74
75 %description -n gnupg-agent
76 GnuPG extension - agent.
77
78 %description -n gnupg-agent -l pl
79 Rozszerzenie GnuPG - agent.
80
81 %package -n gnupg-smime
82 Summary:        GnuPG extension - S/MIME support
83 Summary(pl):    Rozszerzenie GnuPG - obs³uga S/MIME
84 Group:          Applications/File
85 Requires:       gnupg2-common = %{version}-%{release}
86 Conflicts:      gnupg-agent < 1.9.14-2
87
88 %description -n gnupg-smime
89 GnuPG extension - S/MIME support.
90
91 %description -n gnupg-smime -l pl
92 Rozszerzenie GnuPG - obs³uga S/MIME.
93
94 %prep
95 %setup -q -n gnupg-%{version}
96 %patch0 -p1
97
98 %build
99 cp -f /usr/share/automake/config.* scripts
100 %configure \
101         --with-capabilities \
102         %{!?with_pth:--disable-threads} \
103 %ifarch sparc sparc64
104         --disable-m-guard \
105 %else
106         --enable-m-guard \
107 %endif
108         --without-included-gettext \
109         --disable-m-debug \
110         --with-mailprog=/usr/lib/sendmail
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT/etc/profile.d
117 %{?with_xinitrc:install -d $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT \
121         pkglibdir=%{_libexecdir}
122
123 install %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/gnupg-agent.sh
124 %{?with_xinitrc:ln -sf /etc/profile.d/gnupg-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gnupg-agent.sh}
125
126 mv ChangeLog main-ChangeLog || :
127 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
128
129 %find_lang gnupg2
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
136
137 %postun
138 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
139
140 %files 
141 %defattr(644,root,root,755)
142 %doc g10-ChangeLog g10/options.skel
143 %attr(755,root,root) %{_bindir}/gpg2
144 %attr(755,root,root) %{_bindir}/gpgv2
145
146 %files common -f gnupg2.lang
147 %defattr(644,root,root,755)
148 %doc AUTHORS main-ChangeLog NEWS README THANKS TODO 
149 %doc intl-ChangeLog jnlib-ChangeLog m4-ChangeLog po-ChangeLog scripts-ChangeLog common-ChangeLog kbx-ChangeLog tools-ChangeLog doc-ChangeLog
150 %attr(755,root,root) %{_bindir}/gpgconf
151 %attr(755,root,root) %{_bindir}/watchgnupg
152 %attr(755,root,root) %{_sbindir}/addgnupghome
153 %attr(755,root,root) %{_bindir}/kbxutil
154 %{_datadir}/gnupg
155 %{_infodir}/*info*
156
157 %files -n gnupg-smime
158 %defattr(644,root,root,755)
159 %doc sm-ChangeLog
160 %attr(755,root,root) %{_bindir}/gpgsm
161 %attr(755,root,root) %{_bindir}/gpgsm-gencert.sh
162
163 %files -n gnupg-agent
164 %defattr(644,root,root,755)
165 %doc agent-ChangeLog scd-ChangeLog
166 %attr(755,root,root) %{_bindir}/gpg-agent
167 %attr(755,root,root) %{_bindir}/sc-copykeys
168 %attr(755,root,root) %{_bindir}/scdaemon
169 %attr(755,root,root) %{_libexecdir}/gpg-protect-tool
170 %attr(755,root,root) %{_libexecdir}/gpg-preset-passphrase
171 %attr(755,root,root) %{_libexecdir}/pcsc-wrapper
172 %attr(755,root,root) /etc/profile.d/gnupg-agent.sh
173 %{?with_xinitrc:%attr(755,root,root) /etc/X11/xinit/xinitrc.d/gnupg-agent.sh}
This page took 0.081822 seconds and 3 git commands to generate.