]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
- gpg.conf parsing fixed - leading spaces are allowed in this configuration
[packages/gnupg2.git] / gnupg2.spec
1 #
2 # Conditional build:
3 %bcond_without  xinitrc # don't use xinitrc's directory
4 #
5 Summary:        GnuPG extension - agent
6 Summary(pl):    Rozszerzenie GnuPG - agent
7 Name:           gnupg-agent
8 Version:        1.9.10
9 Release:        3
10 License:        GPL
11 Group:          Applications/File
12 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.gz
13 # Source0-md5:  d923cfe0921898fbeb66374a0e32ddc6
14 Source1:        gnupg-agent.sh
15 Icon:           gnupg.gif
16 URL:            http://www.gnupg.org/
17 BuildRequires:  automake
18 BuildRequires:  gettext-devel >= 0.12.1
19 BuildRequires:  libassuan-devel >= 1:0.6.6
20 BuildRequires:  libgcrypt-devel >= 1.1.93
21 BuildRequires:  libgpg-error-devel >= 0.6
22 BuildRequires:  libksba-devel >= 0.9.7
23 BuildRequires:  pcsc-lite-devel
24 BuildRequires:  opensc-devel >= 0.8.0
25 BuildRequires:  pth-devel >= 2.0.0
26 BuildRequires:  texinfo
27 BuildRequires:  zlib-devel
28 Requires:       gnupg
29 Requires:       pinentry
30 %{?with_xinitrc:Requires: xinitrc}
31 Obsoletes:      newpg
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _libexecdir     %{_libdir}/gnupg
35
36 %description
37 GnuPG extension - agent.
38
39 %description -l pl
40 Rozszerzenie GnuPG - agent.
41
42 %prep
43 %setup -q -n gnupg-%{version}
44
45 %build
46 cp -f /usr/share/automake/config.* scripts
47 %configure \
48         --disable-gpg \
49         --with-capabilities \
50 %ifarch sparc sparc64
51         --disable-m-guard \
52 %else
53         --enable-m-guard \
54 %endif
55         --without-included-gettext \
56         --disable-m-debug \
57         --with-mailprog=/usr/lib/sendmail
58
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT/etc/profile.d
64 %{?with_xinitrc:install -d $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d}
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 ln -sf gpg2 $RPM_BUILD_ROOT%{_bindir}/gpg
70 install %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
71 %{?with_xinitrc:ln -sf /etc/profile.d/%{name}.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/%{name}.sh}
72
73 %find_lang gnupg2
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
80
81 %postun
82 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
83
84 %files -f gnupg2.lang
85 %defattr(644,root,root,755)
86 %doc agent/ChangeLog
87 %attr(755,root,root) %{_bindir}/gpg-agent
88 %attr(755,root,root) %{_bindir}/gpgsm
89 %attr(755,root,root) %{_bindir}/kbxutil
90 %attr(755,root,root) %{_bindir}/sc-copykeys
91 %attr(755,root,root) %{_bindir}/sc-investigate
92 %attr(755,root,root) %{_bindir}/scdaemon
93 %attr(755,root,root) %{_libdir}/gnupg/gpg-protect-tool
94 %attr(755,root,root) %{_libdir}/gnupg/pcsc-wrapper
95 %attr(755,root,root) /etc/profile.d/%{name}.sh
96 %{?with_xinitrc:%attr(755,root,root) /etc/X11/xinit/xinitrc.d/%{name}.sh}
This page took 0.054816 seconds and 3 git commands to generate.