]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
- updated to 2.0.2
[packages/gnupg2.git] / gnupg2.spec
1 # TODO:
2 # - separate keys plugins (see gnupg.spec)
3 # - update pl.po (just a note for myself  --q)
4 #
5 # Conditional build:
6 %bcond_without  pth     # without pth-based based version of gnupg
7 %bcond_without  tests   # testsuite on build
8 #
9 Summary:        GNU Privacy Guard - tool for secure communication and data storage - development version
10 Summary(pl):    GnuPG - narzêdzie do bezpiecznej komunikacji i bezpiecznego przechowywania danych - wersja rozwojowa
11 Name:           gnupg2
12 Version:        2.0.1
13 Release:        0.2
14 License:        GPL
15 Group:          Applications/File
16 Source0:        ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-%{version}.tar.bz2
17 # Source0-md5:  eb24e258db73f4cb53a3ce18375efa21
18 Source1:        gnupg-agent.sh
19 Patch0:         %{name}-info.patch
20 Patch1:         %{name}-pth.patch
21 Patch2:         %{name}-disable_tests.patch
22 URL:            http://www.gnupg.org/
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake >= 1:1.9.3
25 BuildRequires:  bzip2-devel
26 BuildRequires:  curl-devel
27 BuildRequires:  gettext-devel >= 0.15
28 BuildRequires:  libassuan-devel >= 1:0.9.3
29 BuildRequires:  libgcrypt-devel >= 1.2.0
30 BuildRequires:  libgpg-error-devel >= 1.4
31 BuildRequires:  libksba-devel >= 1.0.0
32 BuildRequires:  libusb-devel
33 BuildRequires:  openldap-devel
34 BuildRequires:  pcsc-lite-devel
35 %{?with_pth:BuildRequires:      pth-devel >= 2.0.0}
36 BuildRequires:  rpmbuild(macros) >= 1.177
37 BuildRequires:  texinfo
38 BuildRequires:  zlib-devel
39 Requires:       gnupg2-common = %{version}-%{release}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _libexecdir     %{_libdir}/gnupg2
43
44 %description
45 GnuPG is GNU's tool for secure communication and data storage. It can
46 be used to encrypt data and to create digital signatures. It includes
47 an advanced key management facility and is compliant with the proposed
48 OpenPGP Internet standard as described in RFC2440.
49
50 This is development version. Don't use it with production keys.
51
52 %description -l pl
53 GnuPG (GNU Privacy Guard) jest narzêdziem do bezpiecznej komunikacji i
54 bezpiecznego przechowywania danych. Mo¿e byæ u¿ywany do szyfrowania
55 oraz podpisywania danych. Umo¿liwia zaawansowane zarz±dzanie kluczami
56 i spe³nia normy zdefiniowane w standardzie OpenPGP, który jest opisany
57 w RFC2440.
58
59 Wersja rozwojowa. Nie do u¿ytku z kluczami produkcyjnymi.
60
61 %package common
62 Summary:        GnuPG - common files
63 Summary(pl):    GnuPG - pliki wspólne
64 Group:          Applications/File
65 Requires:       libassuan >= 1:0.9.3
66 Requires:       libgpg-error >= 1.4
67 Conflicts:      gnupg-agent < 1.9.14-2
68
69 %description common
70 Common files used by tools from GnuPG project.
71
72 %description common -l pl
73 Pliki wspólne u¿ywane przez ró¿ne narzêdzia z projektu GnuPG.
74
75 %package -n gnupg-agent
76 Summary:        GnuPG extension - agent
77 Summary(pl):    Rozszerzenie GnuPG - agent
78 Group:          Applications/File
79 Requires:       gnupg2-common = %{version}-%{release}
80 Requires:       pinentry
81 Obsoletes:      newpg
82
83 %description -n gnupg-agent
84 GnuPG extension - agent.
85
86 %description -n gnupg-agent -l pl
87 Rozszerzenie GnuPG - agent.
88
89 %package -n gnupg-agent-profile_d
90 Summary:        gnupg-agent start script for text mode
91 Summary(pl):    Skrypt startowy gnupg-agenta dla trybu tekstowego
92 Group:          Applications/File
93 Requires:       gnupg-agent = %{version}-%{release}
94
95 %description -n gnupg-agent-profile_d
96 gnupg-agent start script for text mode.
97
98 %description -n gnupg-agent-profile_d -l pl
99 Skrypt startowy gnupg-agenta dla trybu tekstowego.
100
101 %package -n gnupg-agent-xinitrc
102 Summary:        gnupg-agent start script for X-Window mode
103 Summary(pl):    Skrypt startowy gnupg-agenta dla trybu X-Window
104 Group:          Applications/File
105 Requires:       gnupg-agent = %{version}-%{release}
106 Requires:       xinitrc
107
108 %description -n gnupg-agent-xinitrc
109 gnupg-agent start script for X-Window mode.
110
111 %description -n gnupg-agent-xinitrc -l pl
112 Skrypt startowy gnupg-agenta dla trybu X-Window.
113
114 %package -n gnupg-smime
115 Summary:        GnuPG extension - S/MIME support
116 Summary(pl):    Rozszerzenie GnuPG - obs³uga S/MIME
117 Group:          Applications/File
118 Requires:       gnupg2-common = %{version}-%{release}
119 Conflicts:      gnupg-agent < 1.9.14-2
120
121 %description -n gnupg-smime
122 GnuPG extension - S/MIME support.
123
124 %description -n gnupg-smime -l pl
125 Rozszerzenie GnuPG - obs³uga S/MIME.
126
127 %prep
128 %setup -q -n gnupg-%{version}
129 %patch0 -p1
130 %patch1 -p1
131 %{!?with_tests:%patch2 -p1}
132
133 %build
134 %{__gettextize}
135 %{__aclocal} -I m4 -I gl/m4
136 %{__autoconf}
137 %{__autoheader}
138 %{__automake}
139 %configure \
140         %{!?with_pth:--disable-threads} \
141         --enable-gpg \
142         --enable-symcryptrun \
143         --with-capabilities \
144         --with-mailprog=/usr/lib/sendmail
145
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT \
153         pkglibdir=%{_libexecdir}
154
155 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/gnupg-agent.sh
156 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gnupg-agent.sh
157
158 mv ChangeLog main-ChangeLog || :
159 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
160
161 %find_lang gnupg2
162 rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post
168 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
169
170 %postun
171 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
172
173 %triggerpostun -n gnupg-agent -- gnupg-agent < 1.9.16-2
174 %banner gnupg-agent-1.9.16-2 << EOF
175 Scripts for starting gnupg-agent have been moved to separate
176 subpackages: gnupg-agent-profile_d and gnupg-agent-xinitrc.
177 EOF
178
179 %files
180 %defattr(644,root,root,755)
181 %doc g10-ChangeLog g10/options.skel
182 %attr(755,root,root) %{_bindir}/gpg2
183 %attr(755,root,root) %{_bindir}/gpgv2
184 %attr(755,root,root) %{_libexecdir}/gpg2keys_curl
185 %attr(755,root,root) %{_libexecdir}/gpg2keys_finger
186 %attr(755,root,root) %{_libexecdir}/gpg2keys_hkp
187 %attr(755,root,root) %{_libexecdir}/gpg2keys_ldap
188 %{_mandir}/man1/gpg2.1*
189 %{_mandir}/man1/gpgv2.1*
190
191 %files common -f gnupg2.lang
192 %defattr(644,root,root,755)
193 %doc AUTHORS main-ChangeLog NEWS README THANKS TODO
194 %doc intl-ChangeLog jnlib-ChangeLog m4-ChangeLog po-ChangeLog scripts-ChangeLog common-ChangeLog kbx-ChangeLog tools-ChangeLog doc-ChangeLog
195 %attr(755,root,root) %{_bindir}/gpg-connect-agent
196 %attr(755,root,root) %{_bindir}/gpgconf
197 %attr(755,root,root) %{_bindir}/gpgkey2ssh
198 %attr(755,root,root) %{_bindir}/gpgparsemail
199 %attr(755,root,root) %{_bindir}/kbxutil
200 %attr(755,root,root) %{_bindir}/watchgnupg
201 %attr(755,root,root) %{_sbindir}/addgnupghome
202 %dir %{_libexecdir}
203 %{_datadir}/gnupg
204 %{_mandir}/man1/gpg-connect-agent.1*
205 %{_mandir}/man1/gpgconf.1*
206 %{_mandir}/man1/gpgparsemail.1*
207 %{_mandir}/man1/watchgnupg.1*
208 %{_mandir}/man8/addgnupghome.8*
209 %{_infodir}/*.info*
210
211 %files -n gnupg-smime
212 %defattr(644,root,root,755)
213 %doc sm-ChangeLog
214 %attr(755,root,root) %{_bindir}/gpgsm
215 %attr(755,root,root) %{_bindir}/gpgsm-gencert.sh
216 %{_mandir}/man1/gpgsm.1*
217 %{_mandir}/man1/gpgsm-gencert.sh.1*
218
219 %files -n gnupg-agent
220 %defattr(644,root,root,755)
221 %doc agent-ChangeLog scd-ChangeLog
222 %attr(755,root,root) %{_bindir}/gpg-agent
223 %attr(755,root,root) %{_bindir}/scdaemon
224 %attr(755,root,root) %{_bindir}/symcryptrun
225 %attr(755,root,root) %{_libexecdir}/gnupg-pcsc-wrapper
226 %attr(755,root,root) %{_libexecdir}/gpg-protect-tool
227 %attr(755,root,root) %{_libexecdir}/gpg-preset-passphrase
228 %{_mandir}/man1/gpg-agent.1*
229 %{_mandir}/man1/gpg-preset-passphrase.1*
230 %{_mandir}/man1/scdaemon.1*
231 %{_mandir}/man1/symcryptrun.1*
232
233 %files -n gnupg-agent-profile_d
234 %defattr(644,root,root,755)
235 %attr(755,root,root) /etc/profile.d/gnupg-agent.sh
236
237 %files -n gnupg-agent-xinitrc
238 %defattr(644,root,root,755)
239 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/gnupg-agent.sh
This page took 0.088995 seconds and 3 git commands to generate.