]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- provides gdm-wm (window manager used by gdm)
[packages/gnome-shell.git] / gnome-shell.spec
1 Summary:        Window manager and application launcher for GNOME
2 Name:           gnome-shell
3 Version:        3.2.1
4 Release:        2
5 License:        GPL v2+
6 Group:          X11/Window Managers
7 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.2/%{name}-%{version}.tar.xz
8 # Source0-md5:  9519921d31d8c43d054dbc11e1f0733b
9 URL:            http://live.gnome.org/GnomeShell
10 BuildRequires:  GConf2-devel
11 BuildRequires:  NetworkManager-devel >= 0.8.999
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  clutter-devel >= 1.7.5
15 BuildRequires:  dbus-glib-devel
16 BuildRequires:  evolution-data-server-devel >= 3.1.90
17 BuildRequires:  folks-devel >= 0.6.1
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gjs-devel >= 1.29.18
20 BuildRequires:  glib2-devel >= 1:2.29.10
21 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
22 BuildRequires:  gnome-desktop-devel >= 3.1.90
23 BuildRequires:  gnome-menus-devel >= 3.1.90
24 BuildRequires:  gobject-introspection-devel >= 0.10.1
25 BuildRequires:  gsettings-desktop-schemas-devel >= 3.1.90
26 BuildRequires:  gstreamer-devel >= 0.10.21
27 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
28 BuildRequires:  gtk+3-devel >= 3.0.0
29 BuildRequires:  intltool >= 0.40
30 BuildRequires:  json-glib-devel >= 0.13.90
31 BuildRequires:  libcanberra-devel
32 BuildRequires:  libcroco-devel >= 0.6.2
33 BuildRequires:  libgnome-keyring-devel
34 BuildRequires:  libsoup-devel
35 BuildRequires:  libtool >= 2:2.2.6
36 BuildRequires:  libxml2-devel
37 BuildRequires:  mutter-devel >= 3.2.1
38 BuildRequires:  pkgconfig >= 1:0.22
39 BuildRequires:  polkit-devel >= 0.100
40 BuildRequires:  pulseaudio-devel
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.601
43 BuildRequires:  startup-notification-devel >= 0.11
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  telepathy-glib-devel >= 0.15.5
46 BuildRequires:  telepathy-logger-devel >= 0.2.4
47 BuildRequires:  xorg-lib-libXfixes-devel
48 # for libmozjs.so
49 BuildRequires:  xulrunner-libs
50 BuildRequires:  xz
51 Requires(post,postun):  glib2 >= 1:2.26.0
52 Requires(post,preun):   GConf2
53 Requires:       caribou >= 0.3.5
54 Requires:       evolution-data-server >= 3.1.90
55 Requires:       gnome-bluetooth-libs >= 3.1.0
56 Requires:       gnome-menus >= 3.1.90
57 Requires:       gnome-settings-daemon >= 3.1.90
58 Requires:       gsettings-desktop-schemas >= 3.1.90
59 Requires:       mutter >= 3.2.1
60 Requires:       telepathy-logger >= 0.2.4
61 %requires_eq    xulrunner-libs
62 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
63 Provides:       gdm-wm = 3.2.1-1
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 GNOME Shell is the defining technology of the GNOME 3 desktop user
68 experience. It provides core interface functions like switching to
69 windows and launching applications. GNOME Shell takes advantage of the
70 capabilities of modern graphics hardware and introduces innovative
71 user interface concepts to provide a delightful and easy to use
72 experience.
73
74 %package -n browser-plugin-%{name}
75 Summary:        gnome-shell plugin for WWW browsers
76 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglÄ…darek WWW
77 Group:          X11/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       browser-plugins >= 2.0
80 Requires:       browser-plugins(%{_target_base_arch})
81 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
82 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
83 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
84 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
85
86 %description -n browser-plugin-%{name}
87 gnome-shell plugin for WWW browsers.
88
89 %description -n browser-plugin-%{name} -l pl.UTF-8
90 Wtyczka gnome-shell do przeglÄ…darek WWW.
91
92 %prep
93 %setup -q
94
95 %build
96 %{__intltoolize}
97 %{__libtoolize}
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 export LD_LIBRARY_PATH=%{_libdir}/xulrunner
103 %configure \
104         --with-ca-certificates=/etc/certs/ca-certificates.crt \
105         --disable-schemas-install \
106         --disable-silent-rules \
107         --disable-static
108 %{__make} -j1
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         mozillalibdir=%{_browserpluginsdir}
117
118 # TODO use rpath at link time instead of this hack
119 mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
120 cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
121 #!/bin/sh
122 LD_LIBRARY_PATH=%{_libdir}/xulrunner
123 export LD_LIBRARY_PATH
124 exec %{_bindir}/gnome-shell.bin "$@"
125 EOF
126 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
127
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la \
129         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
130
131 %find_lang %{name}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 %gconf_schema_install gnome-shell.schemas
138 %glib_compile_schemas
139
140 %preun
141 %gconf_schema_uninstall gnome-shell.schemas
142
143 %postun
144 if [ "$1" = "0" ]; then
145         %glib_compile_schemas
146 fi
147
148 %post -n browser-plugin-%{name}
149 %update_browser_plugins
150
151 %postun -n browser-plugin-%{name}
152 if [ "$1" = 0 ]; then
153         %update_browser_plugins
154 fi
155
156 %files -f %{name}.lang
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/gnome-shell
159 %attr(755,root,root) %{_bindir}/gnome-shell.bin
160 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
161 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
162 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
163 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
164 %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
165 %dir %{_libdir}/gnome-shell
166 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
167 %{_libdir}/gnome-shell/Gvc-1.0.typelib
168 %{_libdir}/gnome-shell/Shell-0.1.typelib
169 %{_libdir}/gnome-shell/St-1.0.typelib
170 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
171 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
172 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
173 %{_datadir}/gnome-shell
174 %{_desktopdir}/gnome-shell.desktop
175 %{_mandir}/man1/gnome-shell.1*
176
177 %files -n browser-plugin-%{name}
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.035787 seconds and 4 git commands to generate.