]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- drop ie locale; release 2
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 %define         clutter_ver                     1.21.5
6 # max(ecal_req, eds_req)
7 %define         evolution_data_server_ver       3.33.1
8 %define         gcr_ver                         3.90.0
9 %define         gjs_ver                         1.73.1
10 %define         glib_ver                        1:2.57.2
11 %define         gnome_bluetooth_ver             3.9.0
12 %define         gnome_desktop_ver               3.36.0
13 %define         gsettings_desktop_schemas_ver   42
14 %define         gtk_ver                         3.15.0
15 %define         ibus_ver                        1.5.19
16 %define         json_glib_ver                   0.13.90
17 %define         libsecret_ver                   0.18
18 %define         mutter_ver                      43.0
19 %define         NetworkManager_ver              1.10.4
20 %define         polkit_ver                      0.100
21 %define         pulseaudio_ver                  13
22 %define         startup_notification_ver        0.11
23
24 Summary:        Window manager and application launcher for GNOME
25 Summary(pl.UTF-8):      Zarządca okien i uruchamiania aplikacji dla GNOME
26 Name:           gnome-shell
27 Version:        43.5
28 Release:        2
29 License:        GPL v2+
30 Group:          X11/Window Managers
31 Source0:        https://download.gnome.org/sources/gnome-shell/43/%{name}-%{version}.tar.xz
32 # Source0-md5:  4356867ac23623b7858ed12222a901ec
33 Patch0:         %{name}-no-update.patch
34 URL:            https://wiki.gnome.org/Projects/GnomeShell
35 BuildRequires:  NetworkManager-devel >= %{NetworkManager_ver}
36 BuildRequires:  asciidoc
37 BuildRequires:  at-spi2-atk-devel
38 BuildRequires:  bash-completion-devel >= 1:2.0
39 BuildRequires:  clutter-devel >= %{clutter_ver}
40 BuildRequires:  evolution-data-server-devel >= %{evolution_data_server_ver}
41 BuildRequires:  gcr4-devel >= %{gcr_ver}
42 BuildRequires:  gdk-pixbuf2-devel >= 2.0
43 BuildRequires:  gettext-tools >= 0.19.6
44 BuildRequires:  gjs-devel >= %{gjs_ver}
45 BuildRequires:  glib2-devel >= %{glib_ver}
46 BuildRequires:  gnome-autoar-devel
47 BuildRequires:  gnome-bluetooth3-devel >= %{gnome_bluetooth_ver}
48 BuildRequires:  gnome-control-center-devel
49 BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_ver}
50 BuildRequires:  gobject-introspection-devel >= 1.50.0
51 BuildRequires:  gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_ver}
52 BuildRequires:  gstreamer-devel >= 1.0.0
53 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
54 BuildRequires:  gtk+3-devel >= %{gtk_ver}
55 BuildRequires:  gtk4-devel >= 4
56 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.15}
57 BuildRequires:  ibus-devel >= %{ibus_ver}
58 BuildRequires:  json-glib-devel >= %{json_glib_ver}
59 BuildRequires:  libcanberra-devel
60 BuildRequires:  libcanberra-gtk3-devel
61 BuildRequires:  libsecret-devel >= %{libsecret_ver}
62 # or libsoup 2.4 with -Dsoup2=true, must be in sync with libgweather
63 BuildRequires:  libsoup3-devel >= 3.0
64 BuildRequires:  libxml2-devel >= 2.0
65 BuildRequires:  libxslt-progs
66 BuildRequires:  meson >= 0.58.0
67 BuildRequires:  mutter-devel >= %{mutter_ver}
68 BuildRequires:  ninja >= 1.5
69 BuildRequires:  pipewire-devel >= 0.3
70 BuildRequires:  pkgconfig >= 1:0.22
71 BuildRequires:  polkit-devel >= %{polkit_ver}
72 BuildRequires:  pulseaudio-devel >= %{pulseaudio_ver}
73 BuildRequires:  python3 >= 1:3
74 BuildRequires:  python3-pygobject3 >= 3
75 BuildRequires:  rpm-build >= 4.6
76 BuildRequires:  rpm-pythonprov
77 BuildRequires:  rpmbuild(macros) >= 1.752
78 BuildRequires:  sassc
79 BuildRequires:  sed >= 4.0
80 BuildRequires:  startup-notification-devel >= %{startup_notification_ver}
81 BuildRequires:  systemd-devel
82 BuildRequires:  systemd-units
83 BuildRequires:  tar >= 1:1.22
84 BuildRequires:  xorg-lib-libX11-devel
85 BuildRequires:  xorg-lib-libXfixes-devel
86 BuildRequires:  xz
87 Requires(post,postun):  glib2 >= %{glib_ver}
88 # gjs->gi->NMA.gir
89 Requires:       NetworkManager-libs >= %{NetworkManager_ver}
90 Requires:       adwaita-icon-theme
91 Requires:       at-spi2-atk >= 2.4.0
92 Requires:       clutter >= %{clutter_ver}
93 Requires:       evolution-data-server >= %{evolution_data_server_ver}
94 Requires:       gcr4 >= %{gcr_ver}
95 Requires:       gjs >= %{gjs_ver}
96 Requires:       glib2 >= %{glib_ver}
97 Requires:       gnome-bluetooth3-libs >= %{gnome_bluetooth_ver}
98 Requires:       gnome-desktop >= %{gnome_desktop_ver}
99 Requires:       gnome-settings-daemon >= 3.8.0
100 Requires:       gsettings-desktop-schemas >= %{gsettings_desktop_schemas_ver}
101 Requires:       gtk+3 >= %{gtk_ver}
102 Requires:       ibus >= %{ibus_ver}
103 Requires:       json-glib >= %{json_glib_ver}
104 Requires:       libsecret >= %{libsecret_ver}
105 Requires:       mutter >= %{mutter_ver}
106 Requires:       nautilus >= 3.8.0
107 Requires:       polkit >= %{polkit_ver}
108 Requires:       pulseaudio-libs >= %{pulseaudio_ver}
109 Requires:       startup-notification >= %{startup_notification_ver}
110 # gjs->gir->TelepathyGLib
111 Requires:       telepathy-glib >= 0.17.5
112 # gjs->gir->TelepathyLogger
113 Requires:       telepathy-logger-libs >= 0.2
114 Requires:       telepathy-mission-control
115 Suggests:       gnome-contacts >= 3.2.0
116 Suggests:       gnome-icon-theme-symbolic >= 3.8.0
117 Provides:       gdm-wm = 3.8.0
118 Obsoletes:      browser-plugin-gnome-shell < 3.32.2-1
119 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121 %description
122 GNOME Shell is the defining technology of the GNOME 3 desktop user
123 experience. It provides core interface functions like switching to
124 windows and launching applications. GNOME Shell takes advantage of the
125 capabilities of modern graphics hardware and introduces innovative
126 user interface concepts to provide a delightful and easy to use
127 experience.
128
129 %description -l pl.UTF-8
130 GNOME Shell to technologia definiująca doznania użytkownika środowiska
131 graficznego GNOME 3. Zapewnia podstawowe funkcje interfejsu, takie jak
132 przełączanie między oknami czy uruchamianie aplikacji. GNOME Shell
133 wykorzystuje mozliwości współczesnego sprzętu graficznego i wprowadza
134 innowacyjne koncepcje interfejsu użytkownika, zapewniające przyjemne
135 doznania i łatwość użycia.
136
137 %package -n bash-completion-gnome-shell
138 Summary:        Bash completion for GNOME Shell commands
139 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów poleceń GNOME Shell
140 Group:          Applications/Shells
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       bash-completion >= 1:2.0
143 BuildArch:      noarch
144
145 %description -n bash-completion-gnome-shell
146 Bash completion for GNOME Shell commands.
147
148 %description -n bash-completion-gnome-shell -l pl.UTF-8
149 Bashowe dopełnianie parametrów poleceń GNOME Shell.
150
151 %package devel
152 Summary:        Development files for GNOME Shell
153 Summary(pl.UTF-8):      Pliki programistyczne dla GNOME Shell
154 Group:          Development/Libraries
155 BuildArch:      noarch
156
157 %description devel
158 This package provides development files for GNOME Shell.
159
160 %description devel -l pl.UTF-8
161 Ten pakiet dostarcza pliki programistyczne dla GNOME Shell.
162
163 %package apidocs
164 Summary:        GNOME Shell API documentation
165 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
166 Group:          Documentation
167 Requires:       gtk-doc-common
168 BuildArch:      noarch
169
170 %description apidocs
171 This package provides GNOME Shell API documentation.
172
173 %description apidocs -l pl.UTF-8
174 Ten pakiet dostarcza dokumentację API GNOME Shell.
175
176 %prep
177 %setup -q
178 %patch0 -p1
179
180 %{__sed} -i -e '/^libshew =/ s/ library/ shared_library/' subprojects/shew/src/meson.build
181
182 %build
183 %meson build \
184         %{?with_apidocs:-Dgtk_doc=true} \
185         -Dtests=false
186
187 %meson_build -C build
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
192
193 %meson_install -C build
194
195 # useless
196 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell*.a
197 # evolution already ships this file
198 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/evolution-calendar.desktop
199
200 # not supported by glibc (as of 2.37)
201 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
202
203 %find_lang %{name}
204
205 %clean
206 rm -rf $RPM_BUILD_ROOT
207
208 %post
209 %glib_compile_schemas
210
211 %postun
212 if [ "$1" = "0" ]; then
213         %glib_compile_schemas
214 fi
215
216 %files -f %{name}.lang
217 %defattr(644,root,root,755)
218 %doc NEWS README.md
219 %attr(755,root,root) %{_bindir}/gnome-extensions
220 %attr(755,root,root) %{_bindir}/gnome-extensions-app
221 %attr(755,root,root) %{_bindir}/gnome-shell
222 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
223 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
224 %attr(755,root,root) %{_bindir}/gnome-shell-perf-tool
225 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
226 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
227 %attr(755,root,root) %{_libexecdir}/gnome-shell-overrides-migration.sh
228 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
229 %attr(755,root,root) %{_libexecdir}/gnome-shell-portal-helper
230 %dir %{_libdir}/gnome-shell
231 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
232 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-menu.so
233 %attr(755,root,root) %{_libdir}/gnome-shell/libgvc.so
234 %attr(755,root,root) %{_libdir}/gnome-shell/libshew-0.so
235 %attr(755,root,root) %{_libdir}/gnome-shell/libst-1.0.so
236 %{_libdir}/gnome-shell/Gvc-1.0.typelib
237 %{_libdir}/gnome-shell/Shell-0.1.typelib
238 %{_libdir}/gnome-shell/St-1.0.typelib
239 %dir %{_libdir}/gnome-shell/girepository-1.0
240 %{_libdir}/gnome-shell/girepository-1.0/Shew-0.typelib
241 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
242 %{_datadir}/dbus-1/services/org.gnome.Extensions.service
243 %{_datadir}/dbus-1/services/org.gnome.ScreenSaver.service
244 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
245 %{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
246 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
247 %{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
248 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
249 %{_datadir}/dbus-1/services/org.gnome.Shell.Screencast.service
250 %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
251 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
252 %{_datadir}/gnome-control-center/keybindings/*.xml
253 %{_datadir}/gnome-shell
254 %{_datadir}/metainfo/org.gnome.Extensions.metainfo.xml
255 %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
256 %{_desktopdir}/org.gnome.Extensions.desktop
257 %{_desktopdir}/org.gnome.Shell.desktop
258 %{_desktopdir}/org.gnome.Shell.Extensions.desktop
259 %{_desktopdir}/org.gnome.Shell.PortalHelper.desktop
260 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
261 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.svg
262 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
263 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
264 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
265 %{_mandir}/man1/gnome-extensions.1*
266 %{_mandir}/man1/gnome-shell.1*
267 %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
268 %{systemduserunitdir}/org.gnome.Shell.target
269 %{systemduserunitdir}/org.gnome.Shell-disable-extensions.service
270 %{systemduserunitdir}/org.gnome.Shell@wayland.service
271 %{systemduserunitdir}/org.gnome.Shell@x11.service
272
273 %files -n bash-completion-gnome-shell
274 %defattr(644,root,root,755)
275 %{bash_compdir}/gnome-extensions
276
277 %files devel
278 %defattr(644,root,root,755)
279 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
280 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
281 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
282 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
283 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
284 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
285
286 %if %{with apidocs}
287 %files apidocs
288 %defattr(644,root,root,755)
289 %{_gtkdocdir}/shell
290 %{_gtkdocdir}/st
291 %endif
This page took 0.064794 seconds and 4 git commands to generate.