]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- added missing R:
[packages/gnome-shell.git] / gnome-shell.spec
1 Summary:        Window manager and application launcher for GNOME
2 Name:           gnome-shell
3 Version:        3.2.0
4 Release:        3
5 License:        GPL v2+
6 Group:          X11/Window Managers
7 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.2/%{name}-%{version}.tar.xz
8 # Source0-md5:  684d7620f1dfd144b2d97ab970daa1ad
9 URL:            http://live.gnome.org/GnomeShell
10 BuildRequires:  GConf2-devel
11 BuildRequires:  NetworkManager-devel >= 0.8.999
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  clutter-devel >= 1.7.5
15 BuildRequires:  dbus-glib-devel
16 BuildRequires:  evolution-data-server-devel >= 3.1.90
17 BuildRequires:  folks-devel >= 0.6.1
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gjs-devel >= 1.29.18
20 BuildRequires:  glib2-devel >= 1:2.29.10
21 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
22 BuildRequires:  gnome-desktop-devel >= 3.1.90
23 BuildRequires:  gnome-menus-devel >= 3.1.90
24 BuildRequires:  gobject-introspection-devel >= 0.10.1
25 BuildRequires:  gsettings-desktop-schemas-devel >= 3.1.90
26 BuildRequires:  gstreamer-devel >= 0.10.21
27 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
28 BuildRequires:  gtk+3-devel >= 3.0.0
29 BuildRequires:  intltool >= 0.40
30 BuildRequires:  json-glib-devel >= 0.13.90
31 BuildRequires:  libcanberra-devel
32 BuildRequires:  libcroco-devel >= 0.6.2
33 BuildRequires:  libgnome-keyring-devel
34 BuildRequires:  libsoup-devel
35 BuildRequires:  libtool >= 2:2.2.6
36 BuildRequires:  libxml2-devel
37 BuildRequires:  mutter-devel >= 3.2.0
38 BuildRequires:  pkgconfig >= 1:0.22
39 BuildRequires:  polkit-devel >= 0.100
40 BuildRequires:  pulseaudio-devel
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.601
43 BuildRequires:  startup-notification-devel >= 0.11
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  telepathy-glib-devel >= 0.15.5
46 BuildRequires:  telepathy-logger-devel >= 0.2.4
47 BuildRequires:  xorg-lib-libXfixes-devel
48 # for libmozjs.so
49 BuildRequires:  xulrunner-libs
50 BuildRequires:  xz
51 Requires(post,postun):  glib2 >= 1:2.26.0
52 Requires(post,preun):   GConf2
53 Requires:       caribou >= 0.3.5
54 Requires:       evolution-data-server >= 3.1.90
55 Requires:       gnome-bluetooth-libs >= 3.1.0
56 Requires:       gnome-menus >= 3.1.90
57 Requires:       gnome-settings-daemon >= 3.1.90
58 Requires:       gsettings-desktop-schemas >= 3.1.90
59 Requires:       mutter >= 3.1.91.1
60 Requires:       telepathy-logger >= 0.2.4
61 %requires_eq    xulrunner-libs
62 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 GNOME Shell is the defining technology of the GNOME 3 desktop user
67 experience. It provides core interface functions like switching to
68 windows and launching applications. GNOME Shell takes advantage of the
69 capabilities of modern graphics hardware and introduces innovative
70 user interface concepts to provide a delightful and easy to use
71 experience.
72
73 %package -n browser-plugin-%{name}
74 Summary:        gnome-shell plugin for WWW browsers
75 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglÄ…darek WWW
76 Group:          X11/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       browser-plugins >= 2.0
79 Requires:       browser-plugins(%{_target_base_arch})
80 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
81 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
82 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
83 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
84
85 %description -n browser-plugin-%{name}
86 gnome-shell plugin for WWW browsers.
87
88 %description -n browser-plugin-%{name} -l pl.UTF-8
89 Wtyczka gnome-shell do przeglÄ…darek WWW.
90
91 %prep
92 %setup -q
93
94 %build
95 %{__intltoolize}
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 export LD_LIBRARY_PATH=%{_libdir}/xulrunner
102 %configure \
103         --with-ca-certificates=/etc/certs/ca-certificates.crt \
104         --disable-schemas-install \
105         --disable-silent-rules \
106         --disable-static
107 %{__make} -j1
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         mozillalibdir=%{_browserpluginsdir}
116
117 # TODO use rpath at link time instead of this hack
118 mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
119 cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
120 #!/bin/sh
121 LD_LIBRARY_PATH=%{_libdir}/xulrunner
122 export LD_LIBRARY_PATH
123 exec %{_bindir}/gnome-shell.bin "$@"
124 EOF
125 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
126
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la \
128         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
129
130 %find_lang %{name}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post
136 %gconf_schema_install gnome-shell.schemas
137 %glib_compile_schemas
138
139 %preun
140 %gconf_schema_uninstall gnome-shell.schemas
141
142 %postun
143 if [ "$1" = "0" ]; then
144         %glib_compile_schemas
145 fi
146
147 %post -n browser-plugin-%{name}
148 %update_browser_plugins
149
150 %postun -n browser-plugin-%{name}
151 if [ "$1" = 0 ]; then
152         %update_browser_plugins
153 fi
154
155 %files -f %{name}.lang
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/gnome-shell
158 %attr(755,root,root) %{_bindir}/gnome-shell.bin
159 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
160 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
161 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
162 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
163 %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
164 %dir %{_libdir}/gnome-shell
165 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
166 %{_libdir}/gnome-shell/Gvc-1.0.typelib
167 %{_libdir}/gnome-shell/Shell-0.1.typelib
168 %{_libdir}/gnome-shell/St-1.0.typelib
169 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
170 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
171 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
172 %{_datadir}/gnome-shell
173 %{_desktopdir}/gnome-shell.desktop
174 %{_mandir}/man1/gnome-shell.1*
175
176 %files -n browser-plugin-%{name}
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.043983 seconds and 4 git commands to generate.