]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- updated to 41.1
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 %define         clutter_ver                     1.21.5
6 # max(ecal_req, eds_req)
7 %define         evolution_data_server_ver       3.33.1
8 %define         gcr_ver                         3.7.5
9 %define         gjs_ver                         1.69.2
10 %define         glib_ver                        1:2.57.2
11 %define         gnome_bluetooth_ver             3.9.0
12 %define         gnome_desktop_ver               3.36.0
13 %define         gsettings_desktop_schemas_ver   41
14 %define         gtk_ver                         3.15.0
15 %define         ibus_ver                        1.5.19
16 %define         json_glib_ver                   0.13.90
17 %define         libsecret_ver                   0.18
18 %define         mutter_ver                      41.0
19 %define         NetworkManager_ver              1.10.4
20 %define         polkit_ver                      0.100
21 %define         pulseaudio_ver                  13
22 %define         startup_notification_ver        0.11
23
24 Summary:        Window manager and application launcher for GNOME
25 Summary(pl.UTF-8):      Zarządca okien i uruchamiania aplikacji dla GNOME
26 Name:           gnome-shell
27 Version:        41.1
28 Release:        1
29 License:        GPL v2+
30 Group:          X11/Window Managers
31 Source0:        https://download.gnome.org/sources/gnome-shell/41/%{name}-%{version}.tar.xz
32 # Source0-md5:  b0becc39368c4a4a758b2946f9e6fb86
33 URL:            https://wiki.gnome.org/Projects/GnomeShell
34 BuildRequires:  NetworkManager-devel >= %{NetworkManager_ver}
35 BuildRequires:  asciidoc
36 BuildRequires:  at-spi2-atk-devel
37 BuildRequires:  bash-completion-devel >= 2.0
38 BuildRequires:  clutter-devel >= %{clutter_ver}
39 BuildRequires:  evolution-data-server-devel >= %{evolution_data_server_ver}
40 BuildRequires:  gcr-devel >= %{gcr_ver}
41 BuildRequires:  gdk-pixbuf2-devel >= 2.0
42 BuildRequires:  gettext-tools >= 0.19.6
43 BuildRequires:  gjs-devel >= %{gjs_ver}
44 BuildRequires:  glib2-devel >= %{glib_ver}
45 BuildRequires:  gnome-autoar-devel
46 BuildRequires:  gnome-bluetooth-devel >= %{gnome_bluetooth_ver}
47 BuildRequires:  gnome-control-center-devel
48 BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_ver}
49 BuildRequires:  gobject-introspection-devel >= 1.50.0
50 BuildRequires:  gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_ver}
51 BuildRequires:  gstreamer-devel >= 1.0.0
52 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
53 BuildRequires:  gtk+3-devel >= %{gtk_ver}
54 BuildRequires:  gtk4-devel >= 4
55 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.15}
56 BuildRequires:  ibus-devel >= %{ibus_ver}
57 BuildRequires:  json-glib-devel >= %{json_glib_ver}
58 BuildRequires:  libcanberra-devel
59 BuildRequires:  libcanberra-gtk3-devel
60 BuildRequires:  libsecret-devel >= %{libsecret_ver}
61 # or libsoup3 with -Dsoup2=false, must be in sync with libgweather
62 BuildRequires:  libsoup-devel >= 2.4
63 BuildRequires:  libxml2-devel >= 2.0
64 BuildRequires:  libxslt-progs
65 BuildRequires:  meson >= 0.53.0
66 BuildRequires:  mutter-devel >= %{mutter_ver}
67 BuildRequires:  ninja >= 1.5
68 BuildRequires:  pipewire-devel >= 0.3
69 BuildRequires:  pkgconfig >= 1:0.22
70 BuildRequires:  polkit-devel >= %{polkit_ver}
71 BuildRequires:  pulseaudio-devel >= %{pulseaudio_ver}
72 BuildRequires:  python3 >= 1:3
73 BuildRequires:  python3-pygobject3 >= 3
74 BuildRequires:  rpm-build >= 4.6
75 BuildRequires:  rpm-pythonprov
76 BuildRequires:  rpmbuild(macros) >= 1.752
77 BuildRequires:  sassc
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  startup-notification-devel >= %{startup_notification_ver}
80 BuildRequires:  systemd-devel
81 BuildRequires:  systemd-units
82 BuildRequires:  tar >= 1:1.22
83 BuildRequires:  xorg-lib-libX11-devel
84 BuildRequires:  xorg-lib-libXfixes-devel
85 BuildRequires:  xz
86 Requires(post,postun):  glib2 >= %{glib_ver}
87 # gjs->gi->NMA.gir
88 Requires:       NetworkManager-libs >= %{NetworkManager_ver}
89 Requires:       adwaita-icon-theme
90 Requires:       at-spi2-atk >= 2.4.0
91 Requires:       clutter >= %{clutter_ver}
92 Requires:       evolution-data-server >= %{evolution_data_server_ver}
93 Requires:       gcr >= %{gcr_ver}
94 Requires:       gjs >= %{gjs_ver}
95 Requires:       glib2 >= %{glib_ver}
96 Requires:       gnome-bluetooth-libs >= %{gnome_bluetooth_ver}
97 Requires:       gnome-desktop >= %{gnome_desktop_ver}
98 Requires:       gnome-settings-daemon >= 3.8.0
99 Requires:       gsettings-desktop-schemas >= %{gsettings_desktop_schemas_ver}
100 Requires:       gtk+3 >= %{gtk_ver}
101 Requires:       ibus >= %{ibus_ver}
102 Requires:       json-glib >= %{json_glib_ver}
103 Requires:       libsecret >= %{libsecret_ver}
104 Requires:       mutter >= %{mutter_ver}
105 Requires:       nautilus >= 3.8.0
106 Requires:       polkit >= %{polkit_ver}
107 Requires:       pulseaudio-libs >= %{pulseaudio_ver}
108 Requires:       startup-notification >= %{startup_notification_ver}
109 # gjs->gir->TelepathyGLib
110 Requires:       telepathy-glib >= 0.17.5
111 # gjs->gir->TelepathyLogger
112 Requires:       telepathy-logger-libs >= 0.2
113 Requires:       telepathy-mission-control
114 Suggests:       gnome-contacts >= 3.2.0
115 Suggests:       gnome-icon-theme-symbolic >= 3.8.0
116 Provides:       gdm-wm = 3.8.0
117 Obsoletes:      browser-plugin-gnome-shell < 3.32.2-1
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %description
121 GNOME Shell is the defining technology of the GNOME 3 desktop user
122 experience. It provides core interface functions like switching to
123 windows and launching applications. GNOME Shell takes advantage of the
124 capabilities of modern graphics hardware and introduces innovative
125 user interface concepts to provide a delightful and easy to use
126 experience.
127
128 %description -l pl.UTF-8
129 GNOME Shell to technologia definiująca doznania użytkownika środowiska
130 graficznego GNOME 3. Zapewnia podstawowe funkcje interfejsu, takie jak
131 przełączanie między oknami czy uruchamianie aplikacji. GNOME Shell
132 wykorzystuje mozliwości współczesnego sprzętu graficznego i wprowadza
133 innowacyjne koncepcje interfejsu użytkownika, zapewniające przyjemne
134 doznania i łatwość użycia.
135
136 %package -n bash-completion-gnome-shell
137 Summary:        Bash completion for GNOME Shell commands
138 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów poleceń GNOME Shell
139 Group:          Applications/Shells
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       bash-completion >= 2.0
142 BuildArch:      noarch
143
144 %description -n bash-completion-gnome-shell
145 Bash completion for GNOME Shell commands.
146
147 %description -n bash-completion-gnome-shell -l pl.UTF-8
148 Bashowe dopełnianie parametrów poleceń GNOME Shell.
149
150 %package devel
151 Summary:        Development files for GNOME Shell
152 Summary(pl.UTF-8):      Pliki programistyczne dla GNOME Shell
153 Group:          Development/Libraries
154 BuildArch:      noarch
155
156 %description devel
157 This package provides development files for GNOME Shell.
158
159 %description devel -l pl.UTF-8
160 Ten pakiet dostarcza pliki programistyczne dla GNOME Shell.
161
162 %package apidocs
163 Summary:        GNOME Shell API documentation
164 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
165 Group:          Documentation
166 Requires:       gtk-doc-common
167 BuildArch:      noarch
168
169 %description apidocs
170 This package provides GNOME Shell API documentation.
171
172 %description apidocs -l pl.UTF-8
173 Ten pakiet dostarcza dokumentację API GNOME Shell.
174
175 %prep
176 %setup -q
177
178 %{__sed} -i -e '/^libshew =/ s/ library/ shared_library/' subprojects/shew/src/meson.build
179
180 %build
181 %meson build \
182         %{?with_apidocs:-Dgtk_doc=true} \
183         -Dtests=false
184
185 %meson_build -C build
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
190
191 %meson_install -C build
192
193 # evolution already ships this file
194 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/evolution-calendar.desktop
195
196 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell*.a
197
198 %find_lang %{name}
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post
204 %glib_compile_schemas
205
206 %postun
207 if [ "$1" = "0" ]; then
208         %glib_compile_schemas
209 fi
210
211 %files -f %{name}.lang
212 %defattr(644,root,root,755)
213 %doc NEWS README.md
214 %attr(755,root,root) %{_bindir}/gnome-extensions
215 %attr(755,root,root) %{_bindir}/gnome-extensions-app
216 %attr(755,root,root) %{_bindir}/gnome-shell
217 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
218 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
219 %attr(755,root,root) %{_bindir}/gnome-shell-perf-tool
220 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
221 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
222 %attr(755,root,root) %{_libexecdir}/gnome-shell-overrides-migration.sh
223 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
224 %attr(755,root,root) %{_libexecdir}/gnome-shell-portal-helper
225 %dir %{_libdir}/gnome-shell
226 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
227 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-menu.so
228 %attr(755,root,root) %{_libdir}/gnome-shell/libgvc.so
229 %attr(755,root,root) %{_libdir}/gnome-shell/libshew-0.so
230 %attr(755,root,root) %{_libdir}/gnome-shell/libst-1.0.so
231 %{_libdir}/gnome-shell/Gvc-1.0.typelib
232 %{_libdir}/gnome-shell/Shell-0.1.typelib
233 %{_libdir}/gnome-shell/St-1.0.typelib
234 %dir %{_libdir}/gnome-shell/girepository-1.0
235 %{_libdir}/gnome-shell/girepository-1.0/Shew-0.typelib
236 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
237 %{_datadir}/dbus-1/services/org.gnome.Extensions.service
238 %{_datadir}/dbus-1/services/org.gnome.ScreenSaver.service
239 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
240 %{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
241 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
242 %{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
243 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
244 %{_datadir}/dbus-1/services/org.gnome.Shell.Screencast.service
245 %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
246 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
247 %{_datadir}/gnome-control-center/keybindings/*.xml
248 %{_datadir}/gnome-shell
249 %{_datadir}/metainfo/org.gnome.Extensions.metainfo.xml
250 %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
251 %{_desktopdir}/org.gnome.Extensions.desktop
252 %{_desktopdir}/org.gnome.Shell.desktop
253 %{_desktopdir}/org.gnome.Shell.Extensions.desktop
254 %{_desktopdir}/org.gnome.Shell.PortalHelper.desktop
255 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
256 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.svg
257 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
258 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
259 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
260 %{_mandir}/man1/gnome-extensions.1*
261 %{_mandir}/man1/gnome-shell.1*
262 %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
263 %{systemduserunitdir}/org.gnome.Shell.target
264 %{systemduserunitdir}/org.gnome.Shell-disable-extensions.service
265 %{systemduserunitdir}/org.gnome.Shell@wayland.service
266 %{systemduserunitdir}/org.gnome.Shell@x11.service
267
268 %files -n bash-completion-gnome-shell
269 %defattr(644,root,root,755)
270 %{bash_compdir}/gnome-extensions
271
272 %files devel
273 %defattr(644,root,root,755)
274 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
275 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
276 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
277 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
278 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
279 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
280
281 %if %{with apidocs}
282 %files apidocs
283 %defattr(644,root,root,755)
284 %{_gtkdocdir}/shell
285 %{_gtkdocdir}/st
286 %endif
This page took 0.056769 seconds and 4 git commands to generate.