]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- updated to 3.38.0 (requires new gjs, indirectly requiring rust)
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 %define         clutter_ver                     1.21.5
6 # max(ecal_req, eds_req)
7 %define         evolution_data_server_ver       3.33.1
8 %define         gcr_ver                         3.7.5
9 %define         gjs_ver                         1.65.1
10 %define         glib_ver                        1:2.57.2
11 %define         gnome_bluetooth_ver             3.9.0
12 %define         gnome_desktop_ver               3.36.0
13 %define         gsettings_desktop_schemas_ver   3.33.1
14 %define         gtk_ver                         3.15.0
15 %define         json_glib_ver                   0.13.90
16 %define         libcroco_ver                    0.6.8
17 %define         libsecret_ver                   0.18
18 %define         mutter_ver                      3.38.0
19 %define         NetworkManager_ver              1.10.4
20 %define         polkit_ver                      0.100
21 %define         pulseaudio_ver                  2.0
22 %define         startup_notification_ver        0.11
23
24 Summary:        Window manager and application launcher for GNOME
25 Summary(pl.UTF-8):      Zarządca okien i uruchamiania aplikacji dla GNOME
26 Name:           gnome-shell
27 Version:        3.38.0
28 Release:        1
29 License:        GPL v2+
30 Group:          X11/Window Managers
31 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.38/%{name}-%{version}.tar.xz
32 # Source0-md5:  8a70b4b78fc076b86aefb3c83f0e77d5
33 Patch0:         %{name}-gtkdoc.patch
34 URL:            https://wiki.gnome.org/Projects/GnomeShell
35 BuildRequires:  NetworkManager-devel >= %{NetworkManager_ver}
36 BuildRequires:  at-spi2-atk-devel
37 BuildRequires:  clutter-devel >= %{clutter_ver}
38 BuildRequires:  evolution-data-server-devel >= %{evolution_data_server_ver}
39 BuildRequires:  gcr-devel >= %{gcr_ver}
40 BuildRequires:  gdk-pixbuf2-devel >= 2.0
41 BuildRequires:  gettext-tools >= 0.19.6
42 BuildRequires:  gjs-devel >= %{gjs_ver}
43 BuildRequires:  glib2-devel >= %{glib_ver}
44 BuildRequires:  gnome-autoar-devel
45 BuildRequires:  gnome-bluetooth-devel >= %{gnome_bluetooth_ver}
46 BuildRequires:  gnome-control-center-devel
47 # for cldr2json.py (through pygobject->gi)
48 BuildRequires:  gnome-desktop >= %{gnome_desktop_ver}
49 BuildRequires:  gobject-introspection-devel >= 1.50.0
50 BuildRequires:  gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_ver}
51 BuildRequires:  gstreamer-devel >= 1.0.0
52 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
53 BuildRequires:  gtk+3-devel >= %{gtk_ver}
54 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.15}
55 BuildRequires:  ibus-devel >= 1.5.2
56 BuildRequires:  json-glib-devel >= %{json_glib_ver}
57 BuildRequires:  libcanberra-devel
58 BuildRequires:  libcanberra-gtk3-devel
59 BuildRequires:  libcroco-devel >= %{libcroco_ver}
60 BuildRequires:  libsecret-devel >= %{libsecret_ver}
61 BuildRequires:  libsoup-devel
62 BuildRequires:  libxml2-devel >= 2.0
63 BuildRequires:  libxslt-progs
64 BuildRequires:  meson >= 0.53.0
65 BuildRequires:  mutter-devel >= %{mutter_ver}
66 BuildRequires:  ninja >= 1.5
67 BuildRequires:  pipewire-devel >= 0.3
68 BuildRequires:  pkgconfig >= 1:0.22
69 BuildRequires:  polkit-devel >= %{polkit_ver}
70 BuildRequires:  pulseaudio-devel >= %{pulseaudio_ver}
71 BuildRequires:  python3 >= 1:3
72 BuildRequires:  python3-pygobject3 >= 3
73 BuildRequires:  rpm-pythonprov
74 BuildRequires:  rpmbuild(macros) >= 1.736
75 BuildRequires:  sassc
76 BuildRequires:  sed >= 4.0
77 BuildRequires:  startup-notification-devel >= %{startup_notification_ver}
78 BuildRequires:  systemd-devel
79 BuildRequires:  systemd-units
80 BuildRequires:  tar >= 1:1.22
81 BuildRequires:  xorg-lib-libX11-devel
82 BuildRequires:  xorg-lib-libXfixes-devel
83 BuildRequires:  xz
84 Requires(post,postun):  glib2 >= %{glib_ver}
85 # gjs->gi->NMA.gir
86 Requires:       NetworkManager-libs >= %{NetworkManager_ver}
87 Requires:       adwaita-icon-theme
88 Requires:       at-spi2-atk >= 2.4.0
89 Requires:       clutter >= %{clutter_ver}
90 Requires:       evolution-data-server >= %{evolution_data_server_ver}
91 Requires:       gcr >= %{gcr_ver}
92 Requires:       gjs >= %{gjs_ver}
93 Requires:       glib2 >= %{glib_ver}
94 Requires:       gnome-bluetooth-libs >= %{gnome_bluetooth_ver}
95 Requires:       gnome-desktop >= %{gnome_desktop_ver}
96 Requires:       gnome-settings-daemon >= 3.8.0
97 Requires:       gsettings-desktop-schemas >= %{gsettings_desktop_schemas_ver}
98 Requires:       gtk+3 >= %{gtk_ver}
99 Requires:       ibus >= 1.5.2
100 Requires:       json-glib >= %{json_glib_ver}
101 Requires:       libcroco >= %{libcroco_ver}
102 Requires:       libsecret >= %{libsecret_ver}
103 Requires:       mutter >= %{mutter_ver}
104 Requires:       nautilus >= 3.8.0
105 Requires:       polkit >= %{polkit_ver}
106 Requires:       pulseaudio-libs >= %{pulseaudio_ver}
107 Requires:       startup-notification >= %{startup_notification_ver}
108 # gjs->gir->TelepathyGLib
109 Requires:       telepathy-glib >= 0.17.5
110 # gjs->gir->TelepathyLogger
111 Requires:       telepathy-logger-libs >= 0.2
112 Requires:       telepathy-mission-control
113 Suggests:       gnome-contacts >= 3.2.0
114 Suggests:       gnome-icon-theme-symbolic >= 3.8.0
115 Provides:       gdm-wm = 3.8.0
116 Obsoletes:      browser-plugin-gnome-shell < 3.32.2-1
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %description
120 GNOME Shell is the defining technology of the GNOME 3 desktop user
121 experience. It provides core interface functions like switching to
122 windows and launching applications. GNOME Shell takes advantage of the
123 capabilities of modern graphics hardware and introduces innovative
124 user interface concepts to provide a delightful and easy to use
125 experience.
126
127 %description -l pl.UTF-8
128 GNOME Shell to technologia definiująca doznania użytkownika środowiska
129 graficznego GNOME 3. Zapewnia podstawowe funkcje interfejsu, takie jak
130 przełączanie między oknami czy uruchamianie aplikacji. GNOME Shell
131 wykorzystuje mozliwości współczesnego sprzętu graficznego i wprowadza
132 innowacyjne koncepcje interfejsu użytkownika, zapewniające przyjemne
133 doznania i łatwość użycia.
134
135 %package devel
136 Summary:        Development files for GNOME Shell
137 Summary(pl.UTF-8):      Pliki programistyczne dla GNOME Shell
138 Group:          Development/Libraries
139
140 %description devel
141 This package provides development files for GNOME Shell.
142
143 %description devel -l pl.UTF-8
144 Ten pakiet dostarcza pliki programistyczne dla GNOME Shell.
145
146 %package apidocs
147 Summary:        GNOME Shell API documentation
148 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
149 Group:          Documentation
150 Requires:       gtk-doc-common
151 %if "%{_rpmversion}" >= "4.6"
152 BuildArch:      noarch
153 %endif
154
155 %description apidocs
156 This package provides GNOME Shell API documentation.
157
158 %description apidocs -l pl.UTF-8
159 Ten pakiet dostarcza dokumentację API GNOME Shell.
160
161 %prep
162 %setup -q
163 %patch0 -p1
164
165 %{__sed} -i -e '/^libshew =/ s/ library/ shared_library/' subprojects/shew/src/meson.build
166
167 %build
168 %meson build \
169         %{?with_apidocs:-Dgtk_doc=true}
170
171 %meson_build -C build
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
176
177 %meson_install -C build
178
179 # evolution already ships this file
180 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/evolution-calendar.desktop
181
182 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell*.a
183
184 %find_lang %{name}
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post
190 %glib_compile_schemas
191
192 %postun
193 if [ "$1" = "0" ]; then
194         %glib_compile_schemas
195 fi
196
197 %files -f %{name}.lang
198 %defattr(644,root,root,755)
199 %doc NEWS README.md
200 %attr(755,root,root) %{_bindir}/gnome-extensions
201 %attr(755,root,root) %{_bindir}/gnome-extensions-app
202 %attr(755,root,root) %{_bindir}/gnome-shell
203 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
204 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
205 %attr(755,root,root) %{_bindir}/gnome-shell-perf-tool
206 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
207 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
208 %attr(755,root,root) %{_libexecdir}/gnome-shell-overrides-migration.sh
209 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
210 %attr(755,root,root) %{_libexecdir}/gnome-shell-portal-helper
211 %dir %{_libdir}/gnome-shell
212 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
213 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-menu.so
214 %attr(755,root,root) %{_libdir}/gnome-shell/libgvc.so
215 %attr(755,root,root) %{_libdir}/gnome-shell/libshew-0.so
216 %attr(755,root,root) %{_libdir}/gnome-shell/libst-1.0.so
217 %{_libdir}/gnome-shell/Gvc-1.0.typelib
218 %{_libdir}/gnome-shell/Shell-0.1.typelib
219 %{_libdir}/gnome-shell/St-1.0.typelib
220 %dir %{_libdir}/gnome-shell/girepository-1.0
221 %{_libdir}/gnome-shell/girepository-1.0/Shew-0.typelib
222 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
223 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
224 %{_datadir}/dbus-1/services/org.gnome.Extensions.service
225 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
226 %{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
227 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
228 %{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
229 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
230 %{_datadir}/dbus-1/services/org.gnome.Shell.Screencast.service
231 %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
232 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
233 %{_datadir}/gnome-control-center/keybindings/*.xml
234 %{_datadir}/gnome-shell
235 %{_datadir}/metainfo/org.gnome.Extensions.metainfo.xml
236 %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
237 %{_desktopdir}/org.gnome.Extensions.desktop
238 %{_desktopdir}/org.gnome.Shell.desktop
239 %{_desktopdir}/org.gnome.Shell.Extensions.desktop
240 %{_desktopdir}/org.gnome.Shell.PortalHelper.desktop
241 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
242 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.svg
243 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
244 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
245 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
246 %{_mandir}/man1/gnome-extensions.1*
247 %{_mandir}/man1/gnome-shell.1*
248 %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
249 %{systemduserunitdir}/org.gnome.Shell.target
250 %{systemduserunitdir}/org.gnome.Shell-disable-extensions.service
251 %{systemduserunitdir}/org.gnome.Shell@wayland.service
252 %{systemduserunitdir}/org.gnome.Shell@x11.service
253
254 %files devel
255 %defattr(644,root,root,755)
256 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
257 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
258 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
259 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
260 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
261 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
262
263 %if %{with apidocs}
264 %files apidocs
265 %defattr(644,root,root,755)
266 %{_gtkdocdir}/shell
267 %{_gtkdocdir}/st
268 %endif
This page took 0.139793 seconds and 4 git commands to generate.