]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- updated to 45.4
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 %define         clutter_ver                     1.21.5
6 # max(ecal_req, eds_req)
7 %define         evolution_data_server_ver       3.33.1
8 %define         gcr_ver                         3.90.0
9 %define         gjs_ver                         1.73.1
10 %define         glib_ver                        1:2.57.2
11 %define         gnome_bluetooth_ver             3.9.0
12 %define         gnome_desktop_ver               40
13 %define         gsettings_desktop_schemas_ver   42
14 %define         gtk_ver                         4.0
15 %define         ibus_ver                        1.5.19
16 %define         json_glib_ver                   0.13.90
17 %define         libsecret_ver                   0.18
18 %define         mutter_ver                      45.0
19 %define         NetworkManager_ver              1.10.4
20 %define         polkit_ver                      0.100
21 %define         pulseaudio_ver                  13
22 %define         startup_notification_ver        0.11
23 %define         systemd_ver                     1:246
24
25 Summary:        Window manager and application launcher for GNOME
26 Summary(pl.UTF-8):      Zarządca okien i uruchamiania aplikacji dla GNOME
27 Name:           gnome-shell
28 Version:        45.4
29 Release:        1
30 License:        GPL v2+
31 Group:          X11/Window Managers
32 Source0:        https://download.gnome.org/sources/gnome-shell/45/%{name}-%{version}.tar.xz
33 # Source0-md5:  4b3f4593b986af9799e8a62f87d723ae
34 Patch0:         %{name}-no-update.patch
35 URL:            https://wiki.gnome.org/Projects/GnomeShell
36 BuildRequires:  NetworkManager-devel >= %{NetworkManager_ver}
37 BuildRequires:  asciidoc
38 BuildRequires:  at-spi2-atk-devel
39 BuildRequires:  bash-completion-devel >= 1:2.0
40 BuildRequires:  clutter-devel >= %{clutter_ver}
41 BuildRequires:  evolution-data-server-devel >= %{evolution_data_server_ver}
42 BuildRequires:  gcr4-devel >= %{gcr_ver}
43 BuildRequires:  gdk-pixbuf2-devel >= 2.0
44 BuildRequires:  gettext-tools >= 0.19.6
45 BuildRequires:  gjs-devel >= %{gjs_ver}
46 BuildRequires:  glib2-devel >= %{glib_ver}
47 BuildRequires:  gnome-autoar-devel
48 BuildRequires:  gnome-bluetooth3-devel >= %{gnome_bluetooth_ver}
49 BuildRequires:  gnome-control-center-devel
50 BuildRequires:  gnome-desktop4-devel >= %{gnome_desktop_ver}
51 BuildRequires:  gobject-introspection-devel >= 1.50.0
52 BuildRequires:  gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_ver}
53 BuildRequires:  gstreamer-devel >= 1.0.0
54 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
55 BuildRequires:  gtk4-devel >= %{gtk_ver}
56 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.15}
57 BuildRequires:  ibus-devel >= %{ibus_ver}
58 BuildRequires:  json-glib-devel >= %{json_glib_ver}
59 BuildRequires:  libsecret-devel >= %{libsecret_ver}
60 # or libsoup 2.4 with -Dsoup2=true, must be in sync with libgweather
61 BuildRequires:  libsoup3-devel >= 3.0
62 BuildRequires:  libxml2-devel >= 2.0
63 BuildRequires:  libxslt-progs
64 BuildRequires:  meson >= 0.58.0
65 BuildRequires:  mutter-devel >= %{mutter_ver}
66 BuildRequires:  ninja >= 1.5
67 BuildRequires:  pipewire-devel >= 0.3.49
68 BuildRequires:  pkgconfig >= 1:0.22
69 BuildRequires:  polkit-devel >= %{polkit_ver}
70 BuildRequires:  pulseaudio-devel >= %{pulseaudio_ver}
71 BuildRequires:  python3 >= 1:3
72 BuildRequires:  python3-pygobject3 >= 3
73 BuildRequires:  rpm-build >= 4.6
74 BuildRequires:  rpm-pythonprov
75 BuildRequires:  rpmbuild(macros) >= 1.752
76 BuildRequires:  sassc
77 BuildRequires:  sed >= 4.0
78 BuildRequires:  startup-notification-devel >= %{startup_notification_ver}
79 BuildRequires:  systemd-devel >= %{systemd_ver}
80 BuildRequires:  systemd-units >= %{systemd_ver}
81 BuildRequires:  tar >= 1:1.22
82 BuildRequires:  xorg-lib-libX11-devel
83 BuildRequires:  xorg-lib-libXfixes-devel
84 BuildRequires:  xz
85 Requires(post,postun):  glib2 >= %{glib_ver}
86 # gjs->gi->NMA.gir
87 Requires:       NetworkManager-libs >= %{NetworkManager_ver}
88 Requires:       adwaita-icon-theme
89 Requires:       at-spi2-atk >= 2.4.0
90 Requires:       clutter >= %{clutter_ver}
91 Requires:       evolution-data-server >= %{evolution_data_server_ver}
92 Requires:       gcr4 >= %{gcr_ver}
93 Requires:       gjs >= %{gjs_ver}
94 Requires:       glib2 >= %{glib_ver}
95 Requires:       gnome-bluetooth3-libs >= %{gnome_bluetooth_ver}
96 Requires:       gnome-desktop4 >= %{gnome_desktop_ver}
97 Requires:       gnome-settings-daemon >= 3.8.0
98 Requires:       gsettings-desktop-schemas >= %{gsettings_desktop_schemas_ver}
99 Requires:       gtk4 >= %{gtk_ver}
100 Requires:       ibus >= %{ibus_ver}
101 Requires:       json-glib >= %{json_glib_ver}
102 Requires:       libsecret >= %{libsecret_ver}
103 Requires:       mutter >= %{mutter_ver}
104 Requires:       nautilus >= 3.8.0
105 Requires:       polkit >= %{polkit_ver}
106 Requires:       pulseaudio-libs >= %{pulseaudio_ver}
107 Requires:       startup-notification >= %{startup_notification_ver}
108 # gjs->gir->TelepathyGLib
109 Requires:       telepathy-glib >= 0.17.5
110 # gjs->gir->TelepathyLogger
111 Requires:       telepathy-logger-libs >= 0.2
112 Requires:       telepathy-mission-control
113 Suggests:       gnome-contacts >= 3.2.0
114 Suggests:       gnome-icon-theme-symbolic >= 3.8.0
115 Provides:       gdm-wm = 3.8.0
116 Obsoletes:      browser-plugin-gnome-shell < 3.32.2-1
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %description
120 GNOME Shell is the defining technology of the GNOME 3 desktop user
121 experience. It provides core interface functions like switching to
122 windows and launching applications. GNOME Shell takes advantage of the
123 capabilities of modern graphics hardware and introduces innovative
124 user interface concepts to provide a delightful and easy to use
125 experience.
126
127 %description -l pl.UTF-8
128 GNOME Shell to technologia definiująca doznania użytkownika środowiska
129 graficznego GNOME 3. Zapewnia podstawowe funkcje interfejsu, takie jak
130 przełączanie między oknami czy uruchamianie aplikacji. GNOME Shell
131 wykorzystuje mozliwości współczesnego sprzętu graficznego i wprowadza
132 innowacyjne koncepcje interfejsu użytkownika, zapewniające przyjemne
133 doznania i łatwość użycia.
134
135 %package -n bash-completion-gnome-shell
136 Summary:        Bash completion for GNOME Shell commands
137 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów poleceń GNOME Shell
138 Group:          Applications/Shells
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       bash-completion >= 1:2.0
141 BuildArch:      noarch
142
143 %description -n bash-completion-gnome-shell
144 Bash completion for GNOME Shell commands.
145
146 %description -n bash-completion-gnome-shell -l pl.UTF-8
147 Bashowe dopełnianie parametrów poleceń GNOME Shell.
148
149 %package devel
150 Summary:        Development files for GNOME Shell
151 Summary(pl.UTF-8):      Pliki programistyczne dla GNOME Shell
152 Group:          Development/Libraries
153 BuildArch:      noarch
154
155 %description devel
156 This package provides development files for GNOME Shell.
157
158 %description devel -l pl.UTF-8
159 Ten pakiet dostarcza pliki programistyczne dla GNOME Shell.
160
161 %package apidocs
162 Summary:        GNOME Shell API documentation
163 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
164 Group:          Documentation
165 Requires:       gtk-doc-common
166 BuildArch:      noarch
167
168 %description apidocs
169 This package provides GNOME Shell API documentation.
170
171 %description apidocs -l pl.UTF-8
172 Ten pakiet dostarcza dokumentację API GNOME Shell.
173
174 %prep
175 %setup -q
176 %patch0 -p1
177
178 %{__sed} -i -e '/^libshew =/ s/ library/ shared_library/' subprojects/shew/src/meson.build
179
180 %build
181 %meson build \
182         %{?with_apidocs:-Dgtk_doc=true} \
183         -Dtests=false
184
185 %meson_build -C build
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
190
191 %meson_install -C build
192
193 # useless
194 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/lib*.a
195
196 # not supported by glibc (as of 2.37)
197 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
198
199 %find_lang %{name}
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %post
205 %glib_compile_schemas
206
207 %postun
208 if [ "$1" = "0" ]; then
209         %glib_compile_schemas
210 fi
211
212 %files -f %{name}.lang
213 %defattr(644,root,root,755)
214 %doc NEWS README.md
215 %attr(755,root,root) %{_bindir}/gnome-extensions
216 %attr(755,root,root) %{_bindir}/gnome-extensions-app
217 %attr(755,root,root) %{_bindir}/gnome-shell
218 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
219 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
220 %attr(755,root,root) %{_bindir}/gnome-shell-test-tool
221 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
222 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
223 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
224 %attr(755,root,root) %{_libexecdir}/gnome-shell-portal-helper
225 %dir %{_libdir}/gnome-shell
226 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-menu.so
227 %attr(755,root,root) %{_libdir}/gnome-shell/libgvc.so
228 %attr(755,root,root) %{_libdir}/gnome-shell/libshell-13.so
229 %attr(755,root,root) %{_libdir}/gnome-shell/libshew-0.so
230 %attr(755,root,root) %{_libdir}/gnome-shell/libst-13.so
231 %{_libdir}/gnome-shell/Gvc-1.0.typelib
232 %{_libdir}/gnome-shell/Shell-13.typelib
233 %{_libdir}/gnome-shell/St-13.typelib
234 %dir %{_libdir}/gnome-shell/girepository-1.0
235 %{_libdir}/gnome-shell/girepository-1.0/Shew-0.typelib
236 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
237 %{_datadir}/dbus-1/services/org.gnome.Extensions.service
238 %{_datadir}/dbus-1/services/org.gnome.ScreenSaver.service
239 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
240 %{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
241 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
242 %{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
243 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
244 %{_datadir}/dbus-1/services/org.gnome.Shell.Screencast.service
245 %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
246 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
247 %{_datadir}/gnome-control-center/keybindings/*.xml
248 %{_datadir}/gnome-shell
249 %{_datadir}/metainfo/org.gnome.Extensions.metainfo.xml
250 %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
251 %{_desktopdir}/org.gnome.Extensions.desktop
252 %{_desktopdir}/org.gnome.Shell.desktop
253 %{_desktopdir}/org.gnome.Shell.Extensions.desktop
254 %{_desktopdir}/org.gnome.Shell.PortalHelper.desktop
255 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
256 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.svg
257 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
258 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
259 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
260 %{_mandir}/man1/gnome-extensions.1*
261 %{_mandir}/man1/gnome-shell.1*
262 %{systemduserunitdir}/org.gnome.Shell.target
263 %{systemduserunitdir}/org.gnome.Shell-disable-extensions.service
264 %{systemduserunitdir}/org.gnome.Shell@wayland.service
265 %{systemduserunitdir}/org.gnome.Shell@x11.service
266
267 %files -n bash-completion-gnome-shell
268 %defattr(644,root,root,755)
269 %{bash_compdir}/gnome-extensions
270
271 %files devel
272 %defattr(644,root,root,755)
273 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
274 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
275 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
276 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
277 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
278 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
279
280 %if %{with apidocs}
281 %files apidocs
282 %defattr(644,root,root,755)
283 %{_gtkdocdir}/shell
284 %{_gtkdocdir}/st
285 %endif
This page took 0.05653 seconds and 3 git commands to generate.