]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- 2.15.90, use rpm macros
[packages/gnome-panel.git] / gnome-panel.spec
1 Summary:        The core programs for the GNOME GUI desktop environment
2 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
3 Name:           gnome-panel
4 Version:        2.15.90
5 Release:        1
6 License:        LGPL
7 Group:          X11/Applications
8 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.15/%{name}-%{version}.tar.bz2
9 # Source0-md5:  e3e7d3924fdfea18131b26fd3b321cbd
10 Patch0:         %{name}-finalize-memleak.patch
11 Patch1:         %{name}-no_launchers_on_panel.patch
12 URL:            http://www.gnome.org/
13 BuildRequires:  GConf2-devel >= 2.12.0
14 BuildRequires:  ORBit2-devel >= 1:2.14.2
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  evolution-data-server-devel >= 1.7.90.1
18 BuildRequires:  gnome-common >= 2.12.0
19 BuildRequires:  gnome-doc-utils >= 0.7.1
20 BuildRequires:  gnome-desktop-devel >= 2.15.90
21 BuildRequires:  gnome-menus-devel >= 2.15.90
22 BuildRequires:  gnome-vfs2-devel >= 2.15.90
23 BuildRequires:  gtk+2-devel >= 2:2.10.1
24 BuildRequires:  gtk-doc >= 1.6
25 BuildRequires:  intltool >= 0.35
26 BuildRequires:  libart_lgpl-devel >= 2.3.15
27 BuildRequires:  libglade2-devel >= 1:2.6.0
28 BuildRequires:  libgnomeui-devel >= 2.15.90
29 BuildRequires:  libtool
30 BuildRequires:  libwnck-devel >= 2.15.90
31 BuildRequires:  pango-devel >= 1:1.13.4
32 BuildRequires:  perl-base
33 BuildRequires:  pkgconfig >= 1:0.15.0
34 BuildRequires:  python-libxml2
35 BuildRequires:  rpm-build >= 4.1-10
36 BuildRequires:  rpmbuild(macros) >= 1.311
37 BuildRequires:  scrollkeeper >= 0.3.11
38 BuildConflicts: GConf-devel < 1.0.9-7
39 Requires(post,preun):   GConf2 >= 2.14.0
40 Requires(post,postun):  scrollkeeper
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       hicolor-icon-theme
43 Requires:       gnome-desktop >= 2.15.90
44 Requires:       gnome-icon-theme >= 2.15.90
45 Requires:       xdg-menus
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 GNOME (GNU Network Object Model Environment) is a user-friendly set of
50 applications and desktop tools to be used in conjunction with a window
51 manager for the X Window System. GNOME is similar in purpose and scope
52 to CDE and KDE, but GNOME is based completely on free software.
53
54 The gnome-panel packages provides the GNOME panel, menus and some
55 basic applets for the panel.
56
57 %description -l pl
58 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych dla
59 u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z zarz±dc±
60 okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje ca³kowicie
61 na wolnym oprogramowaniu.
62
63 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
64 panelu GNOME2.
65
66 %package devel
67 Summary:        GNOME panel includes, and more
68 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
69 Group:          X11/Development/Libraries
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       gtk-doc-common
72 Requires:       libgnomeui-devel >= 2.15.2
73
74 %description devel
75 Panel header files for creating GNOME panels.
76
77 %description devel -l pl
78 Pliki nag³ówkowe bibliotek panelu GNOME.
79
80 %package static
81 Summary:        GNOME panel static libraries
82 Summary(pl):    Statyczne biblioteki panelu GNOME
83 Group:          X11/Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Panel static libraries.
88
89 %description static -l pl
90 Statyczne biblioteki panelu GNOME.
91
92 %package libs
93 Summary:        GNOME panel library
94 Summary(pl):    Biblioteka panelu GNOME
95 Group:          X11/Libraries
96 Requires:       libgnomeui >= 2.15.90
97 Requires:       librsvg >= 1:2.15.0
98
99 %description libs
100 GNOME panel library.
101
102 %description libs -l pl
103 Biblioteka panelu GNOME.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 %{__gnome_doc_prepare}
112 %{__gnome_doc_common}
113 %{__intltoolize}
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoheader}
117 %{__autoconf}
118 %{__automake}
119 %configure \
120         --disable-schemas-install \
121         --enable-eds \
122         --enable-gtk-doc \
123         --with-html-dir=%{_gtkdocdir}
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_datadir}/%{name}}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
133
134 install %{name}/panel-default-setup.entries $RPM_BUILD_ROOT%{_datadir}/%{name}
135
136 # short circuit stopper (fix me!)
137 mv ChangeLog main-ChangeLog
138 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
139
140 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/panel-default-setup.entries
141
142 %find_lang %{name} --with-gnome --all-name
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 %scrollkeeper_update_post
149 %gconf_schema_install clock.schemas
150 %gconf_schema_install fish.schemas
151 %gconf_schema_install panel-compatibility.schemas
152 %gconf_schema_install panel-general.schemas
153 %gconf_schema_install panel-global.schemas
154 %gconf_schema_install panel-object.schemas
155 %gconf_schema_install panel-toplevel.schemas
156 %gconf_schema_install window-list.schemas
157 %gconf_schema_install workspace-switcher.schemas
158 %update_icon_cache hicolor
159
160 %{_bindir}/gconftool-2 --direct \
161         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
162         --load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
163 %{_bindir}/gconftool-2 --direct \
164         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
165         --load %{_datadir}/%{name}/panel-default-setup.entries /apps/panel/profiles/default > /dev/null
166
167 %banner %{name} -e << EOF
168 For full functionality, you need to install
169 gnome-utils-screenshot and gnome-utils-search-tool.
170 EOF
171
172 %preun
173 %gconf_schema_uninstall clock.schemas
174 %gconf_schema_uninstall fish.schemas
175 %gconf_schema_uninstall panel-compatibility.schemas
176 %gconf_schema_uninstall panel-general.schemas
177 %gconf_schema_uninstall panel-global.schemas
178 %gconf_schema_uninstall panel-object.schemas
179 %gconf_schema_uninstall panel-toplevel.schemas
180 %gconf_schema_uninstall window-list.schemas
181 %gconf_schema_uninstall workspace-switcher.schemas
182
183 %postun
184 %scrollkeeper_update_postun
185 %update_icon_cache hicolor
186
187 %post   libs -p /sbin/ldconfig
188 %postun libs -p /sbin/ldconfig
189
190 %files -f %{name}.lang
191 %defattr(644,root,root,755)
192 %doc AUTHORS NEWS README *ChangeLog
193 %attr(755,root,root) %{_bindir}/*
194 %attr(755,root,root) %{_libdir}/clock-applet
195 %attr(755,root,root) %{_libdir}/fish-applet-2
196 %attr(755,root,root) %{_libdir}/notification-area-applet
197 %attr(755,root,root) %{_libdir}/wnck-applet
198 %{_datadir}/gnome-2.0/ui/*
199 %{_datadir}/gnome-panel
200 %{_datadir}/gnome/panel
201 %{_datadir}/gnome-panelrc
202 %{_datadir}/idl/gnome-panel-2.0
203 %{_iconsdir}/*/*/apps/*.png
204 %{_libdir}/bonobo/servers/*
205 %{_mandir}/man1/*
206 %{_omf_dest_dir}/clock
207 %{_omf_dest_dir}/fish
208 %{_omf_dest_dir}/%{name}
209 %{_omf_dest_dir}/window-list
210 %{_omf_dest_dir}/workspace-switcher
211 %{_sysconfdir}/gconf/schemas/clock.schemas
212 %{_sysconfdir}/gconf/schemas/fish.schemas
213 %{_sysconfdir}/gconf/schemas/panel-compatibility.schemas
214 %{_sysconfdir}/gconf/schemas/panel-general.schemas
215 %{_sysconfdir}/gconf/schemas/panel-global.schemas
216 %{_sysconfdir}/gconf/schemas/panel-object.schemas
217 %{_sysconfdir}/gconf/schemas/panel-toplevel.schemas
218 %{_sysconfdir}/gconf/schemas/window-list.schemas
219 %{_sysconfdir}/gconf/schemas/workspace-switcher.schemas
220
221 %files devel
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_libdir}/libpanel-applet*.so
224 %{_libdir}/*.la
225 %{_gtkdocdir}/panel-applet
226 %{_includedir}/panel-2.0
227 %{_pkgconfigdir}/*.pc
228
229 %files static
230 %defattr(644,root,root,755)
231 %{_libdir}/lib*.a
232
233 %files libs
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
This page took 0.052599 seconds and 4 git commands to generate.