]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- am fixes
[packages/gnome-panel.git] / gnome-panel.spec
1 Summary:        The core programs for the GNOME GUI desktop environment.
2 Name:           gnome-panel
3 Version:        1.5.18
4 Release:        0.2
5 License:        LGPL
6 Group:          X11/Applications
7 Source0:        ftp://ftp.gnome.org/pub/gnome/pre-gnome2/sources/%{name}/%{name}-%{version}.tar.bz2
8 Patch0:         %{name}-am.patch
9 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
10 URL:            http://www.gnome.org/
11 BuildRequires:  pkgconfig
12 BuildRequires:  ORBit2-devel
13 BuildRequires:  gtk+2-devel
14 BuildRequires:  libgnomeui-devel
15 BuildRequires:  libwnck-devel
16 BuildRequires:  gnome-desktop-devel
17 BuildRequires:  libglade2-devel
18 BuildRequires:  gnome-vfs2-devel
19
20 %define         _prefix         /usr/X11R6
21 %define         _mandir         %{_prefix}/man
22 %define         _sysconfdir     /etc/X11/GNOME2
23 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
24
25 %description
26 GNOME (GNU Network Object Model Environment) is a user-friendly set of
27 applications and desktop tools to be used in conjunction with a window
28 manager for the X Window System. GNOME is similar in purpose and scope
29 to CDE and KDE, but GNOME is based completely on free software. The
30 gnome-core package includes the basic programs and libraries that are
31 needed to install GNOME.
32
33 The GNOME panel packages provides the gnome panel, menu's and some
34 basic applets for the panel.
35
36 %package devel
37 Summary:        GNOME panel libraries, includes, and more.
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}
40
41 %description devel
42 Panel libraries and header files for creating GNOME panels.
43
44 %package static
45 Summary:        GNOME panel libraries, includes, and more.
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-devel
48
49 %description static
50 Panel libraries and header files for creating GNOME panels.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 %build
57 intltoolize --copy --force
58 libtoolize --copy --force
59 gettextize --copy --force
60 aclocal
61 autoconf
62 automake -a -c -f
63 if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
64         CPPFLAGS="`pkg-config libpng12 --cflags`"
65 fi
66 %configure  CPPFLAGS="$CPPFLAGS" \
67         --enable-gtk-doc=no
68 %{__make}
69
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT \
76         omf_dest_dir=%{_omf_dest_dir}/%{name} \
77         pkgconfigdir=%{_pkgconfigdir}
78
79 gzip -9nf AUTHORS ChangeLog NEWS README
80
81 %find_lang %{name} --with-gnome --all-name
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 /sbin/ldconfig
88 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
89 for SCHEMAS in clock.schemas fish.schemas mailcheck.schemas pager.schemas panel-global-config.schemas panel-per-panel-config.schemas tasklist.schemas; do
90         /usr/X11R6/bin/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$SCHEMAS > /dev/null 2>&1
91 done
92
93 %postun
94 /sbin/ldconfig
95 /usr/bin/scrollkeeper-update
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc *.gz
100 %config %{_sysconfdir}/gconf/schemas/*
101 %config %{_sysconfdir}/sound/events/*
102 %attr(755,root,root) %{_bindir}/*
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*
104 %{_libdir}/bonobo/servers/*
105 %{_datadir}/applications/*
106 %{_datadir}/control-center-2.0/capplets/*
107 %{_datadir}/gen_util
108 %{_datadir}/gnome/panel
109 %{_datadir}/gnome-2.0
110 %{_datadir}/gnome-panel
111 %{_datadir}/gtk-doc/html/panel-applet
112 %{_datadir}/idl/gnome-panel-2.0
113 %{_datadir}/pixmaps/fish
114 %{_datadir}/pixmaps/mailcheck
115 %{_datadir}/pixmaps/*.png
116 %{_omf_dest_dir}/%{name}
117 %{_mandir}/man1/*
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/lib*.??
122 %{_includedir}/panel-2.0
123 %{_pkgconfigdir}/*.pc
124
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/*.a
This page took 0.044418 seconds and 4 git commands to generate.