]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- more fixes for gtk-doc files location - maybe now it will work as it should
[packages/gnome-panel.git] / gnome-panel.spec
1 Summary:        The core programs for the GNOME GUI desktop environment
2 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
3 Name:           gnome-panel
4 Version:        2.0.2
5 Release:        1
6 License:        LGPL
7 Group:          X11/Applications
8 Source0:        ftp://ftp.gnome.org/pub/gnome/2.0.0/sources/%{name}/%{name}-%{version}.tar.bz2
9 URL:            http://www.gnome.org/
10 BuildRequires:  ORBit2-devel >= 2.4.0
11 BuildRequires:  glib2-devel >= 2.0.4
12 BuildRequires:  gnome-desktop-devel >= 2.0.3
13 BuildRequires:  gtk-doc
14 BuildRequires:  gtk+2-devel >= 2.0.3
15 BuildRequires:  intltool >= 0.22
16 BuildRequires:  libglade2-devel >= 2.0.0
17 BuildRequires:  libgnomeui-devel >= 2.0.1
18 BuildRequires:  libwnck-devel >= 0.14
19 BuildRequires:  pkgconfig >= 0.12.0
20 BuildRequires:  scrollkeeper >= 0.3.6
21 Requires(post,postun): scrollkeeper
22 Requires(post,postun): /sbin/ldconfig
23 Requires(post): GConf2
24 Requires:       gnome-desktop >= 2.0.3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/X11R6
28 %define         _mandir         %{_prefix}/man
29 %define         _sysconfdir     /etc/X11/GNOME2
30 %define         _gtkdocdir      %{_defaultdocdir}/gtk-doc/html
31 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
32
33 %description
34 GNOME (GNU Network Object Model Environment) is a user-friendly set of
35 applications and desktop tools to be used in conjunction with a window
36 manager for the X Window System. GNOME is similar in purpose and scope
37 to CDE and KDE, but GNOME is based completely on free software.
38
39 The GNOME panel packages provides the gnome panel, menus and some
40 basic applets for the panel.
41
42 %description -l pl
43 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych
44 dla u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z
45 zarz±dc± okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje
46 ca³kowicie na wolnym oprogramowaniu.
47
48 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
49 panelu GNOME2.
50
51 %package devel
52 Summary:        GNOME panel includes, and more
53 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}
56 Requires:       gtk-doc-common
57
58 %description devel
59 Panel header files for creating GNOME panels.
60
61 %description devel -l pl
62 Pliki nag³ówkowe bibliotek panelu GNOME.
63
64 %package static
65 Summary:        GNOME panel static libraries
66 Summary(pl):    Statyczne biblioteki panelu GNOME
67 Group:          X11/Development/Libraries
68 Requires:       %{name} = %{version}-devel
69
70 %description static
71 Panel static libraries.
72
73 %description static -l pl
74 Statyczne biblioteki panelu GNOME.
75
76 %prep
77 %setup -q
78
79 %build
80 intltoolize --copy --force
81 %{__libtoolize}
82 glib-gettextize --copy --force
83 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         --enable-gtk-doc \
88         --with-html-path=%{_gtkdocdir}
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT \
97         omf_dest_dir=%{_omf_dest_dir}/%{name} \
98         pkgconfigdir=%{_pkgconfigdir} \
99         HTML_DIR=%{_gtkdocdir}
100
101 mv ChangeLog main-ChangeLog
102 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
103
104 %find_lang %{name} --with-gnome --all-name
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 /sbin/ldconfig
111 scrollkeeper-update
112 GCONF_CONFIG_SOURCE="" \
113 %{_bindir}/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/*.schemas > /dev/null 
114
115 %postun 
116 /sbin/ldconfig
117 scrollkeeper-update
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS *ChangeLog NEWS README
122 %config %{_sysconfdir}/gconf/schemas/*
123 %config %{_sysconfdir}/sound/events/*
124 %attr(755,root,root) %{_bindir}/*
125 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
126 %attr(755,root,root) %{_libdir}/libgen_util_applet*.so
127 %attr(755,root,root) %{_libdir}/libgen_util_applet*.la
128 %{_libdir}/bonobo/servers/*
129 %{_datadir}/control-center-2.0/capplets/*
130 %{_datadir}/gen_util
131 %{_datadir}/gnome/panel
132 %{_datadir}/gnome-2.0/ui/*
133 %{_datadir}/gnome-panel*
134 %{_datadir}/idl/gnome-panel-2.0
135 %{_datadir}/pixmaps/*
136 %{_omf_dest_dir}/%{name}
137 %{_mandir}/man1/*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libpanel-applet*.??
142 %{_gtkdocdir}/panel-applet
143 %{_includedir}/panel-2.0
144 %{_pkgconfigdir}/*.pc
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libpanel-applet*.a
This page took 0.042397 seconds and 4 git commands to generate.