]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- release 2
[packages/gnome-panel.git] / gnome-panel.spec
1 Summary:        The core programs for the GNOME GUI desktop environment
2 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
3 Name:           gnome-panel
4 Version:        2.1.1
5 Release:        2
6 License:        LGPL
7 Group:          X11/Applications
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.1/%{name}-%{version}.tar.bz2
9 URL:            http://www.gnome.org/
10 BuildRequires:  ORBit2-devel >= 2.4.3
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  glib2-devel >= 2.1.0
14 BuildRequires:  gnome-desktop-devel >= 2.1.0
15 BuildRequires:  gtk-doc >= 0.9-4
16 BuildRequires:  gtk+2-devel >= 2.1.0
17 BuildRequires:  intltool >= 0.22
18 BuildRequires:  libglade2-devel >= 2.0.1
19 BuildRequires:  libgnomeui-devel >= 2.1.0
20 BuildRequires:  libtool
21 BuildRequires:  libwnck-devel >= 2.1.1
22 BuildRequires:  pkgconfig >= 0.12.0
23 BuildRequires:  scrollkeeper >= 0.3.11
24 BuildConflicts: GConf-devel < 1.0.9-7
25 Requires(post,postun): scrollkeeper
26 Requires(post,postun): /sbin/ldconfig
27 Requires(post): GConf2
28 Requires:       gnome-desktop >= 2.1.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _prefix         /usr/X11R6
32 %define         _mandir         %{_prefix}/man
33 %define         _sysconfdir     /etc/X11/GNOME2
34 %define         _gtkdocdir      %{_defaultdocdir}/gtk-doc/html
35 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
36
37 %description
38 GNOME (GNU Network Object Model Environment) is a user-friendly set of
39 applications and desktop tools to be used in conjunction with a window
40 manager for the X Window System. GNOME is similar in purpose and scope
41 to CDE and KDE, but GNOME is based completely on free software.
42
43 The GNOME panel packages provides the gnome panel, menus and some
44 basic applets for the panel.
45
46 %description -l pl
47 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych
48 dla u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z
49 zarz±dc± okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje
50 ca³kowicie na wolnym oprogramowaniu.
51
52 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
53 panelu GNOME2.
54
55 %package devel
56 Summary:        GNOME panel includes, and more
57 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
58 Group:          X11/Development/Libraries
59 Requires:       %{name} = %{version}
60 Requires:       gtk-doc-common
61
62 %description devel
63 Panel header files for creating GNOME panels.
64
65 %description devel -l pl
66 Pliki nag³ówkowe bibliotek panelu GNOME.
67
68 %package static
69 Summary:        GNOME panel static libraries
70 Summary(pl):    Statyczne biblioteki panelu GNOME
71 Group:          X11/Development/Libraries
72 Requires:       %{name}-devel = %{version}
73
74 %description static
75 Panel static libraries.
76
77 %description static -l pl
78 Statyczne biblioteki panelu GNOME.
79
80 %prep
81 %setup -q
82
83 %build
84 intltoolize --copy --force
85 %{__libtoolize}
86 glib-gettextize --copy --force
87 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
88 %{__autoconf}
89 %{__automake}
90 %configure \
91         --enable-gtk-doc \
92         --with-html-path=%{_gtkdocdir}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT \
101         omf_dest_dir=%{_omf_dest_dir}/%{name} \
102         pkgconfigdir=%{_pkgconfigdir} \
103         HTML_DIR=%{_gtkdocdir}
104
105 mv ChangeLog main-ChangeLog
106 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
107
108 %find_lang %{name} --with-gnome --all-name
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 /sbin/ldconfig
115 scrollkeeper-update
116 GCONF_CONFIG_SOURCE="`%{_bindir}/gconftool-2 --get-default-source`" \
117 %{_bindir}/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/*.schemas > /dev/null 
118
119 %postun 
120 /sbin/ldconfig
121 scrollkeeper-update
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS *ChangeLog NEWS README
126 %config %{_sysconfdir}/gconf/schemas/*
127 %config %{_sysconfdir}/sound/events/*
128 %attr(755,root,root) %{_bindir}/*
129 %attr(755,root,root) %{_libdir}/fish-applet-2
130 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
131 %attr(755,root,root) %{_libdir}/libgen_util_applet*.so
132 %attr(755,root,root) %{_libdir}/libgen_util_applet*.la
133 %{_libdir}/bonobo/servers/*
134 %{_datadir}/control-center-2.0/capplets/*
135 %{_datadir}/gen_util
136 %{_datadir}/gnome/panel
137 %{_datadir}/gnome-2.0/ui/*
138 %{_datadir}/gnome-panel*
139 %{_datadir}/idl/gnome-panel-2.0
140 %{_datadir}/pixmaps/*
141 %{_omf_dest_dir}/%{name}
142 %{_mandir}/man1/*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libpanel-applet*.??
147 %{_gtkdocdir}/panel-applet
148 %{_includedir}/panel-2.0
149 %{_pkgconfigdir}/*.pc
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/lib*.a
This page took 0.129329 seconds and 4 git commands to generate.